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Legal information 
Warning notice system 

This manual contains notices you have to observe in order to ensure your personal safety, as well as to prevent 
damage to property. The notices referring to your personal safety are highlighted in the manual by a safety alert 
symbol, notices referring only to property damage have no safety alert symbol. These notices shown below are 
graded according to the degree of danger. 

DANGER 
indicates that death or severe personal injury will result if proper precautions are not taken. 

WARNING 
indicates that death or severe personal injury may result if proper precautions are not taken. 

CAUTION 
indicates that minor personal injury can result if proper precautions are not taken. 

NOTICE 
indicates that property damage can result if proper precautions are not taken. 

If more than one degree of danger is present, the warning notice representing the highest degree of danger will 
be used. A notice warning of injury to persons with a safety alert symbol may also include a warning relating to 
property damage. 

Qualified Personnel 
The product/system described in this documentation may be operated only by personnel qualified for the specific 
task in accordance with the relevant documentation, in particular its warning notices and safety instructions. 
Qualified personnel are those who, based on their training and experience, are capable of identifying risks and 
avoiding potential hazards when working with these products/systems. 

Proper use of IDEC products 
Note the following: 

WARNING 
IDEC products may only be used for the applications described in the catalog and in the relevant technical 
documentation. If products and components from other manufacturers are used, these must be recommended 
or approved by IDEC. Proper transport, storage, installation, assembly, commissioning, operation and 
maintenance are required to ensure that the products operate safely and without any problems. The permissible 
ambient conditions must be complied with. The information in the relevant documentation must be observed. 

Copyright © IDEC CORPORATION All rights reserved 
The reproduction, distribution or use of this document or its contents is not permitted without express written 
authority. Offenders will be liable for damages. All rights reserved, in particular in the event of patents being 
granted or the registration of a utility model or design. 

Disclaimer of Liability 
We have reviewed the contents of this publication to ensure consistency with the hardware and software 
described. Since variance cannot be precluded entirely, we cannot guarantee full consistency. However, the 
information in this publication is reviewed regularly and any necessary corrections are included in subsequent 
editions. 
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WindLGC V8.4 1 
1.1 Security information 

IDEC provides products and solutions with industrial security functions that support the 
secure operation of plants, systems, machines and networks. 

In order to protect plants, systems, machines and networks against cyber threats, it is 
necessary to implement – and continuously maintain – a holistic, state-of-the-art industrial 
security concept.  

Customers are responsible for preventing unauthorized access to their plants, systems, 
machines and networks. Such systems, machines and components should only be connected 
to an enterprise network or the internet if and to the extent such a connection is necessary 
and only when appropriate security measures (e.g. firewalls and/or network segmentation) 
are in place.  

IDEC' products and solutions undergo continuous development to make them more secure. 
IDEC strongly recommends that product updates are applied as soon as they are available and 
that the latest product versions are used. Use of product versions that are no longer 
supported, and failure to apply the latest updates may increase customers' exposure to cyber 
threats.  

1.2 Data protection 
This product does not process / save any personal information, but only technical functional 
data (e.g. time stamps). If the user links this data to other data (e.g. shift plans) or if the user 
save personal information on the same medium (e.g. hard disk) and therefore creates a 
personal reference in the process, the user has to ensure meeting the guidelines regarding 
data protection in their region of use. 
 

 

 Note 
Notes on protecting administrator accounts 

A user with administrator rights has extensive access and manipulation options available to 
the system. 

Therefore, ensure there are adequate safeguards for protecting the administrator accounts to 
prevent unauthorized changes. To do this, use secure passwords and a standard user account 
for normal operation. Other measures, such as the use of security policies, should be applied 
as needed. 

 



WindLGC V8.4  
1.3 Welcome to WindLGC V8.4! 

 WindLGC Online Help 

12 Programming and Operating Manual, 11/2024 

 Note 

To protect WindLGC and FL1F Web Editor from any undesired manipulation when your PC 
suffers malicious attacks from the Internet, we recommend that you install whitelist-based 
security software on the PC. Then use the whitelist-based security software to manage the 
software installed on your PC. 

 

1.3 Welcome to WindLGC V8.4! 
 
 

 

What's new in WindLGC  (Page 17)  

 

Elements of the software interface (Page 26)  

 

Tutorial (Page 172) 

 

Sample applications (Page 236)  

 

Reference material: 
- Constants and terminal blocks (Page 242)  
- Basic functions (FBD and UDF Editors) (Page 257)  
- SFBs (Page 263)  
- Circuit programs (Page 411)  

 

Tips and tricks (Page 421) 

Help → Contents (Page 169)  

Help → Context-sensitive help (Page 170) 
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1.4 DVD contents 

The DVD-ROM 
The DVD-ROM includes your installation software for WindLGC and contains additional useful 
information.  

Start.html 
This file guides you through the contents of the DVD-ROM. It helps you to perform these 
tasks: 

• Install WindLGC 

• Start WindLGC 

The file also provides you with access to the following items: 

• CAD drawings 

• Manuals 

• Drivers 

Folders on the DVD-ROM: 
The list below describes some of the folder contents of the DVD_ROM: 

• The ..\CAD folder contains CAD drawings of the IDEC SmartRelay devices. 

• The ..\Manual folder contains the current IDEC SmartRelay User's manual as a PDF file that 
you can read with Acrobat Reader. 

• The ..\Onlinehelp folder contains the current WindLGC online help as a PDF file that you 
can read with Acrobat Reader. 

• The ..\Tools folder contains the following two folders and a reset file: 

– The ..\FL1F Access Tool folder contains an add-in for Excel and the current FL1F Access 
Tool Help as a PDF file that you can read with Acrobat Reader. 

– The ..\FL1F Web Editor folder contains the installation file and the current FL1F Web 
Editor Online Help as a PDF file that you can read with Acrobat Reader. 

– The _reset.bm file is what you can use to reset your IDEC SmartRelay BM to factory 
setting. Refer to Factory Reset SmartRelay (Page 80) section for detailed operations. 

• The..\Readme folder contains an HTML readme file that includes information that you 
need to know prior to installation. 
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• The ..\Sample folder contains a few sample applications, which give you example solutions 
for a few of the many fields of applications of the versatile IDEC SmartRelay. 

• The DVD-ROM also contains the installation versions of WindLGC: 

– The ..\Windows\Application_32 folder contains the installation files for Windows 32-bit 
operating systems. 

– The ..\Windows\Application_64 folder contains the installation files for Windows 64-bit 
operating systems. 

Simply copy the corresponding ..\Application folder to your hard disk drive and start WindLGC 
by calling ..\Application\WindLGC.  

The ..\Windows\ Application_32 folder is used for Windows 32-bit operating system and the 
..\Windows\ Application_64 folder is used for Windows 64-bit operating system.  

1.5 What's new in WindLGC ? 

1.5.1 What is new in WindLGC V8.4? 
The features described below are only used for WindLGC V8.4. 

New features 
WindLGC V8.4 provides the following new features: 

• New device type in the network project mode: IDEC SmartRelay FL1F FS6 device, IDEC 
SmartRelay FL1F FS6 slave device. 

• New hardware type in diagram mode: IDEC SmartRelay FL1F FS6 device. 

• BM memory extension: VX and VR ranges can be used from V memory area. 

• IoT Cloud connection and data transfer: 

– FL1F FS6 supports IoT Cloud connection with Amazon Web Service (AWS), Azure, 
Alibaba and general MQTT broker. 

– FL1F FS6 supports synchronization of data between IDEC SmartRelay BM and the 
connected IoT cloud. 

• Batch download function: 

– FL1F FS6 supports downloading the same circuit diagram to a batch of connected IDEC 
SmartRelay BMs in diagram mode. 

– FL1F FS6 also supports downloading more than one circuit diagrams to a batch of 
connected IDEC SmartRelay BMs at the same time in network project mode. 

• Sending emails: After configured in WindLGC, FL1F FS6 can send customized-content 
emails to configured recipients at trigger events. 
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• Update Cloud: WindLGC supports to update Cloud version when needed. 

• Scanning BM: WindLGC is strengthened on scanning BM with shorter time and higher 
accuracy. 

• Certificate settings: Support checking the certificate information and updating the 
certificate. 

• Enhanced security settings: 

– Updated access control settings: Support displaying the access security status and 
adding web user and web guest user access. 

– Circuit diagram and network project encryption: Circuit diagrams and network projects 
saved in WindLGC V8.4 and later versions are encrypted. 

– HTTPS is supported. 

• Online test of IDEC SmartRelay TDE 

• Message text settings: Support Use M27 to change the character sets. 

• Zoom function: Support changing the size of text and icons for WindLGC. 

• Updated function block Message text: Support copying and pasting parameters of 
message texts in the same diagram. 

• Multi-line function: Support selecting multiple lines and connecting multiple lines to a 
block. 

• Ethernet connection configuration is moved to General tab of WindLGC settings. 

• Support eastern character for IO status name. 

• Support installing FL1F Web Editor when you install WindLGC V8.4. 

1.5.2 What's new in WindLGC V8.2? 
The features described below are only used for WindLGC V8.2. 

New Features 
 WindLGC V8.2 provides the following new features: 

• Support Go online function to scan IDEC SmartRelay TDE device in network project mode 

• Support online and offline setting for IDEC SmartRelay TDE 



WindLGC V8.4  
1.5 What's new in WindLGC ? 

 WindLGC Online Help 

16 Programming and Operating Manual, 11/2024 

• Updated function blocks: 

− Cursor Key: Set default simulation mode to Momentary pushbutton (make). 

− TD Function Key: Set default simulation mode to Momentary pushbutton (make). 

− Memory marker: Updates the background color for special memory marker. 

 - M8 = Startup memory marker (Displays blue in WindLGC) 

 - M25 = IDEC SmartRelay displays white backlight 

 - M26 = IDEC SmartRelay TDE white backlight 

 - M27 = Message Character Set memory marker (Displays green in WindLGC) 

 - M28 = IDEC SmartRelay displays the amber backlight 

 - M29 = IDEC SmartRelay displays red backlight 

 - M30 = IDEC SmartRelay TDE amber backlight 

 - M31 = IDEC SmartRelay TDE red backlight 

− Data log: New search box in property dialog. 

− Message TextFS 

 - New search box in property dialog 

 - Extended length range of bar graph in Message text (Width: 20; Height: 6). 

− Shift Register: New reset pin to reset the all shift bits and output for Shift Register. 

• Support Modbus connection in both Network Project and Diagram Modes 

• New function blocks: 

− Float/Integer Converter 

− Integer/Float Converter 

• Support NTP (Network Time Protocol) configuration 

• Enhanced import function in Network Project mode 

• Programming improvement: 

− New device type in project mode: ModBus compatible device, FL1F FS5 device and FL1F 
FS5 slave device 

− New default color for reference line 

− Ability to fill a new row in data table. By pressing Enter in the last row, WindLGC adds a 
new row and fills it according to the value in the previous row. 

• Installation languages: After you installed WindLGC V8.2, all built-in languages (English, 
German, Japanese) are installed by default. The display language is which you select 
during the installation. 

FL1F Access Tool 

IDEC provides a new tool, FL1F Access Tool, to view and trace the variables in IDEC 
SmartRelay Base module. You can also save the log files of the traced variables with this tool. 
FL1FAccess Tool uses the same password as Webserver. For more information on the 
password management, see Tools -> Transfer -> Access Control. (Page 89) 
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FL1F Web Editor 

FL1F Web Editor is a new tool used together with IDEC SmartRelay Base Module (BM) and 
WindLGC, and it provides the following features: 

● Create user-defined web pages in Editor pane 

● Visit the whole project through Web Server of IDEC SmartRelay Base Module 

For detailed information, refer to FL1F Web Editor Tool Online Help. 

1.5.3 What's new in WindLGC V8.0? 
The features described below are only used for WindLGC V8.0. 

New features 
WindLGC V8.0 provides a brand new user interface with the following features:  

• Consistent application menu display 

• New network project-based working approach 

• Split display of diagram mode (Page 31) and network project mode (Page 32) 

• Split display of standard toolbar (Page 33) in the general software interface, showing the 
programming toolbar (Page 36) under diagram mode, and showing the networking 
toolbar (Page 43) under project mode 

• Split window (Page 167) display with focus control switching and drag-and-drop 
connections capabilities 

• Ability to work on a network project (Page 420) with tasks of saving, loading, creating and 
closing the network project 

• New access control (Page 89) settings to authorize online access with different access 
occasions 

• Ability to create connections through configuring NI and NQ function blocks 

• Ability to configure screen display for message (Page 51), power-on screen (Page 87) and 
Flags (Page 245) into: 

– 4 lines for IDEC SmartRelay devices prior to FL1F 

– 6 lines for IDEC SmartRelay devices of FL1F 

• New graphical reference for the function block of parameter box (Page 178) in FBD 
diagrams 

• Enhanced system security through setting user passwords and access level accounts 
through access control (Page 89) settings 

• F1LF communication: Base Modules can communicate with each other on an Ethernet 
network with Ethernet capability. 

• UDF (User-defined function) Editor 

• SD card support 
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• Data log 

• Online test of the network transfer data and message text 

• Diagnostics for networking errors and SD card Read/Write errors 

• Simulation of the network 

• Ability to identify IDEC SmartRelay FL1F firmware version 

• I/O name import/export 

• I/O status 

• IDEC SmartRelay Base Module slave mode configuration 

• Ability to display reference information in circuit program 

• Block replacement 

• Remote change of parameters 

Other software updates 
WindLGC V8.0 also includes updates to improve the software performance and ease of use, 
for example:  

• Support for up to 20 digital outputs and 8 analog outputs 

• Support for a longer block name of up to 12 characters in ASCII format 

• New layout recovery abilities after you download the circuit program (Page 78) and load it 
again 

• New parameters of sunrise offset and sunset offset in the astronomical clock (Page 292) 
function block 

• New access control list of up to 8 list items through dynamic IP filter (Page 124) 

• New diagnostic panel (Page 124) with different kinds of error information: 

– 5 types of error information for FL1F 

• Programming improvement: (Page 172) 

– Ability to create connections without choosing the connector tool 

– Ability to add a single block with only a single click the block 

– Ability to add multiple blocks repeatedly using the stamp function by double-clicking 
the block 

• Support for saving a diagram to SD card as a Bin file which can be executed by IDEC 
SmartRelay Basic directly 

• Zooming effects update for zoom in (Page 72) and zoom out (Page 72) 

• Support for displaying 3 cams in the same panel of the Seven-day time switch (Page 286) 
function block 

• Support for using comma or semicolon as CSV separator (Page 167) 

• New printing defaults to only print the function blocks added in the circuit diagram 
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• Ability to check the open blocks in a diagram and display them in the info window 
(Page 29) (with the short-cut of F2) 

• Support for adding and configuring a client/server connection (Page 144) 

• Maximum number of blocks increased from 200 to 400 

• Amount of program memory (RAM) increased from 3800 to 8400 bytes 

• Number of Analog memory markers increased from 6 to 16 

• Number of shift registers increased from 1 to 4, and shift register bits from 8 bits to 32 
bits 

• Number of open connectors increased from 16 to 64 

• RTC buffering time extended from 80 hours to 20 days 

• Zoom factors configurable in Print Preview 

• Two additional object alignment options available 

• Two additional block sorting methods available– sort by block type or name 

• Text wrapping available for text boxes on a circuit program 

• New color setting for UDF block frame 

• Additional warning message prompt for Operating hours counter value reset when 
program downloading 

• One additional option on the Start Screen display 

• Ability to link comments to function blocks and cut connectors 

• LAN time synchronization added to the Set clock function 

 

 Note 

IDEC SmartRelay FL1F no longer supports an RTC (Real Time Clock) battery card. 
 

New project-based working approach 
WindLGC V8.0 provides a brand new working method with which you can easily build up your 
network project in a conceptual network view. You are even able to configure network 
connections by simply dragging and dropping the I/O points of the devices or the network 
compliant function blocks from one to another.  

New connectors 
WindLGC V8.0 provides new network connectors: 

• Network inputs (FL1F and later versions only) (Page 248) 

• Network analog inputs (FL1F and later versions only) (Page 251) 

• Network outputs (FL1F and later versions only) (Page 252) 

• Network analog outputs (FL1F and later versions only) (Page 254) 
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New SFBs 
The following SFBs are new: 

• Astronomical clock (FL1F and later versions only) (Page 292) 

• Analog filter (FL1F and later versions only) (Page 327) 

• Max/Min (FL1F and later versions only) (Page 329) 

• Average value (FL1F and later versions only) (Page 332) 

• Stopwatch (FL1F and later versions only) (Page 294) 

Updated SFBs 
The following SFBs support new features: 

• Message text (IDEC SmartRelay FL1F and later versions) (Page 356) 

• Shift register (FL1F) (Page 381) 

Additionally, WindLGC V8.0 supports new reference parameters for some blocks, such as 
timer blocks and the analog filter block. 

1.5.4 What was new in WindLGC V6.1 compared with V5.x? 

New SFBs 
WindLGC V6.1 introduced the following SFBs:  

• Pulse Width Modulator (PWM) (Page 321) 

• Analog math (Page 324) 

• Analog math error detection (Page 384) 

Updated SFBs 
The following SFBs support new features: 

• Message text (Page 363) 

• Operating hours counter (Page 299) 

• Seven-day time switch (Page 286) 

• Twelve-month time switch (Page 289) 

• Analog watchdog (Page 314) 

• Up/Down counter (Page 296) 

Additionally, WindLGC supports new reference parameters for many blocks (Page 263). 
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New IDEC SmartRelay TD module 
IDEC SmartRelay supports a new text display module. This IDEC SmartRelay TD module 
extends the display and user interface capabilities of an IDEC SmartRelay Base Module. 
WindLGC provides configuration of the following IDEC SmartRelay TD features: 

• Power-on screen 

• Function keys 

• Message texts 

• Backlight function 

For further information about the IDEC SmartRelay TD module, refer to your product 
information and the IDEC SmartRelay User's Manual. 

New features 
WindLGC together with the IDEC SmartRelay FL1E hardware series provides the following 
new features: 

• Method to delete user program and password from IDEC SmartRelay FL1E 

• Additional languages, resolution, and backlight function for the IDEC SmartRelay FL1E 
onboard display 

• Ability to perform online tests of LAD circuit programs 

• Display of PI controller analog output value in a trend view during simulation or online test 

• USB cable communication between a PC and IDEC SmartRelay Base Module 

• New memory card, battery card and combined memory/battery card for IDEC SmartRelay 
FL1E devices. 

Changed functionality 
WindLGC provides changes in the following areas: 

• Number of user program blocks increased to 400 blocks 

• Additional retentive memory for a total of 250 bytes 

• Configuration support for all I/O changes to IDEC SmartRelay Base Modules and expansion 
modules 

Prior versions 
For information about features that were new in versions prior to WindLGC V6.1, refer to the 
documentation for earlier versions.  
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1.6 Ladder Diagram (LAD), Function Block Diagram (FBD) and User-
Defined Function (UDF) 

WindLGC provides you with three options of creating circuit programs:  

• Ladder diagram (LAD) 

• Function block diagram (FBD) 

• User-defined function (UDF) 

Who will use the ladder diagram (LAD)? 
The LAD program editor is suitable for users who are used to working with circuit programs. 

Who will use the function block diagram (FBD)? 
The FBD program editor is suitable for users who are familiar with the logic boxes of Boolean 
algebra. 

What is the User-Defined Function (UDF)? 
UDF is a circuit logic diagram of a group of function blocks, and can be used as a function 
block in an FBD. 

In the following contents, a UDF is called a UDF type, and the copy of a UDF is called a UDF 
instance. For details, see Using the UDF in an FBD circuit program or another UDF (Page 407). 

 

Differences between LAD, FBD and UDF in the online help 
The online help primarily describes the FBD Editor, because its functionality is closely related 
to that of the LAD Editor. The UDF is described separately. Where LAD, FBD and UDF differ, 
the online help describes the differences. The following symbol in the online help indicates 
the difference in LAD, FBD and UDF functionality: 

 

Converting circuit programs 
For information on converting circuit programs, refer to the topics for converting LAD to FBD 
and from FBD to LAD. 

Switching between LAD, FBD, and UDF 
You can switch the editor from the Options selection of the Tools menu (Page 46). 
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1.7 IDEC SmartRelay and WindLGC on the Internet 
From the Support selection at (http://www.idec.com/usa/) you will find abundant information 
about IDEC SmartRelay and WindLGC:  

• Updates and upgrades (Page 170) for WindLGC 

• FAQs (frequently asked questions) 

• Downloads of current manuals 

• News and other information 

1.8 Compatibility 

Compatibility with previous IDEC SmartRelay Hardware series 
  

For FL1F series, WindLGC uses device type to distinguish different IDEC SmartRelay device. 
For more information, you can refer to the following table. 
 
Device Device type in WindLGC WindLGC Version 
SmartRelay BM 
(FL1F-H12RC*, FL1F-
B12RC*, FL1F-H12SCD) 

SmartRelay FL1F WindLGC V8.0 and later version 
SmartRelay FL1F FS5 WindLGC V8.2 and later version 
SmartRelay FL1F FS6 WindLGC V8.4 and later version 

SmartRelay TDE 
(FL1F-RD1) 

SmartRelay TDE WindLGC V8.0 
SmartRelay TDE FS4 WindLGC V8.2 and later version 

WindLGC V8.4 brings in a new project type "snp". You can view and edit the snp file with 
WindLGC V8.4 and later versions. 

You can also use the current WindLGC version to create circuit programs for the previous IDEC 
SmartRelay hardware series. You cannot, however, download programs that use the new 
SFBs or new SFB parameters to IDEC SmartRelay devices prior to the FL1F FS5 series. WindLGC 
provides a list of hardware that is compatible with your circuit program from the Tools → 
Select Hardware (Page 133) menu command. You can download your circuit program to any 
device in the list. 

You can continue to use the input connectors of some of the IDEC SmartRelay FL1F FS5 
devices as they were prior to FL1F FS5, that is, as inputs. For FL1F and later versions, these 
inputs can also be used for analog inputs or high-speed counters. Existing WindLGC programs 
that use these connectors as inputs will function in the same way as they did. New programs 
can make use of the new analog inputs and high-speed counters. Refer to your product 
information and the IDEC SmartRelay User's Manual for detailed information about these 
modules. 

http://www.idec.com/usa/
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Any differences concerning the operation of WindLGC that are based on differences between 
the previous series and IDEC SmartRelay FL1F FS5 are described separately. If programming 
differences exist based on the IDEC SmartRelay series, this online help system uses this 
graphic to alert you to those differences: 
 

 

Compatibility with previous versions of WindLGC 

You can edit and expand circuit programs written with older versions of WindLGC using your 
current WindLGC version. 

Compatibility with previous IDEC SmartRelay memory cards 
Refer to the IDEC SmartRelay User's Manual for compatibility information regarding IDEC 
SmartRelay memory cards. WindLGC does not access programs stored on memory cards. 

Suggested operating systems 
WindLGC V8.4 supports the following operating systems:  

• Windows: Windows 7 (64 bit), Windows 8 (64 bit) , Windows 10 (32 bit / 64 bit) or 
Windows 11 with the following requirements: 

– PC with Pentium IV processor 

– 1 GB free hard disk space 

– 512 MB RAM 

– SVGA graphics card with minimum of 1024 x 768 resolution (at least 256 colors) 

– DVD-ROM 

• Java Runtime Environment Amazon Corretto 11.0.13.8.1, which is recommended 
version. 

Comparison between BM version number and hardware type in WindLGC 
 
BM version number FM version number  Hardware type in WindLGC 
FL1F FS4 or previous version 1.08.02A FL1F 

1.08.02B 
1.08.02C 

FL1F FS5 1.82.01 FL1F FS5 
FL1F FS6 or later version 1.84.01 FL1F FS6 
TDE FS3 or previous version 1.08.02A TDE 

1.08.02B 
1.08.02C 

TDE FS4 or later version 1.82.01 TDE FS4 
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 Note 

You can find the BM version number on the base module. Refer to FL1F manual for more 
information. 

 

See also 
IDEC SmartRelay Hardware (Page 411) 

Here you find information about the individual hardware series. This topic also includes a 
table from which you can see which basic and special functions are available as of which 
hardware series. 
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User interface 2 
2.1 User interface - Overview 

Programming interface  
WindLGC program mode starts with an empty circuit diagram.  

The programming interface for creating your circuit programs occupies the greater part of the 
screen. The icons and logical links of the circuit program are arranged on this programming 
interface. 

To help you to maintain an overview of large circuit programs, the right side and the bottom 
of the programming interface contain scroll bars, which you can use for vertical and 
horizontal scrolling of the circuit program. 

 
 
① Menu bar ⑤ Programming interface 
② Standard toolbar ⑥ Status bar 
③ Mode bar ⑦ Diagram tree 
④ Programming toolbar ⑧ Instruction tree 
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Project interface 
WindLGC project mode starts with the empty user interface of WindLGC. After you choose 
and add a new device in the project, WindLGC enables the diagram editor frame.  

WindLGC displays a Network view in the project interface that shows the devices and network 
connections. The Diagram editor displays the program blocks and logical links of the circuit 
program. Initially, the circuit program is empty.  

To help you to maintain an overview of large circuit project and programs, the right side and 
the bottom of the Network view and programming interface contain scroll bars, which you 
can use for vertical and horizontal scrolling of the circuit program. 

 
 
① Menu bar ⑥ Programming toolbar 
② Standard toolbar ⑦ Programming interface 
③ Mode bar ⑧ Status bar 
④ Networking toolbar ⑨ Device tree 
⑤ Network view ⑩ Instruction tree 
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Menu bar 
The top of the WindLGC window contains the menu bar (Page 45). Here, you can find various 
commands for editing and managing your circuit programs, as well as functions for defining 
your default settings and for transferring of the circuit program to and from IDEC SmartRelay. 

Toolbars 
WindLGC provides the following four toolbars: 

• Standard toolbar (Page 33) 

• Programming toolbar (Page 36) 

• Simulation toolbar (Page 34) 

• Networking toolbar (Page 43) 

Standard toolbar 
The standard toolbar (Page 33) appears above the programming interface. Initially, WindLGC 
shows you a reduced standard toolbar that provides only the essential functions.  

The standard toolbar provides direct access to the essential functions of WindLGC. 

After you have opened a circuit program for editing on the programming interface, you can 
see the complete standard toolbar. 

 
You can use the icons to create a new circuit program or to download, save an existing 
program or project, cut/copy and paste objects, undo/redo the last action, or initiate data 
transfer to and from IDEC SmartRelay devices. 

Programming toolbar 
The top of the programming interface contains programming toolbar (Page 36). You can use 
the icons on this toolbar to change to other editing modes, or for quick and easy creation or 
editing of a circuit program. 

 
You can use the icons to connect/comment/align the blocks, redo/undo the last action, add 
the functional blocks, split windows, simulation/online test the diagram and expand/collapse 
the parameter box. 
 

 

The LAD Editor no longer contains the Basic function (GF) icon, because you 
create logical "AND" and "OR" links by interconnecting individual blocks. 

Simulation toolbar 
This toolbar (Page 34) is only relevant for the simulation of circuit programs. 
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Status bar 
The status bar (Page 30) is located at the bottom of the program window. It shows the 
currently active tool, the program status, the zoom factor, the page number of the circuit 
program and the selected IDEC SmartRelay device. 

2.2 Description of the Info Window 

Content 
The Info Window shows the following information:  

• Error messages generated at the start of simulation 

• IDEC SmartRelay devices that are determined for a program download, as determined by 
the Tools → Determine IDEC SmartRelay  (Page 133) menu command or the [F2] function 
key. 

• The date and time of the message 

• The name of the circuit program for which the message was generated 

If you have opened more than one circuit program, you can determine to which program the 
message belongs. 

At the start of simulation mode, the function analyzes the circuit program with regard to its 
resources and the IDEC SmartRelay to be used. The Info Window displays the resources used 
and the errors that occurred. 

The Info Window displays all information in successive order. Use the scroll bar to browse all 
the information pages. WindLGC deletes all information from the Info Window when you 
close WindLGC. 

Operation 
You can open and close the Info Window with the View → Info window (Page 71) menu 
command or the [F4] function key (Page 30). The Info window usually appears below the 
programming interface and at the right side of the block tree 

You can clear messages by clicking  in the info window. 
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2.3 Description of the status bar 
The status bar consists of four sections and contains useful information about your circuit 
program.  

 
① Information field: displays the currently used tool (Page 36). 
② Displays your selected IDEC SmartRelay by means of a WindLGC tooltip. If you have not yet 

selected an IDEC SmartRelay , or want to change the selection, you can double-click the IDEC 
SmartRelay icon to display the Tools → Select Hardware (Page 133) dialog. 

③ Shows the currently set zoom factor (Page 72). 
④ Displays the current circuit program page. 

2.4 Function keys and shortcuts 
WindLGC provides the following function keys and shortcuts for frequently called functions:  

Function keys in WindLGC: 
 
[F1] Calls the context sensitive Online Help (Page 170)  
[F2] Tools → Determine IDEC SmartRelay  (Page 133)  
[F3] Simulation start/exit (Page 138)  
[F4] View → Info Window (Page 71) 
[F5] Connector tool (Page 38)  
[F6] Constants and connectors tool (Page 242)  
[F7] Basic functions tool (Page 257)  
[F8] Special functions tool (Page 263)  
[F9] Text tool/Insert comments tool (Page 38)  
[F10] Opens the menu bar (Page 45)  
[F11] Cut/Join tool (Page 38)  

Shortcuts in WindLGC: 
 
 In the File menu (Page 46): 
[Ctrl+N] File → New (Page 46) (opens the default editor specified under 

Tools/Options/Editor) 
[Ctrl+O] File → Open (Page 47)  
[Ctrl+F4] File → Close (Page 48) 
[Ctrl+S] File → Save (Page 49)  
[Ctrl+Shift+F1] File → Print preview (Page 50)  
[Ctrl+P] File → Print (Page 50)  
[Alt+Enter] File → Properties (Page 53) 
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[Alt+F4] File → Exit (Page 60)  
 In the Edit menu (Page 61): 
[Ctrl+Z] Edit → Undo (Page 62)  
[Ctrl+Y] Edit → Redo (Page 62)  
[DELETE] Edit → Delete (Page 62) 
[Ctrl+X] Edit → Cut (Page 62)  
[Ctrl+C] Edit → Copy (Page 62)  
[Ctrl+V] Edit → Paste (Page 63)  
[Ctrl+A] Edit → Select all (Page 65)  
[Ctrl+G] Edit → Go to block (Page 66)  
 In the View menu (Page 69): 
[Ctrl+M] Select Connections (Page 71)  
[Ctrl+mouse 
wheel] 

View → Zoom in (Page 72)  
View → Zoom out (Page 72)  

 In the Tools menu (Page 73): 
[Ctrl+D] Tools → Transfer: PC → IDEC SmartRelay  (Page 78)  
[Ctrl+U] Tools → Transfer: IDEC SmartRelay → PC (Page 79)  
[Ctrl+H] Tools → Select Hardware (Page 133)  
[Ctrl+-] Tools → Compare (Page 133)  

 

 

 
How to access functions via the shortcut menu (Page 423)  

2.5 Diagram mode 
In diagram mode, you can create, edit, simulate download and upload your circuit program. 
The programming interface for creating your circuit programs occupies the greater part of the 
screen. The icons and logical links of the circuit program are arranged on this programming 
interface. The diagrams tree and instructions tree are arranged on the left of the 
programming interface. 

• Diagram tree (Page 31) 

• Instructions tree (Page 32) 

• Diagram editor (Page 32) 

2.5.1 Diagram tree 
You can manage your diagrams in the circuit diagram tree. This diagram tree lists all the 
diagrams you newly created or opened. You can switch to a diagram by double clicking its 
name in the diagram tree.  

You can open and close this diagram tree via the icons  or  of the diagram and 
instructions trees. 
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2.5.2 Instruction tree 
This instruction tree provides a hierarchical list of all elements you can use to create your 
circuit program.  
 

 

How to select blocks and place them into your circuit program quickly 
(Page 421)  

2.5.3 Diagram editor 
The diagram editor is the working space for the circuit program. It displays all the opened and 
newly created circuit programs. You can switch to a certain circuit program by clicking its title 
on top of the editor. You can view two or three circuit programs at the same time by splitting 
the working space to two or three windows. 

 

 Note 

Only the IDEC SmartRelay FL1F circuit programs in the project mode supports two-side 
programming. 

When you edit the circuit diagrams in split windows in project mode, you can connect the 
blocks between different IDEC SmartRelay FL1F circuit programs. For more information on 
two sides programming, see Two-side programming (Page 199). 

 

2.6 Network project 
In the project mode, you can configure your network project and manage the circuit 
program. The network view for configuring the network occupies the greater part of the 
screen. When you add a new device in the network, WindLGC creates a new circuit diagram 
automatically. The Network project tree and instruction tree appear to the left of the 
programming interface.  

• Network project tree (Page 32) 

• Network view  (Page 33) 

• Diagram editor (Page 32) 

• Instruction tree (Page 32) 

 

2.6.1 Network project tree 
You can manage your devices in the network project tree. This tree lists all the devices in the 
network project. You can add new devices and configure their settings in the network project 
tree.  

You can open and close the network project and instructions trees via the icons  or  . 
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2.6.2 Network view 
The network view is the working space for configuring the network and displays all the 
devices you have added to the network. You can add/delete devices, configure the settings of 
each device and set the Ethernet connections in the network view. 

2.7 Toolbars 

2.7.1 Standard toolbar overview 
 

The icons of the standard toolbar provide quick access to commands that are also available 
on the menu.  

 
The following commands are found in the standard toolbar: 
 

 File: New (Page 46)  
  Open (Page 47)  
  Close (Page 48)  
  Save (Page 49)  
  Print (Page 50)  

 Edit: Delete (Page 62)  

  Cut (Page 62)  
  Copy (Page 62)  
  Paste (Page 63)  
  Undo (Page 62)  
  Redo (Page 62)  
  Tools: Start IDEC SmartRelay Mode (Page 79)  
   Stop IDEC SmartRelay Mode (Page 79) 
  PC → IDEC SmartRelay (Download) (Page 78)  
  IDEC SmartRelay → PC (Upload) (Page 79)  
 Help: Context-sensitive help (Page 170)  



User interface  
2.7 Toolbars 

 WindLGC Online Help 

34 Programming and Operating Manual, 11/2024 

2.7.2 Simulation toolbar and status window 

The toolbar 
When you open simulation mode, WindLGC displays the simulation toolbar, which contains 
the following icons.  

• Icons (for example, switches) for operator control of the inputs (Page 187) 

• An icon for the simulation of a power failure (Page 188) , for testing the switching 
response with reference to retentivity characteristics after power failure 

• Icons (for example, bulbs) for monitoring outputs (Page 188) 

• Simulation control icons 

• Time control icons 

• Data Table icon 

 
Click "<<" to hide a partial area of the toolbar. To show this area again, click ">>". 

Simulation control icons 
 

 
Start simulation 

 
Stop simulation 

 Hold simulation (pause) 

 Simulate network. If no IP address is configured for a circuit program in WindLGC, the 
network simulation icon is inactive (grey-colored). 

 
Show message window 

Time control icons 
If you have programmed a time-sensitive circuit, you can use the time control to monitor the 
reaction of your circuit program. 
 

 Start simulation for a specific time or number of cycles. 
Set the period and the number of cycles using the following icons. 

 

 

Set the period and the time base for a time-limited simulation or set a specific number 
of cycles 
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Display the current time in WindLGC 

 Modify the current time in WindLGC 

Data Table icon 

 
You can view VM (Variable Memory) values in a data table. For simulation, the values are 
updated each cycle. For online test, the values are updated after each communication. 

Status display 
Prerequisite: You can enable the display of signal states and process variables with the Tools 
→ Options: Simulation (Page 166) command. 

The colored indication identifies the "1" or "0" status of a connecting line. By default, 
connection lines carrying a "1" signal are red while the lines carrying a "0" signal are blue. 

Example for the FBD Editor: 
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PI controller trend view 
If your circuit program includes one or more PI controller function blocks, the simulation 
displays a trend view window of the analog output that shows the change in the AQ and PV 
values relative to the SP parameter over time. The trend view is continually updated while the 
simulation is in progress, at the frequency of the sample period that you configure. You can 
enable or disable the individual displays of the AQ, PV, and SP trend graphs as you choose. 

 
 

If your circuit program has more than one PI controller function block, the trend view has a 
separate tab for each PI controller. 

2.7.3 Programming toolbar 
The programming toolbar contains integral icons for creating, editing and testing programs. 
Each one of these tools represents a programming mode, in which mouse operations have 
different effects.  
 

 Edit: Selection tool (Page 37)  

  Connector tool (Page 38)  

  Cut/Join connection (Page 38) 

  Text tool/insert comments (Page 38) 

 Format: Align Automatically (Page 64) 

  Align Vertically (Page 63) 

  Align Horizontally (Page 63) 

  Horizontally Distribute Space (Page 64) 

  Vertically Distribute Space (Page 63) 
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  Bring to Front (Page 66) 

  Send to back (Page 66) 

 Edit Undo (Page 62) 

  Redo (Page 62) 

  Constants and Connectors (Page 242)  
  Basic functions (FBD and UDF editors only) (Page 257)  
  Special functions (Page 263)  
   Data Log Profile (Page 392) 

 
View: Undo split (Page 167) 

 
 Split into two windows (Page 167) 

 
 Split into three windows (Page 168) 

  Zoom in (Page 72) 

  Zoom out (Page 72) 

  Select Lines (Page 71) 

 File: Page Layout (Page 39)  

 Tools: Circuit program conversion (Page 39) 

  Simulation (Page 138)  

  Online test (Page 40)  

  Hidden parameter box line (Page 42) 

  Expand all parameter box (Page 42) 

  Collapse all parameter box (Page 42) 

2.7.3.1 Selection tool 

 
You can use the selection tool to select and move blocks, text and connecting lines. You can 
select objects individually with a left-click; you can select multiple objects with [Ctrl]+Click, or 
you can use the mouse as a "lasso" to surround objects with a rectangle and capture them as 
a selection.  

You can use the selection tool to select mulitiple lines and connect multiple lines which have 
the same output function block to a block. 



User interface  
2.7 Toolbars 

 WindLGC Online Help 

38 Programming and Operating Manual, 11/2024 

To select multiple lines, use one of the following methods: 

• Keep the left mouse button pressed and draw a frame, and then release the mouse 
button. 

 
  Note 

If there is a function block in the frame, no line is selected. 
 

• Hold down the CTRL key and press the left mouse button, and then select lines as you 
need. 

To connect multiple lines which have the same output function block to a block, select the 
connector with a left-click and move the connector to another function block as you need. 

You can call the selection tool in any other tool by pressing the [ESC] key or by clicking on the 
icon in the programming toolbar. 

Selecting objects (Page 180)  

2.7.3.2 Connector tool 
  

You can use this tool to connect blocks. To do so, move the mouse pointer to a block input or 
output and press the left mouse button. Keep the mouse button pressed and drag the mouse 
pointer from your selected source terminal to the target terminal. Now release the mouse 
button to anchor the connecting line to both terminals. WindLGC displays the connecting 
lines as a straight line between the first terminal and the mouse pointer while you are 
dragging the mouse. Once you anchor the connection line, WindLGC displays the connection 
line as a combination of horizontal and vertical lines, which you can manipulate using the 
selection tool (Page 37).  

For more information on how to connect the blocks, refer to Connecting blocks (Page 175) . 

2.7.3.3 Cut/Join 

 
You can use this tool to cut and join connections between blocks. Left-click the Cut/Join icon 
to activate the tool. To cut a connection, left-click the relevant line while the Cut/Join tool is 
active. When you cut a connection of two blocks, a reference to the partner block appears 
beside each of the block. The reference displays the page number, block number and the I/O 
of the partner block.  

Cut connections (Page 182)  

2.7.3.4 Text tool 

 
You can use this tool to insert or edit user-defined text objects in the programming interface. 
You can create labels for specific blocks. These labels remain with the block whenever you 
move or delete the block. You can associate only one label per block. For each label, you can 
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specify the font type, font size, and font color. To create an associated label, click directly on 
the required block when the text tool is selected.  

There can only be one associated label for each block.  

You can configure "Wrap Text" format for the label text figures. You can adjust the size of a 
text figure typically by dragging the rectangle handles. You cannot enlarge or reduce the 
dimension of text figures that are not in Wrap Text format.  

See also Documentation of the circuit program (Page 184)  

2.7.3.5 Page Layout 
  

In the Page Layout tab, you can specify how and on how many pages to print your circuit 
program. You can preview the pagination in this tab. If you choose more than one program 
page, WindLGC indicates the page breaks with green lines. When you subsequently print the 
circuit program, WindLGC uses this pagination. Note that connections extending to other 
pages are simply cut off when you print the hardcopy. IDEC recommends you to create cross-
references by splitting the file at this position with the help of the Cut/Join tool (Page 38). In 
the File → Page Setup (Page 50) menu you can specify the paper size, page alignment and 
margins.  

The total number of pages(horizontal x vertical) must not exceed 100. 

The standard toolbar (Page 33) also contains an icon for this menu command.  

2.7.3.6 Conversion tool 

 
Use this function to convert your circuit program between LAD and FBD.  

The following rules apply to the conversion from LAD to FBD: 

• A series circuit of contacts is converted into an AND block. 

• A parallel circuit of contacts is converted into an OR block. 

• User-defined comments are not included, as their position in the circuit program cannot 
be defined based on blocks. 

• Crosslinks (connections where a block output is connected to multiple block inputs and at 
least one of the inputs is connected to multiple block outputs) are converted into an OR 
block. 
Inputs for the OR block are all block outputs of the crosslink. 
The output of the OR block is connected to all block inputs of the crosslink. 

• Internal flags are resolved, and the current paths are linked. 

 

 
This function is inactive in the UDF Editor. 
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Use this function to convert your circuit program between FBD and LAD.  

• An AND block is converted into a series contact circuit 

• An OR block is converted into a parallel contact circuit 

• Comments for basic functions are not applied in LAD, as a basic function is converted into 
multiple contacts. Thus, the comment cannot be assigned definitely. 

• In LAD, input comments are assigned to all contacts of this input. 

• User-defined comments are not included, as their position in the circuit program cannot 
be defined based on blocks. 

• XOR blocks must be converted into corresponding LAD logic consisting of positive and 
negative contacts. 

 

 Note 

When converting between LAD and FBD, the total number of blocks in your circuit program 
can sometimes increase. In this case, the number of blocks for your circuit program may 
exceeds the permitted number of a circuit program can use. 

Therefore, you cannot always convert FBD programs to LAD. 

Remedy: Under Tools -> Select Hardware (Page 133), select the hardware series that you are 
using. Start converting to LAD. Then under Tools -> Determine SmartRelay (Page 133), see 
which hardware series is compatible with the circuit program. 

If your circuit diagram contains a UDF block, you cannot use this function to convert it from 
FBD to LAD. 

 

2.7.3.7 Online test 

 
The online test and simulation (Page 138) modes allow you to monitor the execution of your 
circuit program and how it reacts to the various input states.  

For WindLGC V8.4 and later versions, if IDEC SmartRelay TDE device is connected with IDEC 
SmartRelay BM, when you perform an online test for BM, messages shown on the connected 
TDE device are displayed. 

 

 Note 

If SmartRelay BM is connected with multiple SmartRelay TDE devices, messages of only one 
SmartRelay TDE are displayed and you can select which SmartRelay TDE to display. 

 

Difference from simulation mode 
In simulation mode you execute your circuit program on the PC. To do so, you do not require 
an IDEC SmartRelay. You can preset the status of inputs on the PC. 
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During an online test, IDEC SmartRelay executes the circuit program and you can monitor this 
"work" of IDEC SmartRelay. The status of the inputs corresponds with the actual states at IDEC 
SmartRelay inputs. 

Prerequisite for an online test 
You must link your PC to an IDEC SmartRelay. WindLGC uses the interface you specified in 
Tools → Transfer (Page 73) to link to IDEC SmartRelay.  

You can test a circuit program in either FBD or LAD format and you must transfer it to IDEC 
SmartRelay for the online test. 

The circuit programs in WindLGC and on IDEC SmartRelay must be identical. Upload the 
program from IDEC SmartRelay to your PC, or download the program from your PC to IDEC 
SmartRelay if necessary. 

You can monitor the parameters of up to 30 blocks. The number of blocks you can monitor 
simultaneously decreases when you monitor blocks that contain a high number of 
parameters (for example, analog SFBs). 

Starting the online test 
Click the online test icon  in the programming toolbar. 

If IDEC SmartRelay is in STOP, start it with the start button. 
Result: IDEC SmartRelay executes your circuit program. 

Switching IDEC SmartRelay to STOP 
If you want to stop IDEC SmartRelay via WindLGC, click the stop icon .  
 

  
Devices of the FL1C series and later support online tests. 

Possible errors 
The following types of errors can occur: 

• Your IDEC SmartRelay does not support the online test. 
Remedy: Install an IDEC SmartRelay device of the FL1C or later series. 

• The programs on your PC and on IDEC SmartRelay are different. 
Remedy: Upload the circuit program from IDEC SmartRelay to your PC, or download the 
program from your PC to IDEC SmartRelay. 

• You are attempting to monitor too many parameters/blocks simultaneously. 
Remedy: Reduce the number of simultaneously monitored parameters/blocks. 

• The communication between your PC and IDEC SmartRelay is down. 
Remedy: Re-establish the connection. 

 

  
This menu command is inactive in the UDF Editor. 
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2.7.3.8 Showing/hiding reference line (FL1F and later versions only) 

 
You can use this tool to show and hide reference line between parameter boxes. When the 
parameter boxes are hidden, you can press this button to show or hide the reference line 
between boxes. 
 

 
Show the reference line 

 
Hide the reference line 

2.7.3.9 Expanding all parameter boxes (FL1F and later versions only) 

 
You can use this tool to expand all the parameter boxes. When you press this button, all the 
parameter boxes in the working circuit program are expanded. 
 

 
The parameter boxes are collapsed. 

 
The parameter boxes are expanded. 

2.7.3.10 Collapsing all parameter boxes (FL1F and later versions only) 

 
You can use this tool to collapse all the parameter boxes. When you press this button, all the 
parameter boxes in the working circuit program are collapsed. 
 

 
The parameter boxes are expanded. 

 
The parameter boxes are collapsed. 
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2.7.4 Networking toolbar (FL1F and later versions only) 
The network toolbar appears above the Network view and contains the following icons: 
 

 Add new device (Page 196) 

 Go Online (Page 43) 

 Go Offline (Page 45) 

 Zoom In (Page 72) 

 Zoom Out (Page 72) 

 
Show/ Hide device line (Page 45) 

2.7.4.1 Going online (FL1F and later versions only) 

 
You can use this tool to test online connection for IDEC SmartRelay BM and IDEC SmartRelay 
TDE FS4. 

 

 Note 
Network requirements for going online 

The Go online function does not work if your network is in a public or unidentified work 
environment. It works only when your network is in a private, home or work network 
environment. Make sure you set your network location correctly before going online.  

 

For devices that are configured in a network project, you can press the Go online button to 
detect the status of each IDEC SmartRelay device (FL1F or IDEC SmartRelay TDE FS4). 

If the configured device is accessible, WindLGC shows a green check mark on the top-left 
corner of the device image. 

 
 
IDEC SmartRelay BM IDEC SmartRelay TDE FS4 
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If the configured device is inaccessible, WindLGC shows a question mark in the top-left corner 
of the device image. 
 
IDEC SmartRelay BM IDEC SmartRelay TDE FS4 

  
 

 

 Note 

To make sure the Go online function works properly, you must connect the devices to the PC 
in the Network view. 

 

For devices which are in the same subnet as the selected network card and are not 
configured in the network project, you can press the Go online button to detect it and add it 
to the project. WindLGC adds the detected device to the project as an unknown device. 
 
IDEC SmartRelay BM IDEC SmartRelay TDE FS4 

  

For more information on the configuration of device connection, refer to Ethernet 
Connection Configuration (Page 206). 

 

 Note 
Online settings for IDEC SmartRelay BM and TDE 

When Go Online is still in process, scanning devices is not available in configuring online 
settings for IDEC SmartRelay BM and IDEC SmartRelay TDE FS4. You need to terminate the Go 
Online process before configuring online settings. 

For information on IDEC SmartRelay BM and TDE devices online settings configuration, refer 
to Device setting configuration (Page 201). 
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2.7.4.2 Going offline (FL1F and later versions only) 

 
Click Go offline to stop scanning online devices. 

 

 Note 

If you want to add an unknown device in your project, configure it after you detected it. 
When you click Go offline, WindLGC removes all unknown devices in the network view and all 
the accessible status.  

 

2.7.4.3 Show/Hide device line 
  

You can use this tool to show and hide cable line between local PC and the devices in the 
network view.  
 

  
Show device line Hide device line 

2.8 Menu bar 
The menu bar contains administrative and editing functions for the circuit program and 
provides access to the context-sensitive help. 

• File menu (Page 46) 

• Edit menu (Page 61) 

• Format menu (Page 68) 

• View menu (Page 69) 

• Tools menu (Page 73) 

• Window menu (Page 167) 

• Help menu (Page 168) 
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2.8.1 File menu 
The File menu command contains commands for file management. Included are also 
commands for downloading, saving or creating circuit programs, for setting general file 
properties and for printing:  

• New (Page 46) 

• Open (Page 47) 

• Close (Page 48) 

• Close All Diagrams (Page 48) 

• Save (Page 49) 

• Save As (Page 49) 

• Page Setup (Page 50) 

• Print Preview (Page 50) 

• Print (Page 50) 

• Message Text Settings (Page 51) 

• Properties (Page 53) 

• Recent Files (Page 60) 

• Exit (Page 60) 

 

 
Available in the LAD Editor only: Convert (LAD > FBD) (Page 39)  
Available in the FBD Editor only: Convert (FBD > LAD) (Page 39)  

2.8.1.1 File -> New 
  

The command opens a new window with an empty programming interface for programming 
in LAD, FBD or UDF, depending on your set mode. Depending on your default setting, 
WindLGC creates a window with a number of tabs in which you can specify the properties of 
the circuit program you are going to create. You can access this window later to either enter 
or modify the properties with the File → Properties (Page 53) menu.  

An icon for this menu command is also found in the standard toolbar (Page 33). 
 

 Note 

This function is only active in diagram mode. 
 

Switching between LAD, FBD 
You select the editor for creating a new circuit program from the Tools → Options: Standard 
Editor (Page 163) menu command. 
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Select either "FBD Diagram Editor" or "LAD Editor" from the Standard Editor drop-down list. 
WindLGC creates new circuit programs in either LAD or FBD according to your selection. 

2.8.1.2 File -> Open 
 

The command opens a dialog box from which you can select and open a previously created 
circuit program or project for further editing. Circuit programs created in WindLGC have the 
file extensions *.lsc, *.lld, *.bin, and *.lma. Projects created in WindLGC have the file 
extension *.lnp. WindLGC opens the loaded circuit program in a new window.  

The types of files that you can open are listed below: 

• WindLGC File FBD (*.lsc) 

• WindLGC File LAD (*.lld) 

• IDEC SmartRelay UDF File (*.Ima) 

• Binary dump (*.bin) 

• WindLGC Network Project File (*.lnp) 

• WindLGC Network Project File (*.mnp) 

• WindLGC Network Project File (*.snp) 

 

 Note 

For a new project, the saved project type varies: 
• For a new project, if the hardware devices include IDEC SmartRelay FL1F devices, the 

project is saved as (*.lnp) file. 
• For a new project, if the hardware devices include IDEC SmartRelay FL1F FS5 devices or 

Modbus devices, the project is saved as (*mnp) file. 
• For a new project, if the hardware devices include IDEC SmartRelay FL1F FS6 and later 

version devices, the project is saved as (*snp) file. 
 

 Note 

You can open only one project in the Network view at the same time. That means if you open 
a new project, WindLGC will close the project you are editing now. If you have not saved the 
current project, you are prompted in a dialog to save it.  

 

 Note 

The circuit diagram is always opened in diagram mode no matter you are in diagram mode or 
project mode. If you want to implement a circuit program on a device in your network 
project, right-click the device and select import in the shortcut menu. 

 

 An icon for this menu command is also available in the standard toolbar (Page 33).  
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Alternatives 
You can also open a circuit program by one of the following means: 

• In Windows you can also drag and drop a WindLGC circuit program file to the 
programming interface. When you "release" this file on the diagram tree, WindLGC opens 
it in a new window. 

• In Windows you can also drag and drop a WindLGC project file to the programming 
interface. When you "release" this file on the network project tree, WindLGC opens and the 
project you are editing is closed. 

• If you double-click a file with the extension *.lsc, *.lld, *.bin or *.lma in the file manager, 
WindLGC automatically opens the file. 

Recently-opened files 
At the end of File menu you see a list of files that were recently opened in WindLGC. 

 

2.8.1.3 File -> Close 
 

Click the Close menu command to close the active window. If you have not yet saved the 
current circuit program or project, WindLGC prompts you to save it.  

The standard toolbar (Page 33) also contains an icon for this menu command. 

As an alternative, you can right-click the tab of a circuit program and select the Close menu 
command from the shortcut menu. 

2.8.1.4 File -> Close All 
A click on this menu command closes all open windows. If you have not yet saved one or 
more of the current circuit programs, WindLGC prompts you to select the program to be 
saved in a dialog. WindLGC saves all selected programs.  
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 Note 

A click on the Close All menu command in the project mode just hides the diagrams. When 
you click the device, its diagram opens again and all the changes you made remain.  

 

2.8.1.5 File -> Save 
  

When you initially save a newly created program or project, a window opens in which you 
can specify the path and file name under which you want to save your circuit program. You 
can find additional information under File → Save as (Page 49).  

If you are saving a modified version of an existing program or project, WindLGC performs a 
quick save. The revised version overwrites the old version at the same path and name as the 
source file. 

The standard toolbar (Page 33) also contains an icon for this menu command. 

As an alternative, you can right-click the tab of a circuit program and select the Save menu 
command from the shortcut menu. 

 

 Note 

Saving a project automatically saves all of the diagrams. If you want save a diagram in the 
project separately, click the device it belongs and select export in the shortcut menu. 

 

 Note 
• Circuit diagrams saved in WindLGC V8.4 or later versions are encrypted. 
• Network projects saved as (*snp) file are encrypted. 

 

2.8.1.6 File -> Save As 
A dialog opens for you to specify the path and file name under which the current circuit 
program or project is to be saved. This allows you to save modified programs under a 
different name or folder, and thus keep previous versions for retrieval.  

The types of files that you can save are listed below: 

• WindLGC File FBD (*.lsc) 

• WindLGC File LAD (*.lld) 

• IDEC SmartRelay UDF File (*.Ima) 

• Portable Document Format (*.pdf) 

• JPG File (*.jpg) 

• Bitmap File (*.bmp) 

• Binary dump (*.bin) 
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• WindLGC Network Project File (*.lnp) 

• WindLGC Network Project File (*.mnp) 

• WindLGC Network Project File (*.snp) 

 

 
Binary dump file is only for FBD programs to be saved on an SD card: (*.bin) 

The default WindLGC file name extension is *.lsc for FBD programs, *.lld for LAD programs, or 
*.lma for UDF programs.  

You can also save the circuit program in a graphical format: *.jpg, *.bmp or *.pdf. However, 
note that such files do not contain logic elements; you cannot reopen them in WindLGC.  

The PDF file offers a special feature. Saving your circuit program in *.pdf format gives you an 
Acrobat Reader document that is easily distributable. For example, you could distribute this 
document to users who do not have WindLGC , and thus enable them to view your project in 
Acrobat Reader and make hard copies. 

As an alternative, you can right-click the tab of a circuit program and select the Save as menu 
command from the shortcut menu. 

2.8.1.7 File -> Page Setup 
This command opens a dialog box in which you can specify the page settings for creating 
circuit programs. Here you can specify the paper format, page margins or whether to print in 
portrait or landscape format.  

WindLGC offers multi-page printout feature, with the position of page breaks indicated on-
screen. The print area is user-definable.  

You can paginate your circuit program via the menu command File → Properties (Page 53). 

To set the printers, select the File → Print (Page 50) menu command. Finally, you can specify 
the scope of your hard copy with Tools → Options: Print (Page 165). 

2.8.1.8 File -> Print preview 
The print preview option shows what a hard copy of your circuit program looks like. You can 
choose the relevant icons to scroll the pages. You can also click the "Zoom In" or "Zoom Out" 
button, which allows you to zoom in or out per 25% increments. You can also print directly 
from the preview dialog.  

2.8.1.9 File -> Print 
 

This command opens a dialog with which you can select the information to print. You can 
also open this dialog from the Tools → Options: Print (Page 165).  
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 Note 

The first option refers to comments that you input in the "Comment" tab of "Properties" 
dialog. Refer to "File -> Properties - Additional info (Page 58)" for further information. 

The last option allows you to exclude pages that do not contain any graphical objects. If you 
exclude empty pages, your printout will have gaps in the page numbering where the blank 
pages were. 

 

In the printer dialog, you can specify your default printer and the print properties. In the 
control panel of your computer you can specify advanced printer settings. 

The Acrobat Reader *.pdf format provides a further print option. You can save your program 
in Acrobat Reader document format and distribute it to users who do not have WindLGC and 
can then use Acrobat Reader to view and print out your circuit program. 

The standard toolbar (Page 33) also contains an icon for this menu command. 

Set the page format under File → Page Setup (Page 50)  

2.8.1.10 File -> Message Text Settings 
Use this command to configure message text settings that apply to all message texts:  

• Character Set 1: This specifies the primary character set for message texts. Message texts 
are composed of characters from either Character Set 1 or Character Set 2. Either 
character set can be the default for configuring message texts. 

• Character Set 2: This specifies the secondary character set for message texts. Message 
texts are composed of characters from either Character Set 1 or Character Set 2. Either 
character set can be the default for configuring message texts. 
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• Use M27 to change the character sets: This determines whether the message texts of the 
primary character set or the secondary character set are displayed. If M27=0 and you 
select this checkbox, WindLGC displays the message texts of the primary character set 
(Character Set 1). If M27=0 and you select this checkbox, WindLGC displays the message 
texts of the secondary character set (Character Set 2). 

• Analog input filter timer: This time determines the frequency at which IDEC SmartRelay 
refreshes the analog values in a message text. The value is in milliseconds. 

• Ticker Timer Setting: For messages that tick, the ticker timer determines how fast or slow 
a message text ticks or scrolls on the IDEC SmartRelay onboard display. The value is in 
milliseconds, and you can use the adjacent button to access a scroll bar to set the ticker 
timer. 

Supported character sets  
WindLGC , the IDEC SmartRelay onboard display, and the IDEC SmartRelay TD support the 
following character sets: 
 
Character Set in 
IDEC SmartRelay 

Common 
Name 

Support Lan-
guages 

Internet Reference 

ISO-8859-1 Latin-1 English 
German 
Italian 
Spanish (partly) 
Dutch (partly) 

http://en.wikipedia.org/wiki/ISO/IEC_8859-1  

ISO-8859-5 Cyrillic Russian http://en.wikipedia.org/wiki/ISO/IEC_8859-5  
ISO-8859-9 Latin-5 Turkish http://en.wikipedia.org/wiki/ISO/IEC_8859-9  
ISO-8859-16 Latin-10 French http://en.wikipedia.org/wiki/ISO/IEC_8859-16  
GB-2312/GBK Chinese Chinese http://en.wikipedia.org/wiki/GB2312  
Shift-JIS Japanese Japanese http://en.wikipedia.org/wiki/Shift-jis  

 

See the message text function (Page 363) description for details on how these settings apply. 
 

 

The function for configuration message texts is inactive in the UDF Editor. 
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2.8.1.11 File -> Properties 

File -> Properties when the project window is the active window 
If you select the File -> Properties menu command when the project window is the active 
window, IDEC SmartRelay displays the "Project overview properties" dialog. In this dialog you 
configure properties such as Project name, Author, and Customer. In the Comment field, you 
can enter a description of the project or notes related to the project. In the "Network Project 
Password" field, you can set password for the network project or modify the network project 
password. 

 

 Note 

Network project password rule is as follows: 
• The maximum length of password is 10. 
• ASCII characters are supported. 

 

File -> Properties when the diagram editor is the active window 
If you select the File -> Properties menu command when the diagram editor is the active 
window, IDEC SmartRelay displays the "BM settings" dialog. In this dialog, you can configure 
offline and online settings for IDEC SmartRelay. 

You can set the following parameters for an offline IDEC SmartRelay Base Module: 

• General (Page 54) 

• Hardware type (Page 54) 

• I/O settings (Page 54) 

• I/O names (Page 66) 

• Program password (Page 56) 

• Power on (Page 57) 

• Message text (Page 51) 

• Additional info (Page 58) 

• Statistics (Page 58) 

• Comment (Page 58) 

• Modbus address space (Page 58) 

• Email event settings (Page 59) 

You can set the following parameters for an online IDEC SmartRelay Base Module: 

• Connect to SmartRelay (Page 73) 

• Show FW version (Page 80) 

• Assign IP address (Page 81) 

• Set clock (Page 83) 
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• Operating mode (Page 82) 

• Clear program and password (Page 80) 

• TD power-on screen (Page 87) 

• Hours counter (Page 122) 

• Upload data log (Page 81) 

• Diagnostics (Page 124) 

• Summer/Winter time (Page 84) 

• Access control settings (Page 89) 

• Dynamic server IP filter (Page 124) 

• NTP Settings (Page 86) 

• Cloud data transfer settings (Page 93) 

• Cloud connection settings (Page 94) 

• Certificate settings (Page 120) 

• Email settings (Page 120) 

2.8.1.12 File -> Properties - General 
In this tab, you can set the name and IP for your device. You can input the address, subnet 
mask and gateway to assign an IP to the IDEC SmartRelay Base Module. You can configure the 
Ethernet connection for your device.  

In the Program name field, you can enter a program name with up to 16 characters for the 
circuit program. After transfer, IDEC SmartRelay onboard display shows the circuit program 
under this name.  

In the Ethernet connections field, you can enbale FL1F access or Modbus access and 
configure the Ethernet connection. 

2.8.1.13 File -> Properties - Hardware type 
This tab shows the basic information of IDEC SmartRelay Basic, such as known blocks, 
constants/connectors, and the number of digital inputs. 

2.8.1.14 File -> Properties - I/O settings 
When you download the circuit program, WindLGC also transfers the I/O settings to IDEC 
SmartRelay. 

With the setting ①, you can set what the analog outputs of IDEC SmartRelay should be when 
IDEC SmartRelay is in STOP mode and the range of the outputs value. Your choices are as 
follows. 

For "Behavior of analog outputs in STOP mode", select one of the following choices: 

• All outputs keep the last value 

• AQ1 to AQ8 are set to values that you define 
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For "Set analog outputs value range type", select one of the following choices:  

• 0 mA to 20 mA or 0 V to 10 V 

• 4 mA to 20 mA 

With the setting ②, you can choose to enable the optional AI3 and AI4 on the IDEC 
SmartRelay FL1E and later version devices that have an option of four analog inputs. For IDEC 
SmartRelay FL1E and later version devices that support four analog inputs, you can choose 
how many to use. Your choices are as follows: 

• Enable 0 AIs: No AI available for use in your circuit diagram. 

• Enable 2 AIs: Only AI1 and AI2 corresponding to input terminals I7 and I8 are available for 
use in your circuit program. 

• Enable 4 AIs: AI1 and AI2 corresponding to input terminals I7 and I8 are available for use 
in your circuit program. Additionally, AI3 and AI4 corresponding to input terminals I1 and 
I2 are available for use. 

IDEC SmartRelay FL1F devices support 8 analog inputs and 24 digital inputs. 
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2.8.1.15 File -> Properties - Program password 
When you transfer the circuit program, WindLGC also transfers the password specified in 
Program password tab to IDEC SmartRelay.  
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You can assign a password to your circuit program or change or delete an already assigned 
password. To assign a new password, you must enter the password in the two text boxes for 
New password and then confirm with OK. The password can have a maximum of 10 
characters. To change the password, you must first enter the existing password in the Old 
password text box and the new password in the two boxes for New password and then 
confirm with OK. You can delete your assigned password at any time. To do this, enter the 
existing password in the box Old password and leave the two New password boxes empty. 
Then confirm with OK. 

 

 Note 

For FBD, LAD and BIN circuit diagram, you can set the password in this tab. 

The FBD, LAD and BIN circuit diagram password rule is as follows: 
• The maximum length of password is 10. 
• Only English characters (uppercase or lowercase letters) are supported. 
• Do not assume case sensitivity. 

 

The password protects your circuit program on IDEC SmartRelay. You can open or edit circuit 
programs from WindLGC at any time regardless of whether the program is password-
protected or not. For password-protected circuit programs, you must enter the password to 
view or change the program on IDEC SmartRelay, or to load the circuit program from IDEC 
SmartRelay to the computer. 
 

 

The presence of tabs and fields on the Properties dialog depend on the IDEC 
SmartRelay module that you select from the Tools -> Select Hardware 
(Page 133) menu command. 

 

This property is only for FBD and LAD Editors. 
 

2.8.1.16 File -> Properties - Power on 
When you transfer the circuit program, WindLGC also transfers the display content on IDEC 
SmartRelay after power on to IDEC SmartRelay.  

With Display content on IDEC SmartRelay after power on you can set what IDEC 
SmartRelay shows on the onboard display when you switch on IDEC SmartRelay. Your choices 
are as follows: 

• Display the date and time 

• Display inputs and outputs 

• Display menu 

 

 
The presence of tabs and fields on the Properties dialog depend on the IDEC 
SmartRelay module that you select from the Tools -> Select Hardware 
(Page 133) menu command. 

 
This property is only for FBD and LAD Editors. 
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2.8.1.17 File -> Properties - Additional Info 
In this tab, you can enter details of the current circuit program. This dialog includes input 
boxes for project-related and internal company data, as well as the version of your circuit 
program.  

As an alternative to a text string for your company name, you can specify a *.bmp or *.jpg 
file with your company logo for the Company field. This feature lets you create a customized 
layout of your program files. 
 

 

How to identify your circuit program version (Page 423)  

2.8.1.18 File -> Properties - Statistics 
This tab shows the creation date of the circuit program and the last author.  

 

2.8.1.19 File -> Properties - comment 
In this tab, you can enter a description of the circuit program or notes relating to it. When you 
print your circuit program using the File → Print  (Page 50) menu command, you can choose 
to print this comment on a separate printed page.  

2.8.1.20 File -> Properties - Modbus address space 
In this tab, you can view the mapping relationship between ModBus address and IDEC 
SmartRelay resource. 

 
Type Name IDEC SmartRelay 

Resource 
Modbus Address Direction Unit 

I 1 - 24 Discrete input 1 - 24 R bit 
Q 1 - 20 Coil 8193 - 8212 R/W bit 
M 1 - 64 Coil 8257 - 8320 R/W bit 
V 0.0 - 850.7 Coil 1 - 6808 R/W bit 
AI 1 - 8 Input Register 1 - 8 R Word 
VW 0 - 850 Holding Register 1 - 425 R/W Word 
AQ 1 - 8 Holding Register 513 - 520 R/W Word 
AM 1 - 64 Holding Register 529 - 592 R/W Word 
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2.8.1.21 File -> Properties - Email Event Settings 
In this tab, you can configure events that trigger the connected BM to send customized 
emails to the configured email receiving groups.  

 
In column ① , you can select the email trigger event in the drop-down menu: Power On, Run 
-> Stop, Stop -> Run, User program cleared. Except these four default system events, you 
can also find M flag events in the drop-down menu after adding M flag blocks in your circuit 
diagram. You can configure 16 M flag events at most. The configured M flag blocks display 
green backlight.  

 

 Note 

Event&Marker is mandatary to fill in. Otherwise, all configuration for this event item will not 
be saved. 

 

 Note 

Special M flags cannot be configured as email trigger event: M8, M25, M26, M27, M28, M29, 
M30, M31. Refer to section "Flags (Page 245)" for more information. 

 

To add a new row and an event, you can right-click any existing row, and select "Insert Row" 
in the shortcut menu; To delete a row, you can right-click the row you want to delete and 
select "Delete" in the shortcut menu. 
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In column ② , the customized email subject displays here once you finish inputting email 
subject and content. Email subject and email content cannot be empty, otherwise, the 
configuration will fail. The inputting and transferring of email subject and content supports 
texts with UTF-8 coding format.  

 

 Note 
Email subject and content rules 
• The size of each email subject should not exceed 127 bytes. 
• The size of each email content should not exceed 511 bytes. 
• You cannot perform the combination operation of pressing Enter key, pressing Dot key, 

then pressing Enter key in any part of the email content, otherwise, the email content is 
invalid. 

 

In column ③ , you can select receiving groups for each event. You can configure receiving 
groups in Online settings → Email Settings (Page 120). 

 

 Note 
Email sending frequency 

The frequency of BM sending emails cannot be customized, as BM sending email is triggered 
by the configured event. 

 

 Note 
Email sending failure log 

IDEC SmartRelay BM can keep at most 16 error logs of email sending failure. Each error log 
contains information of log ID, time stamp, trigger source and failure cause. 

You can check these error logs on BM through Diagnostics → Email → Mail Logs. 
 

2.8.1.22 File -> Recent Files 
Click on this menu, and it displays in the sub-menu at most 8 latest project or circuit diagram 
files that you have saved. You can click the file in the sub-menu to open the project or circuit 
diagram.  

 

2.8.1.23 File -> Exit 
The Exit command closes WindLGC  

If you are editing a circuit program or project and have not yet saved it, WindLGC prompts 
you about your project. 
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In diagram mode interface you can state which circuit programs are to be saved. 
Alternatively, you can exit WindLGC without saving circuit programs. To do this, click Close 
without saving. In the network project interface, you can click Yes to save the project or click 
No to exit without saving it. 
 

 

A quick way of closing WindLGC without saving the data (Page 424)  

2.8.2 Edit menu 
The Edit menu provides commands for editing your circuit program. The programming 
toolbar contains some of the basic commands for creating and editing circuit programs.  

• Undo (Page 62) 

• Redo (Page 62) 

• Delete (Page 62) 

• Cut (Page 62) 

• Copy (Page 62) 

• Paste (Page 63) 

• Align - Align vertically (Page 63) 

• Align - Align horizontally (Page 63) 

• Align - Horizontally distribute space (Page 63) 

• Align - Vertically distribute space (Page 64) 

• Align - Align automatically (Page 64) 

• Select All (Page 65) 

• Go to block (Page 66) 

• Bring to front (Page 66) 

• Send to back (Page 66) 

• Input/output names (Page 66) 

• Block properties (Page 67) 

• Block properties (all blocks) (Page 67) 

• Cut connections (Page 165) 

• Edit UDF properties (Page 68) 
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2.8.2.1 Edit -> Undo 
  

This command allows you to undo the previous actions. Position your mouse pointer on the 
undo menu command and hold it there briefly. The tooltip (Page 71) opens and shows you 
the actions you can undo by clicking the menu item. You can undo up to 30 actions.  

The standard toolbar (Page 33) and programing toolbar  (Page 36) also contain an icon for 
this menu command. 

2.8.2.2 Edit -> Redo 
 

This command reverts the last undo action. Click the menu command to view the tooltip 
(Page 71) for the action to be redone.  

The standard toolbar (Page 33) and programming toolbar (Page 36) also contain an icon for 
this menu command. 

2.8.2.3 Edit -> Delete 
 

The command deletes selected objects, without copying them to the clipboard. You can 
retrieve deleted objects with the Undo function.  

If you want to delete a device in project mode, a window opens upon delete. You can confirm 
the deletion with Yes or cancel the deletion with No or cancel in the window. 

The standard toolbar (Page 33) also contains an icon for this menu command.  

2.8.2.4 Edit -> Cut 
 

The command deletes one or more selected objects, for example, blocks and/or connecting 
lines, from the programming interface and copies them to the clipboard.  

The standard toolbar (Page 33) also contains an icon for this menu command. 
 

 Note 

You cannot cut the device in Network project interface. 
 

2.8.2.5 Edit -> Copy 
  

Use this command to copy one or more selected objects, for example, blocks, text, device, or 
connecting lines, to the clipboard.  

The standard toolbar (Page 33) also contains an icon for this menu command. 
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2.8.2.6 Edit -> Paste 
 

The command copies the clipboard content to the programming interface. WindLGC 
distributes the devices evenly on the right of the existing devices. WindLGC inserts the objects 
at the mouse location or below the objects you previously selected.  

The standard toolbar (Page 33) also contains an icon for this menu command. 

You can only paste the clipboard content if sufficient resources are available. Blocks require a 
certain amount of resources (Page 413), depending on the block type. WindLGC generates an 
error message if your system does not provide sufficient resources. 

You cannot paste connecting lines with open ends. You can only paste connecting lines if 
they connect two blocks, and you copied them to the clipboard together with those blocks. 

2.8.2.7 Edit -> Align 
This command offers various options of aligning labels and function blocks:  

• Align Vertically (Page 63) 

• Align Horizontally (Page 63) 

• Horizontally Distribute Space (Page 63) 

• Vertically Distribute Space (Page 64) 

• Align Automatically (Page 64) 

2.8.2.8 Edit -> Align -> Align Vertically 
 

This command aligns the selected object vertically to the objects with the highest block 
number or to the object you first selected in the circuit program.  

The programming toolbar (Page 36) also contains an icon for this menu command. 

2.8.2.9 Edit -> Align -> Align Horizontally 
  

This command aligns the selected object horizontally to objects with the highest block 
number or to the object you first selected in the circuit program.  

The Programming toolbar (Page 36) also contains an icon for this menu command. 

2.8.2.10 Edit -> Align -> Horizontally Distribute Space 
 

Use this command to set the horizontal space between objects you select. After you select 
this menu command, the following dialog appears: 
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You can choose the distance from 10 to 3000 pixels, in increments of 5 pixels. You can also 
select the "Use as Default" check box to set the default distance. 

 
The programming toolbar (Page 36) also contains an icon for this menu command.  

2.8.2.11 Edit -> Align -> Vertically Distribute Space 
  

Use this command to set the vertical space between the objects you select.  

 
You can also choose the distance from 10 to 3000 pixels, in increment of 5. You can also 
select the "Use as Default" check box to set the default distance. 

The programming toolbar (Page 36) also contains an icon for this menu command. 

2.8.2.12 Edit -> Align -> Align Automatically 
 

Use this command to align the selected objects automatically in vertical and horizontal 
direction. WindLGC aligns slightly offset or adjoining blocks along a common line. The 
reference for vertical alignment is the relevant upper block of a column. The reference for 
horizontal alignment is the block at the extreme left of a line.  
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The programming toolbar (Page 36) also contains an icon for this menu command. 

2.8.2.13 Edit -> Select all 
You can use this command to select all objects (blocks, connecting lines and labels) on the 
programming interface.  

 

 Note 

The network project interface doesn't include this function. 
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2.8.2.14 Edit -> Go to block 
You can use this command to view a list of all blocks used in a circuit program, including 
information about the block number, block name and block type. By default, WindLGC sorts 
the blocks in the list by type. You can also sort the blocks by name or number. WindLGC 
supports fuzzy search for blocks. You can enter a short description, for example, *p?, in the 
searching field. Then WindLGC lists all the blocks whose names contain the letter p. Here, "*" 
indicates a string and "?" indicates a character. 

 
You can also select a block from the list directly to highlight it on the programming interface. 

2.8.2.15 Edit -> Bring to front 
You can use this command to bring one of a number of overlapping objects to the 
foreground.   

2.8.2.16 Edit -> Send to back 
You can use this command to bring one of a number of overlapping objects to the 
background.  

2.8.2.17 Edit -> Input/output Names 
This command enables you to enter names for the input and output terminals (connector 
names). Use the Tools → Options → Preference (Page 164) menu command to specify 
whether to display the connector names on the programming interface. Use the Tools → 
Options → Print (Page 165) menu command to open a dialog to specify whether to include 
the connector names and connection list in the printed copy of your circuit program.  

In the Connector Names dialog, after entering input and output terminal names, you can click 
the Export button to save the name records as a .CSV file. Also, you can click the Import 
button to import a .CSV file from your PC containing the terminal name information to 
WindLGC .  
 

 

This menu command is inactive in the UDF Editor. 
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2.8.2.18 Edit -> Block properties 
This command displays the block properties of a block that you have selected on the 
programming interface.  

 
The block properties dialog box consists of several tabs. Every block has a Comment tab, 
where you can enter relevant block comments. For some blocks a Parameter tab is available 
where you can describe specific block parameters. You configure input simulation parameters 
from the Simulation tab. 

You can also configure the block properties by right-clicking the required block, and selecting 
the block properties menu command from the shortcut menu. 

2.8.2.19 Edit -> Block properties (all blocks) 
This command opens a window with two sections. In the left section, you can see all the 
blocks that your program uses. Click a block to view its corresponding parameters in the right 
column. You can now edit these parameters and set the changes by clicking the Apply 
button.  

WindLGC displays the modified block in blue in the selection list, if you select another block 
without clicking apply button to accept the parameter changes. WindLGC discards all changes 
you click the Cancel button. You can confirm all your entries and exit the dialog with OK. 

You can sort all the available blocks by name or by number by clicking the corresponding 
button on the upper-right of the list area. 

Here, you can also make a fuzzy search for blocks. For details, see Edit -> Go to block 
(Page 66). 

If you select the "Select block from drawing" check box, when you select subsequent blocks 
from the list, WindLGC highlight them in the circuit program. 

Special functions (Page 263)  

Basic functions (Page 257)  

Constants and connectors (Page 242)  

Data Log (Page 392)  

UDF (Page 395)  
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2.8.2.20 Edit -> Edit UDF properties 
Use this menu command to configure UDF (User-defined function) properties. For more 
information about the configuration for UDF properties, refer to "Configure UDF properties" in 
Editing the UDF (Page 398). 
 

 

This menu command is available only in the UDF Editor. 

2.8.3 Format menu 
This menu provides formatting options for labels and function groups. You can define the 
font, the font size and style as well as the alignment of selected objects with the following 
menu commands. 

• Font (Page 68) 

• Wrap Text (Page 68) 

• Format Grid (Page 69) 

• Snap to Grid (Page 69) 

2.8.3.1 Format -> Font 
You can use this tool to specify the font type, size, style, and the text color. Perform the 
following steps to redefine the format of existing text objects.  

1. Select the objects that you want to format. 

2. Configure the font attributes. 

3. Click OK to apply your configuration 

You can choose to set particular default formats. Then, WindLGC displays new text objects 
with these default settings. 

2.8.3.2 Format -> Wrap Text 
You can insert comments or edit user-defined text objects in the programming interface by 
using the Text Tool (Page 38). You can enlarge or reduce the size of a text figure, typically the 
figure width by dragging the rectangle handles. For example: 

 
When dragging the handle of the figure above to reduce the figure width, the figure 
automatically shrinks to fit the width. 
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2.8.3.3 Format -> Format grid 
This tool helps you to organize the various objects of your circuit program on the 
programming interface. The grid is visible by default.  

You can adjust the grid pattern (spacing) in increments of 5 points. 

If you have enabled the "Snap Block to Grid" function, WindLGC aligns the objects with the 
relevant grid intersections. This helps you to avoid a vertical or horizontal offset of the 
objects. To finely position objects on your programming interface, disable the "Snap Block to 
Grid" function. 

If you have enabled the "Snap Connection to Grid" function, WindLGC aligns the connection 
lines between objects with the relevant grid intersections. To allow connection lines to stay 
unaligned with grid lines on the programming interface, disable the "Snap Connection to 
Grid" function. 

You can hide the grid with the Visibility check box. 

You can select the "Use as Default" check box to keep your settings as the default for 
WindLGC circuit programs. 

2.8.3.4 Format -> Snap to grid 
If you have made changes to the grid pattern, or inserted objects while you disable the grid, 
the position of objects may be offset when you align them to the grid points. Use this 
command to correct the offset of selected objects and to realign them.  

2.8.4 View menu 
 

From the View menu, you can choose the current working mode, decide to show or hide 
various toolbars and trees under each mode, and set the zoom factor for the display of your 
circuit diagram or network project. The View menu contains the following commands.  

• Diagram Mode (Page 70) 

• Project Mode (Page 70) 

• Toolbars (Page 70) 

• Tree (Page 71) 
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• Select Lines (Page 71) 

• Info Window (Page 71) 

• Status bar (Page 71) 

• Tooltips (Page 71) 

• Zoom (Page 72) 

• Zoom In (Page 72) 

• Zoom Out (Page 72) 

2.8.4.1 View -> Diagram mode 
This command lets you hide/show the diagram mode user interface (Page 31).  

The default user interface shows both diagram mode and network project.  

The check mark besides the options "Diagram mode" and "Network project" indicates your 
current working mode. You can hide one of the modes by deselecting that mode from the 
user interface.  

 

 Note 

You cannot deselect both modes. You must have at least one of the two modes visible as the 
current working mode. 

 

2.8.4.2 View -> Network Project 
This command lets you hide/show the Network project overview (Page 32).  

The default user interface shows both the diagram mode and the network project.  

The check mark besides the options "Diagram mode" and "Network project" indicates your 
current working mode. You can hide one of the modes from the user interface by deselecting 
that mode. 

 

 Note 

You cannot deselect both modes. You must have at least one mode visible as the current 
working mode.  

 

2.8.4.3 View -> Toolbar 
This command lets you hide or show the standard toolbar (Page 33).  
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2.8.4.4 View -> Tree 
This command lets you hide or show the trees on the left part of the interface:  

• The diagram tree (Page 31) and the instructions tree (Page 32) under diagram mode. 

• The network project tree (Page 32) and the instruction tree (Page 32) under project mode. 

2.8.4.5 View -> Select Lines 
  

With this tool, you can show all connections (lines) that lead to or away from a selected block 
in color.  

If you select a single connection configured with this function, WindLGC highlight the 
selected connection in color. 

Also, if you select a block configured with this function, WindLGC show the reference block of 
the selected block with its frame in red. 

Under Tools > Options: Preference (Page 164) you can set whether to label the connections 
or not. Under Tools > Options: Colors (Page 166) you can set the colors to use to display the 
connections.  

2.8.4.6 View -> Info Window 
Use this menu command to show or hide the Info Window (Page 29). You can also use the 
function key (Page 30) [F4]. The Info Window lies below the diagram editor frame and at the 
right side of the instructions tree frame. 

 

 Note 

WindLGC hides the info window by default. You need to perform this command to show the 
info window if needed.  

 

2.8.4.7 View -> Status Bar 
Use this menu command to hide or show the status bar (Page 30).  

2.8.4.8 View -> Tooltips 
In WindLGC, you can use the mouse-over-button function to display the icon name, which 
represents the tooltip.  

This helps you to quickly recall the function of the icon, without having to call the menu or 
the help. 
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2.8.4.9 View -> Zoom 
WindLGC offers a variety of options for enlarging or reducing the size of the circuit program 
or circuit project display. By selecting Zoom, you open a dialog box in which you can set the 
zoom factor from a default list or in the relevant box.  

If you choose an unfavorable zoom factor, the objects may appear out of focus on your 
screen. You should therefore use the default zoom factors wherever possible. This effect has 
no influence on the layout of the printed circuit program. 
 

 

WindLGC provides a quick and easy way of zooming your circuit pro-
gram/project window. (Page 423)  

2.8.4.10 View -> Zoom In 
  

WindLGC defines the zoom factor as the below defined increments:  

25 (min) → 50 → 75 → 100 (default) → 150 → 200 → 250 → 300 → 400 (max) 

The zooming base point differs based on what you have selected: 

• With no block selected, zooming in starts from the top left corner. 

• With one block selected, zooming in starts from the chosen block. 

• With multiple blocks selected, zooming in starts from a central point of the chosen blocks. 

The standard toolbar (Page 33) also contains an icon for this menu command. 
 

 

WindLGC provides a quick and easy way of zooming your diagram edi-
tor/network view window. (Page 423)  

2.8.4.11 View -> Zoom Out 
 

WindLGC defines the zoom factor as the below defined increments:  

400 (Max) → 300 → 250 → 200 → 150 → 100 (default) → 75 → 50 → 25 (Min) 

On any occasions, zooming out always starts from the top left corner.  

The standard toolbar (Page 33) also contains an icon for this menu command.  
 

 

WindLGC provides a quick and easy way of zooming your circuit pro-
gram/project window. (Page 423)  
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2.8.5 Tools menu 
The tools menu provides the following menu commands:  

• Transfer (Page 73) 

• Determine SmartRelay (Page 133) 

• Select Hardware (Page 133) 

• Compare (Page 133) 

• Simulation (Page 138) 

• Simulation parameters (Page 138) 

• Connect modem (Page 140) 

• Disconnect modem (Page 143) 

• Ethernet Connections (Page 144) 

• Parameter VM Mapping (Page 152) 

• Options (Page 163) 

2.8.5.1 Tools -> Transfer 
You can transfer data between an IDEC SmartRelay Base Module and WindLGC with the 
Transfer menu commands. 

Prerequisites 
To transfer data between the IDEC SmartRelay Base Module and the WindLGC, you must 
configure a communication interface.  

Whenever you select a menu command in this menu, WindLGC displays the Interface dialog. 
Use this dialog to establish communication between the IDEC SmartRelay Base Module and 
WindLGC. 
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 Note 

For the data transfer, the IDEC SmartRelay Base Module must not be in RUN mode or editing 
mode. 

 

Transfer through IDEC SmartRelay PC Cable (FL1E and prior only) 
For the data transfer through IDEC SmartRelay PC Cable, you need to manually choose IDEC 
SmartRelay Cable as the communication interface, and set the IDEC SmartRelay COM port in 
the drop-down box. 
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Transfer through Ethernet (FL1F and later only) 
If you select Ethernet for the communication, you can either choose a target IP address from 
the accessible IDEC SmartRelay list or enter a known IP address.  

You can also store the IDEC SmartRelay information in the address book in case you need to 
use them in the future.  

Perform the following steps to detect a valid IDEC SmartRelay Base Module automatically.  

 
1. Click "①" on the above screen to show the address book. 

2. Enter the IP address of the IDEC SmartRelay Base Module. 

3. Keep the default subnet address of "255.255.255.0" unchanged. 

4. Enter the correct gateway IP address. Make sure you have completed this step if your IDEC 
SmartRelay Base Module is in the same LAN (Local Area Network or not). 

5. Save the item in your address book. 

 

 Note 

For IDEC SmartRelay FL1F FS5 and earlier versions BM connection, you must enter correct IP 
address and select correct network adapter. 

For IDEC SmartRelay FL1F FS6 and later versions BM connection, you only need to enter 
correct IP address and WindLGC will try all listed network adapters. 

 

You can click  to acquire the new accessible IDEC SmartRelay Base Module FL1F. 

WindLGC saves the scanned IDEC SmartRelay Base Modules to the accessible IDEC SmartRelay 
list for future use.  
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Transfer through Dynamic DNS (FL1F and later only) 
If you select Dynamic DNS for the communication, you can enter a known URL address or 
click the arrow in the URL textbox to recall an URL address you entered before: 

 
You must configure your router in order to access the IDEC SmartRelay Base Module through 
dynamic DNS. Make sure you have completed the following settings before connection: 

• The remote IDEC SmartRelay Base Module has a valid dynamic DNS account for routing. 

• The local router has added the dynamic DNS of the remote IDEC SmartRelay Base Module 
as a HTTP virtual server. 

 

 Note 

IDEC SmartRelay FL1F and FL1F FS5 devices communicate with a remote IDEC SmartRelay 
Base Module with TCP protocol through private port 8080.  

IDEC SmartRelay FL1F FS6 devices communicate with a remote IDEC SmartRelay Base Module 
with HTTPS protocol through private port 8443. 

 

Connection test 
After you select the desired connection interface, you can test the connection in the same 
dialog.  

Click "①" on the following screen to check if the connection is ready.  

The grey connection line turns green and you see a check mark icon above the line if your 
connection is successful.  
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You can also copy your circuit programs to the SD card in the above screen.  

Menu commands overview 
The Tools → Transfer menu contains the following menu commands: 

• Tools → Transfer: PC → SmartRelay  (Page 78) 

• Tools → Transfer: SmartRelay → PC  (Page 79) 

• Tools → Transfer: Start SmartRelay (Page 79) 

• Tools → Transfer: Stop SmartRelay (Page 79) 

• Tools → Transfer: Factory Reset SmartRelay (Page 80) 

• Tools → Transfer: Show FW version (Page 80) 

• Tools → Transfer: Clear User Program and Password (Page 80) 

• Tools → Transfer: Upload Data log (Page 81) 

• Tools → Transfer: Configure Network Address  (Page 81) 

• Tools → Transfer: Configure Master/Slave Mode (Page 82) 

• Tools → Transfer: Set Clock (Page 83) 

• Tools → Transfer: Summer time/Winter time (Page 84) 

• Tools → Transfer: NTP Settings (Page 86) 

• Tools → Transfer: Set SmartRelay TD Power-on Screen (Page 87) 

• Tools → Transfer: Access Control (Page 89) 

• Tools → Transfer → Cloud Settings: Cloud Data Transfer Settings (Page 93) 

• Tools → Transfer:→ Cloud Settings: Cloud Connection Settings (Page 94) 
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• Tools → Transfer: Certificate Settings (Page 120) 

• Tools → Transfer: Email Settings (Page 120) 

• Tools → Transfer: Hours counter (Page 122) 

• Tools → Transfer: I/O Status (Page 122) 

• Tools → Transfer: Diagnostic (Page 124) 

• Tools → Transfer: Dynamic Server IP Filter (Page 124) 

• Tools → Transfer: Configure TDE Device (Page 126) 

• Tools → Transfer → Batch Download: Diagram Batch Download (Page 131) 

• Tools → Transfer → Batch Download: Network Batch Download (Page 132) 

2.8.5.2 Tools -> Transfer -> PC -> SmartRelay 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

 →Tools → Transfer: PC → SmartRelay 

You can use this menu command to download a circuit program created with the WindLGC 
from PC to the IDEC SmartRelay Base Module. You can also use the  button in the standard 
toolbar (Page 33) for such purpose. 

Preparations 
Prior to the download, the system determines the minimum IDEC SmartRelay version required 
for your circuit program. The modular IDEC SmartRelay always provides all available I/O 
resources (Page 418) for your circuit program. You are free to install an appropriate number 
of expansion modules in the base device. 

Error messages 
WindLGC aborts the transfer and displays an error message if the IDEC SmartRelay Base 
Module does not have enough resources for program transfer. The error dialog displays 
unknown IDEC SmartRelay versions prompts you to continue or cancel the download.  

The status bar displays transfer messages and the Info Window displays transfer messages as 
well as detailed error messages. 

Layout recovery (FL1F only) 
When you download a circuit program (FBD only) to your IDEC SmartRelay Base module, 
WindLGC also downloads the program layout. The WindLGC reads the layout information and 
recovers it automatically when you open it again.  

The layout memory size in an IDEC SmartRelay Basic is up to 512 KB. You can check the 
available memory size from the info window by determining IDEC SmartRelay (Page 133) 
before saving a circuit diagram.  
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2.8.5.3 Tools -> Transfer -> SmartRelay -> PC 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

 →Tools → Transfer: SmartRelay → PC 

You can use this menu command to upload a circuit program from SmartRelay Base Module 
to PC with the WindLGC. You can also use the  button in the standard toolbar (Page 33) for 
such purpose. 

Cutting connections 
If you have set the "Cut connections during import/upload" check box under Tools → Options: 
Cut connections (Page 165), WindLGC cuts the relevant connections during the upload from 
WindLGC to the PC according to the rules set in this dialog. 

Password 
When you upload a password-protected circuit program from WindLGC to the PC, WindLGC 
prompts you to enter a password. If you do not enter the correct password, WindLGC aborts 
the transfer and displays an error message. 

2.8.5.4 Tools -> Transfer -> Start SmartRelay 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

 → Tools → Transfer → Start SmartRelay 

When you click this symbol, WindLGC switches the connected SmartRelay Base Module from 
STOP mode to RUN mode.  

As an alternative approach, you can also click the button on the Standard Toolbar (Page 33).  
 

 Note 

This function is only available with devices of the FL1E hardware series or later. 
 

2.8.5.5 Tools -> Transfer -> Stop SmartRelay 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

 → Tools → Transfer → Stop SmartRelay 

When you click this symbol you change the mode of a connected SmartRelay from RUN mode 
to STOP mode.  
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As an alternative approach, you can also click the button on the Standard Toolbar (Page 33).  
 

 Note 

This function is only available with devices of the FL1E hardware series or later. 
 

2.8.5.6 Tools -> Transfer -> Factory Reset SmartRelay (FL1F FS5 and later versions only) 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information. 

When you select this function, WindLGC resets the connected IDEC SmartRelay Base Module 
to Factory setting. 

If WindLGC cannot communicate with your IDEC SmartRelay BM, you can use the reset file in 
the DVD-ROM to reset the IDEC SmartRelay BM to Factory setting. Proceed in the following 
steps: 

1. Copy the _reset.bm file in the DVD-ROM (Page 13) into the root directory of a SD card. 

2. Insert the SD card into the IDEC SmartRelay BM. 

3. Power on the IDEC SmartRelay BM to execute factory reset. After the BM is reset to factory 
setting, the _reset.bm file in the SD card is deleted automatically. 

 

 Note 

The _reset.bm file can only be used to reset Factory setting for FL1F FS6 and later versions 
Base Module. 

 

2.8.5.7 Tools -> Transfer -> Show FW version 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

This command allows you to identify the firmware version of the IDEC SmartRelay Base 
module. 

2.8.5.8 Tools -> Transfer -> Clear User Program and Password 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

This command allows you to clear the circuit program in the connected IDEC SmartRelay 
device and the program password if a password exists. 
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You must respond to a confirmation dialog to ensure that you do intend to clear both the 
circuit program and the password (if configured) from the IDEC SmartRelay device. After you 
confirm the command, WindLGC performs the clear operation. If you do not confirm the 
command, WindLGC performs no action. The circuit program and password (if configured) 
remain in the IDEC SmartRelay device. 

 

 Note 

IDEC SmartRelay devices prior to version FL1E do not support this function. If you attempt this 
command on an earlier device, WindLGC displays a message that states that the device does 
not support this function. 

 

2.8.5.9 Tools -> Transfer -> Upload Data Log (FL1F and later versions only) 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

This menu allows you to upload a data log from the EEPROM or SD card to the connected PC. 

You can upload your data log and browse to a desired directory and save your data log 
document.  

WindLGC uploads the file from the EEPROM and saves it as a .CSV file that you can open from 
Microsoft Excel or a text editor. 

 

 Note 

One data log file contains at most 20000 lines. If you want to upload new data log files 
generated by the same circuit program, to prevent data loss, IDEC suggests you re-upload the 
last old data log file as new data might be written in this file.  

For more information about data log, refer to the section Data Log in IDEC SmartRelay User's 
Manual. 

 

2.8.5.10 Tools -> Transfer -> Configure Network Address (FL1F and later versions only) 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

With this menu command, you can change the IP address, subnet mask and default gateway 
of the IDEC SmartRelay Base Module: 
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Click "①" to implement the change.  

2.8.5.11 Tools -> Transfer -> Configure Master/Slave Mode (FL1F and later versions only) 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

Use this menu command to switch an IDEC SmartRelay Base Module between master mode 
and slave mode. 

If you set the connected IDEC SmartRelay Base Module to slave mode, you must enter the 
destination IP address of the module: 
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 Note 

IDEC SmartRelay restarts automatically whenever you make the following changes in 
WindLGC: 
• Mode switch (from master mode to slave mode or vice versa) 
• Change to the master IP address in slave mode 

 

2.8.5.12 Tools -> Transfer -> Set Clock 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

This menu command allows you to view and set the date and time of the IDEC SmartRelay 
Base Modules.  
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Setting the clock for IDEC SmartRelay Base Modules 
WindLGC allows you to read the date and time from the PC or the IDEC SmartRelay Base 
Module directly:  

 
Click "①" to read the date and time from the connected PC, or to click "②" and acquire it from 
the connected IDEC SmartRelay Base Module.  

Click "③" to save the date and time displayed to the IDEC SmartRelay Base Module connected 
with the WindLGC.  

Click "④" to save the date and time displayed to all the IDEC SmartRelay Base Modules in the 
Local Area Network (LAN).  

WindLGC synchronizes the time and date among Base Modules in the same network segment 
with the local PC.  

Manual input of values 
You can enter the date and time values by entering in the number input box or by clicking the 
UP and DOWN arrow icons. WindLGC automatically corrects any invalid date values. 

2.8.5.13 Tools -> Transfer -> Summer time/Winter time 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

This menu command lets you set an automatic conversion of the summer and winter time for 
the IDEC SmartRelay Clock:  



 User interface 
 2.8 Menu bar 

WindLGC Online Help 

Programming and Operating Manual, 11/2024 85 

 
When you enable summer/winter time conversion, you can specify a country-specific time 
conversion: 

• EU: European Union 

• UK: United Kingdom of Great Britain and Northern Ireland 

• US1 / US2: United States of America 

• Australia 

• Tasmania 

• New Zealand 

• Freely adjustable: customized switchover dates and times 

For the "Freely adjustable" selection, you specify the month and day of the switchover. The 
start time of summer time is 02:00 + the entered time difference; the end time is 03:00 – the 
entered time difference. 
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The United States of America redefined the Daylight Saving Time / Standard Time calendar in 
2007. US1 is the convention in effect prior to 2007 and US2 is the convention defined in 
2007 where Daylight Saving Time is in effect from 2:00 a.m. on the second Sunday in March 
until 2:00 a.m. on the first Sunday in November according to the local time zone. 

 

 Note 

IDEC SmartRelay devices as of series FL1B and later support the summer/winter time 
conversion.  

IDEC SmartRelay devices as of series FL1E and later support the US2 selection. 
 

2.8.5.14 Tools -> Transfer -> NTP Settings (FL1F FS5 and later versions only) 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information. 

This command allows you to configure NTP (Network Time Protocol) settings. With this 
command, you can set BM as NTP server or client. The NTP function is disabled if neither 
mode is selected. 

If you enabled the NTP function for an IDEC SmartRelay Base Module, you must set the time 
zone for it. 

If you set an IDEC SmartRelay Base Module as NTP client, you must enter the NTP server IP 
address for the module. 

 

 Note 

Currently, IDEC SmartRelay can only recognize IP address but not host name. Please parse the 
NTP server host name to IP address first. 
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2.8.5.15 Tools -> Transfer -> Set SmartRelay TD Power-on Screen 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

Use this command to configure a power-on screen for the IDEC SmartRelay TD/TDE from the 
character set that you select: 
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Click "①" to load the previously-configured power-on screen that is stored in the memory of 
the IDEC SmartRelay Base Module.  

Click "②" to copy the currently-configured screen to the IDEC SmartRelay Base Module 
memory.  

The IDEC SmartRelay Base Module updates the IDEC SmartRelay TD/TDE with the power-on 
screen that stored in memory.  

Select a character set for the power-on screen and then use the keyboard to type characters 
into the display window text edit area.  

You can click "③" to switch back to empty screen.  

The power-on screen can only contain simple text strings. 
 

 Note 

IDEC SmartRelay devices prior to version FL1E do not support this function. If you attempt this 
command on an earlier device, WindLGC displays a message that states that the device does 
not support this function. 

 

Copying and pasting text characters 
Whenever you enter characters into the display window text edit area, you can use the 
keyboard shortcuts for copy (Ctrl+C) and paste (Ctrl+V). You can copy and paste characters 
between any documents on your computer, text in a message text, text in an I/O status 
name, or text in the IDEC SmartRelay TD/TDE Power-on screen text edit area. WindLGC verifies 
that any characters to be pasted are valid for the selected character set.  
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You cannot use cut (Ctrl+X) to cut characters for pasting, except from a document on your 
computer. WindLGC does not support the cut operation from the message text, I/O status 
name, or SmartRelay TD Power-on screen editing dialogs. 

2.8.5.16 Tools -> Transfer -> Access Control 
WindLGC requires you confirm the connection interface for each communication attempt. 
See "Tools -> Transfer (Page 73)" for complete information.  

Use this command to authorize access and configure passwords to user profiles on different 
access occasions. 

When establishing communication connection with the IDEC SmartRelay Base Module and 
IDEC SmartRelay TD/TDE through Ethernet or Dynamic DNS, WindLGC displays the access 
security status for different access approaches and allows the following three types of access 
approaches:  

• WindLGC & FWE access 

• Web server access 

• SmartRelay TD/TDE access 

From the access control dialog, scroll down to see all the access types and the configuration 
options. 

Once you enable a user profile, you can then enable and set its password.  

When you apply your modification, WindLGC will switch your IDEC SmartRelay Base Module 
from STOP to RUN mode.  

 

 Note 

Password: Protect the access with a strong password.  

Strong passwords must mix letters, numbers, and special characters, are not words that can 
be found in a dictionary, and are not names or identifiers that can be derived from personal 
information. Keep the password secret and change it frequently.  

WindLGC supports all password inputs including letters, numbers, and special characters with 
ASCII character set.  

The maximum length of password is 10. 

Password strength is displayed after you enter a new password. 
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Access security status 
The access security status is displayed as follows: 

 

WindLGC & FWE access 
Here you enable WindLGC & FWE user access and change the logon password.  
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Web server access 
Here you enable Web server access through Local Area Network (LAN) connections.  

 
To enable the web server access, you need to select the checkbox "Allow Web server access" 
and select "Allow HTTP access (Web Server)" or "Allow HTTPS access only" firstly, and then you 
can select different user roles as you need. 
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Here is the detailed information for each checkbox: 

• Allow Web server access: 

– Allow HTTP access (Web Server): HTTP is not encrypted. The SmartRelay BM data may 
be accessed without authorization and the connection between SmartRelay BM and 
other devices may be hacked. 

– Allow HTTPS access only: HTTPS is encrypted and this access approach is secure. If you 
select HTTPS access, the device performance is affected. 

 
  Note 

If you select the checkbox "Allow HTTPS access only", you need to install the 
SmartRelay Root Certificate in your operating system or browsers. On how to install the 
SmartRelay Root Certificate, refer to the chapter "Security -> Installing SmartRelay Root 
Certificate" of IDEC SmartRelay User's Manual. 

 

• Enable Web User: Here you access the web server as a web user and change the logon 
password. 

• Enable Web Guest User for local web server: Here you access the web server as a web 
guest user and change the logon password. 

For more details about the Web server, refer to the Web server section of IDEC SmartRelay 
User's Manual.  

For more details about different users, refer to the Network Security section of IDEC 
SmartRelay User's Manual. 

SmartRelay TD/TDE access 
Here you enable access to IDEC SmartRelay Base Module from IDEC SmartRelay TD/TDE and 
change the logon password.  

The IDEC SmartRelay TD/TDE logon password is also the password used to switch the menu 
access of Operator to Administrator in IDEC SmartRelay Base Module. Refer to the section 
Configuring menu access protection in IDEC SmartRelay User's Manual for more information. 
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2.8.5.17 Tools -> Transfer -> Cloud Settings -> Cloud Data Transfer Settings 
WindLGC requires you confirm the connection interface for each communication attempt. 
See "Tools -> Transfer (Page 73)" for complete information.  

This menu allows you to configure the Cloud data transfer.  

 
The following table lists the definition for each item: 
 
Item Definition 
ID Note: The maximum number of data record is 64. 
Name Name of cloud data. 

Note: Name can contain letters, numbers, special characters "-" and "_", and the 
maximum size of the name is 15 byte. 

Range Memory area in IDEC SmartRelay BM. 
Address Memory address. 
Type Data type. 
Length Data length.  
At Frequency Enable the data synchronization between IDEC SmartRelay BM and cloud on a 

customized frequency. 
Period (d:h:m:s) Time intervals that IDEC SmartRelay BM synchronize the data with cloud. 

Note: The maximum time intervals is 23 days: 23 hours: 59 minutes: 59 sec-
onds. 

On Change If the value is changed, you can select this checkbox to synchronize the changes 
to cloud. 

Writable Write the data from Cloud to IDEC SmartRelay BM. 
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Item Definition 
SmartRelay Web 
Server Data Format 

Choose the data format as hex string.  
Note: The maximum of total data record is 160 bytes. 

Array Data Format Choose the data format as integer array. 
Note:  
• The maximum of total data record is 160 bytes; 
• The total Length of all the Cloud Data should not exceed 160. 

+ Add a row. 
- Delete a row. 
Import Import cloud data transfer settings table. 
Export Export cloud data transfer settings table. 
Read from Smar-
tRelay 

Read the data transfer settings from IDEC SmartRelay BM. 

Write to Smar-
tRelay 

Write the data transfer settings to IDEC SmartRelay BM. 

The following table lists whether the specific memory area is writable. 
 
Memory Area Block Number Writable 
I I1-I24 No 
Q Q1-Q20 Yes 
M M1-M64 Yes 
AI AI1-AI8 No 
AQ AQ1-AQ8 Yes 
AM AM1-AM64 Yes 
V V0-V850 Yes 
VX VX0-VX2047 Yes 
VR VR0-VR511 Yes 
Cursor Key C1-C4 No 
Function key F1-F4 No 
Shift Register S1.1-S1.8 

S2.1-S2.8 
S3.1-S3.8 
S4.1-S4.8 

No 

The following table lists the specific memory areas for which On Change checkbox is 
disabled. 
 
Memory Area Block Number 
AI AI1-AI16 
AQ AQ1-AQ8 
AM AM1-AM64 

2.8.5.18 Tools -> Transfer -> Cloud Settings -> Cloud Connection Settings 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information. 
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With this menu command, you can configure the Cloud connection for IDEC SmartRelay BM.  
 

 Note 
IDEC SmartRelay BM time 

Before you configure Cloud connection, make sure the time and date of the IDEC SmartRelay 
BM are correct. Otherwise, Cloud connection will fail. 

 

 
 

 Note 

IDEC SmartRelay FL1F FS6 and later versions BM supports Cloud connection with AWS, Azure, 
Alibaba or general MQTT broker. 
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Enable Cloud access 
You can enable Cloud access as follows: 

1. Select the checkbox "Enable Cloud access". 

 
  Note 

For IDEC SmartRelay FL1F FS6 Base Module, you can enable Web Server access and Cloud 
access at the same time. 

 

2. Click the "Apply" button. 

Register an IDEC SmartRelay BM in AWS IoT 

Requirements 

Ensure that the following conditions are met before you register an IDEC SmartRelay BM in 
AWS IoT: 

• The Cloud access must be enabled. 

• An AWS account is created. 

• The access key is applied. 
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Procedures 

Perform the following steps to register an IDEC SmartRelay BM in AWS IoT: 

1. Navigate to "Tools -> Transfer -> Cloud Settings -> Cloud Connection Settings" tab and click 
the "Register Thing" button. Then a "Register" dialog is displayed. 

Select the Cloud type "AWS" and click the "Next" button.  

 
2. Select the IoT Region, enter the "Access Key ID" and "Secret Access Key". If you use AWS 

Temporary Credential Account (TVM) for the register, you need also enter "Session Token". 
Then click the "Next" button. 
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3. Select the checkbox "Create a new thing" or "Using an existing thing". Then click "Next" 

button. 

If you select "Create a new thing", proceed with step 4. If you select "Using an existing 
thing", proceed with step 5. 
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4. Enter the name. Then click "Next" button. 

Naming rule: 

– The length of the name cannot exceed 128 characters. 

– The name consists of any letters, the hyphen "-" and the underline "_". 

For the detailed information, refer to AWS IoT thing naming rule. 

After creating a billing group and assigning tags to it on AWS website, you can assign the 
configured billing group to the IoT thing to categorize and track your IoT service related 
costs.  
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5. Select topic type for the register. Then click "Next" button. 

If the registered IoT thing will be used in your FWE project, which will be deployed to AWS 
as a WebApp, you should select Shadow Topic, and configure the cloud data as 
"SmartRelay Web Server Data Format" in Cloud Data Transfer Settings (Page 93).  
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6. Create a certificate by entering the following information: 

 

Item Rule 
Country/Region Select from the drop-down list. 
State Naming rule: 

• The length of state name or organization name cannot exceed 16 characters. 
• The state name or organization name consists of any alphanumeric charac-

ters, white space, the hyphen "-", the underline "_" and the colon ":". 
For the detailed information, refer to AWS IoT thing service related rule. 

Organization  

Unit Name Naming rule: 
• The length of unit name cannot exceed 16 characters. 
• The unit name consists of any alphanumeric characters. 
For the detailed information, refer to AWS IoT thing service related rule. 
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7. Click the "Next" button, and then the "Register Status" page shows that your registration is 
successful. Click "Finish" button to close the registration dialog. 

 

Register an IDEC SmartRelay BM in Azure IoT 

Requirements 

Ensure that the following conditions are met before you register an IDEC SmartRelay BM in 
Azure IoT: 

• The Cloud access must be enabled. 

• An Azure account is created. 

• An IoT Hub primary connection string is applied. 
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Procedures 

Perform the following steps to register an IDEC SmartRelay BM in Azure IoT: 

1. Navigate to "Tools -> Transfer -> Cloud Settings -> Cloud Connection Settings" tab and click 
the "Register Thing" button. Then a "Register" dialog is displayed. 

Select the Cloud type "Azure" and click the "Next" button.  
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2. Enter the "IoT Hub Primary Connection String". Then click "Next" button. 
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3. Select "Create a new device" or "Using existing device". Then click "Next" button. 

If you select "Create a new device", proceed with step 4; if you select "Using an existing 
device", proceed with step 5. 
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4. Enter the device ID. Then click "Next" button. 

Naming rule: 

– The length of the device ID cannot exceed 128 characters. 

– The device ID can consist of any upper-case or lower-case letters, numbers and certain 
special characters - . _ * ! ( ) , : = @ $ '. 

 
  Note 

If you create Device ID in Azure platform with other special characters than above ones, it 
cannot be displayed in the existing device list in step 3. 
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5. The Register Status page shows you that your registration is successful. Click "Finish" button 
to close the registration dialog. 

 

Register an IDEC SmartRelay BM in Alibaba IoT 

Requirements 

Ensure that the following conditions are met before you register an IDEC SmartRelay BM in 
Alibaba IoT: 

• The Cloud access must be enabled. 

• An Alibaba account is created. 
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Procedures 

Perform the following steps to register an IDEC SmartRelay BM in Alibaba IoT: 

1. Navigate to "Tools -> Transfer -> Cloud Settings -> Cloud Connection Settings" tab and click 
the "Register Thing" button. Then a "Register" dialog is displayed. 

Select the Cloud type "Alibaba" and click the "Next" button.  

 
2. Enter "IoT Region" "Access Key ID" "Secret Access Key" and "Instance ID". The "IoT Region" 

should be consistent with the region that is configured when creating the "Instance ID" on 
Alibaba website. 
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3. Select "Create a new product" or "Using an existing product". Then click "Next" button. 
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4. If you select "Create a new product" in step 3, here you need to enter the new product 
name. Then click "Next" button. 

Naming rule: 

– The length of the product name is between 4 to 30 characters. 

– The product name consists of any Chinese characters, letters, numbers and the special 
character underline "_". One Chinese character counts as two characters. 
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If you select "Using an existing product" in step 3, here you need select "Create a new 
device" or "Using an existing device". Then click "Next" button.  

If you select "Create a new device", proceed with step 5; if you select "Using an existing 
device", proceed with step 6. 
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5. Enter device name. Then click "Next" button. 

Naming rule: 

– The length of the device name is between 4 to 32 characters. 

– The device name consists of any Chinese characters, letters, numbers and certain 
special characters: hyphen "-", underline "_", at sign "@", period "." and colon ".". 
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6. Select topic type for the register. Then click "Next" button. 
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7. The Register Status page shows you that your registration is successful. Click "Finish" button 
to close the registration dialog. 

 

Register an IDEC SmartRelay BM in MQTT broker 
Click here (Page 428) to learn about how to establish IoT Cloud connection between IDEC 
SmartRelay BM and Hive MQTT. 

Click here (Page 438) to learn about how to establish IoT Cloud connection between IDEC 
SmartRelay BM and Mosquitto MQTT. 

Requirement 

Ensure that the following conditions are met before you register an IDEC SmartRelay BM in 
MQTT broker: 

• The Cloud access must be enabled. 

• The corresponding MQTT broker account is created. 
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Procedures 

Perform the following steps to register an IDEC SmartRelay BM in MQTT broker: 

1. Navigate to "Tools -> Transfer -> Cloud Settings -> Cloud Connection Settings" tab and click 
the "Register Thing" button. Then a "Register" dialog is displayed. 

Select the Cloud type "MQTT" and click the "Next" button.  
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2. Enter "MQTT Broker URL" "Port" and "MQTT Client ID". Then click "Next" button. 
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3. Select Authentication Type: TCP, TLS without authentication, TLS one-way or TLS two-way. If 
you select TCP or TLS without authentication, click "Next" button to proceed with step 4; if 
you select TLS one-way, you need upload Broker CA Certificate to authenticate the server; if 
you select TLS two-way, you need to upload Broker CA Certificate, Device Certificate and 
Device Key, to authenticate the client and the server. Then click "Next" button. 

To learn more about authentication type, refer to section Cloud IoT connection -> Secure 
Cloud connection in IDEC SmartRelay User's Manual. 
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4. Enter "Publish Topic". Then click "Next" button. 
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5. The Register Status page shows you that your registration is successful. Click "Finish" button 
to close the registration dialog. 

 

Deregister an IDEC SmartRelay BM 
If the IDEC SmartRelay BM you want to register has been registered, you can deregister this 
IDEC SmartRelay BM by clicking the "Deregister" button. 

 

 Note 

Deregistering an IDEC SmartRelay BM doesn't delete the thing that is registered in AWS IoT, 
which deletes the following items in IDEC SmartRelay BM: AWS endpoint, the certificate that 
is created for registering a thing, and the name of registered thing. 
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2.8.5.19 Tools -> Transfer -> Certificate Settings 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer" (Page 73) for complete information. 

This menu command allows you to check the status of all IDEC SmartRelay certificates. You 
can also download and save each SmartRelay certificate to your local file system. 

You can check the valid period of all SmartRelay certificates. 

 
To save certain SmartRelay certificate, click the Save button below corresponding certificate, 
then you can choose the path to store the certificate file. 

2.8.5.20 Tools -> Transfer -> Email Settings 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer" (Page 73) for complete information. 

This command allows configured email groups to receive customized notification email from 
the connected IDEC SmartRelay BM at trigger events.  
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SMTP Settings 
IDEC SmartRelay FL1F FS6 uses SMTP (Simple Mail Transfer Protocol) to send emails to the 
configured receivers.  

 
Take the following steps to finish SMTP setting: 

1. Input all required SMTP server information. You can get all the required SMTP configuration 
information from certain mail server official document. 

 
  Note 

WindLGC supports three types of connection security: TCP (unencrypted), STARTTLS and 
TLS. If you choose STARTTLS or TLS, for communication security, you can choose to upload 
CA certificate to verify the SMTP server. If the verification fails, then the configured emails 
cannot be sent out successfully, and you can check the error log in BM through: 
Diagnostics → Mail → Mail Logs. Refer to Troubleshooting (Page 425) to learn more about 
email sending error. 

 

2. Click Verify SMTP setting button to verify your SMTP setting. The Send test email dialog 
pops up. 

3. Input appropriate email addresses to receive the test email. Use semicolon to separate each 
email address apart when inputting more than one email address. 

4. Click Send test email button to start the test process. The test status information displays 
on the dialog. 
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 Note 
SMTP server information 

IDEC SmartRelay BM keeps the configured SMTP information. You can find it on BM through: 
Diagnostics → Email → SMTP Info. 

 

Email receiver group settings 
You can configure 8 email receiving groups at most. Each email receiving group can contain 
1 KB characters at most. You can use semicolon to separate each email address apart when 
inputting more than one email address in the email receiving group.  

2.8.5.21 Tools -> Transfer -> Hours counter 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  

Use this menu command to read the hours counter of the connected IDEC SmartRelay.  

See Hours counter (Page 299) for more information.  

You can also access the hours counter from the IDEC SmartRelay devices. You do not have to 
enter a password to read the hours counter even when the target program is password-
protected.  

 

 Note 

Only the IDEC SmartRelay devices of FL1B and later versions support this function.  
 

2.8.5.22 Tools -> Transfer -> I/O Status (FL1F and later versions only) 
WindLGC requires that you confirm the connection interface from the "Interface" dialog for 
each communication attempt. See "Tools -> Transfer (Page 73)" for complete information.  

Use this menu command to display and save I/O status information: 
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Configuring the status display 
Under "①" in the screen above, you can select which I/O to display in the status window. 

Configuring the status display properties 
Here you can define the maximum number of status records. You can choose from 20 to 100. 

Here you can also define the interval between I/O status refreshes. You can choose a refresh 
time from 500 ms to 30000 ms. 

Configuring the log file 
You can export all I/O status information to a .CSV file. You can change or remove the path 
for saving the log file. 

To save the I/O status information to a .CSV file, follow these steps:  

1. Click "②" in the screen above and specify a path for saving the log file. 

2. You can also remove the log file if you click "③" in the screen above. 

3. Save the I/O status information to the specified log file. 

If you do not specify a log file, WindLGC closes the I/O Status Overview without saving it to a 
file. 
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2.8.5.23 Tools -> Transfer -> Diagnostic (FL1F and later versions only) 
WindLGC requires that you confirm the connection interface from the "Interface" dialog for 
each communication attempt. See "Tools -> Transfer (Page 73)" for complete information.  

The diagnostic function tracks the following types of basic error information:  

• IDEC SmartRelay Base Module FL1F: 

– Ethernet link errors 

– Expansion module has changed 

– SD card read/write errors 

– No SD card present 

– The SD card is full 

 
You can use this WindLGC command to get the error information.  

By clicking "①", you can delete all the error records you selected. By clicking "②", you can get 
the latest error information of the connected Base Module.  

2.8.5.24 Tools -> Transfer -> Dynamic Server IP Filter (FL1F and later versions only) 
WindLGC requires that you confirm the connection interface for each communication 
attempt. See "Tools -> Transfer (Page 73)" for complete information.  
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Use this menu command to show and configure the ACL (Access Control List) of the 
connected IDEC SmartRelay Base Module: 

 
If you click checkbox "①", IDEC SmartRelay Base Module allows access requests from all IP 
addresses.  

If you click checkbox "②", WindLGC provides an allowed IP addresses list of eight check boxes, 
each with an IP address input box for IP filtering configurations. 

Click a checkbox in the list, input the IP address of the IDEC SmartRelay Base Module and click 
"③" to authorize its access: 
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2.8.5.25 Tools -> Transfer -> Configure TDE Device ( IDEC SmartRelay TDE FS4 only) 
With this command, you can establish communication between the IDEC SmartRelay TDE and 
WindLGC. 

When you select this menu command, WindLGC displays the following Interface dialog. 
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Transfer through Ethernet  
If you select Ethernet for the communication, you can either choose a target IP address from 
the accessible IDEC SmartRelay TDE list or enter a known IP address. 

You can also store the IDEC SmartRelay TDE information in the address book for your future 
use. 

Perform the steps below to detect a valid IDEC SmartRelay TDE automatically. 
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1. Click Address book button on the above screen to show the address book. 

2. Enter the IP address of the IDEC SmartRelay TDE. Keep the default subnet address of 
"255.255.255.0" unchanged. 

3. Enter the correct gateway IP address. Make sure you have completed this step if your IDEC 
SmartRelay TDE is in the same LAN. 

4. Save the item in your address book. 

You can click  to acquire the new accessible IDEC SmartRelay TDE. 

WindLGC saves the scanned IDEC SmartRelay TDE to the accessible IDEC SmartRelay list for 
your future use.  

Transfer through Dynamic DNS  
If you select Dynamic DNS for the communication,  enter an URL address  to the URL textbox.  

You can recall the URL address you entered before by clicking the arrow in the URL textbox. 
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You must configure your router in order to access the IDEC SmartRelay TDE through dynamic 
DNS. Make sure you complete the following settings before connection: 

• Set a valid dynamic DNS account to remote IDEC SmartRelay TDE 

• Add the dynamic DNS of the remote IDEC SmartRelay TDE to the local router as a HTTP 
virtual server 

Connection test 
After you select the desired connection interface, you can test the connection in the same 
dialog. 

Click Test button on the following screen to check if the connection is ready. 

The grey connection line turns green and you see a check mark icon above the line if your 
connection is successful. 
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Then you can see the IDEC SmartRelay TDE is connected to the WindLGC. After clicking the 
OK button, the IDEC SmartRelay TDE settings dialog appears. 

In the IDEC SmartRelay TDE settings dialog, the Online setting tab is editable. 

 
For the detailed information on IDEC SmartRelay TDE Online setting, refer to Configuring 
IDEC SmartRelay TDE online settings (Page 202). 
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2.8.5.26 Tools -> Transfer -> Batch Download -> Diagram Batch Download 
With this demand, you can download current circuit diagram to the connected target FL1F 
devices in a batch. This command is only available when you are in Diagram Mode.  

When you select this menu command, WindLGC displays the following interface dialog: 

 
To proceed the batch download function, you should firstly get the information of all the 
connected FL1F devices. There are two ways to get these devices: 

• Click  to acquire available devices in the network, which will then be displayed in the 
Accessible SmartRelay table. 

• Click Import button and the Import IP Address dialog pops up for you to add devices 
manually. Click OK button then the devices that you have added will be displayed in the 
Accessible SmartRelay table. 

After getting all accessible devices displayed in the Accessible SmartRelay table, you can click 
checkboxes in the table to select devices you want to download the diagram into. By clicking 
the checkbox in the first row of the table, you can select all devices displayed in the table.  

You can sort each column of the Accessible SmartRelay table by number or letter through 
clicking each column title. 

Click OK button on the interface dialog to start the batch download process. 

After the process finishes, the Batch Download Result dialog pops up. You can check if the 
diagram downloading to each target device succeeds or not. 
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2.8.5.27 Tools -> Transfer -> Batch Download -> Network Batch Download 
With this demand, you can download each circuit diagram to the corresponding FL1F device 
in a batch. This command is only available when you are in Network Project.  

When you select this menu command, WindLGC displays the following interface dialog: 

 
You can find all FL1F devices you have added displayed in the Accessible SmartRelay table. 
You can click checkboxes in the table for the batch download. By clicking the checkbox in the 
first row of the table, you can select all devices and their corresponding diagrams displayed in 
the table.  

You can sort each column of the Accessible SmartRelay table by numbers or letters through 
clicking each column header. 

Click OK button on the interface dialog to start the batch download process. 
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After the process finishes, the Batch Download Result dialog pops up. You can check if each 
diagram downloading to the corresponding device succeeds or not. 

 

2.8.5.28 Tools -> Determine SmartRelay 
When you click this menu command, WindLGC calculates the minimum IDEC SmartRelay 
version requirements for the IDEC SmartRelay circuit program. WindLGC shows the result in 
the status bar (Page 30). The info window displays all versions to which you can download 
the program. You can also use the function key (Page 30) [F2] to execute this menu 
command.  

2.8.5.29 Tools -> Select Hardware 
You have two options of selecting the device when you create your program or project in 
WindLGC:  

• You can first create your program or project and then determine the required IDEC 
SmartRelay by using the Tools → Determine SmartRelay (Page 133) dialog. 

• You can first determine the IDEC SmartRelay version for which you want to create your 
circuit program or project by calling the Tools → Select Hardware dialog. You can also 
select the device by double-clicking the IDEC SmartRelay icon in the status bar. 

The device selection dialog shows you all the blocks and memory resources available. 

If your program contains certain blocks with special functionalities, the hardware selection 
dialog offers you only the IDEC SmartRelay device compliant with these blocks.  

If you are working on a network project, the hardware selection dialog offers you only the 
IDEC SmartRelay devices that support Ethernet connections. 

2.8.5.30 Tools -> Compare 
You can use this function to compare two circuit programs.  

WindLGC does not recognize differences in the graphical block layout and in comments. 
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Overview 
You can use this function to compare two circuit programs. You can either compare two 
circuit programs that are both open in WindLGC, or you can compare a program in WindLGC 
with the other one in the IDEC SmartRelay device.  

 

 Note 

You can compare only circuit programs of the same type, that is: *.lsc with *.lsc, *.lld with 
*.lld, or *.lma with *.lma. 

 

The following screenshot provides an overview of the compare dialog.  
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① Select the two circuit programs to compare. 
• To compare two local diagrams, you can split the diagram editor into two windows and drag 

the diagrams to each window. See Window -> Split into two windows (Page 167) for more 
information. 

• To compare your local diagram with the diagram on a connected IDEC SmartRelay Base 
Module, WindLGC requires that you confirm the connection interface before communica-
tion. See Tools -> Transfer (Page 73) for more information. 

② Click "②" to run the comparison.  
③ Here WindLGC shows you the differences in the two programs: 

- Number of blocks 
- Block parameters 
- Additional/missing blocks 
- Different hardware 
- Different message text FBs (both text and bar graph) 
- Different connections 
- Different parameter VM mapping lines 
- Different Ethernet connections 

Compare two circuit programs with parameter VM mapping settings 
When you compare two circuit programs with parameter VM mapping settings, WindLGC 
compares two lines and displays the comparison results. WindLGC only displays the 
differences between the first two different lines because once two lines differ, WindLGC stops 
comparing subsequent lines.  

Configure different VM mapping settings on the two circuit programs. See Tools -> Parameter 
VM Mapping (FL1F and later versions only) (Page 152) for more information.  
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After you have set the module address and Ethernet connections, you can start to compare 
the two circuit programs. 

 
Result: As shown in the following result display, the parameter names in parameter VM 
mapping line 1 of the two circuit programs are different. 

Compare two circuit programs with Ethernet connections 
When you compare two circuit programs with Ethernet connections, WindLGC compares their 
configurations of Ethernet connections, and then displays the comparison results.  

During the comparison of Ethernet connections, once a difference occurs in a connection 
setting, WindLGC stops comparing subsequent settings.  
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Set module addresses and Ethernet connections following instructions in the Tools -> 
Ethernet Connections (FL1F and later versions only) (Page 144) section: 

 

 
Compare the two diagrams.  
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Result: As shown in the result display above, the two compared circuit programs have 
different module address settings and different IP address settings for two Base Modules that 
are both used as clients. 

Editing 
You can edit the two circuit programs in the diagram comparison windows. 

Different hardware 
If you have configured different IDEC SmartRelay devices in the two programs, you will see a 
considerable number of messages. To avoid such messages, make sure both devices are the 
same. 

Programs with internal markers 
When you compare circuit programs with internal markers, in some circumstances WindLGC 
reports more differences than there really are. 

2.8.5.31 Tools -> Simulation 

Introduction 
Program simulation allows you to test a program and modify its parameters. This ensures the 
program in the WindLGC is fully functioning and optimized, ready for your download.  

Simulation mode 
Click the  icon in the programming toolbar to start the simulation. This changes the 
program to simulation mode. 

For more information, see Simulation. (Page 34) 

WindLGC highlights the icon simulation mode. If you have configured an IP address for your 
circuit program, you can click the  icon to simulate the circuit program in the network. You 
can watch VM (Variable Memory) values in the provided data table. To exit the simulation 
mode, click the  icon or any other icon of the programming toolbar. If you click another 
icon, you exit the simulation mode and open the tool mode of the icon that you clicked, for 
example selecting or inserting blocks. 

At the start of the simulation mode, WindLGC verifies the circuit program and displays the 
results in the Info Window (Page 71). 

2.8.5.32 Tools -> Simulation Parameters 
Select the Tools → Simulation Parameters command to configure the response of an input.  

The dialog shows only the inputs actually used in your circuit program.  
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You have four options for the digital inputs: 

• Switch 

• Momentary pushbutton (make) 

• Momentary pushbutton (break) 

• Frequency 

You have only one option for the analog inputs: 

• Analog 

Name column 
"I" designates Digital inputs (Page 243). 

"AI" designates Analog inputs (Page 247). 

Switch 
A switch latches when actuated and is released by actuating it once again. 

Momentary pushbutton 
A momentary pushbutton is only active while it is held down. The contact opens as soon as 
you release the button.  

You can determine a make or break action for the pushbuttons. 

Frequency 
You can preset or change the frequency of an input while a simulation is running. The device 
frequency is in Hz. A frequency input is a special case, which is only used in conjunction with 
the frequency trigger SFB. 
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Analog 
You can preset the value for the analog input (Page 247) or modify it while running in 
simulation mode. The units for the analog value corresponds with the default process 
variable. The range corresponds with the specified measurement range, provided you have 
selected the option of "Auto range". The value range corresponds in this case with the 
measurement range of the function connected to the input. The analog input represents a 
special case for analog SFBs. 

Refer to the information in the "Analog value processing" section (Page 334) for help on 
analog block parameters. 

Settings 
When you save your circuit program, you also save the simulation settings. Thus, you do not 
need to enter the simulation parameters once again when you exit and reopen your circuit 
program. 

While simulation mode is active, you can click a digital input in the list of input switches to 
change its settings. From the drop-down list select Switch, Momentary pushbutton (make), 
Momentary pushbutton (break) or Frequency. Use the OK button to enter your settings.  

While simulation mode is active, you can also right-click a digital input in the circuit program 
and edit its block properties. In the Simulation tab of the block properties dialog, you can 
select the type of the input as described above.  

Click "OK" to confirm your settings. 

2.8.5.33 Tools -> Connect Modem 
You can build network connections between WindLGC and IDEC SmartRelay devices to 
download and upload circuit programs or network projects by configuring their connected 
modems. WindLGC supports 11-bit modems that use standard AT commands.  

 
Select the Tools → Connect Modem menu command to start the process of configuring 
modems connected to your PC with WindLGC. The IDEC SmartRelay Base Module at the 
remote side is also connected with a modem and ready for network connection. WindLGC 
displays a Modem Information dialog that provides an overview of the configuration process. 

You must complete a series of dialogs to configure your modems. After you configure the 
modems and make the connections, you can download and upload circuit programs or 
network projects between WindLGC and IDEC SmartRelay Base Module across a telephone 
line connection over the modems. 



 User interface 
 2.8 Menu bar 

WindLGC Online Help 

Programming and Operating Manual, 11/2024 141 

The steps for connecting and configuring modems are listed below: 

1. Select Modem (Page 141) 

2. Select Remote Configuration (Page 141) 

3. Configure Remote Modem Command (Page 142) 

4. Configure Remote Modem (Page 142) 

5. Select Local Configuration (Page 142) 

6. Configure Local Modem Command (Page 142) 

7. Configure Telephone Number (Page 142) 

From the modem configuration dialogs, you can click "Next" to proceed through the dialogs, 
or click "Previous" to return to an earlier step. 

 

 Note 

This menu command is valid only for IDEC SmartRelay devices series FL1E or later. 
 

2.8.5.34 Tools -> Connect Modem - Select Modem 
From the Select modem dialog, you can select check boxes to configure the remote modem 
or the local modem. The remote modem is the one connected to the IDEC SmartRelay Base 
Module and the local modem is the one connected to the computer with WindLGC.  

If you have previously configured the remote modem or the local modem from WindLGC, the 
dialog displays the name of the modem as configured from WindLGC. You can click "Detail" 
to display specific information about the WindLGC configuration of a modem.  

If you have configured the remote modem by some means other than WindLGC, you can 
disregard the displayed settings. WindLGC will use the configuration in the actual modem. If 
you have not yet configured the remote modem, or choose to change the existing 
configuration, then select the Remote modem check box. 

For the local modem, WindLGC will use the settings as displayed by the "Detail" button, or 
you can select the Local modem check box to edit the configuration. 

If you need to configure or change the configuration of both modems, then select both check 
boxes.  

If you have already configured both modems but need to set the telephone number, do not 
select the check boxes. When you click "Next", you will advance to the telephone number 
configuration (Page 142) dialog. Otherwise, when you click "Next", you will proceed to 
configuration of the selected modems. 

2.8.5.35 Tools -> Connect Modem - Select Remote Configuration 
From the Select remote configuration dialog, you select whether to edit or delete an existing 
configuration, if one exists, or to create a new configuration.  

Click "Next" to continue with modem configuration. 
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2.8.5.36 Tools -> Connect Modem - Configure Remote Modem Command 
From the Configure remote modem command dialog, you can use the name of the remote 
modem to access and configure a remote modem. You can select the check box to accept the 
default settings for the modem commands, or you can choose not to use the defaults and to 
edit the individual commands. The "Additional" field provides the opportunity to enter other 
modem commands. Separate each one with a blank if you add additional commands. 

The commands are all standard commands. Refer to the documentation provided with your 
modem for specific command syntax. 

Click "Save Configuration" to save this configuration for the remote modem. 

2.8.5.37 Tools -> Connect Modem - Configure Remote Modem 
The Configure remote modem dialog is the last dialog for you to complete remote modem 
configuration. After you ensure that the remote modem is connected to the IDEC 
SmartRelay Base Module, follow these steps: 

1. Select the "Done" check box. 

2. Select the communications port to use. 

3. Click "Configure remote modem". 

WindLGC will complete the modem configuration and display a status message. 

2.8.5.38 Tools -> Connect Modem - Select Local Configuration 
From the Select local configuration dialog, you select whether to edit or delete an existing 
configuration, if one exists, or to create a new configuration.  

Click "Next" to continue with modem configuration. 

2.8.5.39 Tools -> Connect Modem - Configure Local Modem Command 
From the Configure local modem command dialog, you can use the name of the local 
modem to access and configure the local modem. You can select the check box to accept the 
default settings for the modem commands, or you can choose not to use the defaults and to 
edit the individual commands. The "Additional" field provides the opportunity to enter other 
modem commands. Separate each one with a blank if you add additional commands.  

The commands are all standard commands. Refer to the documentation provided with your 
modem for specific command syntax. 

Click "Save Configuration" to store this configuration to the local modem. 

2.8.5.40 Tools -> Connect Modem - Configure Telephone number 
From this dialog you can add and delete telephone numbers for the modem connection.  

Click "Add New" to provide a name, telephone number, and description for a telephone 
connection. To add multiple telephone numbers, click "Add New" and enter additional 
telephone numbers as needed. To remove a telephone number from the list, select it and 
click "Remove". 
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From this dialog, you can dial one of the telephone numbers. To establish modem 
communication across one of the telephone connections, follow these steps: 

1. Verify that the local modem is connected to your computer and that the remote modem is 
connected to IDEC SmartRelay, and click the "Done" check box. 

2. Select a telephone number from the list. 

3. Click "Dial". 

WindLGC establishes the modem connection and displays a status message. If any error 
occurs, WindLGC displays an error message. Check your connections and your configurations 
if you receive an error. Refer to the documentation provided with your modem for additional 
information. 

2.8.5.41 Tools -> Disconnect Modem 
Use this command to disconnect an existing modem connection.  

To configure modems, or to re-connect across configured modems, select the Tools → 
Connect Modem (Page 140) menu command. 
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2.8.5.42 Tools -> Ethernet Connections (FL1F and later versions only) 
Use this menu command to build Ethernet connections for the IDEC SmartRelay Base Module. 

 
① Here you select the Ethernet connection method. 

You first enable the FL1F access or Modbus access before configuring the Ethernet connections.  
② Here you define the Ethernet properties.  

To add a client/server connection, you can right-click a connection item to enable the buttons: 

 
Here you can define up to eight network connections, which are TCP/IP-based FL1F/ Modbus 
communication connections to the following devices: 
• Additional IDEC SmartRelay devices 
• Modbus devices with Ethernet capability 



 User interface 
 2.8 Menu bar 

WindLGC Online Help 

Programming and Operating Manual, 11/2024 145 

Configuring FL1F client connections 
Each FL1F connection can be configured to be a client or a server, in which the local IP/local 
TSAP (Transmission Layer Service Access Point) and remote IP/remote TSAP are configured 
respectively. The server is the data source side in communication, it sends information that 
responds to the requests from the other side - the client. 

To configure the client or server connections of each IDEC SmartRelay connection, double-
click the connection. 

Right-click the desired connection and choose to add a client connection. 

Double-click the connection item to configure the client connection.  

 
① Here you define the properties of the Client. 

TSAP is the Transmission Layer Service Access Point in TCP/IP communication.  
The local TSAP of Client is automatically generated by WindLGC. 

② Here you define the properties of the Server.  
The remote TSAP is the TSAP of the Server that you want to connect. 
The remote IP address is the IP address of the Server that you want to connect. 

③ Here you define the properties of the data transfer connection. (Read:Client <- Server, Write: 
Client -> Server) 
You can create a maximum of 32 data transfers in a Client connection.  
In the read process, the local Base Module reads data from the remote server and stores it; in 
the write process, the local Base Module writes data to the remote server. You can store data 
either on the local Base Module or the remote Server by specifying the corresponding column. 
The maximum transfer data length is 212 bytes for every data transfer. 
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FL1F data transfer configuration 
You can set the following values in the data transfer table in configuring client connections: 

1. Click the following drop-down menu to choose the data value for transferring. 

 
2. Input one address in the address field. 

3. If you configured VM mapping, you can also click  to display the VM mapping table as 
below: 

 
In the VM mapping table, you can perform the following operations:  

– Click a column to choose the desired address or click and drag down and up to choose 
multiple addresses. 

– Click the mapping fields to switch to the parameter VM mapping dialog. 

– Click and drag the black arrow at the bottom right corner to expand or shrink the table. 

See Tools -> Parameter VM Mapping (FL1F and later versions only) (Page 152) for more 
information about the VM mapping.  

4. Click the empty drop-down menu to choose data transfer directions. 

 
5. Input the other address. 

6. To add or remove rows, right-click an existing row to enable the buttons. 

 
7. Save your changes. 
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Configuring FL1F server connections 
Double-click the connection item to configure the server connection.  

 

 Note 

If the server in this connection is a FL1F device, you must configure the server connection on 
the added device. 

 

 
① Here you define the properties of the Server.  

TSAP: The range in IDEC SmartRelay Base Module is 20.00 to FF.FF. 
The local TSAP of Server is automatically generated by WindLGC.  
If you select the "Accept all connections requests" check box, the Server responds to the re-
quests from all Clients in the network. 
The Server can accept a request only from one IP address. This address is the IP address of the 
client that you want to connect. 

② Here you define the properties of the Client.  
The remote TSAP is the TSAP of the Client that you want to connect. 

Data transfer restrictions 
The table below describes the range and local address restrictions for client connections. 

Read requests: 
 
Local address (IDEC SmartRelay) Remote address (IDEC SmartRelay) 
Address Type Range Address Type Range 
VB 0 to 850 VB 

MB 
IB 
QB 

0 to 850 
0 to 7 
0 to 2 
0 to 2 
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 Note 

Address Type: 
• VB: variable byte memory 
• MB: flag byte memory 
• IB: input byte memory 
• QB: output byte memory 

Local address + Data length - 1 ≤ 850 
 

The table below describes the range and local address restrictions of client connection. 

Write requests: 
 
Local address (IDEC SmartRelay) Remote address (IDEC SmartRelay) 
Address Type Range Address Type Range 
VB 
MB 
IB 
QB 

0 to 850 
0 to 7 
0 to 2 
0 to 2 

VB 
MB 
IB 
QB 

0 to 850 
0 to 7 
0 to 2 
0 to 2 

 

 

 Note 

The values should follow the rule: Local address + Data length - 1 ≤ Max value of Local 
address type. 

 

Configuring Modbus client connections (FL1F FS5 and later versions only) 
Each Modbus connection can be configured as a client or a server, in which the local IP and 
remote IP are configured respectively. The server is the data source side in communication, it 
sends information that responds to the requests from the other side - the client. 

To configure the client or server connections of each IDEC SmartRelay connection, double-
click the connection. 

Right-click the desired connection and choose to add a client connection. 

Double-click the connection item to configure the client connection.  
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Modbus data transfer configuration 
You can set the following values in the data transfer table in configuring client connections: 

1. Click the following drop-down menu to choose the data value for transferring. 

 
2. Input one address in the address field. 
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3. If you configured VM mapping, you can also click  to display the VM mapping table as 
below: 

 
In the VM mapping table, you can perform the following operations:  

– Click a column to choose the desired address or click and drag down and up to choose 
multiple addresses. 

– Click the mapping fields to switch to the parameter VM mapping dialog. 

– Click and drag the black arrow at the bottom right corner to expand or shrink the table. 

See Tools -> Parameter VM Mapping (FL1F and later versions only) (Page 152) for more 
information about the VM mapping.  

4. Click the empty drop-down menu to choose data transfer directions. 

 
5. Input the other address. 

6. To add or remove rows, right-click an existing row to enable the buttons. 

 
7. Save your changes. 

Configuring Modbus server connections 
Double-click the connection item to configure the server connection.  

 

 Note 

If the server in this connection is a Modbus device, you must configure the server connection 
on the added device. 
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Here you define the properties of the Server. 

• The port range on IDEC SmartRelay Base Module is from 502 to 510. 

• If you select the "Accept all connections requests" check box, the Server responds to the 
requests from all Clients in the network. 

• The Server can accept a request only from one IP address. This address is the IP address of 
the client that you want to connect. 

Data transfer restrictions 
The table below describes the range and local address restrictions for client connections. 

Read requests: 
 
Local address (IDEC SmartRelay) Remote address (Modbus compatible device) 
Address Type Range Address Type Range 
I 
Q 
M 
V 

1 - 24 bit 
1 - 20 bit 
1 - 64 bit 
0.0 - 850.7 bit 

Coil 
Discrete Input (DI) 

1 to 65535 bit 

VW 
AQ 
AM 
AI 

0 - 850 word 
1 - 8 word 
1 - 64 word 
1 - 8 word 

Holding Register (HR) 
Input Register (IR) 

 
1 to 65535 word 
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 Note 

Address Type: 
• I: input 
• AI: analog input 
• Q: output 
• M: M flag 
• V: variable bit memory 
• VW: variable word memory 
• AQ: analog output 
• AM: analog M flag 

Local address + Data length - 1 ≤ 850 
 

The table below describes the range and local address restrictions of client connection. 

Write requests: 
 
Local address (IDEC SmartRelay) Remote address (Modbus compatible device) 
Address Type Range Address Type Range 
I 
Q 
M 
V 

1 - 24 bit 
1 - 20 bit 
1 - 64 bit 
0.0 - 850.7 bit 

Coil 
 

1 to 65535 bit 
 

VW 
AQ 
AM 
AI 

0 - 850 word 
1 - 8 word 
1 - 64 word 
1 - 8 word 

Holding Register (HR) 1 to 65535 word 

 

 

 Note 

The values should follow the rule: Local address + Data length - 1 ≤ Max value of Local 
address type. 

 

2.8.5.43 Tools -> Parameter VM Mapping (FL1F and later versions only) 

VM overview 
IDEC SmartRelay Base Module uses VM (Variable Memory) as a local data communication 
interface for data exchange by means of connections/data-transfer configuration. 

You can use WindLGC with the Ethernet connections menu command following instructions 
in the Tools -> Ethernet Connections (FL1F and later versions only) (Page 144) section to 
construct the network topology. 



 User interface 
 2.8 Menu bar 

WindLGC Online Help 

Programming and Operating Manual, 11/2024 153 

WindLGC performs data exchange process as follows: 

• The server stores the required data into the VM area specified by the data connection and 
data transfer. This is defined as a "share" action in the following section. 

• The client unit reads the server's VM area and then updates the corresponding local VM 
area in its network process step. 

• After the local update, the circuit program in the client can use the information in the local 
VM originated from the Server. 

 

 Note 

IDEC SmartRelay FL1F FS5 and later version devices supports two types of connection, FL1F 
and Modbus. IDEC SmartRelay FL1F only supports FL1F connection. 

 

Data type and VM address 

The following illustrates VM addressing and data type usage: 

 

Creating a parameter VM mapping 
When you change a parameter value in the local VM, the value in WindLGC changes 
accordingly. In this way, WindLGC synchronizes information with the local VM in real time.  

WindLGC synchronizes the parameter values of a block to the specified VM in each IDEC 
SmartRelay cycle. After the synchronization, IDEC SmartRelay Base Module can use the VM to 
communicate with other devices. You can map up to 64 parameters in VM for each IDEC 
SmartRelay Base Module in the Variable Memory Configuration dialog. For IDEC SmartRelay 
FL1F FS6 and later versions Base Module, 2048 bytes of VX area is extended for block 
parameter VM mapping. 

The following screen is an example of the configuration dialog of parameter VM mapping: 



User interface  
2.8 Menu bar 

 WindLGC Online Help 

154 Programming and Operating Manual, 11/2024 

 
The Block column lists the parameters for SFBs in the current program. The Parameter column 
provides a select list of the parameters of the corresponding block. The Type column displays 
the data type of the selected parameter. The Address column is also configurable. You can 
use it to identify the VM address used to save a parameter value.  

The icon next to a parameter name indicates the property of this parameter: 
 

 The parameter value is a setting value and is writable. 

 The parameter value is an actual value and is read-only. 
 Although the parameter value is an actual value, you can still change the value. 

NOTE: 
Only the Counter parameter of Up/Down counter has such a flag. 

 The parameter value is referenced from an actual value of another already-
programmed function block. 

Note that if no flag appears, then the parameter value is a system value and remains read-
only. 

Within the parameter VM mapping window, you can achieve the following tasks: 

• Select multiple record lines by pressing the Ctrl key or Shift key and clicking the ID of the 
desired line. 

• Insert a down line by pressing the Enter key on the last cell of the desired line. 

• Insert an up line by clicking the ID of the desired line and pressing the Insert key, or right-
clicking the desired line to add a new row. 

• Delete a line by clicking the ID of the desired line and pressing the Delete key, or right-
clicking the desired line to delete an existing row. 

You cannot change the parameter type and must configure a unique address for each 
parameter. The range for a parameter address is from 0 to 850. If the value you input exceeds 
this range, inputs and outputs will be modified to certain VM addresses automatically.  

WindLGC links the block parameters that you specify in the Variable Memory Configuration 
dialog with a VM address. 

Not all of the VM area is available for configuration. WindLGC reserves some bytes of the VM 
area. You cannot specify more than 64 parameters. If you attempt to specify more than 64, 
WindLGC displays a failed operation message. 

After the data transfer from an IDEC SmartRelay Base Module to WindLGC, you can view only 
analog values within the range of -32768 to 32767 on WindLGC. If an analog value exceeds 
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the value range, then only the nearest upper limit (32767) or lower limit (-32768) can be 
displayed. 

Parameter settings 
 
Function Block Data type Read/Write Parameter settings in 

WindLGC 
Parameter settings on a part-
ner device 

On-Delay 
Current Time VW R   
On-Delay VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Remaining Time VW R   
On-Delay Time Base VB R/W 10 milliseconds 1 

Seconds 2 
Minutes 3 

Off-Delay 
Current Time VW R   
On-Delay VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Remaining Time VW R   
On-Delay Time Base VB R/W 10 milliseconds 1 

Seconds 2 
Minutes 3 

On-/Off-Delay 
Current Time VW R   
On Time (TH) VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Off Time (TL) VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
On Time (TH) Remaining 
Time 

VW R   

Off Time (TL) Remaining 
Time 

VW R   

On Time (TH) Time Base VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Off Time (TL) Time Base VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Current Time Base VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Retentive On-Delay 
Current Time VW R   
On-Delay VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Remaining Time VW R   
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Function Block Data type Read/Write Parameter settings in 
WindLGC 

Parameter settings on a part-
ner device 

On-Delay Time Base VB R/W 10 milliseconds 1 
   Seconds 2 

Minutes 3 
Interval time-delay relay/Pulse output 
Current Time VW R   
Off Time (TL) VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Off Time (TL) Remaining 
Time 

VW R   

Off Time (TL) time Base VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Edge-triggered interval time-delay relay 
Current Time VW R   
Pulse Width (TH) VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Interpulse Width (TL) VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Pulse Width (TH) Remaining 
Time 

VW R   

Interpulse Width (TL) Re-
maining Time 

VW R   

Pulse Width (TH) Time Base VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Interpulse Width (TL) Time 
Base 

VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Current Time Base VB R 10 milliseconds 1 
Seconds 2 
Minutes 3 

Asynchronous Pulse Generator 
Current Time VW R   
Pulse Width VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Interpulse Width VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Pulse Remaining Time VW R   
Interpulse Remaining Time VW R   
Pulse Width (TH) Time Base VB R/W 10 milliseconds 1 

Seconds 2 
Minutes 3 

Interpulse Width (TL) Time 
Base 

VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 
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Function Block Data type Read/Write Parameter settings in 
WindLGC 

Parameter settings on a part-
ner device 

Current Time Base VB R 10 milliseconds 1 
Seconds 2 
Minutes 3 

Random Generator 
Current Time VW R   
Max. On Delay (TH) VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Max. Off Delay (TL) VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Max. On Delay (TH) Remain-
ing Time 

VW R   

Max. Off Delay (TL) Remain-
ing Time 

VW R   

Max. On Delay (TH) Time 
Base 

VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Max. Off Delay (TL) Time 
Base 

VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Current Time Base VB R 10 milliseconds 1 
Seconds 2 
Minutes 3 

Stairwell light switch 
Current Time VW R   
Off Delay VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Pre-Warning Time (T!) VW R   
Pre-Warning Period (T!L) VW R   
Off Delay Remaining VW R   
Pre-Warning Time (T!) Re-
maining 

VW R   

Pre-Warning Period (T!L) 
Remaining 

VW R   

Off Delay Time Base VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Dual-function switch 
Current Time VW R   
Off Delay Time (T) VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Permanent Light (TL) VW R/W Unit: Seconds Value range: 0 to 9999 

Unit: Minutes or Hours Value range: 0 to 5999 
Pre-Warning Time (T!) VW R   
Pre-Warning Period (T!L) VW R   
Off Delay Time (T) Remain-
ing 

VW R   
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Function Block Data type Read/Write Parameter settings in 
WindLGC 

Parameter settings on a part-
ner device 

Permanent Light (TL) Re-
maining 

VW R   

Pre-Warning Time (T!) Re-
maining 

VW R   

Pre-Warning Period (T!L) 
Remaining 

VW R   

Off Delay Time (T) Time 
Base 

VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Permanent Light (TL) Time 
Base 

VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Current Time Base VB R 10 milliseconds 1 
Seconds 2 
Minutes 3 

Seven-day time switch (When an entry box is set unavailable or a function is disabled, "0xFF" is displayed on 
FL1F/Modbus PLC and "*" is displayed on a Base Module.) 
Week Day 1 VB R/W Sunday Bit 0 

Monday Bit 1 
Tuesday Bit 2 
Wednesday Bit 3 
Thursday Bit 4 
Friday Bit 5 
Saturday Bit 6 
 NOTE: 

If the related bit is 1, then the 
day is set. 

On Time 1 VW R/W h:m h:m 
Off Time 1 VW R/W h:m h:m 
Week Day 2 VB R/W Sunday Bit 0 

Monday Bit 1 
Tuesday Bit 2 
Wednesday Bit 3 
Thursday Bit 4 
Friday Bit 5 
Saturday Bit 6 
 NOTE: 

If the related bit is 1, then the 
day is set. 

On Time 2 VW R/W h:m h:m 
Off Time 2 VW R/W h:m h:m 
Week Day 3 VB R/W Sunday Bit 0 

Monday Bit 1 
Tuesday Bit 2 
Wednesday Bit 3 
Thursday Bit 4 
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Function Block Data type Read/Write Parameter settings in 
WindLGC 

Parameter settings on a part-
ner device 

Friday Bit 5 
Saturday Bit 6 
 NOTE: 

If the related bit is 1, then the 
day is set. 

On Time 3 VW R/W h:m h:m 
Off Time 3 VW R/W h:m h:m 
Pulsely VB R/W Off 0 

On 1 
Twelve-month time switch (When an entry box is set unavailable, "0xFF" is displayed on FL1F/Modbus PLC and "-" is 
displayed on a Base Module.) 
On Time VW R/W Month:Day Month:Day 

 
Off Time VW R/W Month:Day Month:Day 
On Year VB R/W Year Year 
Off Year VB R/W Year Year 
Monthly VB R/W No 0 

Yes 1 
Yearly VB R/W No 0 

Yes 1 
Pulsely VB R/W Off 0 

On 1 
Astronomical Clock 
Longitude VD R/W  VBx+0  

W 1 
E 0 
° VBx+1 
' VBx+2 
" VBx+3 

Latitude VD R/W  VBx+0 
S 1 
N 0 
° VBx+1 
' VBx+2 
" VBx+3 

Time Zero (E+; W-) VW R/W  -11 to 12 
Low byte bit 7 means sign, for 
example: 00000001 10000000 
means -1. 

SunRise Time VW R  h:m 
SunSet Time VW R  h:m 
Stop Watch 
Time Base VB R/W 10 milliseconds 0 

Seconds 1 
Minutes 2 
Hours 3 
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Function Block Data type Read/Write Parameter settings in 
WindLGC 

Parameter settings on a part-
ner device 

Current Time VD R   
Lap Time VD R   
Output Time VW R   
Up/Down Counter 
Counter VD R/W  0 to 999999 
On Threshold VD R/W  0 to 999999 
Off Threshold VD R/W  0 to 999999 
start value  VD R/W  0 to 999999 
Hours counter 
Maintenance Interval (MI) VD R/W  0 to 599999 (9999H 59M) 
Time-to-Go (MN) VD R   
Total Time (OT) VD R   
Frequency trigger 
Frequency VW R   
On Threshold VW R/W  0 to 9999 
Off Threshold VW R/W  0 to 9999 
Gate Time VW R   
Analog trigger  
On VW R/W  -20000 to 20000 
Off VW R/W  -20000 to 20000 
Gain VW R/W   
Offset VW R/W   
Ax, Amplified VW R   
Analog Differential Trigger 
On VW R/W  -20000 to 20000 
Differential VW R/W  -20000 to 20000 
Gain VW R/W   
Offset VW R/W   
Ax, Amplified VW R   
Off VW R   
Analog Comparator 
On VW R/W  -20000 to 20000 
Off VW R/W  -20000 to 20000 
Gain VW R/W   
Offset VW R/W   
Ax, Amplified VW R   
Ay, Amplified VW R   
Ax (Amplified)-Ay (Ampli-
fied) 

VW R   

Analog Watchdog 
Gain VW R/W   
Offset VW R/W   
Aen (Comparison Value) VW R   
Ax, Amplified VW R   
Differential (+) VW R/W  0 to 20000 
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Function Block Data type Read/Write Parameter settings in 
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Parameter settings on a part-
ner device 

Differential (-) VW R/W  0 to 20000 
Analog Amplifier 
Analog Amplifier: Gain VW R/W  -1000 to 1000 
Analog Amplifier: Offset VW R/W  -10000 to 10000 
Analog Amplifier: Ax, Ampli-
fied 

VW R   

Analog Multiplexer 
AQ Amplified VW R   
V1 (S1=0; S2=0) VW R/W  -32768 to 32767 
V2 (S1=0; S2=1) VW R/W  -32768 to 32767 
V3 (S1=1; S2=0) VW R/W  -32768 to 32767 
V4 (S1=1; S2=1) VW R/W  -32768 to 32767 
PWM 
Min. VW R/W  -10000 to 20000 
Max. VW R/W  -10000 to 20000 
Gain VW R/W  -1000 to 1000 
Offset VW R/W  -10000 to 10000 
Ax, Amplified (Current Peri-
od) 

VW R   

T VW R/W Unit: Seconds Value range: 0 to 9999 
Unit: Minutes or Hours Value range: 0 to 5999 

Periodic Time Base VB R/W 10 milliseconds 1 
Seconds 2 
Minutes 3 

Analog math 
AQ Amplified VW R   
V1 VW R/W  -32768 to 32767 
V2 VW R/W  -32768 to 32767 
V3 VW R/W  -32768 to 32767 
V4 VW R/W  -32768 to 32767 
Operator 1 VB R/W  VBx+0 

+ 0 
- 1 
* 2 
/ 3 

Operator 2 VB R/W  VBx+0 
+ 0 
+ 1 
* 2 
/ 3 

Operator 3 VB R/W  VBx+0 
+ 0 
- 1 
* 2 
/ 3 
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Function Block Data type Read/Write Parameter settings in 
WindLGC 

Parameter settings on a part-
ner device 

Priority1 VB R/W L 0 
M 1 
H 2 

Priority2 VB R/W L 0 
M 1 
H 2 

Priority3 VB R/W L 0 
M 1 
H 2 

Reset Mode VB R/W Reset to zero 0 
Keep last value 1 

Analog Ramp 
Gain VW R/W   
Offset VW R/W   
Current Level VW R   
Level 1 (L1) VW R/W  -10000 to 20000 
Level 2 (L2) VW R/W  -10000 to 20000 
Largest Output Value VW R   
Start/Stop Offset VW R/W  0 to 20000 
Speed of Change VW R/W  1 to 10000 
PI Controller 
Set Value (SP) VW R/W  -10000 to 20000 
PV, Amplified VW R   
Aq VW R   
Kc VW R/W  0 to 9999 
Integration Time (TI) VW R/W Unit: Minutes 0 to 5999 
Direction VB R/W + 0 

- 1 
Manual Output (Mq) VW R/W  0 to 1000 
min VW R/W  -10000 to 20000 
max VW R/W  -10000 to 20000 
Gain VW R/W  -1000 to 1000 
Offset VW R/W  -10000 to 10000 
     
Analog Filter 
Dialog Parameter Average 
Value Sample Number 

VB R/W  3 to 8 
8 3 
16 4 
32 5 
64 6 
128 7 
256 8 

Ax VW R   
Aq VW R   
Max/Min 
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Function Block Data type Read/Write Parameter settings in 
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Parameter settings on a part-
ner device 

Mode VB R/W  0, 1, 2 and other value 
Ax VW R   
Minimum Value VW R   
Maximum Value VW R   
Aq VW R   
When reset=0, reset 
Min/Max 

VB R/W  0 or 1 

Average Value 
Sampling time  VW R/W Unit: Seconds or Minutes Value range: 0 to 59 

Unit: Hours Value range: 0 to 23 
Unit: Days Value range: 0 to 365 

Number of samples VW R/W Unit: Seconds Value range: 1 to St*100 
Unit: Days Value range: 1 to 32767 
Unit: Hours Value range: 1 to 32767 
Unit: Seconds and ≤ 5 
Minutes 

Value range: 1 to St*6000 

Unit: Seconds and ≥ 6 
Minutes 

Value range: 1 to 32767 

Ax VW R   
Aq VW R   
Time Base of Sampling time VB R/W Seconds 1 

Minutes 2 
Hours 3 
Days 4 

2.8.5.44 Tools -> Options 
Here you can select various options for WindLGC:  

• General (Page 163) 

• Preference (Page 164) 

• Print (Page 165) 

• Cut connections (Page 165) 

• Simulation (Page 166) 

• Colors (Page 166) 

• UDF (Page 167) 

• CSV Separator (Page 167) 

2.8.5.45 Tools -> Options: General 
Here you can define your default editor. 

• Edit your circuit diagram always in the FBD Diagram Editor 

• Edit your circuit diagram always in the LAD Editor 
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Here you can also define the user interface language. 

• Display the user interface in Deutsch 

• Display the user interface in English 

• Display the user interface in Japanese 

To set and apply a new language, you must close and restart WindLGC. 
 

 Note 

Change your operating system language prior to changing the language for WindLGC. 
 

Here you can define the zoom factor for the size of user interface text and icons. 

• Set the size scale to 100% 

• Set the size scale to 125% 

• Set the size scale to 150% 

 

 Note 

The zoom factor of network view or diagram editor is not changed after you set a new size 
scale of user interface text and icons. 

 

 Note 

To ensure complete display of WindLGC, you should use the recommended scale size and 
display resolution by your computer system. 

 

To set and apply a new size scale, you must restart WindLGC. 

 

2.8.5.46 Tools -> Options: Preference 
Here you can define your preferred display settings.  

• Whether to display comments 

• Whether to display connector names 

• Whether to display parameters of a block 

• Whether to use antialiasing in the drawing 

• Whether to label marked lines 

• Whether to save the software interface and working environment 

• Whether to start from the diagram tab or project tab 
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Other possible settings: 
• Antialiasing: With antialiasing, corners and edges appear softened. 

• If you enable View > Select lines (Page 71) with Label marked lines, the marked lines are 
labeled as the following example: 

 
B007 > B006/2 means that the connection runs from block 7 to block 6 at input(pin) 2. 
WindLGC does not label connections if the target block to which the connection is running is 
in the immediate vicinity. 

2.8.5.47 Tools -> Options: Print 
Here you can determine the appearance of your printed circuit programs:  

• Whether to print the comment you have entered in the comment tab under File → 
Properties: General (Page 54) 

• Whether to print the Ethernet connections you have configured under Tools -> Ethernet 
Connections (FL1F and later versions only) (Page 144) 

• Whether to print the parameter VM mapping you have configured under Tools -> 
Parameter VM Mapping (FL1F and later versions only) (Page 152) 

• Whether to print the connector names and parameters in a circuit diagram 

• Whether to print the list of the parameters of all blocks, of all selected blocks, or only of 
the special timer functions 

• Whether to print the list of connector names 

• Whether to suppress empty page 

• Inputting the desired zoom factors for the printing 

2.8.5.48 Tools -> Options: Cut Connections 
Here you can choose to cut connections via the Cut/Join (Page 38) either manually or 
automatically.  

You can specify one or both of the following types of connections to be cut: 

• Connections on import or on upload 

• Connections routed across a block 

• Connections exceeding a configurable length 

In the radius text box you can choose either to input the radius points directly or to use the 
scroll bar.  

After confirming these settings, WindLGC will cut connections accordingly.  
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If you configured WindLGC to cut connections during importing or uploading, the software 
cuts connections according in the following cases: 

• When you upload (transfer) a circuit program from IDEC SmartRelay to WindLGC 

• When you import (open) a circuit program created with WindLGC 

2.8.5.49 Tools -> Options: Simulation 
Here you can configure the simulation parameters and its displayed status:  

• For starting a simulation: 

– You can choose whether to start the simulation automatically when you switch to 
simulation mode. Otherwise, you must press the green arrow icon  to start 
simulation from simulation mode. 

– You can choose whether to automatically simulate network communication when the 
IP address is accessible. Otherwise, you must press the icon  to start simulation in 
network. 

– You can specify whether to reset the status of inputs and outputs at the start of 
simulation. 

• For interface display: 

– You can also specify whether to switch the display of signal states and process 
variables on or off in simulation mode. Switching it off improves the performance of 
your simulation because when you disable the display of signal states and process 
variables, there is no need for WindLGC to calculate these values continuously. 

– In addition, you can specify whether to display a separate simulation window for text 
messages on the IDEC SmartRelay TD/TDE. If selected, simulation mode shows active 
message texts for the IDEC SmartRelay Base Module and the IDEC SmartRelay TD/TDE in 
separate windows. 

– You can specify whether to show the elapsed time for simulation in standard 12 hour 
format. 

2.8.5.50 Tools -> Options: Colors 
Here you can define the following elements of the color settings:  

• Desktop color 

• Colors of signal lines carrying a logical "1" or "0" signal in simulation mode 

• Color setting for UDF block frame in circuit program 

• Colors for each of the four maximum possible block inputs and for the block output. 

• Background color of function blocks. 

• Background color of special flags. 

• Color of parameter box lines connecting parameter boxes from each other. 

You can reset color on the chosen field by choosing different color panels from Swatches, 
HSV, HSL, RGB, CMYK and Standard.  

The preview area shows your color selection.  
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2.8.5.51 Tools -> Options: UDF (FL1F and later versions only) 
Use this command to configure the UDF library. 

A UDF library can contain two types of elements: a single UDF (.lma) file and a folder with 
multiple UDF files. 

You can add or remove UDF files or folders in the dialog.  

UDFs added to the UDF library appear immediately in the block tree, and are available for use 
in the circuit program. 

2.8.5.52 Tools -> Options: CSV Separator 
Use this command to choose whether to separate items in the CSV-format log file by 
semicolons or by commas.  

2.8.6 Window menu 
From the Window menu, you can arrange your circuit program windows on the desktop. You 
can duplicate existing circuit programs and split the windows to obtain a clearer overview of 
large programs. The following window options are available:  

• Undo Split (Page 167) 

• Split into two Windows (Page 167) 

• Split into three Windows (Page 168) 

• Selection list (Page 168) 

2.8.6.1 Window -> Undo Split 
You can use this menu command to undo all splits of a circuit program window.  

2.8.6.2 Window -> Split into two windows 
WindLGC allows you to split the diagram editor window into two windows.  

You can drag one diagram to the other window in order to view different areas of this 
diagram. You can then use the scroll bars to view or modify the elements not displayed in 
either window. 

You can also copy one diagram to the other window to compare two circuit programs or to 
modify the pasted diagram.  

The split, of course, affects only the window, but not your circuit program. These changes, 
take effect throughout the circuit program because only the window is split, but not the 
circuit program. 
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In project mode, every time you add an IDEC SmartRelay Base Module in the network view, 
WindLGC creates a corresponding program at the same time in the diagram editor frame. You 
can edit one window at a time. Move your mouse in the desired window frame and click the 
left mouse button on that window to switch highlight to it before operations. You can also 
click the device in the network view when working in project mode.  

 

 Note 
Bilateral programming 

WindLGC supports network programming between two split windows. For more information 
on two-side programming or namely bilateral programming, see Two-side programming 
(Page 199). 

 

 Note 

If you accidentally close a diagram in project mode, you can double-click the device in the 
network view frame to show the diagram again. 

 

2.8.6.3 Window -> Split into three windows 
WindLGC also supports to split diagram editor window into three windows. 

The items to note are the same as Window -> Split into two windows (Page 167), see that 
section for more information.  

2.8.6.4 Window -> Selection list 
The selection list at the end of the Window menu shows you all the windows you have 
opened on the programming interface. You can use this selection list to quickly switch 
between windows.  

2.8.7 Help menu 
This menu provides you with help and information on WindLGC.  

• Contents (Page 169) 

• Context-sensitive Help (Page 170) 

• Update Center (Page 170) 

• Update Cloud (Page 171) 

• About (Page 171) 
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2.8.7.1 Help -> Contents 

The Online Help 
The online help quickly and reliably provides you with information about program and 
network configuration, tools and the creation of circuit programs and network projects with 
WindLGC.  

Topics of the Online Help 
The User interface (Page 45) section describes the user interface with its toolbars and the 
WindLGC menus in detail. 

Refer to the Tutorial (Page 172) for a quick and easy introduction to the basics of operating 
WindLGC, its circuit programming features and its new project networking features.  

Towards the end of this section you will find an extensive Practical example (Page 221) that 
takes you through all the steps of circuit program and network project creation. 

The Sample applications (Page 236) section introduces a few applications for IDEC 
SmartRelay. 

The Reference material (Page 242) chapter contains the following subsections: 

• The Constants and connectors (Page 242) , Basic functions (only the FBD Editor) 
(Page 257) and Special functions (Page 263) subsections provide you with information 
about the various elements of a circuit program. 

• The Circuit programs (Page 411) subsection provides information on memory 
requirements, circuit program limits for IDEC SmartRelay, and additional information 
about blocks. 

• The Network projects (Page 420) subsection gives an overview of the network project. 

• The Data Log profile (Page 392) subsection gives information about the Data Log. 

• The UDF (Page 395) subsection provides information on the UDF (User Defined Function 
block). 

The Tips and Tricks (Page 421) section includes information that supports your daily tasks 
with WindLGC. 

The online help includes an index as well as a full text search feature for keyword and 
terminology based searches. 

Help for blocks 
If you double-click a block in the circuit program, you receive a window with parameters and 
settings for the block. If you then click the Help button in this window you receive the Help 
for this block in its own window.  

Alternatively, you can right-click a block in the circuit program and select Help from the 
shortcut menu. 
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2.8.7.2 Help -> Context-sensitive help 
 → Help Context-sensitive help 

To display help on an object, first click the context-sensitive help icon (see above) and then 
the object.  

Result: A window opens with information on this object. 

You can also right-click objects on the programming interface and select Help from the 
shortcut menu to display a corresponding help topic.  

The standard toolbar (Page 33) also contains an icon for this menu command. 

2.8.7.3 Help -> Update Center 
Note: This function is disabled in current release. You can download the upgrade packages 
manually from IDEC (http://www.idec.com/usa/). 

Update Center 
The Update Center helps you to install additional languages, program add-ons, service packs 
and new versions for your WindLGC.  

If you update the software to a higher version (for example, from Version 6.3 to Version 8.0), 
you can upgrade from either the Update Center or a DVD-ROM. 

How to use the Update Center 
Follow these steps to perform an update/upgrade: 

1. Select whether you want to update/upgrade WindLGC via the Internet or using your local file 
system (DVD-ROM, floppy or hard disk drive). 

2. If you choose to update/upgrade WindLGC from your local file system, then you are 
prompted to enter the folder path in which you save the updates/upgrades. 
If you update/upgrade WindLGC from the Internet, then the correct Internet address is 
already preset in the Settings Internet Update. If you are not connected directly to the 
Internet, then you must specify a proxy server. Consult your network administrator in this 
regard. An Internet connection is then created. 

3. You are then shown all the updates/upgrades available for your software version. Select the 
desired updates/upgrades. If you are updating WindLGC from the Internet, then your 
selected updates/upgrades will be downloaded and installed. 

4. If you are updating/upgrading WindLGC via the Internet, you are prompted to manually 
close the Internet connection when you have completed these actions. 

WindLGC is closed automatically when the update/upgrade is completed. The functionality of 
the installed update/upgrade is available to you after you restart WindLGC. 

Possible errors 
When installing an upgrade/update, if you receive the error message Does not agree with 
magic number, this means the upgrade/update file Setup.exe has not been executed fully.  

http://www.idec.com/usa/
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In this case, download the upgrade/update file from the Internet again and ensure the file is 
transferred completely. 

2.8.7.4 Help -> Update Cloud 
IDEC will release Cloud related updates after Cloud service platforms' corresponding updates. 
In this case, you only need to update Cloud instead of updating WindLGC.  

How to use the Update Cloud 
Follow these steps to update Cloud: 

1. Download the Cloud update package from IDEC (https://us.idec.com/idec-
us/en/USD/Programmable-Logic-Controller/SmartRelay/FL1F-
SmartRelay/c/SmartRelay_FL1F?page=1), and save the file in your local file system. 

2. Unzip the downloaded package. 

3. Click Help -> Update Cloud. The window displays the current Cloud version information, 
then click Next. 

4. In this window, click the folder icon to select the root directory of the unzipped cloud update 
package file. WindLGC verifies the update package and displays if the update package file or 
the version is valid. 

5. Click Next to start the update. After the update, the window displays the update result. 

6. Click Finish to close the window. WindLGC reminds you in a window that the update will 
not take effect until you restart the program. 

2.8.7.5 Help -> About 
The General tab displays the version number and the release version of your WindLGC 
software.  

The System tab provides you with information on the version of the Java Runtime 
environment used, the program paths, the installed operating system and on the memory 
used. 

https://us.idec.com/idec-us/en/USD/Programmable-Logic-Controller/SmartRelay/FL1F-SmartRelay/c/SmartRelay_FL1F?page=1
https://us.idec.com/idec-us/en/USD/Programmable-Logic-Controller/SmartRelay/FL1F-SmartRelay/c/SmartRelay_FL1F?page=1
https://us.idec.com/idec-us/en/USD/Programmable-Logic-Controller/SmartRelay/FL1F-SmartRelay/c/SmartRelay_FL1F?page=1


 

 WindLGC Online Help 

172 Programming and Operating Manual, 11/2024,  

Tutorial 3 
3.1 Prerequisites for working with the tutorial 

To use this tutorial, you must be familiar with PC operation and you must know how to create 
a function block diagram. To download your circuit programs, you also need a PC cable, SD 
card or Ethernet cable for connecting the PC interface to your IDEC SmartRelay device.  

3.2 Getting started with program creation 
You are going to learn the basics of working with WindLGC by creating a simple circuit 
program and simulating it on your PC. Towards the end of this chapter, you will find a few 
sample applications (Page 221) for WindLGC, and information on how to prepare, transfer 
and archive your application.  

If necessary, review the elements of the user interface (Page 26) before beginning the 
tutorial. 

Factory door (Page 238)  

Air-conditioning system (Page 236)  

Fill station (Page 239)  

3.2.1 Creating a circuit program 

Developing a circuit program 
Perform these tasks to develop a circuit program: 

1. Create a new circuit program (Page 173). 

2. Select blocks (Page 173) 

3. Place the blocks (Page 173) 

4. Configure and comment the blocks (Page 174) 

5. Connect the blocks (Page 175) 

6. Optimize the circuit program (Page 180) 

7. Save the circuit program (Page 186) 

Note that not all blocks are available (Page 177) under all circumstances. 
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3.2.1.1 Creating a new circuit program 
After you start WindLGC, you can begin to create a new circuit program.  

To create a new circuit program, select the File -> New menu command or click the New 
button in the standard toolbar.  

 → File → new (Page 46)  

WindLGC opens the FBD Editor (or the default editor specified under Tools/Options/Standard 
Editor), and then you can create the new circuit program in a new window on the 
programming interface. 

Click the small arrow on the right side of the File → new icon to open the LAD, FBD or UDF 
Editor. 

3.2.1.2 Selecting blocks 
Your first programming step is to select the blocks for your circuit program. Determine the 
order in which you want to insert the I/O and the standard/SFB blocks.  

Under Co in the programming toolbar, you find the constants and terminals, that is, a 
collection of I/O and constant signals. Under GF, you find the basic logic functions of Boolean 
algebra: standard digital logic blocks. Under SF you can find the special functions. You can 
also access the respective function groups via the function keys. 

 or [F6] → Constants/connectors (Page 242)  

 or [F8] → SFBs (Page 263)  
 

 

Only in the FBD and UDF Editors: 
 or [F7] → Basic functions (Page 257)  

 

A quick and easy way of selecting blocks and placing them into your circuit pro-
gram (Page 421)  

3.2.1.3 Placing blocks 
Click the icon group that contains the required block or, as an alternative, click the function 
key (Page 30). The programming interface displays all blocks belonging to the selected Basic 
function group.  

Example for the FBD Editor: 
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You can insert the selected function on your programming interface by clicking the 
programming interface. You can select other functions with the mouse before you place 
them. 

Example for the FBD Editor: 

 
There is no need to align the blocks right away. A precise alignment of the blocks at this time 
does not make sense, until you have interconnected them and entered the comments in your 
circuit program. 

Information on block numbering is found here (Page 419). 
 

 

How to quickly and easily select blocks and place them into your circuit pro-
gram (Page 421)  

3.2.1.4 Editing blocks 

Shortcut menus 
Right-click an object opens a shortcut menu that offers you various object editing options. 
The editing options depend on the selected object: 
 

 

 

Objects consist of not only blocks and connecting lines, but also the programming interface 
and toolbars.  

You can also call Help -> Context-sensitive help (Page 170) on the selected object in the 
shortcut menu. 
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Configuring blocks 
Double-click a block to configure block properties. The properties dialog includes a Comment 
tab as well as various parameter tabs for the SFBs (Page 263), and for some of the basic 
functions (Page 257) and constants and connectors (Page 242). You specify here the values 
and settings for your blocks. You can click the Help button to get help on the parameters of 
the selected block. 

You can recognize special functions by the green lettering below the block on the 
programming interface. 

3.2.1.5 Connecting blocks 
To complete the circuit program, you must interconnect the blocks. In the programming 
toolbar (Page 36), select the block connection icon.  

Example for FBD: 

 → Connector (Page 38)  

Click the connector of one block and drag the mouse to a connector of another block to make 
a connection between the two blocks. WindLGC connects the two terminals. 

Example for LAD: 
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WindLGC offers you a further option of connecting blocks when you right-click the input or 
output of a block. In the shortcut menu, click the Connect with block menu command to 
display a selection list that contains all blocks available for your connection. Click the relevant 
target block. WindLGC then draws the connecting line. This method is especially useful for 
connecting a source to a target block over a greater distance on the programming interface. 
 

 

 
 

 

 

Note on the LAD Editor: 
Do not forget to connect the I/O to the bus bar on the left edge of the editor 
window. 

Tips on connecting blocks 
When you connect an input to an output, or vice versa, WindLGC displays a tooltip that shows 
the connection. Release the mouse button to snap the line onto the indicated input. 

You can refer to the short information (tooltips) in WindLGC for additional help on circuit 
programming. Hover over a block to see the name of the block. Hover over a block input to 
see the name of the input. 

 

WindLGC displays a blue frame around the mouse pointer when it can connect to an block 
input (pin) 
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Rules for connecting blocks 
The following rules apply to the connection of blocks: 

• You can connect a single input to multiple outputs. 

• You cannot connect multiple inputs to a single output. 

• You cannot interconnect I/O in the same path of a circuit program. Recursion is not 
permitted. Interconnect a flag (Page 245) or output (Page 244) if necessary. 

• SFBs (Page 263) also have green "connectors". These do not represent connecting pins, 
but are used instead for assigning the parameter settings. 

• Analog I/O cannot be connected to digital I/O. 

Multiple connections 
You can connect I/O to existing connections. 
 

 

A quick and easy way of connecting blocks in large circuit programs (Page 423)  

3.2.1.6 Availability of blocks 

Hardware defaults 
The memory space (Page 418) and the device series (Page 411) of your IDEC SmartRelay 
determines:  

• How many blocks you can use in the circuit program 

• Which blocks are available to create your circuit program 

After you have created a circuit program, you can call the Tools → Determine SmartRelay 
(Page 133) menu command or press the function key (Page 30) [F2] to display an Info 
Window that shows you which IDEC SmartRelay devices are available for executing your 
circuit program. 

 
The blocks which are not available for your selected IDEC SmartRelay are not displayed. 
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Optimizing the circuit program 
Should you determine in the course of creating your circuit program that an IDEC SmartRelay 
device is unable to handle your circuit program, you should first make use of all the 
functional resources offered to you by the IDEC SmartRelay device. You could, for instance, 
replace memory intensive blocks (Page 413) with a structure consisting of several blocks, 
which altogether require less memory space. 

If the various optimization attempts are unsuccessful, then you can use an additional IDEC 
SmartRelay, or optimize/simplify the functionality of your application. 

3.2.1.7 Parameter box overview 
Click the small box below the block to open the parameter box. Not all blocks have parameter 
boxes.  

A parameter box describes each parameter in one line including its name, value and unit.  

 
 
① show/hide button ④ parameter value 
② output connector  ⑤ parameter name 
③ unit ⑥ input connector 

For information on using a parameter box, see Editing a parameter box (Page 179). 
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3.2.1.8 Editing a parameter box 
To create, cut, or delete a connection line, follow these steps: 

1.  Click the connector of one parameter box and drag the mouse to a connector of another 
parameter box to make a connection between the two parameter boxes. 

 

 

 
2. You can cut and rejoin the reference line. For information on cutting the reference line, see 

Cut/Join (Page 38). 

3. You can delete the reference line. Deleting a connection line means deleting their reference 
relationship. For information on deleting a reference line, see Edit → Delete (Page 62). 

4. You can hide or show a parameter box line. For information on hiding/showing a parameter 
box, see shown/hidden parameter box line (Page 42). 

Customized reference line color 
You can define the reference line color in color option dialog. On how to set the color of 
reference line, see section Tools -> Options: Colors (Page 166) for more information. After 
you select a color, WindLGC uses that color for all reference lines. 

Tips on connecting parameter boxes 
After you connect a line from an output connecter to an input connecter, or vice versa, a pop-
up tooltip opens to show the connection. Release the mouse button to snap the line onto the 
indicated input. 
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You can refer to the short information (tooltips) in WindLGC for additional help on circuit 
programming. Hover over a block to see the name of the block. Hover over a block input to 
see the name of the input. 

Rules for connecting parameter boxes 
The following rules apply to the connection of blocks: 

• You can connect a single input to multiple outputs. 

• You cannot connect multiple inputs to a single output. 

To change a time unit  
When the time-type parameters refer to another parameter, you can change the units of the 
parameter by left clicking the small arrow and selecting the unit you want in the drop down 
list. 
 

 

 

  

 
 

 

3.2.2 Editing the layout 
The circuit program is ready for use after you have inserted and connected the blocks. To 
optimize the appearance of your layout, you can reposition the blocks and lines.  

3.2.2.1 Selecting objects 
Before you can move or align objects you must first select them. Click the selection tool in the 
programming toolbar or press the [ESC] key to activate the selection tool.  
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or [ESC] → Selection (Page 37)  

You select single blocks or connecting lines with a simple mouse click. To select groups of 
blocks or connecting lines, you "capture" them with the mouse. To "capture" objects, keep the 
left mouse button pressed and draw a frame around them and then release the mouse 
button. WindLGC highlights the "captured" blocks by small red squares at the corners of the 
selected fields. 

Sample for the FBD Editor: 

 
In addition to the selection of single objects by a simple mouse click or highlighting object 
groups by "capturing", there is a further selection option: Under "optional selection", mark the 
objects one after the other by holding down the [Ctrl] key while you select the objects. To 
remove an object from the selection, hold down the [Ctrl] key and click a selected object once 
again. 

3.2.2.2 Editing selected objects 
You can delete single or grouped objects with the [Del] key, or move them with drag and 
drop or use the keyboard. The cursor keys allow fine positioning in very small steps. However, 
do not set the snap function in the Format → Grid menu when doing so. You can also cut, 
copy and paste selected objects by means of the relevant toolbar icons.  

 → Cut a Selected Object (Page 62)  

 → Copy a Selected Object (Page 62)  

 → Paste a Selected Object (Page 63)  

Editing selected connecting lines 
WindLGC indicates a selected connecting line by round and square blue handles. You can use 
the round handles to move the lines at a right angle into the direction in which they extend. 
You can use the square handles to reassign the beginning or end of a line. Move the lines by 
dragging the round handles. 

Example for the FBD Editor: 
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If you do not connect a line to a suitable target connector, WindLGC reconnects it to its initial 
position after you "release" the mouse button. 

3.2.2.3 Replacing blocks 
To replace a block in your circuit program with another function block, follow these steps:  

1. Insert the new block above or below the block you want to replace. 

2. Rewire the connecting lines of the old block to the new one as described under "Editing 
selected connecting lines" in Editing selected objects (Page 181). 

3. After having rewired all the connecting lines, you can delete the old block and move the 
new block into this position. 

Example for the FBD Editor: 

 
By keeping this block replacement order, you can maintain your connecting lines. If you first 
delete the old block, you also delete its connections, which means you have to recreate all 
connections. 

In an IDEC SmartRelay FL1F Base Module, you can directly replace an old block by dragging 
the new block from the block tree to the old block figure with the left mouse key pressed. 

3.2.2.4 Cutting connections 
It may turn out to be difficult to interpret the layout of a large circuit, especially if it contains 
many line crossings. You can clean up your connection layout, using the "Cut/Join" tool of the 
programming toolbar.  

 →  Cut/Join (Page 38)  

Click a connection after you have called this tool. The selected connecting line is graphically 
split. However, the link between the blocks remains active. 

The open ends of the cut connection are now shown with arrowhead icons, which indicate 
the direction of the signal flow. Above the icons, you can now see the cross-references, 
including the page number of the circuit program, the block name and the number of the 
block terminal that is connected to the open link. 

Right-click the line connecting the two blocks you want to cut, then select the cut command. 
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You can also cut a group of connections, using the Edit → Cut (Page 62) menu command. 
Before you cut any connections, you can also set the cutting criteria, for example, cut all 
connections routed through blocks. 

Example for the FBD Editor: 

 
The connection is closed again by clicking on its open end while the Cut/Join tool is active. 
Optionally, you can close the connection by right-clicking on an open end and calling the Join 
menu command. 

Example for the FBD Editor: 

 
You should not use this tool to edit smaller circuit programs. In most cases you can optimize 
the layout by repositioning the icons. 

Applications and advantages 
Large and complex circuit layouts may contain numerous line crossings, thus making it more 
or less difficult to interpret the circuit. In such cases, the Cut/Join button is a highly effective 
means of clearing up the circuit layout. 

You can quickly jump to the partner connector by right-clicking the open end of a cut 
connection. This opens a shortcut menu, in which you can select the Go To Partner menu 
command to jump to the partner end of the cut connection. 

Another advantage of the Cut/Join tool is its utilization for circuits extending across more 
than one printable page, that is, across a page break. The connecting lines of two circuit 
blocks which are shown on different pages are cut without cross-reference. However, if you 
cut such connections using the Cut/Join tool you generate a cross-reference pointing to the 
source or the connection target. 

Example for the FBD Editor: 
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3.2.3 Documentation and saving 

3.2.3.1 Documentation of the circuit program 

Labels 
You can create block-independent and associated labels using the text tool of the 
programming toolbar. To do so, click the text tool.  

 → Text tool (Page 38)  

When this icon is active, open a text input box by clicking a free area of the programming 
interface or a block. After you have entered the label text, simply click anywhere outside the 
label window or press the [ESC] key. The window is closed and the label text is displayed in 
the diagram. That label can now be selected, moved or aligned. 

Example for the FBD Editor: 

 

Block independent and associated text 
Click a free area of the programming interface to create a block independent label. A label 
can be edited by calling the text tool and then clicking on the relevant label. 
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By clicking a block with the text tool, you create an associated label, namely the block 
comment. You can also input and edit this comment in the comments tab of the block 
properties dialog. The block comment can be used, for example, to name a block or to 
describe the task of the block within your circuit. 
 

 

 

If you select a block with an associated label, the text is not marked. However, when you 
move the block, you also move the label. When you copy or cut the block, only the block itself 
is copied to the clipboard. A cut operation deletes the associated label. However, the 
associated label can be selected and moved, copied, cut or pasted individually. An associated 
label that is pasted from the clipboard is no longer associated with the block. 

In Edit → Input/output Names (Page 66) you can assign block numbers and connector names 
to the I/O. 

Comment linking and connector comments 
Text comments can be linked to function blocks or to cut connectors. 

To link the text and the function blocks, left-click the yellow cubic in the center of the text 
when the text is selected and move the pointer to the block you want link to with the left 
mouse button pressed. When a function block or a cut connector is linked to a comment, its 
frame color is green.  
 

  

A linked comment moves consistently with the figure to which it is attached. You can adjust 
the relative position of the comment to the figure, as you do a block comment. 
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3.2.3.2 Opening and saving a circuit program 

Opening a circuit program 
You can always click the File open icon to open a circuit program for further editing.  

 → File Open (Page 47)  

Saving a circuit program 
Click the File save icon in the standard toolbar to save the circuit program.  

 → File Save (Page 49)  

The circuit program/project is saved under the name it was opened with, while older versions 
are overwritten. When you initially save a file, you are prompted to specify a program path 
and name.  

3.3 Simulation of a circuit program 

3.3.1 Starting the simulation 
Use the Tools → Simulation (Page 138) menu command or the simulation icon  in the 
programming toolbar to place your circuit program in simulation mode.  

At the start of simulation, WindLGC verifies the circuit program and shows any existing errors 
in the Info Window, which you can view by calling the View → Info Window (Page 71) menu 
command or by pressing the function key (Page 30) [F4]. You can also use the function key 
[F2] in the Info Window to display the IDEC SmartRelay modules capable of running your 
program. 

In simulation mode, you have the simulation toolbar and status window (Page 34) available 
for performing the simulation and for observing and controlling the behavior of your circuit 
program.  

 

 Note 

You can simultaneously simulate only three of your circuit programs. A warning dialog 
reminds you when you try to simulate the fourth one. 
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3.3.2 Layout of inputs 
WindLGC displays inputs as key or switch icons, with the name below the icon. An open input 
represents an inactive switch. When you click the icon, WindLGC switch it on and indicates 
that with red.  
 

 

→ Icon for pushbutton I1, not actuated → open input 

 

→ Icon for pushbutton I1, actuated → closed input 

 

→ Icon for pushbutton I2, not actuated → open input 

 

→ Icon for pushbutton I2, actuated → closed input 

Layout of analog and frequency inputs 
You can set the analog voltage or frequency values for analog and frequency inputs by means 
of a slide resistor. Click the relevant block to display and operate this slider directly in the 
diagram. If you want to specify a more precise value, enter it directly or set it directly via the 
up/down keys beside the input window. 

 
 

 

 
→ Display for analog input block  

 

 
 
 

 

 
→ Frequency input 

 

 

Input functions 
You set the response of your inputs for simulation purposes with the Tools → Simulation 
Parameters (Page 138) menu command. 
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3.3.3 Layout of the outputs 
In simulation mode, WindLGC displays the Outputs Q (Page 244) and the Flag M (Page 245) 
as outputs.  

WindLGC indicates the status of an output or flag by a light or dark bulb icon. WindLGC 
displays the name of the output in your circuit program below this icon. 
 

  → Status display of output Q1 → Output switched off 

  

 
→ Status display of output Q1 → Output switched on 

The icon only indicates the status of an output. You cannot turn the output on or off by 
clicking the icon. 

3.3.4 Set output 
In simulation mode, you can set a block output by right-clicking the digital output of the 
block. With this command, you can set the output irrespective of the current status of the 
block. The output remains set until you enable it again or you end the simulation.  

This way you can use a simulation to check how a circuit program will react to certain states. 

3.3.5 Power failure 
The user can simulate a power failure by clicking the Power icon to interrupt the power 
supply to all inputs.  
 

 
 
→ Power icon, not actuated 

 
 
→ Power icon, actuated → Simulated power failure 

You can use this function to test the reaction of the circuit to power failure and restart, as 
well as its retentivity. In contrast to the start of simulation, retentivity is relevant for the 
"Power failure" function. The start of a simulation is equivalent to the "Load Program" 
function in IDEC SmartRelay. WindLGC resets all values, including the retentive values. 
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3.3.6 Layout of message texts 
After you start simulation, the simulation toolbar contains a toggle button that shows the 
message window. 

 

 

If you right-click the entry in the message text, you can see from which block the entry in the 
message text originates. You can also select this block in the circuit program (Go to Block) 
and call up the properties of this block (Block Properties).  

When you configure an IDEC SmartRelay FL1E message text (Page 363), you specify whether 
to display the message text on one destination (the IDEC SmartRelay onboard display or IDEC 
SmartRelay TD) or on both. If you specify to display a message text on one destination, 
simulation mode shows active message texts for that destination in one window. If you select 
to display on both destinations, simulation mode shows active message texts for the IDEC 
SmartRelay onboard display and the IDEC SmartRelay TD in separate windows. If you use IDEC 
SmartRelay FL1D message texts (Page 373) in your circuit program, the message text 
destination can only be the IDEC SmartRelay onboard display.  
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Standard View  
The following display shows you the standard view with the message destination on the IDEC 
SmartRelay display only: 

 
① Tab of the displayed message text stating the priority. 
② Tab of another message text. 
③ Name of the message destination. It can be "SmartRelay onboard display" or "SmartRelay TD", 

depending on your setting.  
④ Details button 

If you click this button, the view changes and you receive more detailed information in the 
Detail View (see below). 

⑤ Enter value manually symbol 
Before you can use this function you must first click a changeable entry in the message text. 
If you then click this button, you can manually change the current value. 
Alternatively you can also double-click an entry to manually change it. 

⑥ Go to Block symbol 
If you click this button, the special function belonging to the message text is selected in the 
circuit program. 

⑦ Options for different character sets, when the circuit program does not use M27 (Page 245) to 
determine the character set selection.  
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Detail View 
The following display shows you the detail view with the message destination on the IDEC 
SmartRelay TD only: 

 
① Details button 

If you click this button, you return to the standard view (see above). 
② Enter value manually symbol 

Before you can use this function you must first click a changeable entry in the message text. 
If you then click this button, you can manually change the current value. 
Alternatively you can also double-click an entry to manually change it. 

③ Go to Block symbol 
If you click this button, the special function belonging to the message text is selected in the 
circuit program. 

④ Entry in message text with information regarding the block from which the entry originated. 
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View for separate IDEC SmartRelay onboard display and IDEC SmartRelay TD message text 
displays 

If you select the option "Show message text for the IDEC SmartRelay TD in a separate 
window" from the Tools -> Options: Simulation (Page 166) dialog and specify that the 
message destination is on both the IDEC SmartRelay onboard display and the IDEC 
SmartRelay TD, simulation mode shows active message texts for both modules in separate 
windows. 

 

3.3.7 Parameter assignment in simulation mode 
You can double-click a block during simulation to open the block properties dialog. Here, as in 
programming mode, you can modify comments or parameters.  

 
Simulation mode shows you the actual parameter values. This analysis option allows you to 
test the reaction of your circuit program. You can open several parameter assignment 
windows concurrently in simulation mode. 
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3.3.8 Alternative operation 
You can click directly the inputs to switch them on or off.  

 

3.3.9 Controlling the simulation time 
The simulation mode of WindLGC allows you to test your circuit program on a timed basis, or 
over a specific number of cycles. You can even modify the time of day to test timer 
operations in your circuit program. See the time control (Page 34) section in the simulation 
toolbar topic for more information on the capabilities you have in simulation mode.  

3.3.10 Simulating network communication (FL1F and later versions only) 
In simulation mode, WindLGC creates a virtual network simulation group in the background 
to support network simulation. You can put one or more circuit programs into this group. You 
can create only one simulation group at a time and the IP address of each circuit program in a 
group must be unique. The following figure shows three circuit programs in a simulation 
group. 

 
After you start simulation, the simulation toolbar contains a toggle button, which is available 
only after you configure the Ethernet connection information. 

 
 If you click the network simulation button, WindLGC displays the circuit programs in the 
simulation group. The following figure shows a circuit program that is being simulated. 
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You can remove a diagram from the simulation group by clicking the button "Simulate out of 
network". After you remove it, WindLGC continues to simulate the circuit program but 
without communication to the other circuit programs. 
 

 

For circuit programs without the network feature, simulation is the same as in IDEC 
SmartRelay FL1E. 

3.3.11 Data table (FL1F and later versions only) 
You can watch Variable Mapping (VM) values in the Data Table. The simulation toolbar 
contains a toggle button for opening or closing the display of the Data Table. 

 
In the Data Table, you can enter VM addresses and choose the corresponding data types. 
WindLGC displays the current values for the VM addresses that you provide. You can add new 
rows by right-clicking an existing row, or pressing the Enter key on the last cell of an existing 
row. You can enter new values in the New Value column for an existing VM address.  
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The table below shows the valid address types and memory ranges: 
 
Address Type Range 
Bit 
VB 
VW 
VD 
IB 
QB 
MB 

x.0 to x.7 
0 to 850 
0 to 849 
0 to 847 
0 to 2 
0 to 2 
0 to 7 

For simulation, the values of the Data Table will be updated each cycle. For online test, the 
values are updated after each communication. 

3.4 Getting started with project creation 
You can learn the basics of working with WindLGC by creating a simple circuit project and 
simulating it on your PC. The online help also includes a few sample applications (Page 236) 
for WindLGC, and information on how to prepare, transfer and archive your application.  

If necessary, review the elements of the user interface (Page 26) before beginning the 
tutorial. 

3.4.1 Creating a Network project 

3.4.1.1 Creating a new circuit project 
After you have started WindLGC, you can start to create a new circuit project.  

To create a new project, click the File → new or click the New button in the standard toolbar 
in project mode. 

 → File → new (Page 46)  
 

 Note 

When you create a new project, the current project will be closed. If you haven't saved the 
current project, WindLGC prompt you to save it. 
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3.4.1.2 Creating a circuit project 

Developing a circuit project 
Perform these tasks to develop a circuit program: 

1. Create a new project (Page 195). 

2. Add a new device (Page 196) 

3. Create a circuit program for the device (Page 172) 

4. Save the project (Page 198) 

3.4.1.3 Adding a new device 
After you create a new project, you can start to design your network and add devices. 

1. Double-click Add new device in the Network project tree. 

2. Select Device in the Device list. 

3. Set the IP address, subnet mask and the Gateway for the device in the configuration dialog. 
You can also change the device name in this window. 

Alternatively, you can click the Add new device button in Networking toolbar  (Page 43)to 
add a new device. 

 

 Note 

When you add a new device in the Network view of project mode, WindLGC automatically 
creates a new circuit program and displays it in the diagram editor. See "Creating a new 
circuit program (Page 173)", for more information. 

 

3.4.1.4 Devices 

Local PC 
You use the local PC to create, edit, and configure the project and circuit program. For how to 
configure the local PC, see Configuring PC settings (Page 201). 

When you add a new device, WindLGC generates an Ethernet connection between the device 
and the local PC. You cannot modify the Ethernet connection line in the Network view. 

IDEC SmartRelay device 
In the network view, you can add the following types of IDEC SmartRelay device: 

• IDEC SmartRelay FL1F 

• IDEC SmartRelay FL1F Slave 

• IDEC SmartRelay FL1F FS5 
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• IDEC SmartRelay FL1F FS5 Slave 

• IDEC SmartRelay FL1F FS6 

• IDEC SmartRelay FL1F FS6 Slave 

The following display shows you the standard view of a device model for IDEC SmartRelay 
FL1F FS6, FL1F FS5 and FL1F. 
 

  
 

 
① Ethernet port This port shows the Ethernet port to other devices. 
② Device image Device image 
③ Normal con-

nector 
You can create Ethernet connections between devices by connecting the 
normal connectors through drag-and-drop operation. For how to connect 
the normal connector, refer to Configuring Ethernet connection, Smar-
tRelay to SmartRelay. (Page 208) 
Note: You can only connect a normal connector to a connector of another 
device. You cannot connect different connectors in one device to each 
other. 

④ Dynamic con-
nector 

You can connect a dynamic connector with a maximum of eight normal 
device connectors. When you create a connection between a dynamic 
connector and a normal connector of another device, WindLGC automati-
cally creates a client connection in the connect device. 
Note: FL1F devices have dynamic connector. A dynamic connector cannot 
be connected with other dynamic connectors. 

⑤ Property icon You can open the device property panel by left-clicking the property icon.  
⑥ Device IP When you connect a device in diagram mode, you must assign the IP ad-

dress for a device before creating an Ethernet connection to or from the 
device. 
In network project mode, WindLGC assigns a default IP address (for exam-
ple, 192.168.1.1) when you add a new device to a project.  

⑦ Device name Note: WindLGC displays the device name, or the first 11 characters of the 
device name. 

 

 

 Note 

You can only connect Modbus devices to FL1F FS5 and later version devices. 
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IDEC SmartRelay slave 

In WindLGC, you can only connect an IDEC SmartRelay slave to an IDEC SmartRelay device 
and you cannot create connection by dragging and dropping. You can only create the 
connection by connecting network blocks. For how to connect IDEC SmartRelay devices, refer 
to Configuring Ethernet connection, IDEC SmartRelay to IDEC SmartRelay slave (Page 213). 

Modbus compatible device 
In WindLGC, you can only connect Modbus devices to FL1F FS5 and later version devices. 
Modbus device has only one connector in WindLGC, but you can create multiple connections 
between Modbus device and IDEC SmartRelay devices(up to 100). For how to connect 
Modbus devices, refer to Configuring Ethernet connection, IDEC SmartRelay to Modbus 
compatible devices (FL1F FS5 and later versions only) (Page 208). 

 

IDEC SmartRelay TDE (WindLGC V8.0) 
You can reserve a IP address for you IDEC SmartRelay TDE in WindLGC. 

 

IDEC SmartRelay TDE FS4 (WindLGC V8.2 and later versions) 
In WindLGC, you can connect IDEC SmartRelay TDE FS4 to an IDEC SmartRelay device for both 
online mode and offline mode. For detailed information, refer to Configuring IDEC 
SmartRelay TDE offline settings (Page 202) and Configuring IDEC SmartRelay TDE online 
settings (Page 202). 

 

3.4.1.5 Opening and saving a circuit project 

Saving a project 
Click the save icon in the standard toolbar to save the project.  
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 →File Save (Page 49) 

WindLGC saves the project under the name it was opened with and overwrites the older 
versions. When you initially save a project, WindLGC prompts you to specify a program path 
and name.  

Saving a circuit program of a device 
Right click the device, and select Export in the shortcut menu to save the circuit program. 

Opening a project 
You can click the File open icon to open a circuit project for further editing.  

→File Open (Page 47)  

Importing a circuit program to a project 
Right-click any blank space in the network view, and select Import... in the shortcut menu to 
import the circuit program. 

3.4.1.6 Two-side programming 
Project mode supports network programming between two diagrams. You can easily create 
the network connection and data transfer by drag and drop.  

You can only use two-side programming between FL1F devices in project mode 

Transferring block data between two diagrams by two-side programming  
Position the mouse pointer on the output connector of a function block. Press the left mouse 
button and hold it. Move the pointer from the source connector to the target input 
connector. Release the mouse button. WindLGC connects the two terminals. 
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When you connect two function blocks in two separate circuit diagrams, WindLGC creates a 
pair of network function blocks, including the Ethernet connection and data transfer 
mechanism. The green color indicates that the IDEC SmartRelay device of the two circuits are 
connected in WindLGC. The network function block turns to red if its IDEC SmartRelay device 
loses the connection to the other IDEC SmartRelay device in WindLGC. 

 
 

An alternative way to set up the connection 
1. Insert a pair of network blocks (for example, NI/NQ) in the two diagrams. 

2. Connect the NI to the block from which you want to get remote value. 
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3. Connect  NQ to the block to which you want to transfer data. 

4. Connect the NI and NQ. 

 

3.4.2 Device setting configuration 

3.4.2.1 Configuring PC settings 
The local PC running WindLGC is the local device for the network configuration.  

When you add new devices, WindLGC connects them automatically to the local PC in the 
network view. 

You can then configure the PC settings by clicking the  icon on the local PC image in the 
network view.  

You can select the network interface that connects the local PC to the IDEC SmartRelay Base 
Module from this dialog.  

3.4.2.2 Configuring IDEC SmartRelay offline settings 
After configuring the local PC settings, you can then configure device offline settings by 
clicking the  icon on the device image in network view.  

You can refer to the File -> Properties (Page 53) for detailed information. 

3.4.2.3 Configuring IDEC SmartRelay online settings 
After connecting your device to the local PC, you are then able to configure the device online 
settings by clicking the  icon on the device image in network view frame.  

You can refer to File -> Properties (Page 53) for detailed information. 
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3.4.2.4 Configuring IDEC SmartRelay TDE offline settings 
In Network view panel, after adding new device (Page 196), you can click the  icon on the 
device image, and then the IDEC SmartRelay TDE settings dialog shows.  

In the IDEC SmartRelay TDE settings dialog, you can configure IDEC SmartRelay TDE FS4 for 
the following offline settings:  

• General 

In this tab, you can set the name and IP for your device. You can set the Device name to 
the IDEC SmartRelay TDE, and then input the IP address, subnet mask and Default gateway 
to assign an IP to the IDEC SmartRelay TDE. 

• Host IP 

In this tab, you can enter the Host IP address or select the IP address from address book by 
clicking the Address book button. 

• Message text 

In this tab, you can configure message text settings in IDEC SmartRelay TDE. There are 
three options for General settings and you can click the radio button to select the option: 

– Character Set 1: This specifies the primary character set for message texts. Message 
texts are composed of characters from either Character Set 1 or Character Set 2. Either 
character set can be the default for configuring message texts. 

– Character Set 2: This specifies the secondary character set for message texts. Message 
texts are composed of characters from either Character Set 1 or Character Set 2. Either 
character set can be the default for configuring message texts. 

– Follow BM's Setting: This option can lead you to follow the BM's setting. For detailed 
information on Message text setting in BM, refer to File -> Message Text Settings 
(Page 51). 

• TDE power-on screen (offline) 

In this tab, you can configure a power-on screen for IDEC SmartRelay TDE in the following 
two ways:  

– To follow the BM's setting, click the check box next to Use BM's setting. 

– To customize TDE power-on screen, select a character set and then use the keyboard to 
type characters into the Content area. The power-on screen can only contain simple 
text strings 

3.4.2.5 Configuring IDEC SmartRelay TDE online settings 
IDEC SmartRelay TDE Settings dialog is composed of Online setting tab and Offline setting 
tab. You can configure IDEC SmartRelay TDE online setting on the Online setting tab.  
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There are two methods to enter the online setting tab: 

• Method 1: After configure TDE device (Page 126), the communication between the IDEC 
SmartRelay TDE and WindLGC is established successfully, and then IDEC SmartRelay TDE 
Settings dialog automatically appears. The Online setting tab is editable and the Offline 
setting tab is not accessible. 

• Method 2: In Network view panel, after adding new device (Page 196) , you can click the 
 icon on the device image, and then the IDEC SmartRelay TDE settings dialog shows. 

In the IDEC SmartRelay TDE settings dialog, you can configure IDEC SmartRelay TDE FS4 for 
the following online settings: 

• Connect to TDE 

In this tab, you can transfer data between a IDEC SmartRelay TDE and WindLGC after 
configuring the communication interface successfully.  

– As for method 1: WindLGC is connected to TDE successfully. 

– As for method 2: you need to connect to TDE firstly, for detailed information, refer to 
Tools -> Transfer -> Configure TDE Device ( IDEC SmartRelay TDE FS4 only) (Page 126). 
After the connection is successful, other settings are editable. 

• Show FW version 

In this tab, you can identify the firmware version of IDEC SmartRelay TDE. 

• Assign IP address 

In this tab, you can change the IP address, subnet mask and default gateway of the IDEC 
SmartRelay TDE in the New IP settings, and click the Assign IP address button to 
implement change. 

• Assign Host IP 

In this tab, you can assign the Host IP address to IDEC SmartRelay TDE, enter the Host IP 
address or select the IP address from Address book, and then click Apply button. 
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• Assign Message text 

In this tab, you can assign message text settings in IDEC SmartRelay TDE. There are three 
options for General settings, you can click the radio button to select the option: 

– Character Set 1: This specifies the primary character set for message texts. Message 
texts are composed of characters from either Character Set 1 or Character Set 2. Either 
character set can be the default for configuring message texts. 

– Character Set 2: This specifies the secondary character set for message texts. Message 
texts are composed of characters from either Character Set 1 or Character Set 2. Either 
character set can be the default for configuring message texts. 

– Follow BM's Setting: This option can lead you to follow the BM's setting. For detailed 
information on Message text setting in BM, refer to File -> Message Text Settings 
(Page 51). 

• TDE power-on screen 

In this tab, you can configure a power-on screen for IDEC SmartRelay TDE in the following 
two ways:  

– To follow the BM's setting, click the checkbox next to Use BM's setting. 

– To customize TDE power-on screen, select a character set and then use the keyboard to 
type characters into the Content area. The power-on screen can only contain simple 
text strings. 

 
Click "①" to read the previously-configured power-on screen that is stored in the 
memory of IDEC SmartRelay TDE. 

Click "②" to write the currently-configured screen to IDEC SmartRelay TDE memory. 
IDEC SmartRelay TDE updates the power-on screen that is stored in memory. 

Click "③" to switch back to empty screen. 
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3.4.2.6 Configuring settings for other standard devices 

For other standard devices 
If you have added Modbus devices, an IDEC SmartRelay TDE, or other devices in the network 
view, you can then edit the device name, IP address, subnet mask, and gateway for those 
devices. 

3.4.2.7 Detecting device online status 
After you configure the online and offline settings, you can go online and view online status 
for the devices. 

Push the devices online to start scanning for any connected IDEC SmartRelay Base Modules.  

WindLGC detects all the devices in the project as accessible, inaccessible and unknown 
devices, see "Going online (FL1F and later versions only) (Page 43)" for more information.  

See "Configuring settings for unknown devices (Page 205)" for more information about 
configuring unknown devices.  

After the your device is found, you can stop displaying the online status for all devices. See 
"Going offline (FL1F and later versions only) (Page 45)" for more information. 

3.4.2.8 Configuring settings for unknown devices 
You can configure the device name, IP address, subnet mask, and gateway of an unknown 
device to define it on the network.  

 

 Note 

On normal occasions, you are able to delete the connection line between local PC and its 
connected device in the network view by choosing it and clicking the button on the 
standard tool bar. But when deleting the unknown devices and their connection lines, you 
will need to disconnect them physically with the local PC, instead of deleting from the 
network view. 

 

Uploading the added devices 
To upload the added device to a project, right-click the device in the network view and select 
Upload from the shortcut menu. If no previous settings, the uploaded device can use the IP 
address, subnet mask, and gateway you defined in the step above. After completion, the 
device is displayed as an identified IDEC SmartRelay Base Module.  

 

 Note 

If the IP address of the uploaded device conflicts with the existing device, a warning message 
of IP address conflict pops out and then you need to reset its IP address according to 
"Configuring IDEC SmartRelay online settings (Page 201)"  
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3.4.3 Create Ethernet connection 
WindLGC supports to create Ethernet connections in network view frame. You can connect 
the device in your project through the following ways: 

• Create Ethernet connection by drag-and-drop (Page 206) 

• Create Ethernet connection, IDEC SmartRelay to non-project devices (Page 215) 

• Create Ethernet connection by two sides programing (FL1F and later version devices only) 
(Page 214) 

For more information, you can refer to Tools -> Ethernet Connections (FL1F and later versions 
only) (Page 144).  

Cross-LAN connection 
WindLGC allows to add devices with different LAN settings to the same network project. 

Make sure the router on both sides can communicate with each other, for information on 
how to create cross-LAN connections, see section Create Ethernet connection, IDEC 
SmartRelay to non-project devices (Page 215) .  

 
 

 Note 

IDEC recommend you don't add cross-LAN connections in a project. If you attempt to connect 
devices outside the LAN, the connections you add may be inapplicable. 

 

Enabling the defined TSAP on the target device 
IDEC SmartRelay Base Module uses the TSAP (Transportation Service Access Point) as an 
identified label of the access point to any other devices.  

The TSAP for the IDEC SmartRelay physical connectors is from 20.00 to 27.00.  

The TSAP for the IDEC SmartRelay dynamic connector is from 00.01 to 18.FF.  

You need to make sure the same TSAP is enabled on the target device in order to build data 
communication successfully.  

3.4.3.1 Create Ethernet connection by drag-and-drop 
WindLGC enables you to create Ethernet connections by dragging and dropping in network 
view. 
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Simply click a connector of the source IDEC SmartRelay Base Module, drag to the desired 
connector on the target device, and release the left button.  

Result: WindLGC creates a pair of Ethernet connection between the two device, and connects 
the two connectors with a line.  

 
WindLGC sets different connections lines with different color. 
 
Connections lines Connection line color 
PC to devices green 
IDEC SmartRelay to IDEC SmartRelay 
 

blue 

IDEC SmartRelay to Modbus compatible device yellow 

 WindLGC automatically identifies the server and client according to your operations. 

• If you connect a normal connector to a dynamic connector, the IDEC SmartRelay device 
using the dynamic connector is the server. 

• If you connect two normal connectors, the start end is the client. 

 

 Note 

When IDEC SmartRelay BM works as a Modbus TCP server through a dynamic connector, IDEC 
SmartRelay BM uses the port 510. 
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Configuring Ethernet connection, IDEC SmartRelay to IDEC SmartRelay 
Double-click the connection line to configure the connection settings: 

 
① Starting point (Client): 

All the fields are read-only.  
② End point (Server): 

All the fields are read-only.  
③ Data transfer table 

See Tools -> Ethernet Connections (FL1F and later versions only) (Page 144) for more infor-
mation about data transfer configurations.  

Configuring Ethernet connection, IDEC SmartRelay to Modbus compatible devices (FL1F FS5 and 
later versions only) 

WindLGC supports the creation and configuration of Ethernet connections between IDEC 
SmartRelay Base Modules and Modbus compatible devices.  

Double-click the connection line to configure the connection settings: 
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① IDEC SmartRelay Base Module: 

The IDEC SmartRelay Base Module is the client by default, you can set it as the client or the server here.  
② Modbus Device: 

The Modbus device is the server by default, you can set it as the server or the client here.  
③ Data transfer table  

See Tools -> Ethernet Connections (FL1F and later versions only) (Page 144) for more information about 
data transfer configurations.  

 

 Note 

If you connect the dynamic connector with an Modbus compatible device, WindLGC 
disables the server/client check boxes. The IDEC SmartRelay Base Module with the 
dynamic connector is always the server in this connection.  

 

3.4.3.2 Create Ethernet connection by network block 

Configuring Ethernet connection, IDEC SmartRelay to remote devices 
WindLGC supports connecting IDEC SmartRelay Base Module to Modbus compatible devices 
or IDEC SmartRelay and IDEC SmartRelay slave devices through network blocks. 
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Creating remote connections 
If you add network blocks to communicate with other devices, you can configure connections 
as follows:  

1. Right-click the function block and set the block properties of this block. 

 
The configure items are different for different device type, for example you need to input 
the port and Unit ID for connecting a Modbus-compatible device. 

2. Define the device to connect as a remote device. 

3. Choose the device name and IP address of the target device. 
Alternatively, you can also browse for a device configured previously. 

 
WindLGC supports to configure your local device to the following remote devices on the 
listed block types and their value range. 
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For NI and NAI: 
 
Function Block Local Device Remote Device Block Type and Value Range 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
NI 

 
 
 
 
 
FL1F FS6 

FL1F FS6 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] / VX: [0, 2047].[0, 7] / VR: 
[0, 511].[0, 7] 

FL1F FS5 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0,7 ] 

FL1F I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] 

Modbus Compatible 
device 

Coil: [1, 65535] / DI: [1, 65535] 

FL1F FS6 Slave I: [1, 24] / Q: [1, 20] 
FL1F FS5 Slave I: [1, 24] / Q: [1, 20] 
FL1F Slave I: [1, 24] / Q: [1, 20] 

 
 
 
 
 
FL1F FS5 

FL1F FS6 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] / VX: [0, 2047].[0, 7] / VR: 
[0, 511].[0, 7] 

FL1F FS5 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] 

FL1F I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] 

Modbus Compatible 
device 

Coil: [1, 65535] / DI: [1, 65535] 

FL1F FS6 Slave I: [1, 24] / Q: [1, 20] 
FL1F FS5 Slave I: [1, 24] / Q: [1, 20] 
FL1F Slave I: [1, 24] / Q: [1, 20] 

 
 
 
 
FL1F 

FL1F FS6 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] / VX: [0, 2047].[0, 7] / VR: 
[0, 511].[0, 7] 

FL1F FS5 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] 

FL1F  I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] 

FL1F FS6 Slave I: [1, 24] / Q: [1, 20] 
FL1F FS5 Slave I: [1, 24] / Q: [1, 20] 
FL1F Slave I: [1, 24] / Q: [1, 20] 

 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
FL1F FS6 

FL1F FS6 V: [0, 849] / V: [0, 2046] / VR: [0, 510] 
FL1F FS5 V: [0, 849] 
FL1F V: [0, 849] 
Modbus Compatible 
device 

IR: [1, 65535] / HR: [1, 65535] 

FL1F FS6 Slave AI: [1, 8] / AQ: [1, 8] 
FL1F FS5 Slave AI: [1, 8] / AQ: [1, 8] 
FL1F Slave AI: [1, 8] / AQ: [1, 8] 

 
 
 
 
 

FL1F FS6 V: [0, 849] / V: [0, 2046] / VR: [0, 510] 
FL1F FS5 V: [0, 849] 
FL1F V: [0, 849] 
Modbus Compatible 
device 

IR: [1, 65535] / HR: [1, 65535] 

FL1F FS6 Slave V: [0, 849] / V: [0, 2046] / VR: [0, 510] 
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Function Block Local Device Remote Device Block Type and Value Range 
 
 
 
NAI 

FL1F FS5 FL1F FS5 Slave AI: [1, 8] / AQ: [1, 8] 
FL1F Slave AI: [1, 8] / AQ: [1, 8] 

 
 
 
 
FL1F  

FL1F FS6 V: [0, 849] / V: [0, 2046] / VR: [0, 510] 
FL1F FS5 V: [0, 849] 
FL1F  V: [0, 849] 
FL1F FS6 Slave AI: [1, 8] / AQ: [1, 8] 
FL1F FS5 Slave AI: [1, 8] / AQ: [1, 8] 
FL1F Slave AI: [1, 8] / AQ: [1, 8] 

For NQ and NAQ: 
 
Function Block Local Device Remote Device Block Type and Value Range 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
NQ 

 
 
 
 
 
FL1F FS6 

FL1F FS6 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] / VX: [0, 2047].[0, 7] / VR: 
[0, 511].[0, 7] 

FL1F FS5 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] 

FL1F I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] 

Modbus Compatible 
device 

Coil: [1, 65535] 

FL1F FS6 Slave Q: [1, 20] 
FL1F FS5 Slave Q: [1, 20] 
FL1F Slave Q: [1, 20] 

 
 
 
 
FL1F FS5 

FL1F FS6 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] / VX: [0, 2047].[0, 7] / VR: 
[0, 511].[0, 7] 

FL1F FS5 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0,7] 

FL1F  I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0,7] 

Modbus Compatible 
device 

Coil: [1, 65535] 

FL1F FS6 Slave Q: [1, 20] 
FL1F FS5 Slave Q: [1, 20] 
FL1F Slave Q: [1, 20] 

 
 
 
FL1F 

FL1F FS6 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0, 7] / VX: [0, 2047].[0, 7] / VR: 
[0, 511].[0, 7] 

FL1F FS5 I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0,7] 

FL1F I: [1, 24] / Q: [1, 20] / M: [1, 64] / V: [0, 
850].[0,7] 

FL1F FS6 Slave Q: [1, 20] 
FL1F FS5 Slave Q: [1, 20] 
FL1F Slave Q: [1, 20] 

 
 
 

 
 
 

FL1F FS6 V: [0, 849].[0, 7] / VX: [0, 2046] / VR: [0, 
510] 

FL1F FS5 V: [0, 849] 
FL1F  V: [0, 849] 
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Function Block Local Device Remote Device Block Type and Value Range 
 
 
 
 
 
 
 
 
 
NAQ 

FL1F FS6 Modbus Compatible 
device 

HR: [1, 65535] 

FL1F FS6 Slave AQ: [1, 8] 
FL1F FS5 Slave AQ: [1, 8] 
FL1F Slave AQ: [1, 8] 

 
 
 
 
FL1F FS5 

FL1F FS6 V: [0, 849].[0, 7] / VX: [0, 2046] / VR: [0, 
510] 

FL1F FS5 V: [0, 849] 
FL1F  V: [0, 849] 
Modbus Compatible 
device 

HR: [1, 65535] 

FL1F FS6 Slave AQ: [1, 8] 
FL1F FS5 Slave AQ: [1, 8] 
FL1F Slave AQ: [1, 8] 

 
 
 
FL1F 
 

FL1F FS6 V: [0, 849].[0, 7] / VX: [0, 2046] / VR: [0, 
510] 

FL1F FS5 V: [0, 849] 
FL1F  V: [0, 849] 
FL1F FS6 Slave AQ: [1, 8] 
FL1F FS5 Slave AQ: [1, 8] 
FL1F Slave AQ: [1, 8] 

Configuring remote connections 
Follow the same approach to configure remote connections as that in section Configuring 
Ethernet connection, IDEC SmartRelay to IDEC SmartRelay (Page 208). Note that WindLGC 
allows you to switch to the diagram of the connected device simply by clicking on the values 
(NI1/NQ1...) in the connection dialog. This operation is only available for network blocks.  

Configuring Ethernet connection, IDEC SmartRelay to IDEC SmartRelay slave 
WindLGC supports the connection of a IDEC SmartRelay Base Module to a IDEC SmartRelay 
slave only through network blocks.  

Switch the target device to slave mode. Refer to Tools -> Transfer -> Configure Master/Slave 
Mode (FL1F and later versions only) (Page 82) for details.  

Follow the same steps as Create Ethernet connection by network block (Page 209). 

Choose the target device and WindLGC automatically changes the device type to slave.  
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 Note 

You can only create connections between a IDEC SmartRelay Base Module and its client using 
network function blocks (NI/NQ/NAI/NAQ). Drag-and-drop operations are not available in this 
case.  

 

 Note 

FL1F and FL1F FS5 support 24 NIs and 20 NQs separately. But no matter NI or NQ, you can 
have maximum 32 data connections in total.  

 

3.4.3.3 Create Ethernet connection by two sides programing (FL1F and later version 
devices only) 

WindLGC also supports the creation of Ethernet connections between two IDEC SmartRelay 
Base module through two-side programing.  

To connect two IDEC SmartRelay Base module, simply click a connector of the source block, 
drag to the desired connector on the target block, and release the left button.  

Results:  

• WindLGC connects the two connectors with a gray line, indicating that the line is read-
only. 

• WindLGC adds a green NQ function block to the source IDEC SmartRelay diagram, and a 
green NI function block to the target IDEC SmartRelay diagram. 
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You need to know the following during your operations:  

• WindLGC creates connection lines in order from left to right. 

• You can only change the server/client status, data transfer address, and direction by 
adding and configuring the related function block. 

• You can only remove the connection line by deleting the added NI and NQ blocks. You 
cannot click on the standard toolbar to remove these blocks. 

• Once you remove one of the two automatically-added green function blocks, the other 
changes to red, warning that the connection is not complete. 

3.4.3.4 Create Ethernet connection, IDEC SmartRelay to non-project devices 
WindLGC supports the creation and configuration of Ethernet connections between IDEC 
SmartRelay Base Modules and devices outside of the current project.  
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Create a connection to remote device 
1.  Right-click the IDEC SmartRelay Base Module or its connector. 

2.  Choose to add a server connection or a client connection. 

3. Choose to add an FL1F connection or a Modbus connection. 

Adding server connection 
Follow the steps below to configure the server connection. 

 
① IDEC SmartRelay Base Module: 

All the fields are read-only. 
② Non-project Device: 

Here you can set whether to allow access from all requests, or enter the IP address and TSAP port to ena-
ble connection to the non-project device.  
You must allow access from all requests if you are trying to connect to devices outside of the LAN (Local 
Area Network).  

③ Data transfer table 
Use the check box to activate the data transfer table.  
See Tools -> Ethernet Connections (FL1F and later versions only) (Page 144) for more information about 
data transfer configurations.  
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Adding client connection 
Follow the steps below to configure the client connection. 

 
① IDEC SmartRelay Base Module: 

All the fields are read-only.  
② Non-project Device: 

Enter the IP address and TSAP port to enable connection to the non-project device.  
③ Data transfer table 

See Tools -> Ethernet Connections (FL1F and later versions only) (Page 144) for more information about 
data transfer configurations.  

Connection result 
WindLGC displays the connection as a terminal in the network view. 
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 Note 
• If you choose the IDEC SmartRelay Base Module when creating connections, the terminal 

automatically uses the available connector in the left-to-right order. 
• If you choose a specific connector, the terminal uses the connector that you selected. 

 

3.4.4 Import or export a device 

3.4.4.1 Export a device 
You can export a device with all function block information and network configurations in a 
project. The exported device could be opened in diagram mode or imported to other projects. 

The remote device names configured in function blocks NI/NQ/NAQ/NAI are converted to IP 
after the exporting.  

The device file is saved as lsc file.  

Export a device from a project 
To export a device from your project, follow the steps below. 

1. Right-click the device, then click ①. 

 
2. Browse to the folder you want to save the device file, then click Save. 
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3.4.4.2 Import a device 
You can import a circuit program and its network configurations to a network view. 

Import a circuit program to a IDEC SmartRelay device 
Follow the below steps to import a circuit to your project. 

1. Right-click a device in the network view, then click ①. 

 
2. Select the circuit program you want to import in your computer. 

 

 Note 

You can only import your circuit program to a device of IDEC SmartRelay FL1F and later 
versions. 

 

 Note 

The importing circuit program replaces the former circuit program saved in the IDEC 
SmartRelay device. 

 

When you import a circuit program to a device which has a different hardware version from 
it, WindLGC will synchronize their hardware version according to their own status. For those 
circuit programs which don't support network functions, you cannot import them to a device. 
See the following flowchart for the detailed information. 
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Create a new FL1F FS5 device by importing a circuit program 
You can create a new FL1F FS5 device by either of the following methods. 

• Import in Network view 

– Right click any blank area in the network view, then click ①. 

 
– Select the circuit program you want to import in your computer. 

• Drag and drop a circuit program to the network project tree. 

Recover network connection 
During the importing, WindLGC checks the IP address of the importing device. If the IP 
address is existed in the current network project, WindLGC prompts you that the IP address 
and network configuration need to be updated. After you click Yes, WindLGC assigns a new IP 
address to the importing device. 

WindLGC reconnects the connectors when their following configuration matches: 

• Client and Server. 

• IP address 

• TSAP 
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For more information on the network setting, refer to Create Ethernet connection 
(Page 206). 

 

 Note 

When a device's dynamic port is fully occupied, the connection to this dynamic port cannot 
be recovered any more. 

 

3.5 Practical example 

3.5.1 Practical example: Introduction 
This practical sample application (Page 221) for a service water pump offers new users a step-
by-step introduction. You learn here how to apply the functions that you have learned, based 
on a practical example.  

Further samples of circuit programs are found in the Sample Applications section (Page 236). 

3.5.2 The task 
In addition to the drinking water supply, rainwater takes an increasing part in domestic water 
supply systems, thus saving money and helping to protect the environment. For example, 
rainwater can be used for the following needs:  

• Washing clothes 

• Watering the garden 

• Watering indoor plants 

• Washing the car 

• Flushing the toilet 

Rainwater can be collected in a suitable system to be used instead of drinking water. 

Description of the system 
The rainwater is collected in a reservoir. From the reservoir, it is pumped into a respective 
water supply system. From there it can be tapped in the same way as drinking water. The 
system functions can be upheld by supplying drinking water if the reservoir runs out of 
service water. Service water may include  water for various services - washing, bathing, 
cooking, watering plants, etc. 

The goal of this task is to create a control circuit that satisfies the requirements for such an 
installation. 

The sketch below illustrates how such a service water system works: 
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Requirements of the control system 
• Service water must be available at all times. An emergency control system must change 

over to drinking water supply, for example, if service water runs low. 

• The ingress of service water into the drinking water network must be prevented when 
switching over to drinking water supply. 

• The pump must be disabled if the service water reservoir runs low of water (dry-run 
protection). 
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3.5.3 Layout of the solution 
The pump and a solenoid valve are controlled by a pressure switch and three float switches, 
which are installed in the service water reservoir. The pump must be switched on if the 
pressure in the reservoir drops below minimum. When the operating pressure is reached, the 
pump is switched off again after a tracking time of a few seconds. The tracking time prevents 
pump oscillation if water is tapped over an extended period.   

 
 

3.5.4 Solution with IDEC SmartRelay 

Connecting field devices 
In addition to the IDEC SmartRelay device, all you need is the pressure switch and the float 
switches to control the pump. If you are using a 3-phase AC motor, a contactor relay is 
required for switching the pump. In systems with single-phase AC pumps, you must install a 
contactor relay if the current of the AC pump exceeds the switching capacity of the output 
relay Q1. A solenoid valve can usually be controlled directly, due to its low power 
consumption.  
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Connection diagram 

 
① Pump 
② Mains water inlet 
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Block diagram 
The block diagram shows you how to interconnect the pump controls and the solenoid valve. 
The layout corresponds with the structure of the circuit program. 

 

Options 
For specific applications, you also have the choice of integrating additional functions which 
could otherwise only be realized with additional switchgear: 

• Enabling the pump at specific times, for example, only during the summer months or at a 
specific time-of-day 

• Indication of an imminent or existing shortage of water 

• System error messages 

3.5.5 Input of project data 
After you have planned your project, you can start to create it in WindLGC. If you do not want 
to start programming right away, you can first input your project data in the Properties dialog 
(Page 54).  

When working through the following steps, remember to save your circuit program at regular 
intervals. You might want to open a revised version at a later time to test out other options. 
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3.5.6 Placing blocks 
In the next step, place the required blocks into the programming interface. Note that in 
addition to the standard and special functions, you also require I/O blocks. At this stage of 
progress it is sufficient for you to place the blocks roughly into position that seems 
appropriate to you for connecting them later. You can carry out fine positioning after making 
all of the connections.  

FBD Editor: 

 

LAD Editor: 
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UDF Editor: 

 

3.5.7 Connecting blocks 
Connect the blocks as you have planned previously. Connect them by drawing the connecting 
line, starting at the output of a source block and ending at the input of the target block. This 
has the advantage that you are shown the name of the connector when you interconnect the 
input, which is particularly advantageous for the various connectors of SFBs.  

FBD Editor: 
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LAD Editor: 

 
 

UDF Editor 

 

3.5.8 Cleaning up the programming interface 
Some of the connecting lines might be routed across blocks, which can make the layout of 
the circuit program hard to read. To "tidy up" the programming interface, select the 
connecting lines and blocks where required and move or align them until you have optimized 
the circuit program layout as far as possible.  
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FBD Editor: 

 

LAD Editor: 

 

UDF Editor 
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3.5.9 Optimizing the view 
You can cut unwanted though unavoidable line crossings using the Cut/Join tool (Page 38) to 
improve the appearance.  

FBD Editor: 

 
 

LAD Editor: 
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UDF Editor 

 
Note that UDF blocks do not support inputs, outputs, analog inputs, analog outputs, M8, 
M25, M26, M27, shift registers, the data log or message text function blocks.  

You have now completed your circuit program. Verify all connections once again and 
configure the block parameters to suit your requirements. 

3.5.10 Testing the circuit program 
Place your circuit program in simulation mode (Page 138) and verify that your program is 
error-free.  

Although you now know that you can run your circuit program in IDEC SmartRelay, you still 
need to make sure your circuit program operates as planned. You may also want to modify 
certain parameters. You can try out different input values, test the reaction of the system to 
power failure and compare your calculations or expectations with the simulated reaction of 
the outputs. The simulation toolbar and status window (Page 34) provide the tools you need 
for these tasks. 

The float and pressure switches have a momentary action. If, however, you wish to simulate 
your circuit for testing purposes, simply change the input function from momentary action to 
switching action. 

Example for the FBD Editor: 
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When you have made all corrections and everything runs as expected, you can start to 
document your circuit program. 

3.5.11 Circuit program documentation 

Program comments  
You can now start to add comments to your program using the Text tool (Page 38). Describe 
the I/O to make your circuit program easy to understand. You do not have to display the 
connector names on-screen. You should nevertheless assign names to the connectors, 
because you may want to print out a connection list at a later time. From the comment tab of 
the File → Properties dialog (Page 53) , you can add a comment to your circuit program, 
which you can include when you print the circuit program.   

Example for the FBD Editor: 

 

Saving the file to a storage medium 
Before you transfer your circuit program, you should save it once again. Choose the relevant 
command from the menu and enter a program name and path. 

Printing the circuit program 
Use the File → Print (Page 50) command to print a copy of your circuit program. From this 
dialog you specify the print format and the details to be included or omitted. 
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3.5.12 Transferring the circuit program 

Password protection 
To protect your process solution and prevent unauthorized access to your circuit program, 
you can assign a password before you transfer it to IDEC SmartRelay.  

To assign this password, use the Parameter tab of the File → Properties (Page 53) menu 
command dialog. Enter your password and confirm it with OK. 

Password protection is used when you transfer the circuit program to IDEC SmartRelay and is 
activated when IDEC SmartRelay exits transfer mode. 

The password protects your circuit program in IDEC SmartRelay. Editing values and 
parameters, or viewing the circuit program in IDEC SmartRelay, or uploading the circuit 
program from IDEC SmartRelay to the PC is now only possible after you have entered the 
password. 

Transferring the circuit program 
Finally, transfer your circuit program to a suitable IDEC SmartRelay version and then connect 
the module. Connect IDEC SmartRelay with the consumer devices in your project. 

You have created the circuit program under WindLGC within a very short time and, compared 
with conventional methods, you have saved yourself a considerable amount of time and 
effort. 

3.5.13 Performing an online test of the circuit program 
After you are satisfied with your program simulation and have downloaded it to IDEC 
SmartRelay Base Module, you can also perform an online test of the circuit program. An 
online test is similar to simulation in that you can view inputs and outputs and block 
parameters. It differs, however, in that you are testing the program running in the IDEC 
SmartRelay Base Module with "live" inputs rather than testing the program on the PC with 
simulated inputs.  

The following example shows an online test of the practical example circuit program. In this 
example, input I1 was turned on and then turned off. The off-delay timer began counting 
when I1 was turned off: 
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 Synchronize message text 

 Data Table 

See the topic Simulating network communication (FL1F and later versions only) (Page 193) 
for prerequisite conditions for an online test. 

During an online test, you can modify a parameter of a function block with the WindLGC. 
After your modification, the IDEC SmartRelay Base Module then synchronizes the modified 
parameter. You can also modify the parameter in the IDEC SmartRelay Base Module, and the 
WindLGC synchronizes the modified parameter. 

 

 Note 

If the IDEC SmartRelay Base Module is still in "Set Param" mode, it can not synchronize your 
modification in the WindLGC. 
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3.6 Connecting to AWS cloud 
WindLGC supports connecting the IDEC SmartRelay Base Module to AWS Cloud. 

Requirements 
• IDEC SmartRelay Base Module is connected with WindLGC. 

• IDEC SmartRelay Base Module is connected to the internet. 

• An AWS account is created. 

Procedures 
Perform the following steps to connect a IDEC SmartRelay Base Module to AWS cloud: 

1. Enable the cloud access (Page 94). 

2. Register an IDEC SmartRelay Base Module to AWS IoT (Page 94). 

3. Configure the cloud data transfer (Page 93). 

 

 Note 

It is recommended that you connect only one IDEC SmartRelay BM device to an IoT thing at a 
time. If multiple IDEC SmartRelay BM devices connect to an IOT thing at the same time, data 
in IoT thing shadow is not consistent with the data you configured. 

 

Then the IDEC SmartRelay BM is connected to AWS Cloud. 



 

 WindLGC Online Help 

236 Programming and Operating Manual, 11/2024,  

Sample applications 4 
 

Introduction 
To give you an impression of the versatility of IDEC SmartRelay, WindLGC includes a small 
collection of applications, in addition to the service water pump application shown in the 
tutorial.  

This online help briefly describes the tasks and presents the relevant solutions with WindLGC. 
You can find these circuit programs, as well as many others, on your WindLGC DVD-ROM in 
the ..\Samples folder. You will also find there documentation for the various samples. 

Note 
IDEC SmartRelay sample applications are available and free of charge to our customers. We 
provide the sample applications without guarantee, and they are intended for general 
information about the possible fields of application for IDEC SmartRelay Base Modules and 
WindLGC software. Custom solutions may be different. 

The user operates the system at his own responsibility. We also refer to local standards and 
system-related installation regulations. 

This section presents the following sample applications: 

• Air-conditioning system (Page 236)  

• Factory door (Page 238)  

• Fill station (Page 239)  

Note the service water pump example (Page 221).  

4.1 Air-conditioning system 

Requirements for an air-conditioning system 
An air-conditioning system supplies fresh air into a room and exhausts the contaminated air. 
Let us look at the following sample system:  

• A room contains an extractor fan and a fresh-air fan. 

• Each fan under monitoring by means of a flow sensor. 

• The pressure in the room may rise above the atmospheric pressure. 

• The fresh-air fan may only be switched on if the flow sensor signals the safe operational 
state of the extractor fan. 

• A warning lamp indicates failure of one of the fans. 
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Standard solution 
The fans are under monitoring by means of flow sensors. If the sensors registered no air flow 
after a short delay time has expired, the system is switched off and an error message is 
generated, which can be acknowledged by pressing the off button. 

Fan monitoring requires an analyzer circuit with several switching devices, in addition to the 
flow sensors. A single IDEC SmartRelay device can replace this analyzer circuit. 

WindLGC solution 
The use of IDEC SmartRelay reduces the amount of switchgear. Thus, you save installation 
time and space in the control cabinet. You may even be able to use as a smaller control 
cabinet. 

With IDEC SmartRelay you can also switch off the fans sequentially after the system is 
switched off. 

The circuit in WindLGC 
The system is switched on and off at the inputs I1 and I2. The fans are connected to outputs 
Q1 and Q2, the flow sensors are connected to the inputs I3 and I4. Blocks B007 and B008 are 
used to set the watchdog times after which the flow sensors should send a signal to the fault 
output Q3. 

 
You can invert output Q3 to use output messages at Q4. Relay Q4 only drops out if main 
power is lost or if there is a fault in the system. The output can then be used for a remote 
message. 
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4.2 Factory door 

Requirements for a gate control system 
In many cases a factory entrance is closed with roll gates. Those gates are only opened when 
vehicles need to enter or leave the factory grounds. The gate is controlled by a gatekeeper. 

• The sliding gate is opened and closed by means of a pushbutton control in the gatehouse. 
The gatekeeper can monitor the gate operation. 

• The roll gate is normally fully opened or it is closed. However, gate movements can always 
be interrupted. 

• A flashing light is activated five seconds before the gate moves and while the gate is in 
motion. 

• A safety pressure strip ensures that people are not injured and that no objects are trapped 
and damaged when the gate is closing. 

Standard solution 
There are many different control systems for operating automatic gates. The OPEN and 
CLOSE buttons initiate gate movements in the relevant direction, provided it is not already 
moving in the opposite direction. Movement of the gate is terminated either by means of the 
STOP button or the relevant limit switch. 

WindLGC solution 
An IDEC SmartRelay circuit provides a further feature compared to standard controls: The 
actuation of a safety bar interrupts the closing motion of the gate. Five seconds before the 
gate opens or closes, a flashing light is activated and signals the start of the movement. It 
continues flashing until the gate has stopped. 

In contrast to standard solutions, IDEC SmartRelay offers an easy and economic means of 
modifying the control system. 
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4.3 Fill station 

Requirements for a fill station 
A box shall be filled with two different items, up to a specified total for each item. When all 
items are in the box, it will be transported to the packaging station. A conveyor belt 
transports the items of both types to the box. (This example does not show the filling 
conveyor belt.) This circuit program for this example uses two up/down counters to count the 
items of each type, a Analog math to sum the total number of items, and message texts to be 
displayed on the IDEC SmartRelay onboard display and IDEC SmartRelay TD (Text Display) that 
show the number of items of each type and the total number counted so far.  

This process is described below: 

• To fill the box, each item is transported by a conveyor belt to the box (not part of this 
example). 

• The sequence in which the items fall into the box is random. 
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• Each item that falls into the box is counted by a sensor. 

• The connected IDEC SmartRelay TD as well as the IDEC SmartRelay onboard display must 
display how many items of each kind have been counted, how many total items are in the 
box. 

The circuit program in WindLGC  
Light barriers are connected to the two digital inputs I1 and I2 sensors that detect when an 
item falls into the box. The two counters (B001 and B002) count each item for the two 
specific types of items as they fall into the box. The on-threshold of each counter specifies the 
maximum number possible for each item type. When the box is full, a conveyor belt activates 
for ten seconds to transport the filled box to the packaging station and to transport an empty 
box to the fill station. 

The circuit program uses a message text function block (Page 363) to display on the IDEC 
SmartRelay TD and IDEC SmartRelay onboard display how many total items and how many of 
each type have been counted. The message text uses the "ticking" feature to alternate 
between displaying bar graphs of the counted items and displaying a text summary of the 
counts.  
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Parameters of the function blocks  
Note the following parameter usage: 

• The on-thresholds of counters B001 and B002 define the maximum number of items of 
each item type to be put in the box. 

• The pulse width (TH) of the edge-triggered interval time-delay relay defines the duration 
of the movement of the conveyor belt. 

• The analog math function block B007 that calculates the total is programmed as follows: 

– Value 1 is a reference parameter to the current value of counter B001. 

– Value 2 is a reference parameter to the current value of counter B002. 

– Operator 1 is "+" to sum the two counters. 

– Priority 1 is high. (This is the only operation in the function block, so the priority in this 
case is irrelevant). 

– The remaining operands and operators are set to "+ 0" and do not affect the output of 
the equation. 

Message texts 
Message text block B010 displays a message text whose four lines all tick "line by line", such 
that two screen forms display in alternation. The first shows bar graph representations of the 
counted items (B001 and B002 current values) and a bar graph for the summed total items as 
calculated by B007. The second screen form shows the same values numerically and with text 
descriptions.  

The message text function block is configured with two character sets enabled. The message 
text for character set 1 is configured with English text and the message text for character set 
2 is configured with German text. You use the File → Message Text Settings (Page 51) to 
select the two character sets. In this case you would select the same character set for both 
English and German characters. When IDEC SmartRelay is in run mode, the current character 
set selection for message texts determines which message will display.  
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Reference material 5 
5.1 Constants and connectors 

 
You must select this tool if you want to place input blocks, output blocks, flags or constants 
(high, low) on the programming interface. You can select the specific type of block to insert 
from an additional toolbar that pops up when you select this tool.  
 

 

Display in the FBD Editor Display in the LAD Editor  Display in the UDF Edi-
tor 

 
Inputs (Page 243) 

 
Normally Open 
Contact (Page 255)   

Fixed signal 
levels 
(Page 244) 

 
Cursor keys 
(Page 243)  

Normally Closed 
Contact (Page 256)  

Open con-
nectors 
(Page 245) 

 
IDEC SmartRelay 
TD/TDE function 
keys (Page 244)  

Analog Input 
(Page 256)  

Flags 
(Page 245) 

 
Shift register bits 
(Page 245)  

Output (Page 256) 
 

Analog flags 
(Page 245) 

  
Fixed signal levels 
(Page 244)  

Output Not 
(Page 256) 

  

 
Outputs 
(Page 244)  

Analog outputs 
(Page 248) 

  

 
Open connectors 
(Page 245)  

Network inputs 
(FL1F and later 
versions only) 
(Page 248) 

  

 
Flags (Page 245) 

 
Network analog 
inputs (FL1F and 
later versions only) 
(Page 251) 

  

 
Analog inputs 
(Page 247)  

Network outputs 
(FL1F and later 
versions only) 
(Page 252) 

  

 
Analog outputs 
(Page 248)  

Network analog 
outputs (FL1F and 
later versions only) 
(Page 254) 

  

 
Analog flags 
(Page 245) 
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Network inputs 
(FL1F and later 
versions only) 
(Page 248) 

    

 
Network analog 
inputs (FL1F and 
later versions only) 
(Page 251) 

    

 
Network outputs 
(FL1F and later 
versions only) 
(Page 252) 

    

 
Network analog 
outputs (FL1F and 
later versions only) 
(Page 254)  

    

 

 

 

The number of available icons depends on the IDEC SmartRelay version you 
have selected.  

5.1.1 FBD and UDF 

5.1.1.1 Inputs 

 
Input blocks represent the input terminals of IDEC SmartRelay. Up to 24 digital inputs are 
available to you.  

In your block configuration, you can assign an input block a new input terminal, if this 
terminal is not already used in the circuit program. 

Overview (Page 242) 
 

 

This block is not available in the UDF Editor. 

5.1.1.2 Cursor keys 

 
Up to four cursor keys are available to you. You can program cursor keys for the circuit 
program in the same ways as other inputs. Cursor keys can save switches and inputs, and 
allow operator control of the circuit program.  
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The four cursor keys on the IDEC SmartRelay TDE are the same cursor key inputs on the IDEC 
SmartRelay Base Module. Pressing ESC and any of the cursor keys, for example, on either the 
IDEC SmartRelay TDE or IDEC SmartRelay activates a single input for a cursor key. 

Overview (Page 242)  
 

 

This block is not available in the UDF Editor. 

5.1.1.3 IDEC SmartRelay TD/TDE function keys 

 
The IDEC SmartRelay TD/TDE module has four function keys that you can use as digital inputs 
in your circuit program. You program the function keys in the same way as other inputs in 
your circuit program. Function keys can save switches and inputs, and allow operator control 
of the circuit program.  

Overview (Page 242)  
 

 

This block is not available in the UDF Editor. 

5.1.1.4 Outputs 

 
Output blocks represent the output terminals of IDEC SmartRelay. You can use up to 20 
outputs. In your block configuration, you can assign an output block a new terminal, 
provided this terminal is not already used in your circuit program.  

The output always carries the signal of the previous program cycle. This value does not 
change within the current program cycle. 

Overview (Page 242)  
 

 

This block is not available in the UDF Editor. 

5.1.1.5 Fixed signal levels 

 
Set the block input to logical hi (hi = high) to set it permanently to logical "H" state.  
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Set the block input to logical lo (lo = low) to set it permanently to logical "L" state. 

Overview (Page 242)  
 

 

This block is available in both FBD and UDF Editors. 

5.1.1.6 Shift register bits 

 
The IDEC SmartRelay FL1F devices provide eight shift register bits S1 to S8, which are 
assigned the read-only attribute in the circuit program. The content of shift register bits can 
only be modified by means of the shift register special function.  

The and IDEC SmartRelay FL1F devices provide a maximum of 32 shift registers bits S1.1 to 
S4.8. 

Overview (Page 242)  
 

 

This block is not available in the UDF Editor. 

5.1.1.7 Open connectors 

 
Interconnect the output of an unused block (for example, message texts) with this block. 
Number of the open connectors: 16 (IDEC SmartRelay FL1E) or 64 (IDEC SmartRelay FL1F).  

Overview (Page 242)  
 

 

This block is available in both FBD and UDF Editors. 

5.1.1.8 Flags 
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Flag blocks output their input signal. IDEC SmartRelay FL1F provides 64 digital flags M1 to 
M64 and 64 analog flags AM1 to AM64.  
 

 

FL1E: 27 digital flags M1 to M27; six analog flags AM1 to AM6. 
FL1C, FL1D: 24 digital flags M1to M24; six analog flags AM1 to AM6 
FL1B, FL1A: eight digital flags M1 to M8 

In your block configuration, you can assign a new number to the flag, provided this flag 
number does not already exist in your circuit program. 

The output always carries the signal of the previous program cycle. This value does not 
change within the current program cycle. 

The following special flags have different background colors: 

• M8 = Startup flag (Displays blue in WindLGC) 

• M25 = IDEC SmartRelay displays white backlight 

• M26 = IDEC SmartRelay TDE white backlight 

• M27 = Message Character Set flag (Displays green in WindLGC) 

• M28 = IDEC SmartRelay displays the amber backlight 

• M29 = IDEC SmartRelay displays red backlight 

• M30 = IDEC SmartRelay TDE amber backlight 

• M31 = IDEC SmartRelay TDE red backlight 

Besides, flag blocks which are configured as email sending trigger event (Page 59) display 
green backlight. 

Startup flag: M8 
The M8 flag is set in the first cycle of the user program and can thus be used in your circuit 
program as a startup flag. It is reset after the first program execution cycle. 

In the subsequent cycles, the M8 flag reacts in the same way as the M1 to M64 flags. 

Backlight flags 
flags M25, M28 and M29 control the backlight of the IDEC SmartRelay onboard display. flags 
M26, M30 and M31 control the backlight of the IDEC SmartRelay TDE. 

You can use the outputs of timers, message texts, or other function blocks to activate the 
backlight flags. To enable multiple conditions to control the backlight of the devices, you can 
use multiple function blocks in parallel or in sequence. 
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Message text character set flag: M27 
The M27 flag, if used, determines whether the message texts of the primary character set or 
the secondary character set will display. You select the two character sets from either IDEC 
SmartRelay or the File → Message Text Settings (Page 51) menu command of WindLGC. Then 
when you configure message texts (Page 363) , you select whether a particular message text 
consists of characters from the primary character set (Character Set 1) or the secondary 
character set (Character Set 2).  

In the circuit program, you can use M27 to enable the message texts of either the primary or 
secondary character set and to disable the message texts of the other. When M27=0 (low), 
then IDEC SmartRelay only displays the message texts from the primary character set; when 
M27=1 (high), then IDEC SmartRelay only displays the message texts from the secondary 
character set. 

Analog flags: AM1 to AM64 
The analog flags can be used as markers for analog inputs or analog instruction blocks. The 
analog flag merely accepts an analog value as input and outputs that value. 

Overview (Page 242)  
 

 

M8, M25, M26, M27, M28, M29, M30 and M31 are not available in the UDF Editor. 

5.1.1.9 Analog inputs 

 
The IDEC SmartRelay FL1F-H12RCE, FL1F-H12SCD, FL1F-B12RCE, FL1F-H12RCA and the 
expansion modules FL1F-J2B2 process analog signals. You can use up to eight analog inputs. 
In your block configuration, you can assign a new input terminal to an input block, provided 
this terminal is not already used in the circuit program.  

Some of the input terminals of the IDEC SmartRelay FL1E versions FL1E-H12RCE, FL1F-
B12RCE have a dual definition: they can be used as either digital inputs or analog inputs. See 
the IDEC SmartRelay User's Manual or product information for specific information about 
specific modules. Circuit programs written for these modules for the IDEC SmartRelay FL1D 
release and earlier can run on IDEC SmartRelay FL1E modules without modification. New 
circuit programs can make use of the new input features, which provide additional fast-speed 
counters and analog capability. 

For help on analog block parameters, refer to information on analog value processing 
(Page 334). 
 

 

The block input number is not determined by the hardware structure in sys-
tems operating with devices of the FL1A series. 
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Overview (Page 242)  
 

 

This block is not available in the UDF Editor. 

5.1.1.10 Analog outputs 

 
Eight analog outputs are available, namely AQ1, AQ2, ... AQ8. You can only set an analog 
value at the analog output, that is, a function with an analog output or analog flag AM.  

If you connect a special function (that has an analog output) to a real analog output, then 
note that the analog output can only process values from 0 to 1000. 

You can configure the behavior of analog outputs for IDEC SmartRelay FL1D and higher 
versions in STOP mode. Analog outputs can retain their last values when IDEC SmartRelay 
goes to STOP mode. Alternatively, you can configure specific values to be set for AQ1 and 
AQ2 (AQ1 to AQ8 for FL1F) when IDEC SmartRelay goes to STOP mode. 

You can also set the analog output value range. You have two choices: 

• Normal (0 V to 10 V or 0 mA to 20 mA) 

• 4 mA to 20 mA 

 

 

FL1A to FL1D: You cannot configure the behavior of AQ1 and AQ2 on transition 
to STOP mode for IDEC SmartRelay modules prior to the FL1D device series. 

Overview (Page 242)  
 

 

This block is not available in the UDF Editor. 

5.1.1.11 Network inputs (FL1F and later versions only) 

 
You can connect a network input to a block input. You can configure up to 64 network 
inputs.  

Network inputs can read values from the following types: 

• VM 

When reading values from VM, the VB address range is 0 to 850. 
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• Remote device 

When reading values from a remote device, you must enter its IP address or select from 
the existing device types. 

– Remote device types for IDEC SmartRelay FL1F FS6/FS5 

 
Available device types and their block types are as follows: 

 

Device type Block type 
IDEC SmartRelay 
FL1F FS6 (Page 209) 

I1 to I24, Q1 to Q20, M1 to M64, VB0.0 to VB850.7, VXB0.0 to VXB 
2407.7, and VRB0.0 to VRB 511.7 

IDEC SmartRelay 
FL1F FS5 (Page 209) 

I1 to I24, Q1 to Q20, M1 to M64, and VB0.0 to VB850.7 

IDEC SmartRelay 
FL1F (Page 209) 

I1 to I24, Q1 to Q20, M1 to M64, and VB0.0 to VB850.7 

ModBus-compatible 
devices (Page 209) 

Coil1 to Coil65535, DI1 to DI65535 

IDEC SmartRelay 
FL1F FS6 Slave 
(Page 209) 

I1 to I24 and Q1 to Q20 

IDEC SmartRelay 
FL1F FS5 Slave 
(Page 209) 

I1 to I24 and Q1 to Q20 

IDEC SmartRelay 
FL1F Slave 
(Page 209) 

I1 to I24 and Q1 to Q20 
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– Remote device types for IDEC SmartRelay FL1F 

IDEC SmartRelay FL1F device cannot read values from Modbus-compatible device. 
Except Modbus-compatible device, all the other device types and their block types are 
available for IDEC SmartRelay FL1F. 

• Diagnostics 

When reading values from the diagnostic information, you need to select a diagnostic 
type first, as shown in the following figures. The diagnostic types correspond to the bits in 
the VM area. Each of the bits is set to 1 or 0, which respectively indicates that an error of 
this type exists or not. 

– IDEC SmartRelay FL1F and later version devices diagnostic type 

 
Overview (Page 242)  
 

 

Network inputs are inactive in the UDF Editor. 
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5.1.1.12 Network analog inputs (FL1F and later versions only) 

 
You can connect a network analog input to a block input. You can configure up to 32 
network analog inputs.  

Network analog inputs can read values from the following types: 

• VM 

When reading values from VM, the VW address range is 0 to 849. 

• Remote device 

When reading values from a remote device, you must enter its IP address or select from 
the existing device types. 

– Remote device types for IDEC SmartRelay FL1F FS6/FS5 
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Available remote device types and their block types are as below: 
 

Device type Block type 
IDEC SmartRelay 
FL1F FS6 (Page 209) 

VW0 to VW849, VXW0 to VXW2046 and VRW0 to VRW510 

IDEC SmartRelay 
FL1F FS5 (Page 209) 

VW0 to VW849 

IDEC SmartRelay 
FL1F (Page 209) 

VW0 to VW849 

ModBus-compatible 
devices (Page 209) 

IR1 to IR65535 and HR1 to HR65535 

IDEC SmartRelay 
FL1F FS6 Slave 
(Page 209) 

AI1 to AI8 and AQ1 to AQ8 

IDEC SmartRelay 
FL1F FS5 Slave 
(Page 209) 

AI1 to AI8 and AQ1 to AQ8 

IDEC SmartRelay 
FL1F Slave 
(Page 209) 

AI1 to AI8 and AQ1 to AQ8  

– Remote device types for IDEC SmartRelay FL1F 

IDEC SmartRelay FL1F device cannot read values from Modbus-compatible device. 
Except Modbus-compatible device, all the other device types and their block types are 
available for IDEC SmartRelay FL1F. 

Overview (Page 242)  
 

 

Network analog inputs are inactive in the UDF Editor. 

5.1.1.13 Network outputs (FL1F and later versions only) 

 
When the IDEC SmartRelay FL1F or later version Base Module is in slave mode, you can 
configure a network output on the master to control a digital output on the remote device. 
You can configure up to 64 network outputs.  

Network outputs can write values to the following types: 

• VM 

When writing values to VM, the VB address range is 0 to 850. 

• Remote device 

When writing values to a remote device, you must first enter the device IP address or 
select the existing device. 

– Remote device types for IDEC SmartRelay FL1F FS6/FS5 



 Reference material 
 5.1 Constants and connectors 

WindLGC Online Help 

Programming and Operating Manual, 11/2024 253 

 
Available device types and their block types are as follows: 

 

Device type Block type 
IDEC SmartRelay 
FL1F FS6 (Page 209) 

I1 to I24, Q1 to Q20, M1 to M64, VB0.0 to VB 850.7, VXB0.0 to VXB 
2047.7, and VRB0.0 to VRB 511.7 

IDEC SmartRelay 
FL1F FS5 (Page 209) 

I1 to I24, Q1 to Q20, M1 to M64 and VB0.0 to VB 850.7 

IDEC SmartRelay 
FL1F (Page 209) 

I1 to I24, Q1 to Q20, M1 to M64 and VB0.0 to VB 850.7 

ModBus-compatible 
devices (Page 209) 

Coil1 to Coil65535 

IDEC SmartRelay 
FL1F FS6 Slave 
(Page 209) 

Q1 to Q20 

IDEC SmartRelay 
FL1F FS5 Slave 
(Page 209) 

Q1 to Q20 

IDEC SmartRelay 
FL1F Slave 
(Page 209) 

Q1 to Q20 

– Remote device types for IDEC SmartRelay FL1F 

IDEC SmartRelay FL1F device cannot read values from Modbus-compatible device. 
Except Modbus-compatible device, all the other device types and their block types are 
available for IDEC SmartRelayFL1F. 
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Overview (Page 242)  
 

 

Network outputs are inactive in the UDF Editor. 

5.1.1.14 Network analog outputs (FL1F and later versions only) 

 
When the IDEC SmartRelay FL1F Base Module (or later version BM) is in slave mode, you can 
configure a network analog output on the master to control an analog output on the slave. 
You can configure up to 16 network analog outputs.  

Network analog outputs can write values to the following types: 

• VM 

When writing values to VM, the VW address range is 0 to 849. 

• Remote device 

When writing values to a remote device, you must first enter the device IP address or 
select the existing device. 

– Remote device types for IDEC SmartRelay FL1F FS6/FS5 
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Available device types and their block types are as follows: 
 

Device type Block type 
IDEC SmartRelay 
FL1F FS6 (Page 209) 

VW0 to VW849, VXW0 to VXW2046 and VRW0 to VRW510 

IDEC SmartRelay 
FL1F FS5 (Page 209) 

VW0 to VW849 

IDEC SmartRelay 
FL1F (Page 209) 

VW0 to VW849 

ModBus-compatible 
device (Page 209) 

HR1 to HR65535 

IDEC SmartRelay 
FL1F FS6 Slave 
(Page 209) 

AQ1 to AQ8 

IDEC SmartRelay 
FL1F FS5 Slave 
(Page 209) 

AQ1 to AQ8 

IDEC SmartRelay 
FL1F Slave 
(Page 209) 

AQ1 to AQ8 

– Remote device types for IDEC SmartRelay FL1F 

IDEC SmartRelay FL1F device cannot read values from Modbus-compatible device. 
Except Modbus-compatible device, all the other device types and their block types are 
available for IDEC SmartRelay FL1F. 

Overview (Page 242)  
 

 

Network analog outputs are inactive in the UDF Editor. 

5.1.2 LAD 

5.1.2.1 Normally Open Contact 

 
Normally Open Contacts, as well as Normally Closed Contact (Page 256) and Analog Input 
(Page 256) represent the input terminals of an IDEC SmartRelay module.  

When you place a contact in your circuit program, WindLGC displays a relevant dialog. In this 
dialog, you can specify the type of input according to the IDEC SmartRelay in use. The cursor 
keys are also available as inputs as are the IDEC SmartRelay TDE function keys if you have an 
IDEC SmartRelay TDE module. You can also select a fixed logical level for the input. 

To change an input in your LAD circuit program, double-click the corresponding block to open 
the relevant dialog. 

Overview (Page 242)  
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5.1.2.2 Normally Closed Contact 

 
Normally Closed Contacts, as well as Normally Open Contact (Page 255) and Analog Input 
(Page 256) represent the input terminals of an IDEC SmartRelay module.  

When you place the contact in your circuit program, WindLGC displays a relevant dialog. In 
this dialog you can specify the type of input according to your IDEC SmartRelay. The cursor 
keys are also available as inputs as are the IDEC SmartRelay TDE function keys if you have an 
IDEC SmartRelay TDE module. You can also select a fixed logical level for the input. 

To change an input in your LAD circuit program, double-click the corresponding block to open 
a dialog in which you can make your changes. 

Overview (Page 242)  

5.1.2.3 Analog Input 

 
Analog Inputs, as well as Normally Closed Contact (Page 256) and Normally Open Contact 
(Page 255) represent the input terminals of an IDEC SmartRelay device.  

When you place a contact in your circuit program, WindLGC displays a relevant dialog. In this 
dialog you can specify the type of input according to your IDEC SmartRelay device. 

To change an input in your LAD circuit program, double-click the corresponding block in your 
circuit program to open a dialog in which you can make your changes. 

Overview (Page 242)  

5.1.2.4 Output 

 
Outputs represent the output terminals like Output Not (Page 256) and Analog output 
(Page 257) on an IDEC SmartRelay.  

To change an output in your LAD circuit program, double-click the corresponding block to 
open a dialog in which you can assign various functions to the output. 

Overview (Page 242)  

5.1.2.5 Output Not 

 
Output Not, as well as Output (Page 256) and Analog output (Page 257) represent the output 
terminals of an IDEC SmartRelay device.  

To change an output in your LAD circuit program, double-click the corresponding block to 
open a dialog in which you can assign various functions to the output. 
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Overview (Page 242)  

5.1.2.6 Analog output 

 
Analog outputs represent the output terminals like Output (Page 256) and Output Not 
(Page 256) on an IDEC SmartRelay. 

To change an output in your LAD circuit program, double-click the corresponding block to 
open a dialog in which you can assign various functions to the output. 

If you connect a special function that has an analog output to a real analog output, then note 
that the analog output can only process values from 0 to 1000. 

Overview (Page 242)  

5.1.2.7 Network inputs (FL1F and later versions only) 
Refer to Network inputs (FL1F and later versions only) (Page 248) in the FBD Editor. 

5.1.2.8 Network analog inputs (FL1F and later versions only) 
Refer to Network analog inputs (FL1F and later versions only) (Page 251) in the FBD Editor. 

5.1.2.9 Network outputs (FL1F and later versions only) 
Refer to Network outputs (FL1F and later versions only) (Page 252) in the FBD Editor. 

5.1.2.10 Network analog outputs (FL1F and later versions only) 
Refer to Network analog outputs (FL1F and later versions only) (Page 254) in the FBD Editor.  

5.2 Basic functions (FBD and UDF Editors) 
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Select this tool if you want to place standard Boolean logic blocks on the programming 
interface. WindLGC then displays a toolbar with all of the Boolean logic blocks:  
 

 AND (Page 258)  
 

 AND with Edge Detection (Page 259)  
 

 NAND (Page 260)  
 

 NAND with Edge Detection (Page 260)  

 OR (Page 261)  
 

 NOR (Page 261)  
 

 XOR (Page 262)  
 

 NOT (Page 263)  

Select the block that you need to place it on the programming interface.  

Inverting the inputs 
You can invert individual inputs: 

• A logical "1" at a specific input is inverted to logical "0" in the circuit program. 

• A logical "0" is inverted to logical "1" in the circuit program. 

To invert an input, right-click the input and select the invert command from the shortcut 
menu. 

You cannot invert the inputs of output blocks. 
 

 

FL1A - FL1B: 
To invert an input, use the basic function NOT (Page 263). 

Timing diagrams 
Each timing diagram of the basic functions displays three inputs to make evaluation easier for 
you. 
 

 

FL1A - FL1B: 
The basic functions have three inputs. 

5.2.1 AND 

 
The output of an AND function is only 1 if all inputs are 1, that is, when they are closed. 

A block input that is not used (x) is assigned: x = 1.  
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AND function logic table 
 
Input 1 Input 2 Input 3 Input 4 Output 
0 0 0 0 0 
0 0 0 1 0 
0 0 1 0 0 
0 0 1 1 0 
0 1 0 0 0 
0 1 0 1 0 
0 1 1 0 0 
0 1 1 1 0 
1 0 0 0 0 
1 0 0 1 0 
1 0 1 0 0 
1 0 1 1 0 
1 1 0 0 0 
1 1 0 1 0 
1 1 1 0 0 
1 1 1 1 1 

Overview (Page 257)  

5.2.2 AND with Edge Detection 

 
The output of an AND function with edge evaluation is only 1 if all inputs are 1 and at least 
one input was 0 during the last cycle. 

The output is set to 1 for the duration of one cycle and must be reset to 0 for the duration of 
the next cycle before it can be set to 1 again. 

A block input that is not used (x) is assigned: x = 1. 

Timing diagram of an AND with Edge Detection: 

 
Overview (Page 257)  
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5.2.3 NAND 

 
The output of an NAND function is only 0 if all inputs are 1, i.e. when they are closed.  

A block input that is not used (x) is assigned: x = 1.  

NAND function logic table 
 
Input 1 Input 2 Input 3 Input 4 Output 
0 0 0 0 1 
0 0 0 1 1 
0 0 1 0 1 
0 0 1 1 1 
0 1 0 0 1 
0 1 0 1 1 
0 1 1 0 1 
0 1 1 1 1 
1 0 0 0 1 
1 0 0 1 1 
1 0 1 0 1 
1 0 1 1 1 
1 1 0 0 1 
1 1 0 1 1 
1 1 1 0 1 
1 1 1 1 0 

Overview (Page 257)  

5.2.4 NAND with Edge Detection 

 

The output is set to 1 for the duration of one cycle and must be reset to 0 at least for the 
duration of the next cycle before it can be set to 1 again.  

A block input that is not used (x) is assigned: x = 1. 

Timing diagram of a NAND with Edge Detection: 
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Overview (Page 257)  

5.2.5 OR 

 
The output of an OR function is 1 if at least one input is 1 (closed).  

A block input that is not used (x) is assigned: x = 0. 

OR function logic table 
 
Input 1 Input 2 Input 3 Input 4 Output 
0 0 0 0 0 
0 0 0 1 1 
0 0 1 0 1 
0 0 1 1 1 
0 1 0 0 1 
0 1 0 1 1 
0 1 1 0 1 
0 1 1 1 1 
1 0 0 0 1 
1 0 0 1 1 
1 0 1 0 1 
1 0 1 1 1 
1 1 0 0 1 
1 1 0 1 1 
1 1 1 0 1 
1 1 1 1 1 

Overview (Page 257)  

5.2.6 NOR 
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The output of an NOR (NOT OR) function is only 1 if all inputs are 0 (open). When one of the 
inputs is on (logical 1 state), the output is off.  

A block input that is not used (x) is assigned: x = 0. 

NOR function logic table 
 
Input 1 Input 2 Input 3 Input 4 Output 
0 0 0 0 1 
0 0 0 1 0 
0 0 1 0 0 
0 0 1 1 0 
0 1 0 0 0 
0 1 0 1 0 
0 1 1 0 0 
0 1 1 1 0 
1 0 0 0 0 
1 0 0 1 0 
1 0 1 0 0 
1 0 1 1 0 
1 1 0 0 0 
1 1 0 1 0 
1 1 1 0 0 
1 1 1 1 0 

Overview (Page 257)  

5.2.7 XOR 

 
The output of an XOR (exclusive OR) function is 1 if the signal status of the inputs is 
different.  

A block input that is not used (x) is assigned: x = 0. 

XOR function logic table 
 
Input 1 Input 2 Output 
0 0 0 
0 1 1 
1 0 1 
1 1 0 

Overview (Page 257)  
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5.2.8 NOT 

 

The output of an NOT function is 1 if the input is 0. The NOT block inverts the input status.  

Advantage of the NOT, for example: IDEC SmartRelay no longer requires Normally Closed 
Contact. You simply use a Normally Open Contact and convert it into a Normally Closed 
Contact with the help of the NOT function. 

NOT function logic table 
 
Input 1 Output 
0 1 
1 0 

Overview (Page 257)  

5.3 Special functions 

 
Select this tool if you want to place additional retentive or time-related function blocks on the 
programming interface. WindLGC then displays a toolbar of special function icons:  
 
 Timers  Analog 

 
On-delay (Page 267)  

 
Analog trigger (Page 305)  

 
Off-delay (Page 269)  

 
Analog differential trigger (Page 309)  

 
On-/Off-delay (Page 271)  

 
Analog comparator (Page 311)  

 
Retentive on-delay (Page 272)  

 
Analog watchdog (Page 314)  

 
Interval time-delay relay/Pulse out-
put (Page 274)   

Analog amplifier (Page 316)  

 
Edge-triggered interval time-delay 
relay (Page 276)   

Analog multiplexer (Page 318)  

 
Symmetrical clock pulse generator 
(Page 277)   

Pulse Width Modulator (PWM) 
(Page 321)  

 
Asynchronous pulse generator 
(Page 278)   

Analog math (Page 324)  
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Random generator (Page 280)  

 
PI controller (Page 347)  

 
Stairwell light switch (Page 281)  

 
Analog ramp (Page 351)  

 
Dual-function switch (Page 284)  

 
Analog filter (FL1F and later versions 
only) (Page 327)  

 
Seven-day time switch (Page 286)  

 
Max/Min (FL1F and later versions only) 
(Page 329)  

 
Twelve-month time switch 
(Page 289)   

Average value (FL1F and later versions 
only) (Page 332)  

 
Astronomical clock (FL1F and later 
versions only) (Page 292)  

 Miscellaneous 

 
Stopwatch (FL1F and later versions 
only) (Page 294)   

Latching relay (Page 354)  

 Counter 
 

Current impulse relay  (Page 355)  

 
Up/Down counter (Page 296)  

 
Message text (IDEC SmartRelay FL1C and 
IDEC SmartRelay FL1D) (Page 373), Mes-
sage text (IDEC SmartRelay FL1E) 
(Page 363), Message text (IDEC Smar-
tRelay FL1F and later versions) 
(Page 356) 

 
Hours counter (Page 299)  

 
Softkey (Page 377)  

 
Frequency trigger (Page 303)  

 
Shift register (FL1C to FL1E) (Page 383) , 
Shift register (FL1F) (Page 381) 

  
 

Analog math error detection (Page 384)  

  
 

Float/Integer converter (FL1F FS5 and 
later versions only) (Page 386) 

  
 

Integer/Float converter (FL1F FS5 and 
later versions only) (Page 388) 

 

 

 

The LAD Editor offers you the following additional functions: 
 AND with Edge Detection (Page 259)  
 NAND with Edge Detection (Page 260)  

 

 

 

FBD and UDF Editors: description of the blocks of special functions 
The description of the blocks of special functions in the circuit program begins 
with timer blocks ("T"), with counter blocks ("C") and with the remaining blocks 
("SF"). 
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The IDEC SmartRelay version you have selected determines these characteris-
tics of your circuit program: 
• Available blocks 
• Parameters that you can set 

This topic also describes the following tasks or characteristics of the special functions: 

• Inverting inputs 

• Block configuration 

• Reference parameters 

• Protection 

• Retentivity 

Inverting inputs 
You can invert individual inputs: 

• You can invert a logical "1" at a specific input to logical "0" in the circuit program. 

• You can invert a logical "0" to logical "1" in the circuit program. 

To do so, right-click the input and select the invert command from the shortcut menu. 

You cannot invert the inputs of output blocks. 
 

 Note 
• Unused logical inputs default to logical "0". 
• You cannot invert the inputs of a UDF block. 

 

 

 

 

FL1A - FL1B: 
To invert an input, use the basic function NOT (Page 263)  

Block configuration 
The block properties dialog provides you with an easy means of setting the various block 
parameters. 

Reference functionality 
You can also assign parameters to blocks with the value from other blocks. Such parameters 
are reference parameters.  

The parameter box displays the block's parameters in a table. You can reference any 
parameter in the parameter box to the parameter of another function. You can use the 
show/hide button to change the visibility of the parameter box. 
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① Show/hide button 
② Output connector 
③ Input connector 

Each parameter has an input connector and/or an output connector. You can simply use drag 
and drop to create a reference line between the parameter connector of one function and the 
parameter connector of another function. Note that you cannot connect output parameters 
to other output parameters. 

 
The reference line between two parameters indicates their reference relation. You can delete 
the reference line to remove the reference. 
 

 

 

LAD Editor/FL1C-FL1E: 
The parameter box is not available in the LAD Editor or for FL1C-FL1E devices. 
Follow the below steps to create a reference:  
1. Click the "Reference" button next to a parameter in the block properties 

window. 
2. WindLGC displays all the blocks available for providing the reference 

parameter. 
3. Select the block you want to refer to. 
For example, if you click the "Reference" button for the Off-Delay parameter of 
an Off-Delay timer, you can then choose a specific block to reuse the time val-
ue of that timer.  

 

 

 

A quick way of changing block parameters (Page 424)  
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IDEC SmartRelay FL1F devices provide a timer reference function. With this function, you can 
take the current time (Ta) of a timer as the reference value (C) in other function blocks. The 
calculation of the reference value (C) follows the formula as shown below: 
 
Current time (Ta) Time base Reference value (C) 
A : B Hours (h : m)  C = A × 60 + B 
A : B Minutes (m : s) C = A × 60 + B 
A : B Seconds (s: 1/100s) C = A × 100 + B 

Protection 
If a Protection Active check box exists for the protection of a block parameter, you can 
enable or lock the display and editing of this parameter in IDEC SmartRelay configuration 
mode. 

Retentivity 
The switching state and counter values of SFBs can be retentive. This means that the current 
data values are retained, for example after a power failure, so that the function is resumed at 
the break position after power on. Hence, a timer is not reset, but instead the time-to-go 
expires. 

You must set the retentivity to enable this feature for the relevant function. There are two 
possible settings: 

• On: Current data values are retained. 

• Off: Current data values are not retained (default). 

The Hours counter (Page 299) is an exception, because it is always retentive. 

5.3.1 Timers 

5.3.1.1 On-delay 

 

Short description 
The output does not switch on until a configured delay time has expired.  
 
Connection Description 
Trg input The Trg (Trigger) input triggers the on-delay time.  
Parameter T:  represents the on-delay time after which the output is switched on (output 

signal transition 0 to 1). 
Retentivity on = the status is retentive in memory.  

Output Q Q switches on after a specified time T has expired, provided Trg is still set. 
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Parameter T 
The actual value of another already-programmed function can provide the time in parameter 
T:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You can select the required function by the block number. 

For information on the validity and accuracy of the time base, refer to the IDEC SmartRelay 
User's manual. 

Timing diagram 
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Description of the function 
The 0 to 1 transition at input Trg triggers the time Ta (the current time in IDEC SmartRelay). 

If the status at input Trg stays 1 at least for the duration of the configured time T, the output 
is set to 1 when this time has expired (the on signal of the output follows the on signal of the 
input with delay). 

The time is reset if the status at input Trg changes to 0 again before the time T has expired. 

The output is reset to 0 when input Trg is 0. 

Special functions (Page 263)  

5.3.1.2 Off-delay 

 

Short description 
The output with off-delay resets after a defined time has expired.  
 
Connection Description 
Input Trg Start the off-delay time with a negative edge (1 to 0 transition) at input Trg (Trig-

ger). 
Input R Reset the off-delay time and set the output to 0 via the R (Reset) input. 

Reset has priority over Trg. 
Parameter T: The output is switched off on expiration of the delay time T (output signal 

transition 1 to 0). 
Retentivity on = the status is retentive in memory. 

Output Q Q switches on for the duration of the time T after a trigger at input Trg. 

Parameter T 
The actual value of another already-programmed function provides the time set in parameter 
T: 

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 
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For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

For information on the validity and accuracy of the time base, refer to the IDEC SmartRelay 
User's Manual. 

Timing diagram 

 

Description of the function 
A 0 to 1 transition at input Trg sets output Q to 1 instantaneously. 

At the 1 to 0 transition at input Trg, IDEC SmartRelay retriggers the current time T, and the 
output remains set. IDEC SmartRelay resets the output Q to 0 when Ta reaches the value 
specified in T (Ta=T) (off delay). 

A one-shot at input Trg retriggers the time Ta. 

You can reset the time Ta and the output via the input R (Reset) before the time Ta has 
expired. 

Special functions (Page 263)  
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5.3.1.3 On-/Off-delay 

 

Short description 
The on-/off- delay function block can set an output after a configured on-delay time and then 
reset it again upon expiration of a second configured time.  
 
Connection Description 
Input Trg You trigger the on-delay with a positive edge (0 to 1 transition) at input Trg 

(Trigger). 
You trigger the off-delay with a negative edge (1 to 0 transition). 

Parameter TH is the on-delay time for the output (output signal transition 0 to 1). 
TL is the off-delay time for the output (output signal transition 1 to 0). 
Retentivity on = the status is retentive in memory 

Output Q Q switches on upon expiration of a configured time TH if Trg is still set. It switches 
off again upon expiration of the time TL and if Trg has not been set again. 

Parameters TH and TL 
The actual value of another already-programmed function can provide the on-delay time and 
off-delay time set in parameter TH and TL:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 
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• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

For information on the validity and accuracy of the time base, refer to the IDEC SmartRelay 
User's Manual. 

Timing diagram 

 

Description of the function 
A 0 to 1 transition at input Trg triggers the time TH. 

If the status at input Trg is 1 for at least the duration of the configured time TH, IDEC 
SmartRelay sets the output to logical 1 upon expiration of this time (output is on-delayed to 
the input signal). 

The time TH resets if the status at input Trg resets to 0 before this time has expired. 

The 1 to 0 transition at the output triggers the time TL is triggered. 

If the status at input Trg remains 0 at least for the duration of a configured time TL, the 
output resets to 0 upon expiration of this time (output is off delayed to the input signal). 

The time TL resets if the status at input Trg returns to 1 before this time has expired. 

Special functions (Page 263)  

5.3.1.4 Retentive on-delay 
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Short description 
A one-shot at the input triggers a configurable time. IDEC SmartRelay sets the output upon 
expiration of this time.  
 
Connection Description 
Input Trg Trigger the on-delay time via the Trg (Trigger) input. 
Input R Reset the on-delay time and reset the output to 0 via input R (Reset). 

Reset takes priority over Trg. 
Parameter T is the on-delay time for the output (output signal transition 0 to 1). 
Output Q Q switches on upon expiration of the time T. 

Parameter T 
The value of another already-programmed function can provide the time in parameter T:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 
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Timing diagram 

 

Description of the function 
A 0 to 1 signal transition at input Trg triggers the current time Ta. IDEC SmartRelay sets the 
output Q to 1 when Ta reaches the time T. A further pulse at input Trg does not affect Ta. 

The output and the time Ta reset to 0 only with a 1 signal at input R. 

If you do not set the retentivity, output Q and the expired time reset after a power failure. 

Special functions (Page 263)  

5.3.1.5 Interval time-delay relay/Pulse output 

 

Short description 
An input signal generates an output signal of a configurable length.  

Connection 
 
Connection Description 
Input Trg You trigger the time for the Interval time-delay relay with a signal at input Trg 

(Trigger). 
Parameter T represents the time after which the output resets (output signal transition 1 to 

0). 
Retentivity on = the status is retentive in memory. 

Output Q A pulse at Trg sets Q. The output stays set until the time T has expired and if Trg 
= 1 for the duration of this time. A 1 to 0 transition at Trg prior to the expiration 
of T also resets the output to 0. 

Parameter T 
The actual value of another already-programmed function can provide the off time T:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 
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• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Timing diagram 

 

Description of the function 
The input signal Trg = 1 sets the output Q to 1. The signal also triggers the time Ta, while the 
output remains set. 

When Ta reaches the value defined at T (Ta=T), the output Q resets to 0 state (pulse output). 

If the signal at input Trg changes from 1 to 0 before this time has expired, the output 
immediately resets from 1 to 0. 

Special functions (Page 263)  
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5.3.1.6 Edge-triggered interval time-delay relay 

 

Short description 
An input pulse generates a preset number of output pulses with a defined pulse/pause ratio 
(retriggerable), after a configured delay time has expired.  
 
Connection Description 
Input Trg You trigger the times for the edge-triggered interval time-delay relay with a signal 

at input Trg (Trigger). 
Input R The output and the current time Ta resets to 0 with a signal at input R. 
Parameter TH, TL: The pulse width TH and the interpulse width TL are adjustable. 

N determines the number of pulse/pause cycles TL/TH: 
Value range: 1 to 9. 
Retentivity on = the status is retentive in memory. 

Output Q Output Q sets when the time TL has expired and resets when TH has expired. 
 

 

 

FL1A, FL1B: 
Only the parameter TH exists. TH represents the off-delay time for the output. 
Input R is not available. 

Parameters TH and TL 
The actual value of another already-programmed function can provide the pulse width TH and 
the interpulse width TL: 

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 
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• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Timing diagram 

 

Description of the function 
The change at input Trg to 1 triggers the time TL (time low). After the time TL has expired, 
IDEC SmartRelay sets the output Q to 1 for the duration of the time TH (time high). 

If IDEC SmartRelay retriggers the input Trg prior to the expiration of the preset time (TL + TH), 
the time Ta resets and the pulse/pause period is restarted. 

Special functions (Page 263)  

5.3.1.7 Symmetrical clock pulse generator 
 

 

The Symmetrical clock pulse generator is only available for devices of the series 
FL1B. 
IDEC SmartRelay devices of the current series use an Asynchronous pulse gen-
erator (Page 278) instead of the Symmetrical clock pulse generator. 
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Short description 
The function outputs a pulse signal with a configurable period.  
 
Connection Description 
Input En You enable (En=1) or disable (En=0) the pulse generator with the signal at input 

En (Enable). 
Parameter T is the on or off time of the output. 
Output Q Q is toggled periodically on and off with the pulse time T. 

Timing diagram 

 

Description of function 
You define the length of the on and off times at the parameter T. The En input enables the 
pulse generator. The pulse generator sets the output to 1 for the duration of the time T, then 
to 0 for the duration of the time T and so forth, until input En = 0. 

Always specify a time T of 0.1 s. A time T is not defined for T = 0.05 s and T = 0.00 s. 

Special functions (Page 263)  

5.3.1.8 Asynchronous pulse generator 

 

Description of function 
The pulse shape at the output can be modified by a configurable pulse/pause ratio.  
 
Connection Description 
Input En You enable/disable the asynchronous pulse generator with the signal at input En. 
Input Inv The Inv input can be used to invert the output signal of the active asynchronous 

pulse generator. 
Parameter TH, TL: You can customize the pulse width (TH) and the interpulse width (TL). 
Output Q Q is toggled on and off cyclically with the pulse/pause times TH and TL. 
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Parameters TH and TL 
The pulse width TH and the interpulse width TL can be provided by the actual value of another 
already-programmed function: 

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Timing diagram 
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Description of the function 
You can set the pulse/pause ratio at the TH (Time High) and TL (Time Low) parameters. 

The INV input can be used to invert the output signal. The input block INV only inverts the 
output signal if the block is enabled with EN. 

Special functions (Page 263)  

5.3.1.9 Random generator 

 

Short description 
The output of a random generator is toggled within a configurable time.  
 
Connection Description 
Input En The positive edge (0 to 1 transition) at the enable input En (Enable) triggers the 

on-delay for the random generator. 
The negative edge (1 to 0 transition) triggers the off-delay for the random gener-
ator. 

Parameter TH: The on-delay is determined at random and lies between 0 s and TH. 
TL: The off-delay is determined at random and lies between 0 s and TL. 

Output Q Q is set on expiration of the on-delay if En is still set. It is reset when the off-delay 
time has expired and if En has not been set again. 

Parameters TH and TL 
The on-delay time TH and the off-delay time TL can be provided by the actual value of another 
already-programmed function: 

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 
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• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Timing diagram 

 

Description of the function 
With the 0 to 1 transition at input En, a random time (on-delay time) between 0 s and TH is 
set and triggered. If the status at input En is 1 for at least the duration of the on-delay, the 
output is set to 1 when this on-delay time has expired. 

The time is reset if the status at input En is reset to 0 before the on-delay time has expired. 

When input En is reset 0, a random time (off-delay time) between 0 s and TL is set and 
triggered. 

If the status at input En is 0 at least for the duration of the off-delay time, the output Q is 
reset to 0 when the off-delay time has expired. 

The time is reset if the status at input En returns to 1 before the on-delay time has expired. 

Special functions (Page 263)  

5.3.1.10 Stairwell light switch 
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Short description 
The edge of an input pulse triggers a configurable time. The output is reset when this time 
has expired. An off warning can be output prior to the expiration of this time.  
 
Connection Description 
Input Trg You trigger the time (off-delay) for the stairwell light switch with a signal at input 

Trg (Trigger). 
Parameter T : The output is reset (1 to 0 transition) when the off-delay time T has expired. 

T! : determines the triggering time for the prewarning. 
T!L : determines the length of the prewarning time. 
Retentivity on = the status is retentive in memory. 

Output Q Q is reset after the time T has expired. A warning signal can be output before this 
time has expired. 

Parameters T, T! and T!L 
The off-delay time T, the prewarning time T! and the prewarning period T!L can be provided by 
the actual value of another already-programmed function:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 
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• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Timing diagram 

 
 

 

The prewarning time is set to 15 s. The T! and T!L parameters thus become ob-
solete. 

 

Changing the time base 
You can change the prewarning time base and the period. 
 
Time base T Prewarning time Prewarning period 
Seconds * 750 ms 50 ms 
Minutes 15 s 1 s 
Hours 15 min 1 min 
 * makes sense only for programs with a cycle time of < 25 ms 

Description of the function 
Output Q is set to 1 with a 0 to 1 signal transition at input Trg. The 1 to 0 transition at input 
Trg triggers the current time and output Q remains set. 

Output Q is reset to 0 when Ta reaches the time T. Before the off delay time (T - T!) has 
expired, you can output a prewarning that resets Q for the duration of the off prewarning 
time T!L. 

Ta is retriggered (optional) at the next high/low transition at input Trg and if Ta is expiring. 
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Scan cycle time 
For information on how to determine the scan cycle time of an IDEC SmartRelay, refer to the 
appendix of the IDEC SmartRelay User's Manual. 

Special functions (Page 263)  

5.3.1.11 Dual-function switch 

 

Short description 
Switch with two different functions:  

• Pulse switch with off delay 

• Switch (continuous light) 

 
Connection Description 
Input Trg A signal at input Trg (Trigger) sets output Q (permanent light) or resets Q with an 

off-delay. When active, output Q can be reset with a signal at input Trg. 
Input R A signal at input R resets the current time Ta and resets the output. 
Parameter T : determines the off-delay time. The output is reset (1 to 0 transition) when the 

time T expires. 
TL : determines the period during which the input must be set in order to enable 
the permanent light function. 
T! : determines the on delay for the prewarning time. 
T!L : determines the length of the prewarning time period. 
Retentivity on = the status is retentive in memory. 

Output Q Output Q is set with a signal at input Trg, and it is reset again after a configured 
time has expired and depending on the pulse width at input Trg, or it is reset with 
another signal at input Trg. 

Parameters T, TL, T! and T!L 
The off-delay time T, the permanent light time TL, the on-delay prewarning time T!, and the 
prewarning time period T!L can be provided by the actual value of another already-
programmed function:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 
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For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Timing diagram 

 
 

 

FL1A, FL1B: 
Only the TL and T parameters exist. 
The output is reset when T has expired. 
TL determines the period during which the input must be set in order to enable 
the permanent light function. 
Input R is not available to the user. 
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Description of the function 
Output Q is set to 1 with a 0 to 1 signal transition at Trg. 

If output Q = 0, and input Trg is set hi for at least the duration of TL, the permanent lighting 
function is enabled and output Q is set accordingly. 

The off-delay time T is triggered when the status at input Trg changes to 0 before the time TL 
has expired. 

Output Q is reset when the Ta = T.  

You can output an off-warning signal prior to the expiration of the off-delay time (T - T!) that 
resets Q for the duration of the off prewarning time T!L. A subsequent signal at input Trg 
always resets T and output Q. 

Caution 
The time base for T, T! and T!L must be identical. 

Special functions (Page 263)  

5.3.1.12 Seven-day time switch 

 

Caution 
Your IDEC SmartRelay must be equipped with an internal real-time clock if you are going to 
use this SFB. 

Short description 
The output is controlled by means of a configurable on/off date. The function supports any 
combination of weekdays.  
 
Connection Description 
Parameters No1, 
No2, No3 

At the No1, No2, No3 (Cam) parameters you set the on- and off-time triggers for 
each cam of the Seven-day time switch. For each Cam you specify the day of the 
week and the time of day for the on- and off-times. 

Par You specify whether the timer pulses on for one cycle when activated and is then 
reset. The pulse parameter applies to all three cams. 

Output Q Q is set when the configured cam is actuated. 
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Timing diagram (three practical examples) 

 

Description of the function 
Each Seven-day time switch is equipped with three cams. You can configure a time hysteresis 
for each individual cam. At the cams you set the on- and off-hysteresis. The Seven-day time 
switch sets the output at a certain time, provided it is not already set.  

The Seven-day time switch resets the output at the off-time if you configured an off-time, or 
at the end of the cycle if you specified a pulse output. A conflict is generated in the Seven-day 
time switch when the on-time and the off-time at another cam are identical. In this case, cam 
3 takes priority over cam 2, while cam 2 takes priority over cam 1. 

The switching status of the Seven-day time switch is determined by the status at the No1, 
No2 and No3 cams. 

On-times 
The on-time is any time between 00:00 h and 23:59 h. You can also configure the on-time to 
be a pulse signal. The timer block will be activated at the specified time for one cycle and 
then the output is reset. The off-time is disabled in this case as it is not applicable. 

Special characteristics to note when configuring 
The block properties window offers a tab for each one of the three cams. Here you can set 
the day of the week for each cam. Each tab offers you in addition an option of defining the 
on- and off-times for each cam in hour and minute units. Hence, the shortest switching cycle 
is one minute. Also on each tab you have the option of specifying a pulse output for the cam. 

You can disable the on- and off-times individually. You can achieve switching cycles 
extending across more than one day, for example, by setting the on-time for cam 1 to 
Monday 7:00 h and the off-time of cam 2 to Wednesday 13:07 h, while disabling the on time 
for cam 2. 
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The Pulse setting is available only as of the FL1E device series. 

Backup of the real-time clock 
The internal real-time clock of IDEC SmartRelay is buffered against power failure. The 
buffering time is influenced by the surrounding temperature, and is typically 20 days (for 
IDEC SmartRelay FL1F devices) or 80 hours (for IDEC SmartRelay FL1E) at a surrounding 
temperature of 25 °C. 

The IDEC SmartRelay FL1E devices support the option of a battery card or a combined 
program module (memory) and battery card. The real-time clock is buffered for several years 
with either of these cards. 

Special functions (Page 263)  
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5.3.1.13 Twelve-month time switch 

 

Short description 
The output is controlled by means of a configurable on/off date. You can configure the timer 
to activate on a yearly, monthly, or user-defined time basis. With any mode, you can also 
configure the timer to pulse the output during the defined time period. The time period is 
configurable within the date range of January 1, 2000 to December 31, 2099.  

 

 Note 

To use this function block, you must use an IDEC SmartRelay with an internal real-time clock. 
 

 

 
Connection Description 
Parameter At the No (cam) parameter, you configure the timer mode, the on-/off-times for 

the timer, and whether the output is a pulse output. 
Output Q Q is set on when the configured cam is switched on. 

Timing diagrams 
Example 1: Yearly selected, On Time = 2000.06.01, Off Time = 2099.08.31, Every year on 
June 1 the timer output switches on and remains on until August 31. 

 

Example 2: Yearly selected, Pulse Output selected, On Time = 2000.03.15, Off Time = 
2099.**.**. Every year on March 15, the timer switches on for one cycle. 

 
Example 3: Yearly selected, On Time = 2008.06.01, Off Time = 2010.08.31. On June 1 of 
2008, 2009, and 2010, the timer output switches on and remains on until August 31. 
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Example 4: Yearly selected, Pulse Output selected, On Time = 2008.03.15, Off Time = 
2010.**.**. On March 15 of 2008, 2009, and 2010, the timer output switches on for one 
cycle. 

 

Example 5: Monthly not selected, Yearly not selected, On Time = 2008.06.01, Off Time = 
2010.08.31. On June 1, 2008 the timer output switches on and remains on until August 31, 
2010. 

 
Example 6: Monthly not selected, Yearly not selected, Pulse Output selected, On Time = 
2008.03.15, Off Time = ****.**.**. On March 15, 2008 the timer switches on for one cycle. 
Because the timer does not have a monthly action or yearly action, the timer output pulses 
only one time at the specified On Time. 

 

Example 7: Yearly selected, On Time = 2008.12.15, Off Time =2010. 01.07. On December 
15 of 2008 and 2009, the timer output switches on and remains on until January 7 of the 
following year. When the timer output turns off on January 7, 2010 it does NOT turn on again 
the following December 15. 

 
Example 8: Monthly selected, On Time = 2008.**.01, Off Time = 2010.**.05. Starting in 
2008, on the first day of each month the timer output switches on and switches off on the 
fifth day of the month. The timer continues in this pattern through the last month of 2010. 
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Description of the function 
The Twelve-month time switch sets and resets the output at specific on and off dates. Sets 
and resets are executed at 00:00. If your application requires a different time, use a Seven-
day time switch together with a Twelve-month time switch in your circuit program. 

The On Time specifies the month and day when the timer is set. The Off Time identifies the 
month and day on which the output is reset again. For the on and off times, note the order of 
the fields: The first field defines the year, the second the month and the third the day.  

When you select the Monthly check box, the timer output switches on each month at the 
specified day of the start time and remains on until the specified day of the Off Time. The On 
Year specifies the initial year in which the timer is activated. The Off Year defines the last year 
in which the timer turns off. The maximum year is 2099. 

If you select the Yearly check box, the timer output switches on each year at the specified 
month and day of the start time and remains on until the specified month and day of the Off 
Time. The On Year specifies the initial year in which the timer is activated. The Off Year 
defines the last year in which the timer turns off. The maximum year is 2099.  

If you select the Pulse Output check box, the timer output switches on at the specified On 
Time for one cycle and then the timer output is reset. You can choose to pulse a timer on a 
monthly or yearly basis, or just a single time. 

If you select none of the Monthly, Yearly, or Pulse check boxes, you can define a specific time 
period with the On Time and Off Time. It can span any time period that you choose. 

For a process action that is to be switched on and off at multiple but irregular times during 
the year, you can define multiple Twelve-month time switches with the outputs connected by 
an OR function block. 
 

 

The Yearly and Pulse Output settings are available only as of the FL1E device 
series 
The Monthly setting is available only as of the FL1C device series. 

Backup of the real-time clock 
The internal real-time clock of IDEC SmartRelay is buffered against power failure. The 
buffering time is influenced by the surrounding temperature, and is typically 20 days (for 
IDEC SmartRelay FL1F and later version devices) or 80 hours (for IDEC SmartRelay FL1E 
devices) at a surrounding temperature of 25°C. If you are using the optional IDEC SmartRelay 
Battery card, or combined IDEC SmartRelay Memory/Battery card, IDEC SmartRelay can retain 
the clock time for up to two years. 

Special characteristics to note when configuring 
You can numerically enter values for the month and day fields. Enter values within the logical 
range of month values and day values; otherwise WindLGC returns an error message.  
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The calendar icon offers you an easy way of setting the date. It opens a window where you 
can set the days and months by clicking the relevant buttons on a calendar page. 

Sample configuration 
The output of an IDEC SmartRelay is to be switched on annually, from the 1st of March to the 
4th of April and from the 7th of July to the 19th of November. This requires two blocks for 
configuring the specific On Times. The outputs are then linked via an OR block. 

 
Place two Twelve-month time switch SFBs on your programming interface. Configure the On 
Time for the first Twelve-month time switch to 03.01 and the Off Time to 04.04. Configure 
the On Time for the second Twelve-month time switch to 07.07 and the Off Time to 11.19. 

Create a logical link of the blocks with a standard OR block. The OR output is 1 if at least one 
of the Twelve-month time switches is set. 

 
Special functions (Page 263)  

5.3.1.14 Astronomical clock (FL1F and later versions only) 

 

Short description 
The astronomical clock SFB is used to set an output high between sunrise and sunset based 
on the local time at the geographical location of the IDEC SmartRelay FL1F devices. The 
output status of this function block also depends on the configuration of summer time/winter 
time conversion.  
 
Connection Description 
Parameter The location info including longitude, latitude, time zone, and TR (sunrise 

time)/TS (sunset time) offsets. 
Output Q Q is set to hi when sunrise time is reached. It holds this state until sunset time is 

reached.  
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Parameters 

 
In the astronomical clock dialog, you can select the location of the IDEC SmartRelay device 
from one of the following pre-defined time zone locations: 

• Beijing 

• Berlin 

• London 

• Rome 

• Moscow 

• Tokyo 

• Washington 

• Ankara 

• Madrid 

• Amsterdam 

If you select one of these locations, WindLGC uses the latitude, longitude, and time zone of 
your selection. 

Alternatively, you can configure a specific latitude, longitude, and time zone for your 
location, and provide a name for this custom location. 

Based on the location and time zone, IDEC SmartRelay calculates the absolute sunrise and 
sunset time for the current day. The block also takes summer time/winter time into 
consideration, if it is configured on the computer where WindLGC is installed. To do such 
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configuration, you should select check box of "Automatically adjust clock for daylight for 
saving changes" in the "Date and Time Properties" dialog. 

Timing diagram 

 

Description of function 
The function calculates the value at the input and sets or resets Q depending on the sunrise 
time and sunset time at the configured location and time zone of the module. 

Special functions (Page 263)  

5.3.1.15 Stopwatch (FL1F and later versions only) 

 

Short description 
The stopwatch records the time elapsed since it was enabled.  
 
Connection Description 
Input En En (Enable) is the monitoring input. IDEC SmartRelay sets the current elapsed time 

to 0 and begins counting elapsed time when En transitions from 0 to 1. When En 
transitions from 1 to 0, the elapsed time is frozen. 

Input Lap A positive edge (0 to 1 transition) at input Lap pauses the stopwatch, and sets out-
put to lap time. A negative edge (1 to 0 transition) at input Lap resumes the stop-
watch, and set the output to current elapsed time. 

Input R A signal at input R (Reset) clears the current elapsed time and lap time.  
Parameter Time base for elapsed time, which you can set to hours, minutes, seconds, or 

1/100ths of seconds. 
Output AQ The output AQ outputs value of the current elapsed time when it is a negative edge 

(1 to 0 transition) at the input Lap, and outputs value of the Lap time when it is a 
positive edge (0 to 1 transition) at the input Lap. 
A positive edge (0 to 1 transition) resets the value at output AQ to 0.  
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Parameters Time base 
You can configure the time base for the analog output: 

 
The time base for the elapsed time can be in hours, minutes, seconds, or 1/100ths of seconds 
(units of 10 milliseconds). The smallest time base, and therefore the resolution, is 
10 milliseconds, or 1/100ths of seconds. 

Timing diagram 

 

Description of the function 
When En = 1, the current time increases. 

When En = 0, the current time counting pauses. 
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When En = 1 and Lap = 0, the output AQ outputs the value of the current elapsed time. 

When En = 1 and Lap = 1, the current time continue increasing, but the output AQ outputs 
the value of the Lap time. 

When En = 0 and Lap =1, the output AQ outputs the value of the Lap time. 

When En = 0 and Lap = 0, the output AQ outputs the value of the latest current time. 

When R = 1, both the current time and the Lap time are reset. 

Special functions (Page 263)  

5.3.2 Counters 

5.3.2.1 Up/Down counter 

 

Short description 
An input pulse increments or decrements an internal value, depending on the parameter 
setting. The output is set or reset when a configured threshold is reached. The direction of 
count can be changed with a signal at input Dir.  
 
Connection Description 
Input R You reset the output and the internal counter value to the start value (StartVal) 

with a signal at input R (Reset) 
Input Cnt This function counts the 0 to 1 transitions at input Cnt. It does not count 1 to 0 

transitions. 
• Use the inputs I3, I4, I5, and I6 for high-frequency counts (IDEC SmartRelay 

FL1F-H12RCE/-B12RCE, IDEC SmartRelay FL1F-H12SCD): max. 5 kHz, if the fast 
input is directly connected to the Up/Down counter function block 

• Use any other input or circuit element for low-frequency counts (typically 4 
Hz). 

Input Dir Input Dir (Direction) determines the direction of count: 
Dir = 0: Up 
Dir = 1: Down 

Parameter On: On threshold / Value range: 0 to 999999 
Off: Off threshold / Value range 0 to 999999 
Start Value: Initial value from which to begin counting either down or up. 
Retentivity on = the status is retentive in memory. 

Output Q Q is set and reset according to the actual value at Cnt and the set thresholds.  
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Parameters On and Off 
The on threshold On and the off threshold Off can be provided by the value of another 
already-programmed function:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

For information on the validity and accuracy of the time base, refer to the IDEC SmartRelay 
User's Manual. 
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Timing diagram 

 

Description of the function 
The function increments (Dir = 0) or decrements (Dir = 1) the internal counter by one count 
with every positive edge at input Cnt. 

You can reset the internal counter value to the start value with a signal at the reset input R. 
As long as R=1, the output Q is 0 and the pulses at input Cnt are not counted. 

Output Q is set and reset according to the actual value at Cnt and the set thresholds. See the 
following rules for calculation. 

Calculation rule 
• If the on threshold ≥ off threshold, then: 

Q = 1, if Cnt ≥ On 
Q = 0, if Cnt < Off. 

• If the on threshold < off threshold, then: 
Q = 1, if On ≤ Cnt < Off. 

 

 

FL1C-FL1D: 
The Start Value parameter does not exist. The counter always counts up or 
down from 0. 
FL1A-FL1B: 
The off parameter does not exist. The calculation rule is therefore void. 

Caution 
The function polls the limit value of the counter once in each cycle. 

Thus, if the pulses at the fast inputs I3, I4, I5, or I6 are faster than the scan cycle time, the SFB 
might not switch until the specified limit has been exceeded. 

Example: Up to 100 pulses per cycle can be counted; 900 pulses have been counted so far. 
On = 950; Off = 10000. The output is set in the next cycle, after the value has reached 1000. 

The output would not be set at all if the value Off = 980 
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Scan cycle time 
For information on how to determine the scan cycle time of an IDEC SmartRelay, refer to the 
appendix in the IDEC SmartRelay User's Manual. 

Special functions (Page 263) 

5.3.2.2 Hours counter 

 

Short description 
A configured time is triggered with a signal at the monitoring input. The output is set when 
this time has expired.  
 
Connection Description 
Inout R A positive edge (0 to 1 transition) at input R resets output Q and sets a config-

ured value MI at the counter for the duration of the time-to-go (MN). 
Input En En is the monitoring input. IDEC SmartRelay scans the On Time of this input. 
Input Ral A positive edge at input Ral (Reset all) resets the hours counter (OT) and the out-

put, and sets the time-to-go value (MN) to the configured maintenance interval 
(MI): 
• Output Q = 0 
• The measured operating hours OT = 0 
• The time-to-go of the maintenance interval MN = MI. 

Parameter MI: Maintenance interval to be specified in units of hours and minutes 
Range of values: 0000 h to 9999 h, 0 m to 59 m 
OT: Accumulated total operating time. An offset start time can be specified in 
hours and minutes. 
Range of values: 00000 h to 99999 h, 0 m to 59 m 
Q → 0: 
• When "R" is selected: 

Q = 1, if MN = 0; 
Q = 0, if R = 1 or Ral = 1 

• When "R+En" is selected: 
Q = 1, if MN = 0; 
Q = 0, if R = 1 or Ral = 1 or En = 0. 

Output Q The output is set when the time-to-go MN = 0. The output is reset: 
• When "Q → 0:R+En", 

if R = 1 or Ral = 1 or En = 0 
• When "Q → 0:R",  

if R = 1 or Ral = 1. 
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Parameter MI 
The maintenance interval MI can be provided by the actual value of another already-
programmed function:  

• Analog comparator: Ax - Ay 

• Analog trigger: Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 
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Timing diagram 

 
These values are always retentive. 

Description of the function 
The hours counter monitors input En. As long as the status at this input is 1, IDEC SmartRelay 
calculates the expired time and the time-to-go MN. IDEC SmartRelay displays these times 
when set to configuration mode. The output is set to 1 when the time-to-go is equal to zero. 

You reset output Q and the time-to-go counter to the specified value MI with a signal at input 
R. The hour counter OT remains unaffected. 

You reset output Q and the time-to-go counter to the specified value MI with a signal at input 
Ral. The hour counter OT is reset to 0. 

Depending on your configuration of the Q parameter, the output is either reset with a reset 
signal at input R or Ral ("Q  →  R"), or when the reset signal is 1 or the En signal is 0 ("Q  →  
R+En"). 

Viewing the MI, MN and OT values 
In WindLGC you can fetch the hours counter via the Tools -> Transfer -> Hours counter 
(Page 122) menu command. 

Limit value of OT 
The value of the operating hours in OT is retained when you reset the hours counter with a 
signal at input R. The hours counter OT will be reset to zero with a transition from 0 to 1 at 
Ral. The hours counter OT continues the count as long as En = 1, irrespective of the status at 
the reset input R. The counter limit of OT is 99999 h. The hours counter stops when it reaches 
this value.  



Reference material  
5.3 Special functions 

 WindLGC Online Help 

302 Programming and Operating Manual, 11/2024 

In programming mode, you can set the initial value of OT. MN is calculated according to the 
following formula when reset input R is never enabled: MN = MI - (OT % MI). The % operator 
provides an integer division remainder. 

Example: 

MI = 30h, OT = 100h 

MN = 30 - (100 % 30) 

MN = 30 -10 

MN = 20h 

 
In runtime mode, the value OT cannot be preset. If the value for MI is changed, there would 
be no calculation for the MN. MN would take on the value of MI. 

Parameter preset 
In WindLGC, you can define MI and an OT start value. 

You determine that Q does not depend on En by selecting the corresponding check box. 

Retentivity with the hours counter 
The hours counter in the IDEC SmartRelay is retentive. 

If the values of the hours counter are lost after a power failure, then select the respective 
block in your circuit program. Right-click the hours counter and select Block Properties > 
Parameter. The option Retentivity must be activated and unchangeable (grayed out). 

If the Retentivity option is not available, then delete the block and insert a new special 
function hours counter at the same position. 
 

 

FL1A-FL1D: 
The maintenance interval (MI) and the start time for OT are specified in hours.  
FL1E-FL1F FS5: 
The maintenance interval (MI) and the start time for OT are specified in hours 
and minutes.  
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Value reset 
If you download a circuit program that contains an hours counter function from WindLGC to 
an IDEC SmartRelay FL1F Base Module, WindLGC prompts you whether to continue or not. If 
you continue with the download, the hours counter value is reset. 

 
 

 

 Note 

If you copy a circuit program that contains an hours counter function from an SD card to an 
IDEC SmartRelay Base Module, the hours counter value is reset with no notification. 
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5.3.2.3 Frequency trigger 

 

Short description 
The output is switched on and off depending on two configurable frequencies.  
 
Connection Description 
Input Fre The function counts 0 to 1 transitions at input Fre. Transitions from 1 to 0 are not 

counted. 
• Use the inputs I3, I4, I5, and I6 for high-frequency counts (IDEC SmartRelay 

FL1F-H12RCE/-B12RCE, IDEC SmartRelay FL1F-H12SCD): max 5kHz, if the fast 
input is directly connected to the Frequency trigger function block 

• Use any other input or circuit element for low frequencies (typical 4 Hz). 

Parameter On: On threshold 
Range of values: 0000 to 9999 
Off: Off threshold 
Range of values: 0000 to 9999 
G_T: Time interval or gate time during which the input pulses are measured. 
Range of values: 00:00 s to 99:99 s 

Output Q Q is set or reset according to the threshold values. 
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Parameter G_T 
The gate time G_T can be provided by the actual value of another already-programmed 
function:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Timing diagram 
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Description of the function 
The trigger measures the signals at input Fre. The pulses are captured during a configurable 
period G_T.  

Q is set or reset according to the set thresholds. See the following calculation rule. 

Calculation rule 
• If the threshold (On) ≥ threshold (Off), then: 

Q = 1, if fa > On 
Q = 0, if fa ≤ Off. 

• If the threshold (On) < threshold (Off), then Q = 1, if 
On ≤ fa < Off. 

Special functions (Page 263) 

5.3.3 Analog 
5.3.3.1 Analog trigger 

 

Short description 
The output is set or reset depending on two configurable thresholds (hysteresis).  
 
Connection Description 
Input Ax Input Ax is one of the following analog signals: 

• AI1 to AI8 (*) 
• AM1 to AM6, or AM1 to AM64 (if FL1F) 
• NAI1 to NAI32 (if FL1F) 
• AQ1 and AQ2, or AQ1 to AQ8 (if FL1F) 
• NAQ1 to NAQ16 (if FL1F) 
• The block number of a function with analog output 

Parameter Gain 
Range of values: -10.00 to 10.00 
Offset 
Range of values: -10000 to 10000 
On: On threshold 
Range of values: -20000 to 20000 
Off: Off threshold 
Range of values: -20000 to 20000 
p: Number of decimals 
Range of values: 0, 1, 2, 3 

Output Q Q is set or reset depending on the set thresholds. 
* AI1 to AI8: 0 to 10 V corresponds with 0 to 1000 (internal value). 
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Parameters On and Off 
The On and Off parameters can be provided by the actual value of another already-
programmed function:  

• Analog comparator: Ax - Ay 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 
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You select the required function by the block number. 
 

 

FL1C: 
A: Gain 
Range of values 0.00 to 10.00 

 FL1A, FL1B: 
These parameters apply: 
G: Gain in [%] 
Range of values 0% to 1000% 
O: Offset 
Range of values -999 to 999 
On: On threshold 
Range of values 0 to 9999 
Off: Off threshold 
Range of values 0 to 9999 

Parameter p (number of decimals) 
Parameter p applies only to the display of On, Off and Ax values in a message text. 

Parameter p does not apply to the comparison of On and Off values. (The compare function 
ignores the decimal point.) 

Timing diagram 

 

Description of the function 
The function reads the value of the signal at the analog input Ax.  

This value is multiplied by the value of parameter A (gain). Parameter B (offset) is added to 
the product, hence 

(Ax * Gain) + Offset = Actual value Ax. 

Output Q is set or reset depending on the set threshold values. See the following calculation 
rule. 
 

 

FL1A, FL1B: 
The function is as follows: 
The offset parameter is added to the read analog value. The sum is multiplied by 
the value of the gain parameter. 
Value = (AI+offset)*gain 
Output Q is set to 1 if the calculated value exceeds the on threshold (TH high). 
Q is reset to 0 when the value reaches or drops below the off threshold (TH low). 
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Calculation rule 
• If threshold (On) ≥ threshold (Off), then: 

Q = 1, if the actual value Ax > On 
Q = 0, if the actual value Ax ≤ Off. 

• If threshold (On) < threshold (Off), then Q = 1, if 
On ≤ the actual value Ax < Off. 

Particular characteristics to be noted when configuring 
Refer to the help on analog block parameters in the Analog value processing (Page 334) 
section. 
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 Note 

The decimal point setting must be identical in the minimum and maximum range. 
 

5.3.3.2 Analog differential trigger 

 

Short description 
The output is set and reset depending on a configurable threshold and a differential value.  
 
Connection Description 
Input Ax Input Ax is one of the following analog signals: 

• AI1 to AI8 (*) 
• AM1 to AM6 or AM1 to AM64 (if FL1F) 
• NAI1 to NAI32 (if FL1F) 
• AQ1 and AQ2, or AQ1 to AQ8 (if FL1F) 
• NAQ1 to NAQ16 (if FL1F) 
• The block number of a function with analog output 

Parameter Gain 
 Range of values: -10.00 to 10.00 
Offset  
 Range of values: -10000 to 10000 
On: On/Off threshold 
 Range of values: -20000 to 20000 
Δ: Differential value for calculating the off parameter 
 Range of values: -20000 to 20000 
p: Number of decimals 
 Range of values: 0, 1, 2, 3 

Output Q Q is set or reset, depending on the threshold and difference values. 
* AI1 to AI8: 0 to 10 V corresponds with 0 to 1000 (internal value). 

 

 

 

A: Gain 
Range of values: 0.00 to 10.00 

Parameter p (number of decimals) 
Parameter p applies only to the display of On, Off and Ax values in a message text. 

Parameter p does not apply to the comparison of On and Off values. (The compare function 
ignores the decimal point.) 
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Timing diagram A: Function with negative difference Delta 

 

Timing diagram B: Function with positive difference Delta 

 

Description of the function 
The function fetches the analog signal at input Ax.  

Ax is multiplied by the value of the A (gain) parameter, and the value at parameter B (offset) 
is added to product, i.e. 

(Ax * gain) + offset = actual value of Ax. 

Output Q is set or reset, depending on the set (On) threshold and difference value (Delta). 
The function automatically calculates the Off parameter: Off = On + Delta, whereby Delta 
may be positive or negative. See the calculation rule below. 

Calculation rule 
• When you set a negative differential value Delta, the On threshold ≥ Off threshold, and: 

Q = 1, if the actual value Ax > On 
Q = 0, if the actual value Ax ≤ Off. 
See the timing diagram A. 

• When you set a positive differential value Delta, the On threshold < the Off threshold, and 
Q = 1, if: 
On ≤ the actual value Ax < Off. 
See the timing diagram B. 

Particular characteristics to be noted when configuring 
Refer to the help on analog block parameters in the Information on analog value processing 
(Page 334) section. 

Special functions (Page 263)  
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5.3.3.3 Analog comparator 

 

Short description 
The output is set and reset depending on the difference Ax – Ay and on two configurable 
thresholds.  
 
Connection Description 
Inputs Ax, Ay Inputs Ax, Ay are two analog signals from the followings: 

• AI1 to AI8 (*) 
• AM1 to AM6, or AM1 to AM64 (if FL1F) 
• NAI1 to NAI32 (if FL1F) 
• AQ1 and AQ2 , or AQ1 to AQ8 (if FL1F) 
• NAQ1 to NAQ16 (if FL1F) 
• The block number of a function with analog output 

Parameter Gain 
Range of values: -10.00 to 10.00 
Offset 
Range of values: -10000 to 10000 
On: On threshold 
Range of values: -20000 to 20000 
Off: Off threshold 
Range of values: -20000 to 20000 
p: Number of decimals 
Range of values: 0, 1, 2, 3 

Output Q Q is set or reset depending on the set thresholds. 
* AI1 to AI8: 0 to 10 V corresponds with 0 to 1000 (internal value). 

 

 

 

FL1C: 
A: Gain 
Range of values: 0.00 to 10.00 

 FL1A - FL1B: 
The following parameters apply: 
G : Gain in [%] 
Range of values: 0% to 1000% 
O : Offset 
Range of values: -999 to 999 
delta : Threshold 
Q is set to 1 when the difference Ax-Ay exceeds the threshold. 
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Parameters On and Off 
The on threshold On and the off threshold Off can be provided by the actual value of another 
already-programmed function:  

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Parameter p (number of decimals) 
Parameter p applies only to Ax, Ay, Delta, On and Off values displayed in a message text. 

Parameter p does not apply to the comparison of on and off values. (The compare function 
ignores the decimal point.) 
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Timing diagram 

 

Description of the function 
The function reads the value of the signal at the analog input Ax.  

This value is multiplied by the value of parameter A (gain). Parameter B (offset) is added to 
the product, hence 

(Ax * gain) + offset = Actual value Ax.  

(Ay * gain) + offset = Actual value Ay. 

Output Q is set or reset depending on the difference of the actual values Ax – Ay and the set 
thresholds. See the following calculation rule. 

Calculation rule 
• If threshold On ≥ threshold Off, then: 

Q = 1, if (actual value Ax - actual value Ay) > On 
Q = 0, if (actual value Ax - actual value Ay) ≤ Off. 

• If threshold On < threshold Off, then Q = 1, then: 
On ≤ (actual value Ax - actual value Ay) < Off. 

 

 

FL1A, FL1B: 
The following functions/calculation rules apply: 
The function adds the relevant specified offset to the analog values Ax and Ay. 
The sum is multiplied with the value of the gain parameter. The difference is 
formed from both calculated values. 
Output Q is set if this difference between these values exceeds the threshold 
you have configured under delta. 
Calculation rule: 
Q = 1, if: 
((Ax + offset) * gain) - ((Ay + offset)*gain) > threshold delta 
Q is reset to 0 when the threshold reaches or drops below delta. 
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Reducing the input sensitivity of the analog comparator 
You can delay the output of the analog comparator selectively by means of the "on delay" and 
"off delay" SFBs. By doing so, you determine that output Q is only set if the input trigger 
length Trg (= output of the analog comparator) exceeds the defined on delay time. 

This way you can set a virtual hysteresis, which renders the input less sensitive to short 
changes. 

Particular characteristics to be noted when configuring 
For help on analog block parameters, refer to the Analog value processing (Page 334) 
section. 

Special functions (Page 263)  

5.3.3.4 Analog watchdog 

 

Short description 
This special function saves the process variable of an analog input to memory, and sets the 
output when the output variable exceeds or drops below this stored value plus a configurable 
offset.  
 
Connection Description 
Input En A positive edge (0 to 1 transition) at input En saves the analog value at input Ax 

("Aen") to memory and starts monitoring of the analog range Aen +- Delta. 
Input Ax Input Ax is one of the following analog signals: 

• AI1 to AI8 (*) 
• AM1 to AM6, or AM1 to AM64 (if FL1F) 
• NAI1 to NAI32 (if FL1F) 
• AQ1 and AQ2, or AQ1 to AQ8 (if FL1F) 
• NAQ1 to NAQ16 (if FL1F) 
• The block number of a function with analog output 

Parameter Gain 
Range of values: -10.00 to 10.00 
Offset 
Range of values: -10000 to 10000 
Threshold 1: Difference value above Aen: on/off threshold 
Range of values: 0 to 20000 
Threshold 2: Difference value below Aen: on/off threshold 
Range of values: 0 to 20000 
p: Number of decimals 
Possible settings: 0, 1, 2, 3 
Retentivity on = the status is retentive in memory. 

Output Q Q is set/reset, depending on the stored analog value and the offset. 
* AI1 to AI8: 0 to 10 V corresponds with 0 to 1000 (internal value). 
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Parameters Threshold 1 and Threshold 2 
The two threshold parameters Threshold 1 and Threshold 2 can be provided by the actual 
value of another already-programmed function:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

The thresholds are represented by the symbol Δ on the IDEC SmartRelay Base Module and in 
the timing diagram below. 
 

 

FL1C: 
Gain: Range of values: 0.00 to 10.00 

Parameter p (number of decimals) 
Parameter p applies only to the display of Aen, Ax, Threshold 1 and Threshold 2 values in a 
message text. 
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Timing diagram 

 

Description of the function 
A 0 to 1 transition at input En saves the value of the signal at the analog input Ax. This saved 
process variable is referred to as "Aen". 

Both the analog actual values Ax and Aen are multiplied by the value at parameter A (gain), 
and parameter B (offset) is then added to the product, as follows:  

(Ax * gain) + offset = Actual value Aen, when input En changes from 0 to 1, or 

(Ax * gain) + offset = Actual value Ax. 

Output Q is set when the signal at input En = 1 and if the actual value at input Ax is out of 
range of Aen + Threshold 1 / Aen - Threshold 2. 

Output Q is reset, when the actual value at input Ax lies within the range of Aen + Threshold 
1 / Aen - Threshold 2, or when the signal at input En changes to lo. 

Particular characteristics to be noted when configuring 
Refer to the help on analog block parameters in the Analog value processing (Page 334) 
section. 

Special functions (Page 263) 

5.3.3.5 Analog amplifier 
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Short description 
This SFB amplifies an analog input value and returns it at the analog output.  
 
Connections Description 
Input Ax Input Ax is one of the following analog signals: 

• AI1 to AI8 (*) 
• AM1 to AM6, or AM1 to AM64 (if FL1F) 
• NAI1 to NAI32 (if FL1F) 
• AQ1 and AQ2, or AQ1 to AQ8 (if FL1F) 
• NAQ1 to NAQ16 (if FL1F) 
• The block number of a function with analog output 

Parameter Gain 
Range of values: -10.00 to 10.00 
Offset 
Range of values: -10000 to 10000 
p: Number of decimals 
Possible settings: 0, 1, 2, 3 

Output AQ Value range for AQ: -32768 to +32767 
* AI1 to AI8: 0 to 10 V corresponds with 0 to 1000 (internal value). 

 

 

 

FL1C: 
A: Gain 
Range of values: 0.00 to 10.00 

Parameter p (number of decimals) 
Parameter p applies only to the display of Ax and Ay values in a message text. 

Parameter p does not apply to the comparison of On and Off values. (The compare function 
ignores the decimal point.) 

Description of the function 
The function reads the value of an analog signal at the analog input Ax.  

This value is multiplied by the gain parameter A. Parameter B (offset) is added to the product, 
as follows: 

(Ax * gain) + offset = Actual value Ax. 

The actual value Ax is output at AQ. 

Particular characteristics to be noted when configuring 
For help on analog block parameters, refer to the Analog value processing (Page 334) 
section. 
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Analog output 
If you connect this special function to a real analog output, then note that the analog output 
can only process values from 0 to 1000. To do this, connect an additional amplifier between 
the analog output of the special function and the real analog output. With this amplifier you 
standardize the output range of the special function to a value range of 0 to 1000. 

Example: additional amplifier behind an analog multiplexer. 

 
Special functions (Page 263)  

5.3.3.6 Analog multiplexer 

 

Short description 
When enabled, the analog multiplexer SFB displays one of four pre-defined analog values, 
depending on input conditions.  
 
Connection Description 
Input En 1 on input En (Enable) switches, dependent on S1 and S2, a parameterized ana-

log value to the output AQ. 
0 on input EN switches 0 to the output AQ. 

Inputs S1 
and S2 

S1 and S2 (selectors) for selecting the analog value to be issued. 
S1 = 0 and S2 = 0: The value V1 is issued 
S1 = 0 and S2 = 1: The value V2 is issued 
S1 = 1 and S2 = 0: The value V3 is issued 
S1 = 1 and S2 = 1: The value V4 is issued 

Parameter V1 to V4: Analog values (Value) that will be issued. 
Value range: -32768 to +32767 
p: Number of decimal places 
Possible settings: 0, 1, 2, 3 

Output AQ Analog output 
Value range for AQ: -32768 to +32767 

Parameters V1 to V4 
The values for V1 to V4 can be provided by the value of another already-programmed 
function:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog multiplexer: AQ 

• PI controller: AQ 
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• Analog Ramp: AQ 

• Analog math: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Parameter p (number of decimal places) 
Parameter p applies only to the display of AQ, V1, V2, V3 and V4 values in a message text. 

Timing diagram 
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Description of function 
If input En is set, then the function issues one of four possible analog values V1 to V4 at the 
output AQ, depending on the inputs S1 and S2. 

If the input En is not set, then the function issues the analog value 0 at output AQ. 

Particular characteristics to be noted when configuring 
For help on analog block parameters, refer to the Basics (Page 334) section. 

Analog output 
If you connect this special function to a real analog output, then note that the analog output 
can only process values from 0 to 1000. To do this, connect an additional amplifier between 
the analog output of the special function and the real analog output. With this amplifier you 
standardize the output range of the special function to a value range of 0 to 1000. 

Example: additional amplifier behind an analog multiplexer. 

 
Special functions (Page 263)  
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See also 
Analog comparator (Page 311) 

Analog trigger (Page 305) 

Analog ramp (Page 351) 

Analog math (Page 324) 

PI controller (Page 347) 

Up/Down counter (Page 296) 

On-delay (Page 267) 

Off-delay (Page 269) 

On-/Off-delay (Page 271) 

Retentive on-delay (Page 272) 

Interval time-delay relay/Pulse output (Page 274) 

Edge-triggered interval time-delay relay (Page 276) 

Asynchronous pulse generator (Page 278) 

Stairwell light switch (Page 281) 

Dual-function switch (Page 284) 

Stopwatch (FL1F and later versions only) (Page 294) 

Analog filter (FL1F and later versions only) (Page 327) 

Average value (FL1F and later versions only) (Page 332) 

Max/Min (FL1F and later versions only) (Page 329) 

5.3.3.7 Pulse Width Modulator (PWM) 

 

Short description 
The Pulse Width Modulator (PWM) instruction modulates the analog input value Ax to a 
pulsed digital output signal. The pulse width is proportional to the analog value Ax.  
 
Connection Description 
Input En A positive edge (0 to 1 transition) at input En enables the PWM function block. 
Input Ax Analog signal to be modulated to a pulsed digital output signal. 



Reference material  
5.3 Special functions 

 WindLGC Online Help 

322 Programming and Operating Manual, 11/2024 

Parameter Gain 
Range of values: -10.00 to 10.00 
Offset 
Range of values: -10,000 to 10,000 
PT: Periodic time over which the digital output is modulated 
p: Number of decimals 
Possible settings: 0, 1, 2, 3 

Output Q Q is set or reset for the proportion of each time period according to the propor-
tion of the standardized value Ax to the analog value range. 

 

 

 

FL1A - FL1D: 
The PWM function block did not exist prior to FL1E. 

Parameter PT 
The periodic time PT can be provided by the actual value of another already-programmed 
function:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 
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• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Parameter p (number of decimals) 
Parameter p applies only to the display of the Ax value in a message text. 

Description of the function 
The function reads the value of the signal at the analog input Ax.  

This value is multiplied by the value of parameter A (gain). Parameter B (offset) is added to 
the product, as follows:  

(Ax * Gain) + Offset = Actual value Ax 

The function block calculates the proportion of the value Ax to the range. The block sets the 
digital output Q high for the same proportion of the PT (periodic time) parameter, and sets Q 
low for the remainder of the time period. 

Examples with Timing Diagrams 
The following examples show how the PWM instruction modulates a digital output signal 
from the analog input value: 

Example 1 

Analog input value: 500 (range 0 to 1000)  
Periodic time T: 4 seconds 

The digital output of the PWM function is 2 seconds high, 2 seconds low, 2 seconds high, 2 
seconds low and continues in that pattern as long as parameter "En" = high. 

 
 

Example 2 

Analog input value: 300 (range 0 to 1000) 
Periodic time T: 10 seconds 

The digital output of the PWM function is 3 seconds high, 7 seconds low, 3 seconds high, 7 
seconds low and continues in that pattern as long as parameter "En" = high. 
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Calculation rule 
Q = 1, for (Ax – Min) / (Max – Min) of time period PT 
Q = 0, for PT – [(Ax – Min) / (Max – Min)] of time period PT. 

Note: Ax in this calculation refers to the actual value Ax as calculated using the Gain and 
Offset. Min and Max refer to the minimum and maximum values specified for the range. 

Particular characteristics to be noted when configuring 
Refer to the help on analog block parameters in the Analog value processing (Page 334) 
section. 

Special functions (Page 263)  

5.3.3.8 Analog math 

 

Short description 
The analog math block calculates the value AQ of an equation formed from the user-defined 
operands and operators.  
 
Connection Description 
Input En A positive edge at input En enables the analog math function block 
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Parameter V1: Value 1: First operand 
V2: Value 2: Second operand 
V3: Value 3: Third operand 
V4: Value 4: Fourth operand 
Range of values: -32768 to 32767 
Operator 1:  First operator 
Operator 2: Second operator 
Operator 3: Third operator 
Priority 1:  Priority of first operation 
Priority 2: Priority of second operation 
Priority 3: Priority of third operation 
p: Number of decimals 
Possible settings: 0, 1, 2, 3 

Output AQ The output AQ is the result of the equation formed from the operand values and 
operators. AQ will be set to 32767 if a divide by 0 or overflow occurs, and -32768 
if a negative overflow (underflow) occurs. 

 

 

 

FL1A - FL1D:  
The analog math function block did not exist prior to FL1E. 

Parameters V1, V2, V3, and V4 
The values V1, V2, V3, and V4 can be provided by the actual value of another already-
programmed function:  

• Analog comparator: Ax - Ay 

• Analog trigger: Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 
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• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Parameter p (number of decimals) 
Parameter p applies to the display of V1, V2, V3, V4 and AQ in a message text. 

Description of the function 
The analog math function combines the four operands and three operators to form an 
equation. The operator can be any one of the four standard operators: +, -, *, or /. For each 
operator, you must set a unique priority of High ("H"), Medium ("M"), or Low ("L"). The high 
operation will be performed first, followed by the medium operation, and then by the low 
operation. You must have exactly one operation of each priority. The operand values can 
reference another previously-defined function to provide the value. The analog math 
function rounds the result to the nearest integer value. 

The number of operand values is fixed at four and the number of operators is fixed at 3. If 
you need to use fewer operands, use constructions such as " + 0" or " * 1" to fill the remaining 
parameters. 

You can also configure the behavior of the function when the Enable parameter "En"=0. The 
function block can either retain its last value or be set to 0.  

Possible errors: Zero division and overflow 
If the analog math function block execution results in zero division or overflow, it sets 
internal bits that indicate the type of error that occurred. You can program an analog math 
error detection function block in your circuit program to detect these errors, and to control 
the program behavior as needed. You program one Analog math error detection (Page 384) 
function block to reference one specific analog math function block. 

Examples 
The following tables show some simple example analog math block parameters, and the 
resulting equations and output values: 
 
V1 Operator1 

(Priority 1) 
V2 Operator2 

(Priority 2) 
V3 Operator3 

(Priority 3) 
V4 

12 + (M) 6 / (H) 3 - (L) 1 
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Equation: (12 + (6 / 3)) - 1 
Result: 13 

 
 
V1 Operator1 

(Priority 1) 
V2 Operator2 

(Priority 2) 
V3 Operator3 

(Priority 3) 
V4 

2 + (L) 3 * (M) 1 + (H) 4 

Equation: 2 + (3 * (1 + 4)) 
Result: 17 

 
 
V1 Operator1 

(Priority 1) 
V2 Operator2 

(Priority 2) 
V3 Operator3 

(Priority 3) 
V4 

100 - (H) 25 / (L) 2 + (M) 1 

Equation: (100 – 25) / (2 + 1) 
Result: 25 

Special functions (Page 263)  

5.3.3.9 Analog filter (FL1F and later versions only) 

 

Short Description 
The Analog filter function block is used to smooth the analog input signal.  
 
Connection Description 
Input Ax Input Ax is one of the following analog signals: 

• AI1 to AI8 (*) 
• AM1 to AM64 (if FL1F) 
• NAI1 to NAI32 
• AQ1 to AQ8 (if FL1F) 
• NAQ1 to NAQ16 
• The block number of a function with analog output 

Parameter Sn (Number of samples): determines how many analog values are sampled with-
in the program cycles that are determined by the set number of samples. IDEC 
SmartRelay samples an analog value within every program cycle. The number of 
program cycles is equal to the set number of samples. 
Possible settings: 
8, 16, 32, 64, 128, 256 

Output AQ AQ outputs an average value of the analog input Ax over the current number of 
samples, and it is set or reset depending on the analog input and the number of 
samples. 

* AI1 to AI8: 0 to 10 V corresponds with 0 to 1000 (internal value). 
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Parameter 
You can set the number of samples to the following values: 

 
After you set the parameter, the analog filter calculates the average value of the samples and 
assigns this value to AQ. 

Timing diagram 

 

Description of function 
The function outputs the average value after sampling the analog input signal according to 
the set number of samples. This SFB can reduce the error of analog input signal. 

 

 Note 

There are a maximum of eight analog filter function blocks available for use in the circuit 
program in WindLGC V8.2 and later versions. 

 

Special Functions Overview (Page 263)  
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5.3.3.10 Max/Min (FL1F and later versions only) 

 

Short description 
The Max/Min function block records the maximum or minimum value.  
 
Connection Description 
Input En The function of input En (Enable) depends on the settings of parameter Mode 

and the selection of check box "when En = 0, reset Max/Min". 
Input S1 This input is enabled when you set Mode =2: 

A positive transition (0 to 1) at input S1 sets the output AQ to the maximum 
value. 
A negative transition (1 to 0) at input S1 sets the output AQ to the minimum 
value. 

Input Ax Input Ax is one of the following analog signals:  
• AI1 to AI8 (*) 
• AM1 to AM64 (if FL1F) 
• NAI1 to NAI32 
• AQ1 to AQ8 (if FL1F) 
• NAQ1 to NAQ16 
• Block number of a function with analog output 

Parameter Mode 
Possible settings: 0, 1, 2, 3 
Mode = 0: AQ = Min 
Mode = 1: AQ = Max 
Mode = 2 and S1= 0 (low): AQ = Min  
Mode = 2 and S1= 1 (high): AQ = Max 
Mode = 3 or a block value is referenced: AQ = Ax 

Output AQ AQ outputs a minimum, maximum, or actual value depending on the inputs, or is 
reset to 0 if configured to do so when function is disabled 

* AI1 to AI8: 0 to 10 V corresponds with 0 to 1000 (internal value). 

Parameter Mode 
You can set the values for parameter Mode based on the actual values of another already-
programmed function: 

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 
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• Up/Down counter: Cnt 

• Frequency trigger: Fre 

• Max/Min: Ax 

• PI controller: AQ 

• Analog filter: AQ 

• Average value: AQ 

• On-delay: Ta 

• Off-delay: Ta 

• On-/Off-delay: Ta 

• Retentative on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

You can select the required function by the block number. 

Timing diagram 

 
*) If you select the check box "when En = 0, reset Max/Min" 
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Description of the function 

 
If you select the check box "when Enable = 0, reset Max/Min": 

• Enable = 0: The function sets the AQ value to 0. 

• Enable = 1: The function outputs a value at AQ, depending on the settings of Mode and 
S1. 

If you do not select the check box "when Enable = 0, reset Max/Min": 

• Enable = 0: The function holds the value of AQ at the current value. 

• Enable = 1: The function outputs a value at AQ, depending on the settings of Mode and 
S1. 

Mode = 0: The function sets AQ to the minimum value 

Mode = 1: The function sets AQ to the maximum value 

Mode = 2 and S1 = 0: The function sets AQ to the minimum value 

Mode = 2 and S1 = 1: The function sets AQ to the maximum value 

Mode = 3 or a block value is referenced: The function outputs actual analog input value.  

Special functions (Page 263)  
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See also 
Analog comparator (Page 311) 

Analog trigger (Page 305) 

Analog amplifier (Page 316) 

Analog multiplexer (Page 318) 

Analog ramp (Page 351) 

Analog math (Page 324) 

Up/Down counter (Page 296) 

PI controller (Page 347) 

Analog filter (FL1F and later versions only) (Page 327) 

Average value (FL1F and later versions only) (Page 332) 

On-delay (Page 267) 

Off-delay (Page 269) 

On-/Off-delay (Page 271) 

Retentive on-delay (Page 272) 

Interval time-delay relay/Pulse output (Page 274) 

Edge-triggered interval time-delay relay (Page 276) 

Asynchronous pulse generator (Page 278) 

Stairwell light switch (Page 281) 

Dual-function switch (Page 284) 

Stopwatch (FL1F and later versions only) (Page 294) 

5.3.3.11 Average value (FL1F and later versions only) 

 

Short description 
The average value function samples the analog input signal during configured time period 
and outputs the average value at AQ.  
 
Connection Description 
Input En A positive edge (0 to 1 transition) at input En (Enable) sets the output AQ to the 

average value of input Ax after the configured time. A negative edge (1 to 0 tran-
sition) holds the output at its last calculated value. 

Input R A positive edge (0 to 1 transition) at input R (Reset) resets the output AQ to 0. 
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Input Ax Input Ax is one of the following analog signals: 
• AI1 to AI8 (*) 
• AM1 to AM16, or AM1 to AM64 (if FL1F) 
• NAI1 to NAI32 
• AQ1 and AQ2, or AQ1 to AQ8 (if FL1F) 
• NAQ1 to NAQ16 
• The block number of a function with analog output 

Parameter St (Sampling time): You can set it to Seconds, Days, Hours or Minutes. 
Range of values: 
If St = Seconds: 1 to 59 
If St = Days: 1 to 365 
If St = Hours: 1 to 23 
If St = Minutes: 1 to 59 
Sn (Number of samples): 
Range of values: 
If St = Seconds: 1 to St*100 
If St = Days: 1 to 32767 
If St = Hours: 1 to 32767 
If St = Minutes and St ≤ 5 minutes: 1 to St*6000 
If St = Minutes and St ≥ 6 minutes: 1 to 32767 

Output AQ AQ outputs the average value over the specified time of sampling. 
* AI1 to AI8: 0 to 10 V corresponds with 0 to 1000 (internal value). 

Parameter St and Sn 
Parameter St represents the sampling time and parameter Sn represents the number of 
samples. 

Timing diagram 
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Description of the function 
When En = 1, the average value function calculates the average value of the samples during 
the configured time interval. At the end of the sampling time, this function sets output AQ to 
this calculated average value. 

When En = 0, the calculation stops, and AQ retains the last calculated value. When R = 1, AQ 
is reset to 0. 

Special functions (Page 263)  

5.3.4 Analog value processing 

5.3.4.1 Basics 

Analog and digital 
An analog signal is a physical quantity, which, within a given range, can adopt any value - any 
continuous intermediate value. The opposite of analog is digital. A digital signal knows just 
two states: 0 and 1 or "off" and "on".  

From electrical signal to analog value 
Basic order of events 

Several steps are required for IDEC SmartRelay to process physical quantities: 

1. IDEC SmartRelay can read in electric voltages from 0 V to 10 V or electric currents from 0 mA 
to 20 mA to one analog input. 
The physical quantities (for example, temperature, pressure, speed etc.) must therefore be 
converted into one electric quantity. This conversion is performed by an external sensor. 

2. IDEC SmartRelay reads in the electric quantity and, with further processing, converts it into a 
standardized value within the range 0 to 1000. This value is then used in the circuit program 
as the input of an analog special function. 

3. In order to adapt the standardized value to the application, IDEC SmartRelay uses an analog 
special function, while taking into consideration the gain and offset, to calculate the analog 
value. The analog value is then evaluated by the special function (for example, analog 
amplifier). If an analog special function has an analog output, then the analog value is used 
as the output of the special function. 

4. With the IDEC SmartRelay you can also convert analog values back into an electric voltage. In 
doing so, the voltage can adopt values between 0 V and 10 V. 

5. Using this voltage, IDEC SmartRelay can control an external actuator, which converts the 
voltage and also the analog value back into a physical quantity. 

The following diagram illustrates this order of events. 
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Gain 
The standardized value is multiplied with a parameter. Using this parameter you can boost 
the electric quantity; hence, this parameter is called the "gain". 

Zero point offset 
You can add or subtract a parameter to or from the boosted standardized value. 

Using this parameter you can move the zero point of the electric quantity; hence, this 
parameter is called the "zero point offset". 

Gain and offset 
The analog value is therefore calculated as follows: 

Analog value = (standardized value x gain) + offset 

The following diagram illustrates this formula and the significance of gain and offset: 
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The straight line in the graphic describes which standardized value is being converted into 
which analog value. Gain corresponds to the slope of the straight line and offset to the 
movement of the zero point of the straight line on the y-axis. 

Analog output 
If you connect a special function (that has an analog output) to a real analog output, then 
note that the analog output can only process values from 0 to 1000. 

Possible settings with WindLGC (Page 336)  

Possible settings with IDEC SmartRelay (Page 337)  

Example: Heating Control (Page 338)  
 

 
FL1A to FL1C (Page 339)  

5.3.4.2 Possible settings with WindLGC 

Sensor 
Set your sensor type. (0 V to 10 V; 0 mA to 20 mA; 4 mA to 20 mA; no sensor)  

With sensor type 4 mA to 20 mA the value range for the standardized value is 200 and 1000. 

Measurement range 
Stipulate the measurement range. The measurement range is the value range shown for the 
analog value. 
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WindLGC then automatically calculates the gain and offset from this. 

Gain and offset 
If you want to set the gain, you can enter values between -10.00 and 10.00. The value 0 
makes no sense, as, irrespective of the applied analog value, you will always obtain the value 
0 as a result. 

If you wish to set the offset, enter values between -10000 and 10000. 

Rounding error 
WindLGC calculates the gain and zero point offset with utmost precision, while IDEC 
SmartRelay calculates internally using whole numerical values; therefore, not all parameter 
combinations are possible on IDEC SmartRelay. In this case, prior to transferring to IDEC 
SmartRelay, WindLGC detects a rounding error and proposes a possible replacement value 
range. 

Simulation in WindLGC 
With simulation in WindLGC you can read the following values: 

 
① Physical value; the ranges are stipulated by the measuring range (3) 
② Standardized value 
③ Measurement range 
④ Analog value (after processing gain and offset) 
⑤ Analog value on the analog output 

5.3.4.3 Possible settings with IDEC SmartRelay 
If you directly program your circuit program on the IDEC SmartRelay, then you can only enter 
the gain and offset parameters. You can calculate the gain and offset as follows:  

External value range minSensor - maxSensor: 

Range of a physical quantity that the sensor can measure. 

Standardized value range minnorm - maxnorm: 
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Value range of the standardized values.  

With sensors that provide 0 to 10 V or 0 to 20 mA, the standardized value range is 0 – 1000. 

With sensors that provide 4 to 20 mA, the standardized range is 200 – 1000. 

So for gain and offset it follows: 

Gain = (maxSensor - minSensor) / (maxnorm – minnorm) 

Offset = [(minSensor x maxnorm) – (maxSensor x minnorm)] / (maxnorm – minnorm) 

If you have calculated either the gain or the offset in accordance with the formulas above, 
you can then calculate the respective other value in accordance with the following formula: 

Gain = (minSensor - Offset) / minnorm 

Offset = (minSensor – (Gain x minnorm) 

5.3.4.4 Example 

Prerequisites 
Sensor: temperature sensor, measuring range: -50 °C to 100 °C  

Temperature to be measured: 25 °C 

Order of events with WindLGC 
1. The sensor converts the temperature from 25 °C to a voltage value of 5.0 V. 

2. WindLGC converts the 5.0 V to the standardized value 500. 

3. Using the sensor and measurement range data, WindLGC calculates and ascertains the value 
0.15 for the gain and the value -50 for the offset. 
According to the formula: 
Analog value = (standardized value × gain) + offset  
WindLGC calculates as analog value: 
Analog value = (500 × 0.15) - 50 = 25 

Order of events with IDEC SmartRelay 
1. The sensor converts the temperature from 25 °C to a voltage value of 5.0 V. 

2. IDEC SmartRelay converts the 5.0 V to the standardized value 500. 
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3. From the sensor and measuring range data, you must establish the values for gain and 
offset. 
According to the formulas: 
Gain = (maxSensor – minSensor) / (maxnorm – minnorm) 
and 
Offset = minSensor – (Gain × minnorm) 
it follows that 
Gain = (100 – (-50)) / (1000 – 0) = 0.15 
Offset = -50 – (0.15 × 0) = -50 

4. According to the formula 
Analog value = (standardized value × gain) + offset  
IDEC SmartRelay calculates as analog value: 
Analog value = (500 × 0.15) - 50 = 25 

Additional examples 
 
Physical quan-
tity 

Electric quan-
tity of sensor 

Standardized 
value 

Gain Offset Analog value 

 0 V 
5 V 
10 V 

0 
500 
1000 

0.01 0 0 
5 
10 

 4 mA 
12 mA 
20 mA 

0 
500 
1000 

10 0 0 
5000 
10000 

 0 mA 
10 mA 
20 mA 

0 
500 
1000 

1 50 50 
550 
1050 

1000 mbar 
3700 mbar 
5000 mbar 

O V 
6.75 V 
10 V 

0 
675 
1000 

4 1000 1000 
3700 
5000 

-30 °C 
0 °C 
70 °C 

0 mA 
6 mA 
20 mA 

0 
300 
1000 

0.1 -30 -30 
0 
70 

5.3.4.5 FL1A to FL1C 

 

Restriction for device family FL1C 
The Gain cannot be a negative value.  
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Calculation with the device families FL1A to FL1B 
With IDEC SmartRelay devices from these device families, IDEC SmartRelay adds or subtracts 
the parameter offset to or from the standardized value before multiplying the value with the 
parameter gain. 

Therefore, the following formulas apply: 

Analog value = (standardized value + offset) x (gain x 100) 

Gain (in percent) = (maxSensor - minSensor) / [(maxnorm – minnorm) x 100] 

Offset = [(minSensor x maxnorm) – (maxSensor x minnorm)] / (maxSensor – minSensor) 

Gain (in percent) = minSensor / [(minnorm + offset) x 100] 

Offset = [maxSensor / (gain x 100)] - maxnorm 

Gain 
This parameter is given in %. 

The Gain (Page 334) cannot be a negative value. 

Zero point offset 
You can enter values between -999 and +999 for the zero point offset (Page 334). 

5.3.5 Control and regulate 

5.3.5.1 Control and regulate basics 
In engineering, quantities can be both controlled and regulated.  

Controlling manipulates a quantity without being able to compensate for outside influences. 
Regulating maintains a quantity at a specific value in order to compensate for outside 
influences. 

In the following example, controlling means that the person can set the heat output at a 
fixed value. The heater cannot compensate for the drop in room temperature when a 
window is opened. 

In the example below, regulating means that the person can increase the heat output if the 
room temperature drops below 20 °C. If the room temperature rises above 20 °C, the heat 
output is reduced. 
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Basic concepts of regulating 
In the example, the current for the electric heating is the manipulated variable. The 
changeable resistance is the actuator. The hand that operates the actuator is the control. 
The actual room temperature is the controlled variable or the process value. The desired 
room temperature is the command variable or the setpoint value. The electric heating is the 
control process. The thermometer is the sensor. The temperature loss from opening the 
window is the disturbance variable. 

So this means that the person measures the process value (room temperature) with the 
sensor (thermometer), compares the process value (room temperature) with the command 
variable (desired room temperature) and uses the actuator (changeable resistance) to 
manually regulate the manipulated variable (heating current), in order to compensate for the 
disturbance variable (temperature drop from opening the window). The person is therefore 
the controller. 
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The control device consists of the actuator and the control. 

The control and controller together form the regulating device. 

The following picture gives an abstract portrayal of the situation described above. 

The comparing element uses the sensor to compare the command variable with the process 
value. If the command variables and process value deviate from one another, this results in a 
positive or negative loop error that in turn changes the process value. 

 



 Reference material 
 5.3 Special functions 

WindLGC Online Help 

Programming and Operating Manual, 11/2024 343 

Control loop 
The process value x influences the manipulated variable M by means of the regulating device. 
This creates a closed circuit that is also known as a control loop. 

If, in the example above, the window is opened, the temperature in the room drops. The 
person must increase the heat output of the heater. If the heat output increases too much, it 
gets too hot. The person must then reduce the heat output. 

If the heat output increases or reduces too quickly, then the control loop starts to oscillate. 
The room temperature fluctuates. It is either too hot or too cold. To prevent this, the person 
must carefully and slowly reduce or increase the heat output. 

Loop error 
The loop error is the difference between the command variable and the process value. In 
other words: the deviation of a process value from a set value. 

e = SP – PV 

The loop error e brings about a change to the manipulated variable M. 

The example above illustrates this very well: if, with a desired temperature of 20 °C (= 
command value w), the room temperature is 22 °C (= process value PV), this results in the 
loop error: 

e = SP – PV = 20 °C - 22 °C = -2 °C 

In this case, the negative sign indicates a reversing action: the heat output reduces. 

In a control loopstate of equilibrium, the loop error is zero or very small. If the command 
variable changes or there is a disturbance, a loop error arises. The manipulated variable M 
corrects the loop error. 

Controller basics (Page 343)  

Description of the individual parameters (Page 346)  

PI controller (Page 347)  

Analog ramp (Page 351)  

5.3.5.2 Controller basics 
A controller can be simply portrayed as follows:  

 
The comparing element and the controller function describe the conduct of the controller. 
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The following describes the most important types of controller. A controllerstep response 
tells us a lot about its conduct. The step response describes how a controller reacts to the 
erratic change in the process value. 

The three basic types of controllers are as follows: 

• Proportional-action controller (P controller) 

• Integral-action controller (I controller) 

• Differential-action controller (D controller – not described here) 

Controllers can combine the three types. For example, a PI controller is a proportional/integral 
controller. 

P Controller 
A proportional-action controller (P controller) changes the manipulated variable M 
proportional to the loop error. The P controller works immediately. By it cannot drive the loop 
error to zero. 

MPn = kP × en 

MPn: Manipulated variable of the P controller at the time n 

kP: Gain of the P controller 

en: Loop error at the time n 

The following picture shows a jump in process value and step response of the controller:  

 
Summary 

The P controller has the following characteristics: 

• It cannot correct faults with the control process > lasting loop error. 

• It reacts immediately to a change in the process value. 

• It is stable. 

I Controller 
An integral-action controller (I controller) changes the manipulated variable M proportional 
to the loop error and to the time. The I controller works by delayed action. It completely 
remedies a loop error. 

In order to calculate the value of the manipulated variable at a period of time n, the time up 
until this period of time must be divided into small time slices. The loop errors at the end of 
each time slice must be added up (integrated) and they are then entered in the calculation. 
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MIn = kI × (TS / TI) × (en + en-1 + en-2 + en-3 + … + e0) = kI × (TS / TI) × en + MIn-1 

MIn: Manipulated variable of the I controller at the time n 

MIn-1: Manipulated variable of the I controller at the time n-1; also called integral sum 

kI: Gain of the I controller 

TS: Sampling time, duration of a time slice 

TI: Integral time: by means of this time, the influence of the integral part is controlled on the 
manipulated variable, also known as integral-action time 

en: Loop error at the time n 

en-1: Loop error at the time n-1; etc. 

e0: Loop error at the beginning of the calculations 

The following picture shows a jump in process value and step response of the controller:  

 
Summary 

The I controller has the following characteristics: 

• It sets the process value exactly to the command variable. 

• By so doing, it tends to oscillate and is unstable. 

• It requires more time to carry out the control action than the P controller . 

PI controller 
A PI controller reduces the loop error immediately and will eventually drive the loop error to 
zero. 

Mn = MPn + MIn = kP × en + kI × (TS / TI) × en + MIn-1 

Mn: Manipulated variable at the time n 

MPn: Proportional part of the manipulated variable  

MIn: Integral part of the manipulated variable  

MIn-1: Manipulated variable of the I controller at the time n-1; also called integral sum 

kP: Gain of the P controller 

kI: Gain of the I controller 

TS: Sampling time, duration of a time slice 

TI: Integral time; by means of this time the influence of the integral part is controlled on the 
manipulated variable, also known as the integral-action time 
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en: Loop error at the time n 

The following picture shows a jump in process value and step response of the controller:  

 
Summary 

The PI controller has the following characteristics: 

• The P controller components quickly intercept an occurring loop error. 

• The I controller components can then remedy the remaining loop error. 

• The controller components supplement each other so that the PI controller works quickly 
and precisely. 

5.3.5.3 Description of the individual parameters 
 

Controller parame-
ters 

Portrayed in IDEC SmartRelay Possible value 
range in the 

IDEC SmartRelay 
Mn 
Manipulated variable 
at the time n 

Output of the PI controller block 0 to 1000 

kP 
Gain of the P part 
kI 
Gain of the I part 
 

In the IDEC SmartRelay, the parameter KC applies as an 
increase for the I part and the P part of the controller equal-
ly 
Should you enter KC=0, then the P part of the controller 
switches off. In this special case, k is automatically set to 1 
for the I part. 
If KC = 0: kP = 0 and kI = 1 
If KC ≠ 0: kP = kI = KC 

0.00 to 99.99 

TS 
Sampling time, dura-
tion of a time slice 

Fixed 500 ms 

TI  
Integral time 

Parameter TI: if you set this parameter to 99.59 min, then 
you switch off the I part of the controller. 

00:01 min to 
99.59 min 

en 
Loop error at the 
time n; generally 
applies: 
E = SP - PV 

Refer to SP and PV " 

SP The parameter SP is the set-value assignment w. For this 
parameter you can use the analog output of a different 
special function. 

-10000 to 
+20000 



 Reference material 
 5.3 Special functions 

WindLGC Online Help 

Programming and Operating Manual, 11/2024 347 

Controller parame-
ters 

Portrayed in IDEC SmartRelay Possible value 
range in the 

IDEC SmartRelay 
PV PV is the process value x and is calculated as follows:  

PV = analog value on input * gain) + offset. 
You can connect the input for example by means of an 
analog input with a PT100 sensor. 

" 

 The gain parameter has an effect on PV 0.0 to 10.0 
 The offset parameter has an effect on PV -10000 to 

+20000 
 PV is restricted by the parameters Min. and Max. In each case: 

10000 to +20000 
 The Dir parameter gives the action direction of the control-

ler. 
Positive means: If set value > process value then the pro-
cess value is increased; if set value < process value then the 
process value is reduced. 
Negative means: If set value > process value then the pro-
cess value is reduced; if set value < process value then the 
process value is increased. 
Example, heat regulation: if the set value is greater than 
the process value (room is too cold), the manipulated vari-
able increases the process value. 

- or + 

 

Refer to the PI controllers - description of special function for more details (for example, 
switching from manual to automatic mode, parameter sets, etc.).  

5.3.5.4 PI controller 

 

Short description 
A PI controller is a proportional-action and integral-action controller. You can use both 
proportional action and integral action individually or combined.  
 
Connection Description 
Input A/M Set the mode of the controller: 

1: automatic mode 
0: manual mode 

Input R Use the input R to reset the output AQ. As long as this input is set, the input A/M 
is disabled. The output AQ is set to 0. 

Input PV Analog value: process value, influences the output 
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Connection Description 
Parameter Sensor: Type of sensor being used 

Min.: Minimum value for PV  
Value range: -10,000 to +20,000 
Max.: Maximum value for PV  
Value range: -10,000 to +20,000 
Gain 
Value range: -10.00 to +10.00 
Offset 
Value range: -10,000 to +10,000 
SP: Set-value assignment 
Value range: -10,000 to +20,000 
Mq: Value from AQ with manual mode. 
Value range: 0 to 1,000 
Parameter sets: application-related presets for KC, TI and Dir (see below) 
KC: Gain 
Value range: 00.00 to 99.99 
TI: Integral time 
Value range 00:01 min to 99:59 min 
Dir: Action direction of the controller 
Possible settings: + or - 
p: Number of decimal places 
Possible settings: 0, 1, 2, 3 

Output AQ Analog output (manipulated variable) 
Value range for AQ: 0 to 1,000 

Parameters SP and Mq 
The actual value of another already-programmed function can provide the set-value SP and 
the value for Mq:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Analog math: AQ 

• Up/Down counter: Cnt 

For FL1F and late version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 
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• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 

• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Parameter P (number of decimal places) 
Parameter p only applies for displaying the values from PV, SP, Min. and Max. in a message 
text. 

Timing diagram 
The nature, manner and speed with which the AQ changes depends on the parameters KC 
and TI. Thus, the course of AQ in the diagram is merely an example. A control action is 
continuous; therefore the diagram portrays just an extract. 
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① A disturbance causes the PV to drop, as Dir is positioned upwards, AQ increases until PV corre-
sponds again to SP. 

② A disturbance causes the PV to drop, as Dir is positioned downwards, AQ decreases until PV 
corresponds again to SP.  
Dir is coordinated to the basic conduct of a control loop. The direction (dir) cannot be changed 
during the term of the function. The change in Dir here is shown for the purposes of clarifica-
tion. 

③ As the input R sets AQ to 0, PV changes. This is based on the fact that PV increases, which on 
account of Dir = upwards causes AQ to drop. 

PI controller trend view in simulation or online test 
When you view the circuit program in an online test (Page 40) or in a simulation (Page 34), 
WindLGC displays a trend view of the PI controller showing input PV, output AQ and the 
parameter SP. The trend view shows the change in AQ and PV over time, in reference to the 
SP. The time sampling period is configurable, allowing you to see frequent samples over a 
short amount of time, or less-frequent samples over a longer period of time. 

Description of function 
If the input A/M is 0, then the special function issues output AQ with the value that you set 
with parameter Mq. 

If the input A/M is 1, then automatic mode commences. As the adopted value Mq is an 
integral sum, the controller function begins the calculations in accordance with the formulas 
given in Control and regulate basics (Page 340). Use the updated value PV in the formulas: 

Updated value PV = (PV * gain) + offset 

If the updated value PV = SP, then the special function does not change the value of AQ. 

Dir = upwards/+ (timing diagram numbers 1 and 3) 

• If the updated value PV > SP, then the special function reduces the value of AQ. 

• If the updated value PV < SP, then the special function increases the value of AQ. 

Dir = downwards/- (timing diagram number 2) 

• If the updated value PV > SP, then the special function increases the value of AQ. 

• If the updated value PV < SP, then the special function reduces the value of AQ. 

With a disturbance, AQ increases or decreases until the updated value PV again corresponds 
to SP. The speed with which AQ changes depends on the parameters KC and TI. 

If the input PV exceeds the parameter Max., then the updated value PV is set to the value of 
Max. If the PV falls short of the parameter Min., then the updated value PV is set to the value 
of Min. 

If the input R is 1, then the AQ output is reset. As long as R is set, the input A/M is disabled. 

Sampling time 
The sampling time fixs at 500 ms. 



 Reference material 
 5.3 Special functions 

WindLGC Online Help 

Programming and Operating Manual, 11/2024 351 

Parameter sets 
In order to simplify the use of the PI controller, the parameters for KC, TI and Dir are already 
given as sets for the following applications: 
 

Parameter set Application example Parameter 
KC 

Parameter 
TI (s) 

Parameter 
Dir 

Temperature 
fast 

Temperature, cooling control of small 
spaces; small volumes 

0.5 30 + 

Temperature 
slow 

Heating, ventilation, temperature, cool-
ing control of large spaces; large vol-
umes 

1.0 120 + 

Pressure 1 Quick pressure change, compressor 
control 

3.0 5 + 

Pressure 2 Slow pressure change, differential pres-
sure control (flow controller) 

1.2 12 + 

Full level 1 Vat and/or reservoir filling without drain 1.0 99:59 + 
Full level 2 Vat and/or reservoir filling with drain 0.7 20 + 

Characteristics when configuring 
Observe the control and regulate basics (Page 340). 

5.3.5.5 Analog ramp 

 

Short Description 
The Analog Ramp instruction allows the output to be changed from the current level to the 
selected level at a specified rate.  
 
Connection Description 
Input En A change in the status from 0 to 1 at input En (Enable) applies the start/stop level 

(Offset "B" + StSp) to the output for 100 ms and starts the ramp operation to the 
selected level. 
A change in the status from 1 to 0 immediately sets the current level to Offset "B", 
which makes output AQ equal to 0. 

Input Sel SeI = 0: The step 1 (level 1) is selected. 
SeI = 1: The step 2 (level 2) is selected. 
A change in status of Sel causes the current level to start changing to the selected 
level at the specified rate. 

Input St A change in the status from 0 to 1 at input St (Decelerated Stop) causes the cur-
rent level to decrease at a constant rate until the start/stop level (Offset "B" + 
StSp) is reached. The start/stop level is maintained for 100 ms and then the cur-
rent level is set to Offset "B", which makes output AQ equal to 0. 
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Connection Description 
Parameter L1 and L2: Levels to be reached; value range for each level: -10000 to 20000 

MaxL: Maximum value that must not be exceeded. 
Value range: -10000 to 20000 
StSp: Start/Stop offset: value that is added to Offset "B" to create the start/stop 
level. If the Start/Stop offset is 0, then the start/stop level is Offset "B"). 
Value range: 0 to 20000 
Rate: Speed with which level 1, level 2 or offset is reached. Steps/seconds are 
issued. 
Value range: 1 to 10000 
Gain 
Value range: 0 to 10.00 
Offset 
Value range: -10000 to 10000 
p: Number of decimal places 
Possible settings: 0, 1, 2, 3 

Output AQ The output AQ is scaled using the formula: 
(Current Level - Offset "B") / Gain "A" 
Note: when AQ is displayed in parameter mode or message mode, it is displayed 
as an unscaled value (engineering units: current level). 
Value range for AQ: 0 to 32767 

Parameters Level1 and Level2  
The level parameters Level 1 and Level 2 can be provided by the actual value of another 
already-programmed function:  

• Analog comparator: Ax - Ay 

• Analog trigger : Ax 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog math: AQ 

• PI controller: AQ 

• Up/Down counter: Cnt 

For FL1F and later version devices, you can additionally use the actual values of the following 
already-programmed functions: 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Retentive on-delay: Ta 

• Interval time-delay relay/Pulse output: Ta 

• Edge-triggered interval time-delay relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairwell light switch: Ta 

• Dual-function switch: Ta 
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• Stopwatch: AQ 

• Analog filter: AQ 

• Average value: AQ 

• Max/Min: AQ 

• Frequency trigger: Fre 

You select the required function by the block number. 

Parameter p (number of decimal places) 
Parameter p only applies for displaying the values of AQ, level 1, level 2, MaxL, StSp, and Rate 
in a message text. 

Timing diagram for AQ 

 

Description of function 
If the input En is set, then the function sets the value StSp + Offset "B" for 100 ms. 

Then, depending on the connection of Sel, the function runs from the level StSp + Offset "B" 
to either level 1 or level 2 at the acceleration set in Rate. 

If the input St is set, the function runs to a level of StSp + B at the acceleration set in Rate. 
Then the function holds the level at StSp + Offset "B" for 100 ms. After 100 ms, the level is set 
to Offset "B". Output AQ. The scaled value (output AQ) is 0. 

If the input St is set, the function can only be restarted once the inputs St and En have been 
reset. 

If input Sel has been changed, depending on the connection of Sel, the function runs from 
the current target level to the new target level at the rate that is specified. 

If the input En is reset, the function immediately sets the current level to Offset "B". 

The current level is updated every 100 ms. Note the relationship between output AQ and the 
current level: 
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Output AQ = (current level – Offset "B" ) / Gain "A" 

Particular characteristics to be noted when configuring 
For help on analog block parameters, refer to the Analog value processing (Page 334) 
section. 

 

Special functions (Page 263)  

5.3.6 Miscellaneous 

5.3.6.1 Latching relay 

 

Short description 
A signal at input S sets output Q. A signal at input R resets output Q.   
 
Connection Description 
Input S Set output Q with a signal at input S (Set). 
Input R Reset output Q with a signal at input R (Reset). Output Q is reset if S and R are 

both set (reset has priority over set). 
Parameter Retentivity set (on) = the status is retentive in memory. 
Output Q Q is set with a signal at input S and remains set until it is reset with signal at 

input R. 

Timing diagram 

 

Description of the function 
The latching relay represents a simple binary memory logic. The output value depends on the 
input states and the previous status at the output. 

Logic table of the latching relay: 
 
S R Q Remark 
0 0 x Status unchanged 
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0 1 0 Reset 
1 0 1 Set 
1 1 0 Reset 

When retentivity is enabled, the output signal corresponds with the signal status prior to the 
power failure. 

 

Special functions (Page 263)  

5.3.6.2 Current impulse relay 

 

Short description 
The output is set and reset with a short one-shot at the input.  
 
Connection Description 
Input Trg You switch output Q on or off with a signal at input Trg (Trigger) input. 
Input S A one-shot at input S (Set) sets the output to logical 1. 
Input R A one-shot at input R (Reset) resets the output to logical 0 
Parameter Selection: 

RS (input R priority), or 
SR (input S priority) 
Retentivity set (on) = the status is retentive in memory. 

Output Q Q is switched on with a signal at Trg and is reset again at the next Trg pulse, if 
both S and R = 0. 

 

 

 

FL1A-FL1B: 
The special function does not have an S input and priority preselection. 
The following applies to output Q:  
Q is switched on with a signal at Trg and is switched off again with the next 
signal at Trg or R. 
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Timing diagram 

 

Description of the function 
The status of output Q changes with each 0 to 1 transition at input Trg and if both S and R = 
0, that is, the output is switched on or off. 

Input Trg does not influence the SFB when S = 1 or R = 1. 

A one-shot at input S sets the Current impulse relay, that is, the output is set to logical 1. 

A one-shot at input R resets the Current impulse relay to its initial state, that is, the output is 
set to logical 0. 

Either the input R takes priority over input S (the signal at input S has no effect as long as R = 
1), or the input S takes priority over input R (the signal at input R has no effect as long as S = 
1), depending on your configuration. 
 

 

FL1A-FL1B: 
The valid function is: 
The status at output Q is toggled with each 0 to 1 transition at input Trg, that 
is, the output is switched on or off. 
You reset the Current impulse relay to its initial state with a one-shot at input, 
that is, the output is reset to 0. 
The Current impulse relay is reset and output Q = 0 after power on or by a reset 
signal. 

Caution 
If Trg = 0 and Par = RS, the "Current impulse relay" SFB corresponds with the "Latching relay" 
SFB function. 

 

Special functions (Page 263)  

5.3.6.3 Message text (IDEC SmartRelay FL1F and later versions) 
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Short description 
This function displays message texts and parameters of other blocks on the IDEC 
SmartRelay onboard display or IDEC SmartRelay TDE when IDEC SmartRelay is in RUN mode. 
 
Connection Description 
Input En A 0 to 1 transition at En (Enable) triggers the output of the message text. 
Input P P is the priority of the message text. 

0 is the lowest, 127 the highest priority. 
Ack: Acknowledgement of the message text 

Parameter Text: Input of the message text 
Par: Parameter or actual value of another, already configured , which can be displayed 
numerically or as a bar graph (see "Visible parameters or actual values") 
Time: Shows the continuously updated time-of-day 
Date: Shows the continuously updated date 
EnTime: Display of the time of the 0 to 1 transition of the signal at input En 
EnDate: Display of the date of the 0 to 1 transition of the signal at input En 
I/O Status Names: Display of a digital input or output status name, for example "On" 
or "Off". IDEC SmartRelay FL1F devices can display the status names of following ele-
ments: 
• Digital inputs 
• Digital outputs 
• Flags 
• Cursor keys 
• IDEC SmartRelay TDE function keys 
• Shift register bits 
• Function block outputs 
Analog Input: Display of analog input value to the shown in message text and updat-
ed according to the analog time. 
Scale time: Display of the actual value of a referenced function block as a time value 
scaled based on the timebase configured for the message text function block. Possible 
time display formats are as shown below: 
• hours : minutes : seconds . milliseconds 
• hours : minutes : seconds 
• hours : minutes 
• hours 
(for example, "01: 20 : 15 .15") 
Symbol: Display of characters selected from the supported character sets 

Output Q Q remains set as long as the message text is queued. 
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Settings 
In addition to the function block inputs and the parameters of the message text, the 
following settings provide additional control over the display of message texts: 

• Character set selection: You can choose to compose a message text from characters 
from the primary character set or the secondary character set. You set the two character 
sets from either the "Msg Config" menu on the IDEC SmartRelay Base Module, or by using 
the WindLGC File → Message Text Settings (Page 51) menu command. 

• Message destination: You can choose to display the message text on the IDEC 
SmartRelay onboard display, the IDEC SmartRelay TDE, or both. If you select the Web 
server as a destination, you can display IDEC SmartRelay message texts through the Web 
server. 

• Ticker setting: The message text can tick or not tick, meaning it can scroll on and off the 
display. Two types of message ticking exist: 

– Character by character 

– Line by line 

You can configure each individual line of a message text to tick or not to tick at all. The 
"character by character" or "line by line" setting applies to all lines that you configure to 
tick. Select the check box beside a line number to enable ticking for that line. The number 
of lines depends on your selection on the File → Message Text Settings (Page 51) dialog. 
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Particular characteristics to be noted when configuring 

 
① Block name area 

Here you can provide a name for the block 
② Settings area 

Here you can configure the following settings:· 
• Priority of the message text 
• Acknowledge Message check box: if set requires a message to be acknowledged in order to 

be closed 
• Character set selection for the message text 

③ Block area 
Here is where you select blocks from all of the blocks in the circuit program. You can subse-
quently choose parameters from these blocks to display in the message text. 

④ Tick area 
Here you define the tick parameters for the message text: 
• Character by Character tick format 
• Line by Line tick format 
• Tick enabled checkbox for each display line 
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⑤ Message destination area 
Here you choose whether the target destination for the message is the IDEC Smar-
tRelay onboard display, the IDEC SmartRelay TDE, or both. If you select the Web server as a 
destination, you can display IDEC SmartRelay message texts through the Web server. 

⑥ Show message information in details 
Here you can choose to show the message texts in detail. By default, the message text only 
show the status of priority, acknowledge message, and character sets. By selecting this func-
tion, you can see the ticker setting, message text setting, and message texts in the diagram 
editor. 

⑦ Block parameters area 
Here you can select the parameters to be displayed in the message text from the block that is 
selected in the Blocks area. 

⑧ Insert Parameter button 
This button is for inserting a selected block parameter into the message text. 

⑨ Message area 
Here you arrange the message text. The information that you enter in this area corresponds to 
what is to be displayed on the IDEC SmartRelay onboard display or IDEC SmartRelay TDE. 
Above this area are additional buttons: 

 Delete button: for deleting entries from the message area 
 Special characters button: for inserting special characters into the message area 

 Bar Graph button: for placing a horizontal or vertical bar graph into the message area 
AI button: for placing an analog input value into the message area 

ON/OFF button: for specifying a digital value to be represented by one of two strings 
corresponding to the 0 state and 1 state, for example "OFF" and "ON". 

Symbol button: for opening the virtual keyboard panel. You can insert characters of 
current character set. 

 Scale time button: for referencing an actual value and showing it in a specified time base 
format. 

Edit manually button: for using the static editor to add, move, or delete message 
text elements without changing the position of any other elements. 
Note: For WindLGC V8.4 and later versions, copying and pasting parameters of message texts in 
the same circuit diagram are supported. 
Below this area is one additional button: 
Overwrite:  
• If you double click the Overwrite button, this button turns grey, you move the cursor over 

an existing parameter and enter a new parameter, the new parameter is inserted before the 
existing parameter in the message area. 

• If you don't double click the Overwrite button, move the cursor over an existing parameter 
and enter a new parameter, the existing parameter is replaced by the new parameter. 
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Scale time 
To configure the time scale for a function block, click button to display the "Scale time 
setting" dialog: 

 
With this dialog, you can configure the scale time base for a function block value. You select a 
function block, an actual value and a time base, and click "OK" to confirm your settings. 

The calculation for displaying a time value in a message text based on the configured time 
base is shown below, where "C" represents the actual value: 
 
Time base of 
message text 

Time format Calculation for time value 

Hour xx C 
Minute xx : xx C / 60 : C % 60 
Second xx : xx : xx (C / 60) / 60 : (C / 60) % 60 : C % 60 
10 milliseconds xx : xx : xx : xx C / 100 / 60 / 60 : ((C / 100 / 60) % 60 : (C / 100) % 60 : C % 100 
 /: Integer division 
%: Remainder of integer division 

To arrange the message text 
The IDEC SmartRelay FL1F and later version devices support six-line message text display. The 
message area shows a grid of six lines and character positions. 

If you choose the IDEC SmartRelay onboard display as the target destination for the message, 
the message text area is 32 characters wide for Western European character sets or 16 
characters wide for Asian character sets. If you choose the IDEC SmartRelay TDE as the target 
destination for the message, the message text area is 40 characters wide for Western 
European character sets or 20 characters wide for Asian character sets. Either way, the 
character width of each line is double that of the IDEC SmartRelay onboard display or IDEC 
SmartRelay TDE. If you choose both as the target destination, the message text area is still 32 
characters wide for Western European character sets or 16 characters wide for Asian 
character sets. In this case, there is a red vertical line in the message text area indicating the 
boundary of the IDEC SmartRelay TDE display. If you also select the Web server as a 
destination, the message text displays through the Web server in the same way as on the 
IDEC SmartRelay onboard display. 

Message lines that are longer than the width of the actual display can be set to "tick". In the 
message area, WindLGC indicates the region corresponding to the visible area of the IDEC 
SmartRelay onboard display or IDEC SmartRelay TD in green, and the region that can only be 
shown by using the message ticking feature in blue. 
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To configure the content of a message text, follow these steps: 

1. From the "Block" area, select the block whose parameters you want to output. 

2. Drag and drop the parameters required from the "Parameter" area to the "Message Text" 
area. You can also use the "Insert Parameter" button to insert a parameter value. 

3. In the "Message Text" area, you can add parameter data, time or date values from the block 
parameter area as required and enter text. To enter text, select the character set for the 
message text, and then type. You can also use the buttons above the message text area to 
add special characters, bar graphs, analog input values, and names for digital I/O states. 

New special characters 
There are five new special characters (     ) available for the message text display on 
IDEC SmartRelay FL1F devices or IDEC SmartRelay TDE. With these special characters, you can 
create large texts for message display. 

Example: 

 

Simulation mode 
Layout of message texts (Page 189) 

Message online test 
With the message online test function, you can view the same message texts as shown in the 
IDEC SmartRelay Base Module. 

You can start or stop messages online by clicking the  toggle button, and the messages are 
displayed as follows: 
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During a message online test, you cannot use WindLGC to edit message text parameters, 
change the character set, acknowledge a message text, or shift a message text. You can, 
however, use the "Go to block" button. 

Special Functions Overview (Page 263)  

See also 
Message text (IDEC SmartRelay FL1E) (Page 363) 

5.3.6.4 Message text (IDEC SmartRelay FL1E) 

 

Short description 
This function displays message texts and parameters of other blocks on the IDEC 
SmartRelay onboard display or IDEC SmartRelay TD when IDEC SmartRelay is in RUN mode. 
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The IDEC SmartRelay FL1E devices support many new message text features that IDEC 
SmartRelay FL1D devices and earlier did not support. Some of the new features are only for 
IDEC SmartRelay FL1E. You can choose, however, whether to use the message text function 
block with the new features of IDEC SmartRelay FL1D or earlier message text function blocks 
in your circuit program. This selection is on the File → Message Text Settings (Page 51) 
dialog, along with other global settings. You can also use the button "Enable new style 
message and setting" at the bottom of the message dialog to switch your message text 
function block to the one with the new features. You can not mix and match the message 
text function blocks with new features and IDEC SmartRelay FL1D and earlier message text 
function blocks in your circuit program.  
 
Connection Description 
Input En A 0 to 1 transition at En (Enable) triggers the output of the message text. 
Input P P is the priority of the message text. 

0 is the lowest, 127 the highest priority. 
Ack: Acknowledgement of the message text 

Parameter Text: Input of the message text 
Par: Parameter or actual value of another, already configured , which can be displayed 
numerically or as a bar graph (see "Visible parameters or actual values") 
Time: Shows the continuously updated time-of-day 
Date: Shows the continuously updated date 
EnTime: Display of the time of the 0 to 1 transition of the signal at input En 
EnDate: Display of the date of the 0 to 1 transition of the signal at input En 
I/O Status Names: Display of a digital input or output status name, for example "On" 
or "Off".  
Analog Input: Display of analog input value to the shown in message text and updat-
ed according to the analog time. 

Output Q Q remains set as long as the message text is queued. 

Settings 
In addition to the function block inputs and the parameters of the message text, the 
following settings provide additional control over the display of message texts: 

• Character set selection: You can choose to compose a message text from characters 
from the primary character set or the secondary character set. You set the two character 
sets from either the "Msg Config" menu on the IDEC SmartRelay Base Module, or by using 
the WindLGC File → Message Text Settings (Page 51) menu command. 

• Message destination: You can choose to display the message text on the IDEC 
SmartRelay onboard display, the IDEC SmartRelay TD, or both. 

• Tick settings: The message text can tick or not tick, meaning it can scroll on and off the 
display. The tick capabilities and your choices are described in more detail below. 

Description of the function 
With a 0 to 1 transition of the signal at input En, and with IDEC SmartRelay in run mode, the 
IDEC SmartRelay onboard display and/or IDEC SmartRelay TD displays your configured 
message text. 

When the "Acknowledgement message" checkbox is not selected, the message text is hidden 
with a 1 to 0 signal transition at input En. 
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When the "Acknowledgement message" checkbox is selected, then after input En is reset to 0, 
the message text is displayed until acknowledged by pressing the OK button. The message 
text cannot be acknowledged as long as input En is high. 

If several message text functions were triggered with En=1, the message with the highest 
priority (0 = lowest, 127 = highest) is displayed. This also implies that a new message text is 
only displayed if its priority is higher than that of previously enabled message texts. 

If the circuit program uses flag M27 (Page 245) , then whenever M27=0 (low) IDEC 
SmartRelay only displays message texts that are in the primary character set (Character Set 
1). If M27=1 (high), then IDEC SmartRelay only displays message texts that are in the 
secondary character set (Character Set 2). 

After a message text is disabled or acknowledged, the display automatically shows the 
previously active message text with the highest priority. 

You can change between the display in RUN mode and the message texts by means of the  
and  buttons. 

Particular characteristics to be noted when configuring 
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① Block name area 
Here you can provide a name for the block 

② Settings area 
Here you can configure the following settings:· 
• Priority of the message text 
• Acknowledge Message check box: if set requires a message to be acknowledged in order to be 

closed 
• Character set selection for the message text 

③ Block area 
Here is where you select blocks from all of the blocks in the circuit program. You can subsequently 
choose parameters from these blocks to display in the message text. 

④ Tick area 
Here you define the tick parameters for the message text: 
• Character by Character tick format 
• Line by Line tick format 
• Tick enabled checkbox for each display line 

⑤ Message destination area 
Here you choose whether the target destination for the message is the IDEC SmartRelay onboard 
display, the IDEC SmartRelay TD, or both.  

⑥ Block parameters area 
Here you can select the parameters to be displayed in the message text from the block that is se-
lected in the block area. 

⑦ Insert Parameter button 
This button is for inserting a selected block parameter into the message text. 

⑧ Message area 
Here you arrange the message text. The information that you enter in this area corresponds to 
what will be displayed on the IDEC SmartRelay onboard display or IDEC SmartRelay TD. 
Above this area are additional buttons: 

 Delete button: for deleting entries from the message area 
 Special characters button: for inserting special characters into the message area 

 Bar Graph button: for placing a horizontal or vertical bar graph into the message area 
AI button: for placing an analog input value into the message area 

ON/OFF button: for specifying a digital value to be represented by one of two strings cor-
responding to the 0 state and 1 state, for example "OFF" and "ON". 

Edit manually button: for using the static editor to add, move, or delete message text 
elements without changing the position of any other elements. 

Symbol button: for opening the virtual keyboard panel. You can insert characters of current 
character set. 
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To arrange the message text 
The message area shows a grid of four lines and character positions. The message text 
configuration area is 24 characters wide for Western European character sets or 16 characters 
wide for Asian character sets. Either way, the character width of each line is double that of 
the IDEC SmartRelay onboard display or IDEC SmartRelay TD. Message lines that are longer 
than the width of the actual display can be set to "tick". In the message area, WindLGC 
indicates the region corresponding to the visible area of the IDEC SmartRelay onboard display 
or IDEC SmartRelay TD in one color, and the region that can only be shown by using the 
message ticking feature in another color. 

To configure the content of a message text, follow these steps: 

1. From the "Block" area, select the block whose parameters you want to output. 

2. Drag and drop the parameters required from the "Parameter" area to the "Message Text" 
area. You can also use the "Insert Parameter" button to insert a parameter value. 

3. In the "Message Text" area, you can add parameter data, time or date values from the block 
parameter area as required and enter text. To enter text, select the character set for the 
message text, and then type. You can also use the buttons above the message text area to 
add special characters, bar graphs, analog input values, and names for digital I/O states. 

Message text character set 
IDEC SmartRelay FL1E and higher versions support five character sets for messages. Of these, 
you can select two for the display of message texts with the File → Message Text Settings 
(Page 51) menu command or from the "Msg Config" menu of IDEC SmartRelay. Of the fifty 
possible message texts that you can configure, you can select any number of them to be from 
the first language and any number from the second language. For example, you could 
configure fifty message text function blocks that have a single message text for Character Set 
1. Alternatively, you could configure twenty-five message text function blocks, each of which 
has two message texts: one for Character Set 1 and one for Character Set 2. Any combination 
is valid such that the total does not exceed fifty. 

The Message text dialog displays the character sets that are currently available for your 
message text, as configured in the message text settings. To use a character set, select the 
"Enabled" check box, and the button for the character set. Characters that you subsequently 
type will be from the character set that you enabled and selected. If you deselect the 
"Enabled" check box for a character set, WindLGC will prompt you for confirmation and then 
delete the message text, if it exists, that corresponds to that character set. 

The character set of a message text is independent of the language setting for the IDEC 
SmartRelay onboard display menus. They can be different.  

Chinese character set 
The IDEC SmartRelay Base Module and IDEC SmartRelay TD support the Chinese character set 
(GB-2312) for the People's Republic of China. The devices use Microsoft Windows encoding 
for this character set. The Windows encoding allows the devices to display the same 
characters as shown in the WindLGC message text editor when you are using a Chinese 
emulator or a Chinese version of Microsoft Windows. 
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The Chinese character set requires a Chinese version of Windows or a Chinese emulator to 
properly display Chinese characters in the WindLGC message text editor. You must start the 
Chinese emulator before you open the message text function block in WindLGC. 

Message ticker 
You can configure a message text to tick, or to not tick. Two types of message ticking exist: 

• Character by character 

• Line by line 

Messages that tick character by character scroll off the characters of the message line one 
character at a time to the left with the additional characters scrolling in one at a time from 
the right. The time interval for the tick is specified by the TickTime message text setting. 

Messages that tick line by line by line scroll one half of the message off the display to the left 
with the second half of the message scrolling in from the right. The time interval for the tick 
is ten times the TickTime parameter. The two halves of the message simply alternate on the 
IDEC SmartRelay onboard display or IDEC SmartRelay TD. 

The tick time is the interval of time by which a character or a line of text ticks off the screen. 
The tick time is a global message text parameter for all message texts. 

Example: Tick Message Character by Character 

The following illustration shows the configuration in WindLGC of a one-line, 24-character 
message text: 

 
If you set this message to tick "character by character" with a tick interval of 0.1 seconds, then 
the initial appearance of this message line on the IDEC SmartRelay onboard display or IDEC 
SmartRelay TD is as shown in this illustration: 

 
After 0.1 second, one character of the message line ticks. The message appears as follows on 
the IDEC SmartRelay onboard display or IDEC SmartRelay TD: 

 
After the next 0.1 second, another character of the message line ticks. The message appears 
as follows on the IDEC SmartRelay onboard display or IDEC SmartRelay TD: 

 
Example: Tick Message Line by Line 
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The following example uses the same message configuration as the previous example: 

 
If you set this message to tick "line by line" with a tick interval of 0.1 seconds, then the initial 
appearance of this message on the IDEC SmartRelay onboard display or IDEC SmartRelay TD is 
the left half of the message as shown in this illustration: 

 
After 1 second (10 x 0.1 second), the message ticks to show the right half of the message as 
shown in this illustration: 

 
The screen display alternates between the two message halves every second. 

You can configure each individual line of a message text to tick or not to tick at all. The 
"character by character" or "line by line" setting applies to all lines that you configure to tick. 
Select the check box beside a line number to enable ticking for that line.  

Bar graphs 
You can specify a bar graph representation for the actual value of any other function block in 
your circuit program. The bar graph can be horizontal or vertical on the IDEC 
SmartRelay onboard display or IDEC SmartRelay TD. You can configure up to four bar graphs 
per message text. 

Use the bar graph button  in the message text area to place a bar graph in the message 
text area. From the Bar Setting dialog you must provide the following information: 

• Block from your circuit program that the bar graph represents 

• Minimum and maximum value for the bar graph: IDEC SmartRelay will calculate the length 
or height of the bar graph by scaling the actual value between the minimum and 
maximum values. 

• Orientation of the bar graph: horizontal or vertical 

• Width or height of the bar graph, in character spaces 

Example: 

Consider a bar graph in a message text with the following characteristics: 

• Configured bar graph length: 4 character spaces 

• Orientation: Horizontal 

• Configured minimum value: 1000 
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• Configured maximum value: 2000 

• Actual value: 1750 

The resulting bar graph will be 3 character spaces long. 

Text representation of digital I/O states 
You can assign names such as "On" or "Off" to the two states of a digital input or output. With 
the IDEC SmartRelay FL1E series, you can display this name of a digital I/O state in a message 
text. The maximum number of characters for a state name is eight for Western language 
character sets; for Asian language character sets the number of characters is four. Use the 
ON/OFF button in the message text area to define names for the two states of a digital input 
or output to be used in the message text. 

Within a single message text, you can configure up to four digital I/O state name displays. 

Within one circuit program, a maximum of 20 I/O state names can be used in message text 
function blocks. 

Display of remaining timer time 
With the IDEC SmartRelay FL1E series, you can display the remaining time of a timer in a 
message text. Prior to this feature you could display the current elapsed time of a timer and 
the timer parameters.  

When placed in a message text, the remaining time will show the time that remains before 
the timer expires. For timers with multiple timer values (for example on-delay time, off-delay 
time), you can display the remaining time of each one in a message text. 

Display of analog inputs 
You can also select analog inputs to be displayed in a message text. Use the AI button in the 
message text area to select a specific AI to place in the message text area. 

If you have analog inputs in a message text, the global message text setting (Page 51) for the 
Analog input filter timer specified how often the message text is updated with current values. 
The refresh time choices are 100 ms, 200 ms, 400 ms, 800 ms, and 1000 ms. If you have 
more than one analog input in a message text, the refresh rate applies to them all. 

Static editor (Edit manually) 
WindLGC provides a static editor for message texts that can help when you need to reposition 
text elements. For example, it has a recycle bin area where you can temporarily move 
message text elements in order to rearrange the position of elements on the display area. 
You can move elements up, down, left, or right without changing the position of any other 
elements. 
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To use the static editor, click the "Edit manually" button above the message text area. You will 
also be prompted to edit manually if you try to place or move elements in the message area 
that have a position conflict with existing elements. 
 

 

FL1A-FL1B: 
Maximum number of message texts: 5 
Not supported: message ticker, bar graphs, analog inputs, I/O status names, 
and remaining timer time. 
FL1C-FL1D: 
Maximum number of message texts: 10 
Not supported: message ticker, bar graphs, analog inputs, I/O status names, 
and remaining timer time. 

Virtual keyboard 
You can access the virtual keyboard by clicking the  button above the message text 
menu. The virtual keyboard dialog is shown as follows: 

 
The virtual keyboard displays some of the characters of the current character set. When you 
select a character, you can view its corresponding character code in the "Character Code 
(hex)" field. To insert the selected character, click the "Insert" button. 

IDEC SmartRelay does not support all of the characters of all of the character sets. For SJIS 
character set, the supported code area is [0x21, 0x7E] && [0xA1, 0xDF], and for other 
character sets, the supported code area is [0x21, 0x7E] && [0xA1, 0xFF]. You can find the 
detailed descriptions of the supported characters and their character codes on the DVD for 
WindLGC. 
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Copying and pasting text characters 
Whenever you enter characters into the message text area or into the I/O status name text 
edit area, you can use the keyboard shortcuts for copy (Ctrl-c) and paste (Ctrl-v). You can 
copy and paste characters between any document on your computer, text in a message text, 
text in an I/O status name, or text in the IDEC SmartRelay TD Power-up screen (Page 87) text 
edit area. WindLGC verifies that any characters to be pasted are valid for the selected 
character set. Only character entry areas of text messages, I/O status names, and the IDEC 
SmartRelay TD Power-up screen support copy and paste. You cannot, for example, copy and 
paste bar graphs, function block parameters, or anything other than text characters of the 
selected character set.  

You cannot use Ctrl-x to cut characters for pasting, except from a document on your 
computer. WindLGC does not support the cut operation from the message text, I/O status 
name, or IDEC SmartRelay TD Power-up screen editing dialogs. 
 

 

WindLGC V8.0 keeps the text information when you copy and paste a Message text 
function block.  
If you paste a Message text function block to another circuit program with a differ-
ent character set, WindLGC keeps only the characters of the character set of the 
circuit program into which you are pasting. WindLGC displays a "?" in place of the 
unsupported characters. 

Message text after changing the character set 
WindLGC V8.0 keeps the text information when you change the character set.  

WindLGC keeps only the characters supported by the current character set, and displays a "?" 
in place of the unsupported characters. 

Restrictions 
The following restrictions apply to message text function blocks: 

• Up to 50 message text functions are available. 

• Up to 32 total bar graphs in message texts are available. 

• WindLGC supports all of the defined features for message texts. When programming 
directly on the IDEC SmartRelay device, you can only program a limited number of the 
message text features. See the IDEC SmartRelay User's Manual for a description of 
message text programming from the IDEC SmartRelay device. 

• Each message line can contain 24 characters (Western language character sets) or 16 
characters (Asian language character sets). Within a message text the following 
limitations apply: 

– Maximum number of parameters: 4 

– Maximum number of bar graphs: 4 

– Maximum number of I/O status names: 4 

– Maximum number of time/date values: 4 

– Maximum number of analog inputs: 2 
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Particular characteristics to be noted when configuring 
The message text can be configured in the block properties dialog. You can enter up to four 
lines for each message text (the text display of the IDEC SmartRelay onboard display and IDEC 
SmartRelay TD has four rows) and set the priority. You can move to the next line using the 
cursor keys or the mouse. Hit the [ENTER] key to confirm all your entries in the block 
properties dialog and to close the dialog. 

You can also specify the actual values of other blocks in the text lines. To do so, select the 
relevant block from the Block dialog. A Parameter dialog opens to display a list of all 
parameters available for the selected block. The block parameter you select in this dialog is 
written to the selected text line. The actual parameter value is now included when you call 
the message text. 

Set the "Acknowledge message" attribute to specify whether a message is be acknowledged 
before it is closed. 

Simulation mode 
Layout of message texts (Page 189)  

See also 
Special functions (Page 263) 

Message text (IDEC SmartRelay FL1C and IDEC SmartRelay FL1D) (Page 373) 

5.3.6.5 Message text (IDEC SmartRelay FL1C and IDEC SmartRelay FL1D) 

 

Short description 
This function displays message texts and parameters of other blocks on the IDEC 
SmartRelay onboard display when IDEC SmartRelay is in RUN mode.  
 
Connection Description 
Input En A 0 to 1 transition at En (Enable) triggers the output of the message text. 
Input P P is the priority of the message text. 

0 is the lowest, 30 the highest priority 
Ack: Acknowledgement of the message text 

Parameter Text: Input of the message text 
Par: Parameter or actual value of another, already configured function (see "Visi-
ble parameters or actual values") 
Time: Shows the continuously updated time-of-day 
Date: Shows the continuously updated date 
EnTime: Shows the time of the 0 to 1 transition 
EnDate: Shows the 0 to 1 transition of the date 

Output Q Q remains set as long as the message text is queued. 
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Description of the function 
With a 0 to 1 transition of the signal at input En, the display outputs your configured message 
text (actual value, text, TOD, date) in RUN mode. 

Acknowledgement disabled (Ack = Off): 

The message text is hidden with a 0 to 1 signal transition at input En. 

Acknowledgement enabled (Ack = On): 

After input En is reset to 0, the message text is displayed until acknowledged by pressing the 
OK button. The message text cannot be acknowledged as long as input En is high. 

If several message text functions were triggered with En=1, the message with the highest 
priority (0 = lowest, 30 = highest) is displayed. This also implies that a new message text is 
only displayed if its priority is higher than that of previously enabled message texts. 

After a message text is disabled or acknowledged, the function automatically shows the 
previously active message text that takes the highest priority. 

You can change between the display in RUN mode and the message texts by means of the  
and  buttons.  

Restrictions 
Up to ten message text functions are available. 
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Particular characteristics to be noted when configuring 

 
① Block name area 

Here you can provide a name for the block. 
② Setting area 

Here you will find the following settings: 
• Priority of the message text 
• Check box for message text acknowledgment 

③ Block area 
Here is where you select blocks from all of the blocks in the circuit program. You can subse-
quently choose parameters from these blocks to display in the message text. 

④ Delete button 
Button for deleting entries from the message area 
Special characters button 
Button for inserting special characters in the message area 
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⑤ Message area 
You arrange the message text in this area. Information entered in this area corresponds with 
that on the IDEC SmartRelay onboard display. 

⑥ Insert button 
Button for inserting a selected block parameter into the message text. 

⑦ Block parameter area 
Shows the parameters of a block selected from the block area which you can output in the 
message text. 

⑧ General parameter area 
Shows general parameters such as the current date. 

To arrange the message text 
1. From the "Block" area, select the block whose parameters you want to output. 

2. Drag and drop the parameters required from the block parameters to the messages area. 
You may also use the "Insert" button to do so. 

3. In the messages area, you can add parameter data as required. 

Simulation mode 
Layout of message texts (Page 189)  

Special functions (Page 263)  

5.3.6.6 Message text (IDEC SmartRelay FL1A and IDEC SmartRelay FL1B) 

 

Short description 
Display of a configured message text in RUN mode. 
 
Connection Description 
Input En The message text is output with a 0 to 1 transition at input En (Enable). 
Parameter P P is the priority of the message text. 

0 is the lowest, 9 the highest priority. 
Parameter Par: Parameter or actual value of another, already programmed function 

(see "Displayable parameters or actual values") 
Output Q Q remains set as long as the message text is queued. 
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Description of the function 
In RUN mode, a 0 to 1 transition of the signal at input En triggers the output of your 
configured message text on the display. The message text is closed after a 1 to 0 transition at 
input En and if the acknowledgment attribute is not set. If the acknowledgment attribute is 
set, the message text is not closed until input En=0 and the message is acknowledged at the 
IDEC SmartRelay with OK. The status at output Q remains 1 as long as the message text is 
displayed. 

Of several message text functions triggered with En=1, the one with the highest priority is 
displayed. Low-priority messages can also by displayed by pressing the  button on the IDEC 
SmartRelay. 

You can switch between the standard display and the message text display by means of the 
IDEC SmartRelay buttons  and . 

Restrictions 
Up to five message text functions are available. 

Particular characteristics to be noted when configuring 
The message text can be configured in the block properties dialog. You can enter up to four 
lines for each message text (the text display of the IDEC SmartRelay has four rows) and set 
the priority. You can move to the next line using the cursor keys or the mouse. Hit the 
[ENTER] key to confirm all your entries in the block properties dialog and to close the dialog. 

You may also enter the actual values of other blocks in the text lines. To do so, select the 
relevant block from the Block dialog. A Parameter dialog opens to display a list of all 
parameters available for the selected block. The block parameter you select in this dialog is 
written to the selected text line. The actual parameter value is now included when you call 
the message text. 

Set the "Acknowledge message" attribute to specify whether a message is be acknowledged 
before it is closed. 

Simulation mode 
Layout of message texts (Page 189)  

Special functions (Page 263)  

5.3.6.7 Softkey 
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Short description 
This SFB provides the action of a mechanical pushbutton or switch.  
 
Connection Description 
Input En Output Q is set with a 0 to 1 signal transition at input En (Enable) and if in addi-

tion, 'Status=On' has been confirmed in configuration mode. 
Parameter Switch: Sets either a momentary pushbutton action for one cycle (On) or a 

switching action of the function (Off). 
Status: On or Off state that is applied in the initial cycle after program startup. 

Output Q Output Q remains set 1, as long as En=1 and the status at the parameter Type = 
Switch and Status = On. 
Output Q is set for the duration of one cycle if EN=1. Switch = On (momentary 
pushbutton) and Status = On. 

Factory state 
The default of the Switch parameter is switching action. 

Timing diagram 

 

Description of the function 
The output is set when input En is set and the 'Status' parameter is set to 'On' and confirmed 
with OK. This action is performed irrespective of a configured switch or pushbutton function. 

The output is reset to '0' in the following three cases: 

• With a 1 to 0 signal transition at input En 

• When a pushbutton function is configured and one cycle has expired after its actuation 

• When the 'Status' parameter sets the 'Off' status in configuration mode, and this has been 
confirmed with OK 

Particular characteristics to be noted when configuring 
The softkey can be used both with momentary pushbutton or switching action. At the status 
parameter you can define the on (actuated) or off state for the switch/pushbutton. 

If the softkey is assigned a pushbutton action, the output is always set for the duration of one 
cycle with a 0 to 1 transition at input En when the pushbutton is in on state, or if the 
pushbutton state changes from Off to On when En=1. 

 

Special functions (Page 263)  
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5.3.6.8 Shift register (FL1F FS5 and later versions only) 

 

Short description 
The shift register function reads an input value and shifts the bits. The output value 
corresponds with the configured shift register bit. The shift direction can be changed at a 
special input. 

For FL1F FS5 devices, you can use a maximum of four shift registers with eight bits for each 
shift register in one circuit program. 
 
Connection Description 
Input In The function when started reads this input value. 
Input Trg The SFB is started with a positive edge (0 to 1 transition) at input Trg (Trigger). A 1 to 

0 transition is irrelevant. 
Input Dir You define the shift direction of the shift register bits Sx.1 to Sx.8 at the Dir input: 

Dir = 0: shift up (Sx.1 >> Sx.8) 
Dir = 1: shift down (Sx.8 >> Sx.1) 
NOTE: 
"x" refers to the index of the shift register. 

Input R The SFB is reset with a positive edge (0 to 1 transition) at input R (Reset). When the 
SFB is reset, all the shift register bit (Sx.1 to Sx.8) and the output at Q are set to 0. 

Parameter Shift register index: the index of shift register in the circuit program. 
Possible settings: 1 to 4 
Shift register bit that determines the value of output Q. 
Possible settings: 1 to 8 
Retentivity set (on) = the status is retentive in memory. 

Output Q The output value corresponds with the configured shift register bit. 
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Parameter 
FL1F FS5 devices provide four shift registers, with eight bits for each shift register. The shift 
register index corresponds to one of the four shift registers in the circuit program. The shift 
register bits are numbered in Sx.y, in which x is the index, and y is the bit number. 

 

Timing diagram 
If the shift register index is 1, the shift register bits will be S1.1 to S1.8. 

 

Description of the function 
The function reads the value of input In with a positive edge (0 to 1 transition) at input Trg 
(Trigger). 
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This value is written to shift register bits (Page 245) Sx.1 to Sx.8, depending on the set shift 
direction: 

• Dir = 0 (Shift up): Sx.1 accepts the value of input In, the previous value of Sx.1 is shifted to 
Sx.2, Sx.2 to Sx.3 ... Sx.7 to Sx.8 

• Dir = 1 (Shift down): Sx.8 accepts the value of input In; the previous value of S1.8 is 
shifted to Sx.7, Sx.7 to Sx.6 ... Sx.2 to Sx.1. 

 A positive edge (0 to 1 transition) at input R (Reset) reset the shift register. All the shift 
register bit (Sx.1 to Sx.8) and the output at Q are set to 0. 

Q outputs the value of the configured shift register bits. 

If retentivity is not enabled, the shift function restarts at Sx.1 or Sx.8 after a power failure. 

Special functions (Page 263)  

5.3.6.9 Shift register (FL1F) 

 

Short description 
The shift register function reads an input value and shifts the bits. The output value 
corresponds with the configured shift register bit. The shift direction can be changed at a 
special input. 

For IDEC SmartRelay FL1E, you can use only one shift register in one circuit program, but for 
IDEC SmartRelay FL1F devices, you can use a maximum of four shift registers with eight bits 
for each shift register in one circuit program. 
 
Connection Description 
Input In The function when started reads this input value. 
Input Trg The SFB is started with a positive edge (0 to 1 transition) at input Trg (Trigger). A 1 to 

0 transition is irrelevant. 
Input Dir You define the shift direction of the shift register bits Sx.1 to Sx.8 at the Dir input: 

Dir = 0: shift up (Sx.1 >> Sx.8) 
Dir = 1: shift down (Sx.8 >> Sx.1) 
NOTE: 
"x" refers to the index of the shift register. 

Parameter Shift register index: the index of shift register in the circuit program. 
Possible settings: 1 to 4 
Shift register bit that determines the value of output Q. 
Possible settings: 1 to 8 
Retentivity set (on) = the status is retentive in memory. 

Output Q The output value corresponds with the configured shift register bit. 
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Parameter 
IDEC SmartRelay FL1F devices provide four shift registers, with eight bits for each shift 
register. The shift register index corresponds to one of the four shift registers in the circuit 
program. The shift register bits are numbered in Sx.y, in which x is the index, and y is the bit 
number. 

 

Timing diagram 
If the shift register index is 1, the shift register bits will be S1.1 to S1.8. 

 

Description of the function 
The function reads the value of input In with a positive edge (0 to 1 transition) at input Trg 
(Trigger). 
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This value is written to shift register bits (Page 245) Sx.1 to Sx.8, depending on the set shift 
direction: 

• Dir = 0 (Shift up): Sx.1 accepts the value of input In, the previous value of Sx.1 is shifted to 
Sx.2, Sx.2 to Sx.3 ... Sx.7 to Sx.8 

• Dir = 1 (Shift down): Sx.8 accepts the value of input In; the previous value of S1.8 is 
shifted to Sx.7, Sx.7 to Sx.6 ... Sx.2 to Sx.1. 

Q outputs the value of the configured shift register bits. 

If retentivity is not enabled, the shift function restarts at Sx.1 or Sx.8 after a power failure. 

Special functions (Page 263)  

5.3.6.10 Shift register (FL1C to FL1E) 

 

Short description 
The shift register function reads an input value and shifts the bits. The output value 
corresponds with the configured shift register bit. The shift direction can be changed at a 
special input. For device series FL1C to FL1E, you can use only one shift register in one circuit 
program. 
 
Connection Description 
Input In The function when started reads this input value. 
Input Trg The SFB is started with a positive edge (0 to 1 transition) at input Trg (Trigger). A 

1 to 0 transition is irrelevant. 
Input Dir You define the shift direction of the shift register bits S1...S8 at the Dir input: 

Dir = 0: shift up (S1 >> S8) 
Dir = 1: shift down (S8 >> S1) 

Parameter Shift register bit that determines the value of output Q. 
Possible settings: S1 to S8 
Retentivity set (on) = the status is retentive in memory. 

Output Q The output value corresponds with the configured shift register bit. 
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Timing diagram 

 

Description of the function 
The function reads the value of input In with a positive edge (0 to 1 transition) at input Trg 
(Trigger).  

This value is written to shift register bits (Page 245) S1 or S8, depending on the set shift 
direction: 

• Shift up: S1 accepts the value of input In; the previous value of S1 is shifted to S2, S2 is 
shifted to S3, etc. 

• Shift down: S8 accepts the value of input In; the previous value of S8 is shifted to S7, S7 is 
shifted to S6, etc. 

Q outputs the value of the configured shift register bits. 

If retentivity is not enabled, the shift function restarts at S1 or S8 after a power failure. 

Special functions (Page 263)  

5.3.6.11 Analog math error detection 

 

Short description 
The analog math error detection block sets an output if an error has occurred in the 
referenced analog math function block.  
 
Connection Description 
Input En Enable the analog math error detection function block. 
Input R Reset the output. 
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Connection Description 
Parameter Referenced FB: block number of analog math. 

Error to detect: Zero division, Overflow, or Zero division OR Overflow. 
Auto Reset: Reset the output when the failure condition clears. 

Output Q Q is set high if the error to detect occurred in the last execution of the referenced 
analog math function block. 

 

 

 

FL1A - FL1D: 
The analog math error detection function block did not exist prior to FL1E. 

Parameter Referenced FB 
The value for the Referenced FB parameter references the block number of an already-
programmed analog math function block.  

Description of the function 
The analog math error detection block sets the output when the referenced analog math 
function block has an error. You can program the function to set the output on a zero division 
error, an overflow error, or when either type of error occurs. 

If you select the "Automatically reset" check box, the output is reset prior to the next 
execution of the function block. If not, the output retains its state until the analog math error 
detection block is reset with the R parameter. 

In any scan cycle, if the referenced analog math function block executes before the analog 
math error detection function block, the error is detected in the same scan cycle. If the 
referenced analog math function block executes after the analog math error detection 
function block, the error is detected in the next scan cycle. 

Analog math error detection logic table 
In the table below, Error to Detect represents the parameter of the analog math error 
detection instruction that selects which type of error to detect. Zero represents the zero 
division bit set by the analog math at the end of its execution: 1 if the error occurred, 0 if not. 
OF represents the overflow bit set by the analog math: 1 if the error occurred, 0 if not. Zero 
division OR Overflow represents the logical OR of the zero division bit and the overflow bit of 
the referenced analog math. Output (Q) represents the output of the analog math error 
detection function. An "x" indicates that the bit can be either 0 or 1 with no influence on the 
output. 
 
Error to Detect Zero  OF Output (Q) 
Zero division 1 x 1 
Zero division 0 x 0 
Overflow x 1 1 
Overflow x 0 0 
Zero division 
OR Overflow 

1 0 1 
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Error to Detect Zero  OF Output (Q) 
Zero division 
OR Overflow 

0 1 1 

Zero division 
OR Overflow 

1 1 1 

Zero division 
OR Overflow 

0 0 0 

If the referenced analog math function block is null, then the output is always 0. 

Special functions (Page 263)  

See also 
Analog math (Page 324) 

5.3.6.12 Float/Integer converter (FL1F FS5 and later versions only) 

 

Short description 
This function convert a float stored in VM to an integer and output the result via the 
parameter (eAQ) or AQ. 
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IDEC SmartRelay only deals with integers. If you transfer some float from outer system by 
network with FL1F/Modbus protocol, IDEC SmartRelay cannot deal with it directly. With float 
to integer converter, you can convert floating numbers stored in VM to integers. This SFB 
does the conversion by dividing the float by a resolution. You need to set a suitable resolution 
for the input float in the parameter tab. 
 
Connection Description 
Analog output AQ AQ is the analog output value. It has the following features. 

• Used as input value of the other function block. 
• Signed 16 bit value. 
• Range of values: -32768 to 32767. 

Extended analog 
output eAQ 

Extended analog output for programming via parameter reference. 
• Used as a reference parameter of the other function block. 
• Signed 32 bits value. 
• Range of values: -999,999,999 to 999,999,999. 

Parameter Par • Type: It specifies the type of input data. 
– Float: it is a 32 bits single-precision float number; 
– Double: it is a 64 bits double-precision float number. 

• VM: Variable Memory Address, starting address of float or double stored in 
VM. 

Range of values: 
– For Float: 0-847 
– For Double: 0-843 

• Resolution: it’s a divider for input data. 
• Range of values: 0.001 to 1000 

Parameter 
You can use the following parameters to control the float to integer converter: 
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Data Input: The input for this SFB is from VM. 

• Type: You can chose the input data as Float or Double. 

• VM Address: You can specify the start VM address where the input float stores. 

– Size: The input float occupies 4 bytes while double occupies 8 bytes. 

– Range: Float (0-847), Double (0-843). 

Resolution: You can set the multiplier for the input float. 

• Range: 0.001 to 1000 

• Precision: 1/1000 

Description of the function  
You usually need both the blocks Float/Integer converter and Integer/Float converter to 
complete a task. A typical way to use these function blocks is: 

1. Transfer the floats from outer system by network (with FL1F/Modbus protocol) and store 
them in VM. 

2. Convert the floats stored in VM to integer by Float/Integer converter. 

3. Process the integer with IDEC SmartRelay BM. 

4. Convert the result to floats by Integer/Float and store them in the VM. 

5. Transfer the floats to outer system (with FL1F/Modbus protocol). 

Calculation rule  
Define Q =Data Input/Resolution 

Analog output (AQ) 

• if -32768 ≤ Q ≤ 32767, the Analog output = Q. 

• if the Q ≥ 32767, then Analog output = 32767. 

• if the Q ≤ -32768, then Analog output = -32768. 

Extended analog output (eAq) 

• if -999,999,999 ≤ Q ≤ 999,999,999, the Extended analog output = Q. 

• if the Q ≥ 999,999,999, then Extended analog output = 999,999,999. 

• if the Q ≤ -999,999,999, then Extended analog output = -999,999,999. 

5.3.6.13 Integer/Float converter (FL1F FS5 and later versions only) 
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Short description 
This function converts integers to floats, and store them in VM. 

IDEC SmartRelay only deal with integers. If you transfer some float from outer system by 
network with FL1F/Modbus protocol, IDEC SmartRelay cannot deal with it directly. With this 
SFB, IDEC SmartRelay can output floating numbers. This SFB converts integers to floating 
numbers by multiplying a resolution into the floating number. You need to set a suitable 
resolution for the input integers in the parameter tab. 
 
Connection Description 
Analog input Ax Input Ax is one of the following analog signals:  

• AI1 to AI8 (*) 
• AM1 to AM64 
• NAI1 to NAI32 
• AQ1 to AQ8 
• NAQ1 to NAQ16 
• Block number of a function with analog output 

Extended analog 
input eAx 

If the analog input (Ax) is not available, you can assign a value to Extended ana-
log input (eAQ) by inputting a value to the eAx field or referring to other FB's 
parameter.  
Range of values: -999,999,999 to 999,999,999 

Parameter Par • Type: It specifies the type of output data. 
– Float: it is a 32 bits single-precision float number; 
– Double: it is a 64 bits double-precision float number. 

• VM: Variable Memory Address, starting address of float or double stored in 
VM: 
– For Float: 0 to 847 
– For Double: 0 to 843 

• Resolution: it’s a multiplier for input data. 
Range of values: 0.001 to 1000 

Output AQ AQ is the analog output value. It has the following features. 
• Used as input value of the other function block. 
• Signed 16 bit value. 
• Range of values: -32768 to 32767. 

Extended analog 
output 
eAQ 

Extended analog output for programming through parameter reference. 
• Used as a reference parameter of the other function block. 
• Signed 32 bits value. 
• Range of values: -999,999,999 to 999,999,999. 
 

* AI1 to AI8: 0 to 10 V corresponds with 0 to 1000 (internal value). 
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Parameter 
In addition to the function block inputs, the following settings provide additional control over 
the integer to float converter: 

 
Data Output: The output of Integer/Float is stored in VM. You can chose the output type as 
float or double and the start VM address where the converted float stores. 

• Type: You can chose the output data as Float or Double. 

• VM Address: You can specify the start VM address where the output float stores. 

– Size: The input float occupies 4 bytes while double occupies 8 bytes. 

– Range: Float (0 - 847), Double (0 - 843). 

Resolution: You can set the dividend for the input integer. 

• Range: 0.001 - 1000 

• Precision: 1/1000 

Extended Analog Input: You can also set the input value here. If you don't connect the input 
pin In, the SFB uses the value set here as its input. It can also be used as reference for other 
parameter value, such as counter value. 

• Range: -999,999,999 ~ 999,999,999 

Description of the function  
You usually need both the blocks Float/Integer converter and Integer/Float converter to 
complete a task. A typical way to use these function blocks is: 

1. Transfer the floats from outer system by network (with FL1F /Modbus protocol) and store 
them in VM. 

2. Convert the floats stored in VM to integer by Float/Integer converter. 
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3. Process the integer with IDEC SmartRelay BM. 

4. Convert the result to floats by Integer/Float and store them in the VM. 

5. Transfer the floats to outer system(with FL1F/Modbus protocol). 

Extended analog input eAX 
The eAX value can be provided by another already-programmed function: 

• Analog comparator: Ax - Ay 

• Analog amplifier: Ax 

• Analog multiplexer: AQ 

• Analog ramp: AQ 

• Mathematic instruction: AQ 

• PI controller: AQ 

• Up/down counter: Cnt 

• Analog value: AQ 

• Max/Min: AQ 

• On-delay: Ta 

• Off-delay: Ta 

• On-/off-delay: Ta 

• Wiping relay (pulse output): Ta 

• Edge-triggered wiping relay: Ta 

• Asynchronous pulse generator: Ta 

• Stairway lighting switch: Ta 

• Multiple function switch: Ta 

• Stopwatch: AQ 

• Threshold trigger: Fre 

• Integer/Float Converter: eAQ 

You select the required function by the block number. 

Calculation rule  

Float Value in VM address  

Float Value in VM address = Analog input x Resolution 
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Analog output (AQ) 

• Analog input connector is connected: Analog output = Analog input 

• Analog input connector isn’t connected: 

– if -32768 ≤ Extended analog input ≤ 32767, the Analog output = Extended analog 
input. 

– if the Analog input ≥ 32767, then Analog output = 32767. 

– if the Analog input ≤ -32768, then Analog output = -32768. 

Extended analog output (eAQ):  

• If the analog input connector is connected: Extended analog input = analog input. 

• Extended analog input connector isn’t connected: 

– if -999,999,999 ≤ Extended analog input ≤ 999,999,999, the Extended Analog Output 
= Extended analog input. 

– if the Extended analog input ≥ 999,999,999, then Extended analog output = 
999,999,999. 

– if the Extended analog input ≤ -999,999,999, then Extended analog output = -
999,999,999. 

5.3.6.14 Additional functions of the LAD Editor 
In LAD circuit programs the AND with edge detection  (Page 259)instruction and the NAND 
with edge detection (Page 260) instruction are available in the group of miscellaneous 
functions.  

5.4 Data log profile (FL1F and later versions only) 

5.4.1 What is a data log? 

 
You can configure a data log to record the actual values of the function blocks and memory 
areas in a circuit program.  
 
Connection Description 
En The Data Log begins logging data with a positive edge (0 to 1 transition) at input En 

(Enable) 
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Short description 
You can access the data log profile in the WindLGC navigation tree: 

 
You can configure one data log per circuit program. After you configure a data log, the icon 
in the navigation tree becomes gray so that you can no longer select it: 

 

5.4.2 Configuring the data log 
In a circuit program, you can only configure one data log to record the actual values of 
function blocks, and the following memory areas:  

• I 

• Q 

• M 

• AI 

• AQ 

• AM 

For digital I/O and memory, you must log data in groups of eight bits, for example, I1 to I8, 
Q9 to Q16, M17 to M24. For analog data, you select one value to log, for example, AI1, AQ2, 
or AM1. You configure function block values in groups of eight bits or single values, 
depending on the value type (digital or non-digital). 

You can log a maximum of 32 items (analog values or eight-bit digital groups) in the data log. 
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You can only configure the data log from WindLGC. You can not create, configure, or delete 
the data log from an IDEC SmartRelay device. 

5.4.3 Transferring the data log 
After configuring the data log, you can download the circuit program into IDEC SmartRelay 
FL1F devices which store the data log in internal EEPROM. 

You can transfer the data log to your PC or an SD card in .CSV format. To upload the data log 
from the internal EEPROM to your PC, use the menu command "Tools -> Transfer -> Upload 
Data Log (FL1F and later versions only) (Page 81)", and the IDEC SmartRelay FL1F devices 
must be in STOP mode.  

5.4.4 Opening an uploaded data log 
After successfully uploading the data log into your PC, double-click this .CSV file and it opens 
in Microsoft Excel by default. You can also open it with a text editor regardless. 
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5.5 UDF (FL1F and later versions only) 

5.5.1 What is a UDF? 
A UDF (User-Defined Function block) provides you a convenient way to deal with circuit logic 
that is composed of a group of function blocks and used in several places of a circuit program 
or among multiple circuit programs. A UDF helps you avoid copying and pasting a common 
set of blocks to multiple places and results in more readable program logic with fewer 
connection lines. With a UDF, you can do the modifications of all occurrences of the circuit 
logic at just one place. 

To create and use a UDF, follow these steps: 

1. Edit mode: create and edit a UDF 

– You can create a new UDF via menus or toolbars, and edit this UDF. 

– You can use a group of selected blocks in an existing circuit program as the start 
contents of the new UDF. 

– You can save the UDF to a UDF library path where you can import the UDF later. 

– You can create your own UDF library or copy a UDF library from a third party. 

2. Use mode: use the UDF in an FBD or in another UDF (nested UDF) 

If you have imported the UDF, it is available in the block tree like general function blocks. 
You can use it in the same way as a general function block. 

5.5.2 Creating a UDF 
You can create an empty UDF from the File → New (Page 46) menu command.  
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A UDF has a rectangle to indicate its edit area. You can edit the position and dimensions of 
this area. 

Restrictions for a UDF: 

• Input (analog + digital): 8 

• Output (analog + digital): 4 

• Parameter: 8 

 
  Note 

Not all blocks can be added to a UDF. Items shown below cannot be added to a UDF: 
• Inputs 
• Outputs 
• Analog inputs 
• Analog outputs 
• M8 
• M25 to M31 
• Shift registers 
• PI controllers 
• Data Log 
• Message texts 

 

You can also create a UDF from selected figures. To create a new UDF, select the blocks, 
right-click, and select "①" from the following context menu. 
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If the selection includes blocks that a UDF does not support, WindLGC excludes them from 
the UDF. If an included function block is connected to an excluded one, WindLGC creates an 
input or output in place of the excluded block. If the number of inputs and outputs would 
exceed the restrictions, WindLGC does not make inputs or outputs that would exceed the 
restriction. 

WindLGC creates the UDF and opens it in the UDF Editor: 
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5.5.3 Editing the UDF 

Add/Remove connectors  
You can create an input/output by dragging a connection line from a block to the left or right 
side of the UDF edit rectangle area: 

 
To remove an input/output, select the yellow connector figure and select "①" in the context 
menu. The corresponding connection line(s) will be deleted as well: 
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Configure UDF properties  
UDF properties include information such as identifier, password, connector names, 
parameters, comments and so on. To edit the UDF properties, double-click the identifier text 
above the UDF edit box or use menu command "Edit -> Edit UDF properties (Page 68)". 
WindLGC displays the following dialog: 

 
The dialog includes three tabs: 

• I/O 

• Parameters 

• Comment 
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The I/O-specific tab  
From this tab, you can configure the identifier, the UDF password, and the names of input 
connectors and output connectors: 

 
In Field "①" of the above dialog, you can enter an identifier for your UDF. The identifier is 
"UDF" by default. 

UDF password offers the capability to hide the details of a UDF such that a UDF library can be 
distributed without the details. In the use mode, you can right-click the UDF, and select "②" 
in the following context menu list to expand the UDF and view its details:  
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 Note 

The UDF circuit diagram password rule is as follows: 
• The maximum length of password is 10. 
• English characters (uppercase and lowercase letters) and digits are supported. 

 

If you did not configure a password for the UDF, WindLGC displays the expanded UDF content 
when you select "②": 

 
If you did configure a password for the UDF and select "② ", you must first enter the 
password before WindLGC displays the expanded UDF content: 
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The parameter-specific tab  
In this tab, you can configure the parameters of the UDF: 

 
You can reference the available parameters of the function blocks used in the UDF as the 
parameters of the UDF. "④" shows the function blocks, while "⑤" shows the parameters that 
the selected block includes. Double-click a parameter or use "②" to move a parameter from 
"⑤" to "①". 

To remove a parameter from ①, select the parameter and click ③. The parameter then re-
appears in ⑤. 

Use the first column in ① to identify each parameter. Set a unique identifier for each 
parameter: 
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The comment-specific tab  
You can use this tab to add a description of your UDF. 

The comment can describe how to use the UDF, the function of the inputs and outputs, and 
any other details. By default, the comment appears to the right of the UDF edit box, but you 
can place it wherever you choose: 
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UDF identifier  
The UDF identifier appears on the UDF edit box as an easy, short identifier of the UDF, and 
also appears in the block tree: 

 
Double-click the UDF identifier above the expanded UDF to open the following properties 
dialog. You can enter up to eight characters for the UDF name. You can also password-
protect the UDF in the following dialog:  
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User-defined name for a UDF block 
You can also configure a user-defined name for a UDF. It is the block name which appears 
above the UDF block as other function blocks in a circuit program. 

To configure a user-defined name for the UDF, double-click the UDF block and WindLGC 
displays the following dialog: 

 
Enter a name for the UDF, and click "①" in the above dialog. Then WindLGC displays the new 
UDF block name : 
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5.5.4 Saving the UDF 
Saving a UDF 

You can save a single UDF as .Ima file by clicking  or selecting "File -> Save (Page 49)"/"File -
> Save As (Page 49)" from the menu bar.  

Saving a UDF library 

You can configure a UDF library structure that represents either a single UDF or a folder of 
multiple UDFs. See Tools -> Options:UDF (Page 167) for UDF library path configuration. 
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Version control in the edit mode  
You can revise a UDF as needed to add new functions or to resolve logic problems. WindLGC 
uses "version" to identify differences; the valid version range is 0.0.1 to 255.255.255. If you 
make any change to a UDF and click , the following dialog appears: 

 
The new version must be an increment from the previous value. For example, in the example 
shown above, version 1.0.3 or 0.254.3 would be invalid. 

5.5.5 Using the UDF in an FBD circuit program or another UDF 
There are two methods available to configure a UDF library: 

• Select the Tools -> Options: UDF (Page 167) menu command 

• Right-click "UDF" in the following instruction tree and select "①" to call the dialog for 
configuring the UDF library 

 
The block tree shows the UDFs and UDF library that you have configured:  
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 Note 

Not all UDFs can be used in a circuit program. Invalid UDFs appear in the block tree, but are 
gray. A UDF is invalid if it meets one or more of these conditions: 
• The UDF has no blocks or connectors 
• The UDF has input or output connectors, but no block connections 
• The UDF contains blocks, but no in or out connectors 

 

A circuit program can have at most 16 different UDFs, and no more than 64 UDF instances in 
total. 

Within a circuit program, interaction with UDFs is consistent to other function blocks. Double-
clicking, for example, produces the following dialog. With this dialog, you can set user-
defined names and comments as other function blocks. 

 
Similarly, other blocks can reference UDF parameters, for example, you can drag the input 
connector of the parameter box of a function block to the output connector of the parameter 
box of a UDF block: 

 
You can include editable UDF parameters in message texts (Page 356): 
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 Note 

You can not invert the input connectors of a UDF. 
 

If a UDF internally references a parameter that is provided by another already-programmed 
function block, this parameter appears as "U*" when you use the UDF in a circuit program, for 
example: 
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5.5.6 Synchronizing UDF versions 
You can use a UDF in multiple circuit programs. If you update a UDF to a new version, 
synchronize the UDF instances, including any nested UDF instances, to the new version. 
Depending on how you use the UDF, WindLGC indicates various conditions pertaining to the 
UDF update.  

 
WindLGC displays a warning signal (!) in the upper right corner to indicate that the UDF is out 
of date. You can right-click the block, and select "①" from the following context menu to 
update the UDF to a new version.  

 
WindLGC displays a question mark (?) if the UDF is not available in the current library. You 
have to re-import the UDF to the current UDF library to remove this problem. 

A green mark ( ) means the UDF is configured and of the latest version. 

You can also update multiple UDFs at once. Select a group of UDFs, right-click, and select "①" 
from the context menu below. If there are conflicts, WindLGC only updates the UDFs that can 
be updated without conflict. WindLGC leaves those with conflicts as is, and produces a failure 
report in the "Info Window". 
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5.6 Circuit programs 
With WindLGC you can start right away to design your own circuit programs. The tutorial 
(Page 172) section provides you with detailed information about the creation and simulation 
of circuit programs. 

You first use the WindLGC software to write your programs, and secondly let WindLGC 
calculate (Page 133) the minimum IDEC SmartRelay version that you need to put your ideas 
into practice! 

No particular program settings are required. 

The type of IDEC SmartRelay device you can use to put your ideas into practice depends on a 
number of factors: 

• The number of I/O to be used 

• Memory requirements (Page 413) of the circuit program 

• The use of particular SFBs 

5.6.1 IDEC SmartRelay hardware 

IDEC SmartRelay hardware series 
WindLGC lets you create programs for IDEC SmartRelay devices of various series. IDEC 
SmartRelay device series vary in performance, memory space, number of program blocks (for 
example, flag blocks) and in the structure of the devices.  
 

 

Because there are device-specific differences with regard to the functions, you 
must not only distinguish between the IDEC SmartRelay versions, but also take 
their version status into account. You can identify the version status by the suffix 
of the IDEC SmartRelay type number. 
The current IDEC SmartRelay BM versions belong to the 6th generation. They can 
be identified by the last letter of their type number: FL1F. 
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Current devices 
• IDEC SmartRelay FL1F-H12RCE* 

• IDEC SmartRelay FL1F-H12SCD* 

• IDEC SmartRelay FL1F-H12RCA (AC/DC) 

• IDEC SmartRelay FL1F-H12RCC (AC/DC) 

• IDEC SmartRelay FL1F-B12RCE* 

• IDEC SmartRelay FL1F-B12RCA (AC/DC) 

• IDEC SmartRelay FL1F-B12RCC (AC/DC) 

* With analog inputs 

Memory space is identical for all these devices. 

The following expansion modules are available for the standard devices: 

• IDEC SmartRelay FL1F-M08C2R2 

• IDEC SmartRelay FL1F-M08B1S2 

• IDEC SmartRelay FL1F-M08B2R2 

• IDEC SmartRelay FL1F-M08D2R2 

• IDEC SmartRelay FL1F-J2B2 

• IDEC SmartRelay FL1F-K2BM2 

• IDEC SmartRelay FL1F-RD1 

Special functions, depending on IDEC SmartRelay versions 
 
Special function FL1A all FL1B all FL1C all FL1D all FL1E all FL1F FL1F FS5 

and FS6 
On delay X X Xr Xr Xr Xr Xr 
Off delay X X Xr Xr Xr Xr Xr 
Retentive on delay X X Xr Xr Xr Xr Xr 
On/off delay X X Xr Xr Xr Xr Xr 
Latching relay Xr Xr Xr Xr Xr Xr Xr 
Current impulse relay Xr Xr Xr Xr Xr Xr Xr 
Interval time-delay relay/Pulse 
output 

X X Xr Xr Xr Xr Xr 

Edge-triggered interval time-
delay relay 

X X Xr Xr Xr Xr Xr 

Seven-day time switch)* X X X X X X X 
Twelve-month time switch)* X X X X X X X 
Up/Down counter Xr Xr Xr Xr Xr Xr Xr 
Hours counter Xr Xr Xr Xr Xr Xr Xr 
Symmetrical clock pulse genera-
tor 

X X X X X X X 

Asynchronous pulse generator X X Xr Xr Xr Xr Xr 
Random generator X X X X X X X 
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Special function FL1A all FL1B all FL1C all FL1D all FL1E all FL1F FL1F FS5 
and FS6 

Frequency trigger X X X X X X X 
Analog trigger  X X X X X X X 
Analog comparator X X X X X X X 
Stairwell light switch X X Xr Xr Xr Xr Xr 
Dual-function switch X X Xr Xr Xr Xr Xr 
Message text X X X X X X X 
Softkey - Xr Xr Xr Xr Xr Xr 
Shift register - - Xr Xr Xr Xr Xr 
Analog watchdog - - Xr Xr Xr Xr Xr 
Analog Amplifier - - X X X X X 
Analog Differential trigger - - X X X X X 
Analog multiplexer - - - X X X X 
PI Controller - - - Xr Xr Xr Xr 
Analog Ramp - - - - X X X 
Pulse width moderator (PWM) - - - - X X X 
Analog math - - - - X X X 
Analog math error detection - - - - X X X 
Astronomical clock - - - - - X X 
Stopwatch - - - - - Xr Xr 
Analog filter - - - - - X X 
Max/Min - - - - - Xr Xr 
Average value - - - - - Xr Xr 
Float/Integer converter - - - - - - X 
Integer/Float converter - - - - - - X 
 X = Yes; - = No 

)* = Use of this function only makes sense for IDEC SmartRelay versions with integrated real-time clock. 
r= retentive 

5.6.2 Memory 

5.6.2.1 Memory requirements 
The blocks in your circuit program require a certain amount of memory space. The table 
shows you how much of the memory space each block occupies.  

The "Rem" column (retentivity enabled) specifies the memory space required for data backup 
after power failure. 

For IDEC SmartRelay FL1F devices 
 
Block RAM 

(Bytes) 
Rem 
(Bytes) 

AND (Edge) 12 - 
NAND  12 - 
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Block RAM 
(Bytes) 

Rem 
(Bytes) 

OR (Edge) 12 - 
NOR 12 - 
XOR 8 - 
NOT 8 - 
On delay 12 3 
Off delay 16 3 
On/off delay 16 3 
Retentive on delay 16 3 
Interval time-delay relay 12 3 
Edge-triggered Interval time-delay relay 20 4 
Asynchronous pulse generator 16 3 
Random generator 16 - 
Stairwell light switch 16 3 
Dual-function switch 20 3 
Seven-day time switch 24 - 
Twelve-month time switch 12 - 
Astronomical clock 40 - 
Stopwatch 28 19 
Up/Down counter 32 5 
Hours counter 36 13 
Frequency trigger  20 - 
Analog trigger 20 - 
Analog differential trigger 20 - 
Analog comparator 24 - 
Analog watchdog 24 3 
Analog amplifier 12 - 
Pulse width modulator (PWM) 32 - 
Analog math 24 - 
Analog math error detection 16 1 
Latching relay 12 1 
Current impulse relay  12 1 
Message text 12 - 
Softkey 12 2 
Analog multiplexer 20 - 
PI Controller 44 2 
Analog filter 20 - 
Max/Min 20 7 
Average value 32 20 
Analog ramp 40 - 
Shift register 16 1 
Float/Integer converter 20 - 
Integer/Float converter 24 - 
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For IDEC SmartRelay FL1E devices 
 
Block RAM 

(Bytes) 
Rem 
(Bytes) 

AND (Edge) 12 - 
NAND  12 - 
OR (Edge) 12 - 
NOR 12 - 
XOR 8 - 
NOT 4 - 
On delay 8 3 
Off delay 12 3 
On/off delay 12 3 
Retentive on delay 12 3 
Interval time-delay relay 8 3 
Edge-triggered interval time-delay relay 16 4 
Asynchronous pulse generator 12 3 
Random generator 12 - 
Stairwell light switch 12 3 
Dual-function switch 16 3 
Seven-day time switch 20 - 
Twelve-month time switch 12 - 
Up/Down counter 28 5 
Hours counter 28 9 
Frequency trigger  16 - 
Analog trigger  16 - 
Analog differential trigger 16 - 
Analog comparator 24 - 
Analog watchdog 20 3 
Analog amplifier 12 - 
Pulse width modulator (PWM) 24 - 
Analog math 20 - 
Analog math error detection 12 1 
Latching relay 8 1 
Current impulse relay  12 1 
Message text 8 - 
Softkey 8 2 
Analog multiplexer 20 - 
PI Controller 40 2 
Analog ramp 36 - 
Shift register 12 1 
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For IDEC SmartRelay FL1D devices 
 
Block RAM 

(Bytes) 
Rem 
(Bytes) 

AND (with/without edge evaluation) 12 - 
NAND  12 - 
OR (with/without edge evaluation) 12 - 
NOR 12 - 
XOR 8 - 
NOT 4 - 
On delay 8 3 
Off delay 12 3 
On/off delay 12 3 
Retentive on delay 12 3 
Interval time-delay relay 8 3 
Edge-triggered interval time-delay relay 16 4 
Asynchronous pulse generator 12 3 
Random generator 12 - 
Stairwell light switch 12 3 
Dual-function switch 16 3 
Seven-day time switch 20 - 
Twelve-month time switch 8 - 
Up/Down counter 24 5 
Hours counter 24 9 
Frequency trigger  16 - 
Analog trigger  16 - 
Analog differential trigger 16 - 
Analog comparator 24 - 
Analog value monitoring 20 - 
Analog amplifier 12 - 
Latching relay 8 1 
Current impulse relay  12 1 
Message text 8 - 
Softkey 8 2 
Analog multiplexer 20 - 
Controller 40 2 
Analog ramp 36 - 
Shift register 12 1 

For IDEC SmartRelay FL1C devices 
 
Block RAM 

(Bytes) 
Rem 
(Bytes) 

AND (with/without edge evaluation) 12 - 
NAND  12 - 
OR (with/without edge evaluation) 12 - 
NOR 12 - 
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Block RAM 
(Bytes) 

Rem 
(Bytes) 

XOR 8 - 
NOT 4 - 
On delay 8 3 
Off delay 12 3 
On/off delay 12 3 
Retentive on delay 12 3 
Interval time-delay relay 8 3 
Edge-triggered interval time-delay relay 16 4 
Asynchronous pulse generator 12 3 
Random generator 12 - 
Stairwell light switch 12 3 
Dual-function switch 16 3 
Seven-day time switch 20 - 
Twelve-month time switch 8 - 
Up/Down counter 24 5 
Hours counter 24 9 
Frequency trigger  16 - 
Analog trigger  16 - 
Analog differential trigger 16 - 
Analog comparator 24 - 
Analog value monitoring 20 - 
Analog amplifier 12 - 
Latching relay 8 1 
Current impulse relay  12 1 
Message text 8 - 
Softkey 8 2 
Shift register 12 1 

 
 

 

FL1A - FL1B: The following specifications apply: 

The blocks in your circuit program require a certain amount of memory space. The table 
below shows you how much memory space the blocks use in the various memory areas: 
 
Block Par RAM Timer REM 
Basic functions 0 0 0 0 
On delay 1 1 1 0 
Off delay 2 1 1 0 
On/off delay 2 1 1 0 
Retentive on delay 2 1 1 0 
Interval time-delay relay 1 1 1 0 
Edge-triggered interval time-delay relay 1 1 1 0 
Symmetrical clock pulse generator 1 1 1 0 
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Block Par RAM Timer REM 
Asynchronous pulse generator 3 1 1 0 
Random generator 2 1 1 0 
Stairwell light switch 1 1 1 0 
Dual-function switch 2 1 1 0 
Seven-day time switch 6 2 0 0 
Twelve-month time switch 2 0 0 0 
Up/Down counter* 2 (2) 0 (2) 
Hours counter 2 0 0 4 
Frequency trigger  3 3 1 0 
Analog trigger  4 2 0 0 
Analog comparator 3 4 0 0 
Latching relay* 0 (1) 0 (1) 
Current impulse relay * 0 (1) 0 (1) 
Message texts 1 0 0 0 
Softkey* 1 (1) 0 (1) 

*: Depending on whether the function is configured with or without retentivity, it occupies 
the following memory space: 

• Retentivity off: The function occupies RAM space 

• Retentivity on: The function occupies REM space 

Here you will find information on memory space provide by IDEC SmartRelay. (Page 418)  

5.6.2.2 Memory space 
For IDEC SmartRelay FL1F devices, you can use up to 400 blocks in your circuit program. 

The maximum memory space an IDEC SmartRelay circuit program can use is as follows: 

• RAM: 8500 bytes (if FL1F) 

• Retentive data (REM): 250 bytes 

For IDEC SmartRelay FL1E devices, you can use up to 400 blocks in your circuit program. 

The maximum memory space an IDEC SmartRelay circuit program can use is as follows: 

• RAM: 3800 bytes 

• Retentive data (REM): 250 bytes 

The Info Window displays the memory space used when you select the Tools → Determine 
IDEC SmartRelay (Page 133) menu command, or when you press the function key (Page 30) 
[F2]. 
 

 

The following specifications apply 

 IDEC SmartRelay 
series 

Blocks Par RAM Timer REM Flags 
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 IDEC SmartRelay 
FL1C to FL1D 

130 Not re-
stricted 

Not re-
stricted 

Not re-
stricted 

60 24 

 IDEC SmartRelay 
FL1A to FL1B 

56 48 27 16 15 8 

A circuit program consists of a number of blocks, which start with an input and end with an 
output. 

5.6.3 Blocks and block numbers 

5.6.3.1 Blocks 
Blocks represent terminals or functions. WindLGC distinguishes between various types of 
block and identifies them by means of an abbreviation: 
 
Block type Identifier 
Input I 
Output Q 
Shift register bit S 
Status 1 (high) Hi 
Status 0 (low) Lo 
Open connector X 
Cursor key C 
Function B 
IDEC SmartRelay TD function key F 
Flag M 
Analog input AI 
Analog output AQ 
Analog flag AM 
Network input NI 
Network analog input NAI 
Network output NQ 
Network analog output NAQ 
Data Log Profile L 
UDF UDF 

5.6.3.2 Block numbers 

Block number assignment 
WindLGC assigns every block you insert in the circuit program a block number. IDEC 
SmartRelay displays the number of the current block at the top of the display. WindLGC 
displays the block number directly above the inserted block.  
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The IDEC SmartRelay onboard display uses block numbers for orientation and for the 
assignment of logical links. In WindLGC you can also track cut connections by means of their 
indicated block number. 

Constants and terminals (Page 242) use the terminal name or a simple block name for 
identification rather than a block number. You can assign additional block identifiers to inputs 
(Page 243), outputs (Page 244), and flags (Page 245) with comments. The high and low 
(Page 244) signal blocks do not have a block number. 

Determination of block numbers on an IDEC SmartRelay 
IDEC SmartRelay has no default position for analog inputs or digital outputs. The hardware 
structure determines the block number. 
 

 

On an IDEC SmartRelay without modular structure, the position of an analog or digital 
output is fixed. 

5.7 Network projects 

Introduction 
With WindLGC V8.2 and later versions, you can design your own network project in the 
project mode. 

A network project typically consists of the following elements: 

• Devices selected from the project tree 

• Circuit diagrams for the devices 

• Settings of the devices 

• Network configuration of the devices 

The Tutorial (Page 172) section provides you with detailed information about the creation, 
device setting and Ethernet configuration of network projects. 
 

 

The LAD and UDF Editors are not available in the project mode. 
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Tips and tricks 6 
6.1 Tips and tricks 

How to maintain an overview during simulation (Page 421)  

A quick and easy way of selecting blocks and placing these into your circuit program 
(Page 421)  

A quick and easy way of connecting blocks in large circuit programs (Page 423)  

How to display a corresponding tooltip for a function key (Page 423)  

How to identify your circuit program version (Page 423)  

How to access functions via the shortcut menu (Page 423)  

A quick and easy way of zooming your circuit program window (Page 423)  

A quick way of changing block parameters (Page 424)  

A quick way of closing circuit diagrams without saving the data (Page 424)  

How to establish the cycle time (Page 424)  

6.2 How to maintain an overview during simulation 
To maintain a clear overview of large circuit programs when working with small or low-
resolution monitors, follow these steps: 

1. Maximize the WindLGC application window to full screen size. 

2. Close the Info Window and minimize the diagram tree and instruction tree. 

Advantage: You have increased the space for editing the circuit program. You can access the 
I/O toolbars without restriction, since they always remain in the foreground. 

Note: You can restore the diagram tree and instruction tree to their original position by left-
clicking the  icon. 

6.3 A quick and easy way of selecting blocks and placing these into 
your circuit program 

You have two alternatives to the standard selection of blocks from the programming toolbar 
icons: 
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Alternative 1 
1. Expand the catalog from the instruction tree. 

2. Click the required block in the catalog to select it. 

3. In your circuit program, left-click the block insert position. The block appears at the correct 
position. 

4. To insert more than one instance of a block at a time, double-click the block, which causes 
WindLGC to display a stamp icon beside the block. Left-click the locations on the 
programming interface for placing the multiple block instances. 

Advantage: When you change between constants/terminals, basic functions and SFBs, you 
save yourself having to click the relevant icons in the programming toolbar. 

Alternative 2 
1. Open the catalog of the programming toolbar. 

2. Click any block in the catalog to select it. 

3. If you are creating a large program, you can close the catalog and also hide the 
programming toolbar. 

4. Hold down the Ctrl key and left-click the block insert position in your circuit program. 
WindLGC displays a mask with block list, from which you can select the required block with a 
double-click. 

Tip: The mask header also contains an input field. You could, for example, enter the initial 
letter of the required SFB to restrict the display in the mask to a list of blocks with this 
initial. You thus do not have to browse the entire mask, and you can quickly find the 
relevant block. 
WindLGC inserts the block at the correct position in your circuit program. 

5. To insert further instances of this block, left-click the relevant insert positions. 

Advantage: You do not have to depend on the catalog to create large programs. You can 
thus close and hide it to provide more screen space for your circuit program. 
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6.4 A quick and easy way of connecting blocks in large circuit 
programs 

In addition to the conventional method of creating connections with the programming 
toolbar icons, you have another alternative: 

1. After you have placed the blocks into the circuit program, double-click the input or output of 
a block. 

2. A mask opens with a list of the target blocks. Double-click to select a block. 
Tip: The mask header also contains an input field. You could, for example, enter the initial 
letter of the required SFB to restrict the display in the mask to a list of blocks with this initial. 
You thus do not have to browse the entire mask, and you can quickly find the relevant 
block. 
In addition, you can also use wildcards such as * or ?. 

WindLGC makes the connection between the two blocks. 

Advantage: Particularly when you are handling large circuit programs, this method provides 
you with a quick and easy means of creating connections. 

6.5 How to display a corresponding tooltip for a function key 
Prerequisite: The tooltips (Page 71) are enabled. 

You can hover over an icon to see a tooltip for the icon, as well as the function key (Page 30) 
(if available) that performs the corresponding function. 

6.6 How to identify your circuit program version 
You can specify the version number of your current circuit program in the Version field in the 
File → Properties: Additional Info (Page 58) dialog. WindLGC maintains the version 
information when you download and upload the circuit program between the PC and IDEC 
SmartRelay. 

6.7 How to access functions via the shortcut menu 
Right-click an object to open a shortcut menu that offers you all the major functions for that 
object. 

6.8 A quick and easy way of zooming your circuit program window 
Press [CTRL] and turn the mouse wheel. 

Result: The size of your circuit program window changes. 
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6.9 A quick way of changing block parameters 
Click the parameter field you want to change, and turn the mouse wheel. 

Result: The parameter changes. 

6.10 A quick way of closing circuit diagrams without saving the data 
You quickly close one or more circuit programs without saving the data: 

• Open the File menu, press [CTRL] and click the Close menu command. 

Result: The currently active circuit program is closed without prompt. 

• Open the File menu, press [CTRL] and click the Close All menu command. 

Result: All open circuit programs are closed without prompt. 

Caution: New or changed circuit programs will not be saved. 

6.11 How to establish the cycle time 
The cycle time is the program processing time (reading inputs, executing programs and 
writing outputs). 

The cycle time of each function is less than 0.1 ms. You can establish the cycle time of the 
circuit program by using a test program. Refer to the IDEC SmartRelay User's Manual, 
Appendix B for more information. 
 

 

The execution time of individual functions in IDEC SmartRelay hardware series 
FL1B or older is indeterminate, and the times vary for each function. You can 
only establish the time for one program cycle. Refer to the IDEC SmartRelay Us-
er's Manual, Appendix B for more information. You can download this from the 
IDEC SmartRelay homepage on the Internet. 
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Troubleshooting 7 
7.1 Troubleshooting 

This chapter provides you with tips on how to locate and troubleshoot problems. 

Sending emails 
Diagnostics information is displayed on IDEC SmartRelay Base module through menu: 
Diagnostics → Email → Mail Logs. You can refer to the following table to troubleshoot the 
error cause and fix the error through corresponding solution. 

 
Diagnostics Possible cause Possible remedy 

Mail busy Emails are sent too frequently. When the 
server is sending an email, another email 
is triggered to send.  

As you cannot change the email sending frequency, 
modify the email sending trigger event. 

Time out • The network connection is unstable. 
• SMTP server response is time-out. 

• Check if your network connection is interrupted. 
• Check if the communication with the SMTP server 

is normal. 

Failed to parse DNS • Network connection to DNS server is 
interrupted. 

• Some error occurs on the SMTP do-
main name. 

• Check if the connection with the DNS server is 
normal. 

• Change DNS server. 
• Check if the SMTP server domain name is correct. 

Failed to login The login account or login password is 
incorrect in the SMTP settings. 

Check the login account or password in SMTP settings. 
Additional application code is required for certain 
SMTP server login. Refer to the user manual of speci-
fied email server for detailed information. 

Receiver error • Email receiver is not configured. 
• Some error occurs on the configured 

email receiver. 

• Check if the email receiving group is configured 
with email receivers. On how to configure email 
receiver, refer to Tools -> Transfer -> Email Settings 
(Page 120) 

• Check if the receiver email address is correct. 
• Check if the receiver email address is within the 

receiving range of the SMTP server. 

Net error The network is disconnected when the 
server is sending the email. 

Check your network connection. 

No configuration SMTP server is not configured in 
WindLGC. 

Configure SMTP in WindLGC. Refer to Tools -> Transfer 
-> Email Settings (Page 120).  
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Diagnostics Possible cause Possible remedy 
Server error • SMTP server rejects the email sending 

request. 
• SMTP server response doesn't meet 

with the SMTP specifications. 

Check if error occurs on the SMTP server or the SMTP 
server login email account. 

Failed to verify certifi-
cate 

The SMTP server certificate is invalid. • Upload valid certificate in SMTP configuration. 
• Check if the BM time is correct. Incorrect BM time 

makes it fail to verify certificate. 
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Cloud connection 
Diagnostics information is displayed on IDEC SmartRelay Base module through menu: 
Diagnostics → Cloud → Connect Status. You can refer to the following table to troubleshoot 
the error cause and possible solution. 

 
Diagnostics Possible cause Possible remedy 

Failed to parse DNS • DNS server is not available. 
• Error occurs when parsing IP address 

from DNS server. 
 

• Check your network connection. 
• Check if the gateway configuration is correct. 
• Check if the broker URL is correct. 

Server connection 
timeout 

• No response from server when IDEC 
SmartRelay is establishing TCP/TLS 
connection with it. 

• Server is not accessible 

• Check your network connection. 
• Check if the broker URL is correct. 
• Contact server technical support. 

Server connection error Error occurs when IDEC SmartRelay is 
establishing TCP/TLS connection with 
server. 

Check connection parameters, for example, port, 
authentication mode, key, certificate. 

No reply from MQTT 
broker 

Server's MQTT service is unavailable. Contact server technical support. 

Failed to send data to 
MQTT broker 

Cloud connection with MQTT broker is 
interrupted when IDEC SmartRelay is 
sending data. 

Check your network connection. 

Failed to receive data 
from MQTT broker 

• Cloud connection with MQTT broker 
is interrupted when IDEC SmartRelay 
is receiving data. 

• Received data is invalid, for example, 
packet format error, unrecognizable 
packet type. 

• Check your network connection. 
• Check server configuration. 

Unacceptable protocol 
version 

The server does not support the level of 
the MQTT protocol requested by the 
client. 

Check if the server supports MQTT 3.1/3.1.1 protocol. 

Identifier rejected The client identifier is UTF-8 which is not 
supported by the server. 

Contact server technical support. 

Server unavailable The network is connected but MQTT 
services is unavailable. 

Contact server technical support. 

Bad user name or 
password 

The data in the user name or password is 
malformed. 

• Check if user name and password are correct. 
• Contact server technical support. 

Not authorized The client is not authorized to connect. Check if user name and password are provided. 
Data from MQTT broker 
is too long 

Data received from the server is mal-
formed or too long. 

• Check if data sent from the server is valid. 
• Contact server technical support. 
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User example A 
A.1 How to connect with HiveMQ Cloud 

Requirements 
• Cloud access is enabled in WindLGC 

Procedures 
Follow these steps to set up IoT connection between IDEC SmartRelay BM and Hive MQTT.  

1. Sign up in HiveMQ Cloud (https://console.hivemq.cloud/?utm_source=hivemq-
com&utm_medium=download-page&utm_campaign=cloud). 

2. Sign in. 

3. Click ③ to get the Cloud connection configuration information. 

 

https://console.hivemq.cloud/?utm_source=hivemq-com&utm_medium=download-page&utm_campaign=cloud
https://console.hivemq.cloud/?utm_source=hivemq-com&utm_medium=download-page&utm_campaign=cloud
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Here you get the Cluster URL, Port information. Copy and paste these information in a text 
file for later use in WindLGC Cloud connection configuration. 

 
4. Click ④ to set up credentials for your IoT devices. Remember the credential you set, which 

will be used in WindLGC configuration. 

 
5. Register Hive MQTT IoT thing through Tools -> Transfer -> Cloud Settings -> Cloud 

Connection Settings (Page 94) in WindLGC. Click Register Thing button to start the process. 
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6. Select "MQTT" in Cloud Type and click "Next" button. 
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7. Enter MQTT Broker URL, Port which you have gotten in step 3; enter User Name and 
Password which you have set in step 4; set MQTT Client ID. Then click "Next" button. 

 



User example  
A.1 How to connect with HiveMQ Cloud 

 WindLGC Online Help 

432 Programming and Operating Manual, 11/2024 

8. Select "TLS without authentication" as the Authentication Type. Then click "Next" button. 
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9. Enter "Publish Topic" and "Subscribe Topic". You can name them by yourself. Then click 
"Next" button. Remember these two topic names, which will be used later to subscribe or 
publish data on Hive MQTT client. 
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10. The Register Status page shows you that your registration is successful. Click "Finish" button 
to close the registration dialog. 
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Subscribe data from SmartRelay 
To subscribe and read data from IDEC SmartRelay BM on Hive MQTT web client, follow these 
steps: 

1. Open cloud data transfer settings window through Tools -> Transfer -> Cloud Settings -> 
Cloud Data Transfer Settings (Page 93). 

2. Add a data item. In this example, we use "Array Data Format". Click "Write to SmartRelay" to 
finish the configuration. 

 
3. Click "WEB CLIENT" in Hive MQTT to configure client connection. 
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4. Enter the Username and Password, then click "CONNECT CLIENT" button. You can use the 
credential you have created in "ACCESS MANAGEMENT". Or you can click "CONNECT WITH 
GENERATED CREDENTIALS" button to connect client. 

 
  Note 

The credential for client connection in Hive MQTT should not be the same credential that 
you use to configure Cloud connection in WindLGC. Otherwise, the Cloud connection 
might be interrupted. 

 

5. Browse to Topic Subscriptions part. Enter the Publish Topic you have configured in Cloud 
connection in WindLGC. Then click "SUBSCRIBE" button to subscribe messages. 

 
 Now you can see messages IDEC SmartRelay BM sends to the web client. 
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Publish data to SmartRelay 
To write and publish data from Hive MQTT web client to SmartRelay BM, follow these steps: 

1. Browse to Publish Message part in Hive MQTT web client after client connection completes. 

2. Enter the Subscribe Topic you have configured in Cloud connection in WindLGC. 

3. Write the data in integer array format in the Message box, then click "PUBLISH" button. Later 
you can see the successfully published messages in the web client, and you can also see the 
data is successfully changed in SmartRelay BM. 
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A.2 How to connect with Mosquitto MQTT 

Requirements 
• Cloud access is enabled in WindLGC 

Procedures 
Follow these steps to set up IoT connection between SmartRelay BM and Mosquitto MQTT.  

1. Download Mosquitto MQTT application in Mosquitto Download Website 
(https://mosquitto.org/download/). 

2. Click the .exe file to install the application on your PC. 

3. Open the mosquitto.conf file under the root folder of the installed application. Configure the 
host PC's IP address and Port in mosquitto.conf file. 

 
4. Change the configuration of "allow anonyous false" into "allow anonymous true" in 

mosquitto conf file. 

 
5. Disable the firewall in your PC to ensure the stable connection between the BM and 

Mosquitto MQTT. 

https://mosquitto.org/download/
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6. Open the cmd window in root folder of the installed Mosquitto appliction. Input command 
mosquitto -c mosquitto.conf -v to start Mosquitto application. 

 
  Note 

Leave the cmd window open during the whole process of connection. Otherwise, the IoT 
connection will be interrupted. 

 

 
7. Register Mosquitto MQTT IoT thing through Tools -> Transfer -> Cloud Settings -> Cloud 

Connection Settings (Page 94) in WindLGC. Click Register Thing button to start the process. 

8. Select "MQTT" in Cloud Type and click "Next" button. 
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9. Enter MQTT Broker URL, Port which you have configured in step 3; set MQTT Client ID. Then 
click "Next" button. 
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10. Select "TCP" as the Authentication Type. Then click "Next" button. For how to configure 
Mosquitto when selecting other authentication type, refer to Mosquitto Website 
(https://mosquitto.org/man/mosquitto-conf-5.html). 

 

https://mosquitto.org/man/mosquitto-conf-5.html
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11. Enter "Publish Topic" and "Subscribe Topic". You can name them by yourself. Then click 
"Next" button. Remember these two topic names, which will be used later to subscribe or 
publish data on Mosquitto MQTT client. 

 



 User example 
 A.2 How to connect with Mosquitto MQTT 

WindLGC Online Help 

Programming and Operating Manual, 11/2024 443 

12. The Register Status page shows you that your registration is successful. Click "Finish" button 
to close the registration dialog. 
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Subscribe data from SmartRelay 
1. Open cloud data transfer settings window through Tools -> Transfer -> Cloud Settings -> 

Cloud Data Transfer Settings (Page 93). 

2. Add a data item. In this example we use "Array Data Format". Click "Write to SmartRelay" to 
finish the configuration. 

 
3. Input command in the cmd window: mosquitto_sub -h 192.168.0.66 -p 1883 -t 

"Topic 1". You will see messages in the cmd window sent from the BM. 
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Publish data to SmartRelay 
1. Open another cmd window in root folder of the installed Mosquitto application. 

2. Input the following commands in the new cmd window to publish data to the BM: 

–  mosquitto_pub.exe -h 192.168.0.66 -p 1883 -t "Topic 2" -m 
"{\"state\":{\"var1\":{\"value\":[0,0]},\"var2\":{\"value\":[0]
}}} 

–  mosquitto_pub.exe -h 192.168.0.66 -p 1883 -t "Topic 2" -m 
"{\"state\":{\"var1\":{\"value\":[50,100]},\"var2\":{\"value\":
[1]}}} 

In the subscribe cmd window, you can see the successfully published messages, and you 
can also see the data is successfully changed in the BM. 
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